]> git.pld-linux.org Git - packages/povray.git/blame - povray.spec
boost rebuild
[packages/povray.git] / povray.spec
CommitLineData
8f6042bf 1#
bc24fd67 2# Conditional build:
9efdfbd6 3%bcond_without x # - without X11 subpackage
be0816cf 4%bcond_with pvm # - with PVM support
9efdfbd6 5%bcond_with svga # - with svgalib support (doesn't work on many platforms)
8f6042bf 6#
849976ce 7%define subver beta.2
a0ce0319 8%define rel 2
520c1407 9Summary: Persistence of Vision Ray Tracer
5c6661ca 10Summary(pl.UTF-8): Persistence of Vision Ray Tracer
520c1407 11Name: povray
849976ce 12Version: 3.8.0
f3be0366 13Release: 0.%{subver}.%{rel}
e107cc8d 14Epoch: 1
f3be0366 15License: AGPL v3+
520c1407 16Group: Applications/Graphics
f3be0366
JB
17#Source0Download: https://github.com/POV-Ray/povray/releases
18Source0: https://github.com/POV-Ray/povray/archive/v%{version}-%{subver}/%{name}-%{version}-%{subver}.tar.gz
849976ce 19# Source0-md5: f253c837495da02189723059236e9434
f3be0366 20Patch1: x32.patch
520c1407 21URL: http://www.povray.org/
f3be0366
JB
22BuildRequires: OpenEXR-devel >= 1.2
23BuildRequires: SDL-devel >= 1.2
24BuildRequires: autoconf >= 2.59
25BuildRequires: automake >= 1:1.9
26BuildRequires: boost-devel >= 1.38
27BuildRequires: libjpeg-devel >= 6b
28BuildRequires: libpng-devel >= 2:1.4.0
b7a98b2e 29BuildRequires: libstdc++-devel
f3be0366
JB
30BuildRequires: libtiff-devel >= 3.6.1
31BuildRequires: perl-base
4094ca7d
JK
32%{?with_pvm:BuildRequires: pvm-devel >= 3.4.3-24}
33%{?with_svga:BuildRequires: svgalib-devel}
73c51aff 34%{?with_x:BuildRequires: xorg-lib-libX11-devel}
f3be0366
JB
35BuildRequires: zlib-devel >= 1.2.1
36Requires: OpenEXR >= 1.2
37Requires: SDL >= 1.2
38Requires: libtiff >= 3.6.1
39Requires: zlib >= 1.2.1
9416b15a 40BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
4d562464 41
d436f42a 42%if %{with pvm}
697b1b4f 43%define _pvmarch %(/usr/bin/pvmgetarch)
09c1e7ed 44%define _pvmroot /usr/%{_lib}/pvm3
d436f42a 45%endif
a37cc0c6 46
e665b1ae
JR
47%define specflags -std=c++11
48
4d562464 49%description
4d562464 50The Persistence of Vision(tm) Ray-Tracer creates three-dimensional,
2702972f 51photo-realistic images using a rendering technique called ray-tracing.
52It reads in a text file containing information describing the objects
53and lighting in a scene and generates an image of that scene from the
54view point of a camera also described in the text file. Ray-tracing is
55not a fast process by any means, but it produces very high quality
56images with realistic reflections, shading, perspective and other
57effects.
4d562464 58
2ea14a87
JR
59%description -l pl.UTF-8
60Persistence of Vision(tm) Ray-Tracer tworzy trójwymiarowe,
61fotorealistyczne obrazy za pomocą techniki renderingu zwanej
62ray-tracing. Program pobiera z pliku tekstowego informacje opisujące
63obiekty oraz światło przedstawianego świata, a następnie generuje
64rysunek z punktu widzenia kamery, która także jest definiowana w w/w
65pliku tekstowym. Ray-tracing nie pozwala na szybkie tworzenie obrazów,
66ale za to twórca otrzymuje wyskokiej jakości bitmapy z realistycznymi
67efektami, tj. odbicia światła, cienie, perspektywa i inne.
4d562464 68
fceafdc6 69%package X11
41b49d87 70Summary: X Window povray executable
5c6661ca 71Summary(pl.UTF-8): povray pod X Window
fceafdc6 72Group: Applications/Graphics
38f80171 73Requires: %{name} = %{epoch}:%{version}-%{release}
41b49d87 74
75%description X11
76The Persistence of Vision(tm) Ray-Tracer X Window executable.
caec2118 77
2ea14a87 78%description X11 -l pl.UTF-8
8ecf04d1 79Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla X
80Window.
a37cc0c6 81
a37cc0c6 82%package pvm
3af417fe 83Summary: PVM/Unix povray executable
84Summary(pl.UTF-8): Plik wykonywalny povray dla PVM/Unix
a37cc0c6 85Group: Applications/Graphics
38f80171 86Requires: %{name} = %{epoch}:%{version}-%{release}
a37cc0c6
AF
87
88%description pvm
3af417fe 89The Persistence of Vision(tm) Ray-Tracer PVM/Unix executable.
a37cc0c6 90
2ea14a87 91%description pvm -l pl.UTF-8
8ecf04d1 92Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla
3af417fe 93PVM/Unix.
caec2118 94
a37cc0c6
AF
95%package pvm-X11
96Summary: PVM/xwin povray executable
5c6661ca 97Summary(pl.UTF-8): Plik wykonywalny povray dla PVM/xwin
a37cc0c6 98Group: Applications/Graphics
38f80171 99Requires: %{name} = %{epoch}:%{version}-%{release}
a37cc0c6
AF
100
101%description pvm-X11
102The Persistence of Vision(tm) Ray-Tracer PVM/xwin executable.
caec2118 103
2ea14a87 104%description pvm-X11 -l pl.UTF-8
8ecf04d1 105Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla
106PVM/xwin.
fceafdc6 107
4d562464 108%prep
f3be0366 109%setup -q -n %{name}-%{version}-%{subver}
f3be0366
JB
110%ifarch x32
111%patch1 -p1
f65cefa1 112%endif
4d562464 113
114%build
8b2043c3
JR
115cd unix
116./prebuild.sh
117cd ..
118
ea227ab9 119COMPILED_BY="PLD/Linux Team";export COMPILED_BY;
f3be0366 120# disable optimiz-arch, it means -march=native for gcc
09c1e7ed 121%if %{with x} && %{with pvm}
697b1b4f 122%configure \
09c1e7ed 123 --libdir=%{_datadir} \
f3be0366 124 --disable-optimiz-arch \
e665b1ae 125 --disable-strip \
697b1b4f
AF
126 --enable-pvm \
127 --with-pvm-arch=%{_pvmarch} \
e4be19f9 128 --with-pvm-libs=%{_libdir}
697b1b4f 129%{__make}
21729b33 130install unix/povray x-pvmpov
697b1b4f
AF
131%endif
132
09c1e7ed 133%if %{with pvm}
697b1b4f
AF
134%{__make} clean
135
136%configure \
09c1e7ed 137 --libdir=%{_datadir} \
f3be0366 138 --disable-optimiz-arch \
e665b1ae 139 --disable-strip \
697b1b4f
AF
140 --enable-pvm \
141 --with-pvm-arch=%{_pvmarch} \
09c1e7ed 142 --with-pvm-libs=%{_libdir} \
697b1b4f
AF
143 --without-x
144%{__make}
21729b33 145install unix/povray pvmpov
697b1b4f
AF
146%endif
147
09c1e7ed 148%if %{with x}
b7a98b2e 149%configure \
f3be0366 150 --libdir=%{_datadir} \
e665b1ae
JR
151 --disable-optimiz-arch \
152 --disable-strip
b7a98b2e 153%{__make}
21729b33 154install unix/povray x-povray
b7a98b2e 155%{__make} clean
2c916a3a 156%endif
b7a98b2e 157
158%configure \
09c1e7ed 159 --libdir=%{_datadir} \
f3be0366 160 --disable-optimiz-arch \
e665b1ae 161 --disable-strip \
b7a98b2e 162 --without-x
163%{__make}
4d562464 164
165%install
61158218 166rm -rf $RPM_BUILD_ROOT
e4be19f9 167install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_bindir},%{_datadir}}
ea227ab9
AM
168%if %{with pvm}
169install -d $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}
170%endif
61158218 171
e4be19f9
JR
172%{__make} install \
173 INSTALL="install -c -D" \
174 mkdir_p="mkdir -p" \
b7a98b2e 175 DESTDIR=$RPM_BUILD_ROOT
4d562464 176
09c1e7ed 177%if %{with x}
a5a450ff 178install x-povray $RPM_BUILD_ROOT%{_bindir}
2c916a3a 179%endif
180
09c1e7ed 181%if %{with x} && %{with pvm}
a5a450ff 182install x-pvmpov $RPM_BUILD_ROOT%{_bindir}/x-pvmpov
09c1e7ed 183ln -s %{_bindir}/x-pvmpov $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}/x-pvmpov
697b1b4f
AF
184%endif
185
09c1e7ed 186%if %{with pvm}
a5a450ff 187install pvmpov $RPM_BUILD_ROOT%{_bindir}/pvmpov
09c1e7ed 188ln -s %{_bindir}/pvmpov $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}/pvmpov
697b1b4f
AF
189%endif
190
4d562464 191%clean
192rm -rf $RPM_BUILD_ROOT
193
194%files
49c88a8f 195%defattr(644,root,root,755)
be0816cf 196%doc AUTHORS ChangeLog NEWS README* changes.txt
fceafdc6 197%attr(755,root,root) %{_bindir}/povray
09c1e7ed 198%{_datadir}/povray*
21729b33 199%{_docdir}/povray*
f3be0366 200%{_mandir}/man1/povray.1*
e11b17d4 201%dir %{_sysconfdir}/povray
e665b1ae
JR
202%dir %{_sysconfdir}/povray/3.8
203%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/3.8/povray.conf
204%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/3.8/povray.ini
fceafdc6 205
09c1e7ed 206%if %{with x}
96df36ec 207%files X11
2702972f 208%defattr(644,root,root,755)
a5a450ff 209%attr(755,root,root) %{_bindir}/x-povray
a37cc0c6
AF
210%endif
211
8f6042bf 212%if %{with pvm}
697b1b4f
AF
213%files pvm
214%defattr(644,root,root,755)
215%attr(755,root,root) %{_pvmroot}/bin/%{_pvmarch}/pvmpov
a5a450ff 216%attr(755,root,root) %{_bindir}/pvmpov
697b1b4f
AF
217%endif
218
09c1e7ed 219%if %{with pvm} && %{with x}
697b1b4f
AF
220%files pvm-X11
221%defattr(644,root,root,755)
222%attr(755,root,root) %{_pvmroot}/bin/%{_pvmarch}/x-pvmpov
a5a450ff 223%attr(755,root,root) %{_bindir}/x-pvmpov
697b1b4f 224%endif
This page took 0.095829 seconds and 4 git commands to generate.