]> git.pld-linux.org Git - packages/postgresql.git/commitdiff
upstream patch to fix build with llvm 11
authorJan Palus <atler@pld-linux.org>
Sat, 2 Jan 2021 10:46:20 +0000 (11:46 +0100)
committerJan Palus <atler@pld-linux.org>
Sat, 2 Jan 2021 10:46:20 +0000 (11:46 +0100)
llvm11.patch [new file with mode: 0644]
postgresql.spec

diff --git a/llvm11.patch b/llvm11.patch
new file mode 100644 (file)
index 0000000..0f16a8d
--- /dev/null
@@ -0,0 +1,28 @@
+From c001c115bcb2accddc23a25c605886e01475db4f Mon Sep 17 00:00:00 2001
+From: Andres Freund <andres@anarazel.de>
+Date: Thu, 28 May 2020 15:08:12 -0700
+Subject: [PATCH] llvmjit: Fix building against LLVM 11 by removing unnecessary
+ include.
+
+LLVM has removed this header, in the branch that will become llvm
+11. But as it turns out we didn't actually need it, so just remove it.
+
+Author: Jesse Zhang <sbjesse@gmail.com>
+Discussion: https://postgr.es/m/CAGf+fX7bvtP0YXMu7pOsu_NwhxW6dArTkxb=jt7M2-UJkyJ_3g@mail.gmail.com
+Backpatch: 11, where JIT support using llvm was introduced.
+---
+ src/backend/jit/llvm/llvmjit_inline.cpp | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/src/backend/jit/llvm/llvmjit_inline.cpp b/src/backend/jit/llvm/llvmjit_inline.cpp
+index aa0473dacd22..c489a632ff9e 100644
+--- a/src/backend/jit/llvm/llvmjit_inline.cpp
++++ b/src/backend/jit/llvm/llvmjit_inline.cpp
+@@ -56,7 +56,6 @@ extern "C"
+ #include <llvm/Support/Error.h>
+ #endif
+ #include <llvm/IR/Attributes.h>
+-#include <llvm/IR/CallSite.h>
+ #include <llvm/IR/DebugInfo.h>
+ #include <llvm/IR/IntrinsicInst.h>
+ #include <llvm/IR/IRBuilder.h>
index 498452cab986aed66371dea595ae880d3c38d826..06b4744f64a28665637ade4383388092615c5cd0 100644 (file)
@@ -56,6 +56,7 @@ Patch4:               %{name}-disable_horology_test.patch
 Patch5:                %{name}-heimdal.patch
 Patch6:                %{name}-link.patch
 Patch7:                llvm10.patch
+Patch8:                llvm11.patch
 URL:           http://www.postgresql.org/
 BuildRequires: autoconf >= 2.69
 BuildRequires: automake
@@ -793,6 +794,7 @@ Różne moduły dołączone do PostgreSQL-a.
 %patch5 -p1
 %patch6 -p1
 %patch7 -p1
+%patch8 -p1
 
 # force rebuild of bison/flex files
 find src -name \*.l -o -name \*.y | xargs touch
This page took 0.206785 seconds and 4 git commands to generate.