]> git.pld-linux.org Git - packages/postgresql.git/blobdiff - postgresql.spec
- up to 9.6.10
[packages/postgresql.git] / postgresql.spec
index ff41c5d97bb8ec9d9d8e59c37faec2dfa27ab081..64010e56529d5b6aec5d2a0c68c0852719bed4aa 100644 (file)
@@ -1,7 +1,8 @@
 # TODO:
 # - python 3 and python 2 subpackages?
-# - consider dns_sd/Bonjour support (--with-bonjour)
+# - subpackage *_plperl and *_plpython contribs?
 # - think about pg_upgrade integration (sysconfig variable to allow upgrade from 8.3+ without dump/restore?)
+#   create postgresqlM.N packages with parts of old pgsql required by pg_upgrade
 # - test init script (db initialization)
 #
 # Conditional build:
 %bcond_without kerberos5               # disable kerberos5 support
 %bcond_without perl                    # disable Perl support
 %bcond_without python                  # disable Python support
+%bcond_with    bonjour                 # Bonjour/DNS_SD support
 %bcond_without ldap                    # disable LDAP support
 %bcond_without selinux                 # sepgsql contrib module
+%bcond_without systemd                 # systemd (notify) support
+%bcond_with    systemtap               # systemtap/dtrace probes
 %bcond_with    absolute_dbpaths        # enable absolute paths to create database
                                        # (disabled by default because it is a security risk)
 #
 
 %define beta %{nil}
-%define mver 9.2
-
-%define prevmver 9.1
-%define prevver 9.1.6
+%define mver 9.6
 
 Summary:       PostgreSQL Data Base Management System
 Summary(de.UTF-8):     PostgreSQL Datenbankverwaltungssystem
@@ -33,41 +34,42 @@ Summary(tr.UTF-8):  Veri Tabanı Yönetim Sistemi
 Summary(uk.UTF-8):     PostgreSQL - система керування базами даних
 Summary(zh_CN.UTF-8):  PostgreSQL 客户端程序和库文件
 Name:          postgresql
-Version:       %{mver}.1
-Release:       0.1
+Version:       %{mver}.10
+Release:       1
 License:       BSD
 Group:         Applications/Databases
-Source0:       ftp://ftp.postgresql.org/pub/source/v%{version}/%{name}-%{version}.tar.bz2
-# Source0-md5: c0b4799ea9850eae3ead14f0a60e9418
+Source0:       http://ftp.postgresql.org/pub/source/v%{version}/%{name}-%{version}.tar.bz2
+# Source0-md5: 9a7f465252c0fbe2212566e3c079e062
 Source1:       %{name}.init
 Source2:       pgsql-Database-HOWTO-html.tar.gz
 # Source2-md5: 5b656ddf1db41965761f85204a14398e
 Source3:       %{name}.sysconfig
-Source5:       %{name}.upstart
-Source6:       %{name}-instance.upstart
-Source7:       ftp://ftp.postgresql.org/pub/source/v%{prevver}/%{name}-%{prevver}.tar.bz2
-# Source7-md5: 000755f66c0de58bbd4cd2b89b45b8e2
+Source4:       %{name}@.service
+Source5:       %{name}.service
+Source6:       %{name}.target
 Patch0:                %{name}-conf.patch
 Patch1:                %{name}-absolute_dbpaths.patch
 Patch2:                %{name}-ecpg-includedir.patch
-Patch3:                %{name}-ac_version.patch
+
 Patch4:                %{name}-disable_horology_test.patch
 Patch5:                %{name}-heimdal.patch
-Patch6:                %{name}_%{prevmver}-ac_version.patch
+Patch6:                %{name}-link.patch
 URL:           http://www.postgresql.org/
-BuildRequires: autoconf
+BuildRequires: autoconf >= 2.69
 BuildRequires: automake
+%{?with_bonjour:BuildRequires: avahi-compat-libdns_sd-devel}
 # not needed for releases... but fixes something in snapshot
 BuildRequires: bison >= 1.875
 BuildRequires: docbook-dtd42-sgml
 BuildRequires: docbook-dtd42-xml
 BuildRequires: docbook-style-xsl
 BuildRequires: flex >= 2.5.31
-BuildRequires: gettext-devel
+BuildRequires: gettext-tools
+BuildRequires: gnome-doc-tools
 %{?with_kerberos5:BuildRequires:       heimdal-devel}
-%{?with_selinux:BuildRequires: libselinux-devel >= 2.0.93}
+%{?with_selinux:BuildRequires: libselinux-devel >= 2.1.10}
 BuildRequires: libtool
-BuildRequires: libxml2-devel >= 2.6.23
+BuildRequires: libxml2-devel >= 1:2.6.23
 BuildRequires: libxslt-devel
 BuildRequires: libxslt-progs
 BuildRequires: ncurses-devel >= 5.0
@@ -82,7 +84,9 @@ BuildRequires:        python-devel >= 1:2.3
 BuildRequires: python-modules >= 1:2.3
 %endif
 BuildRequires: readline-devel >= 4.2
-BuildRequires: rpmbuild(macros) >= 1.268
+BuildRequires: rpmbuild(macros) >= 1.671
+%{?with_systemd:BuildRequires: systemd-devel >= 1:209}
+%{?with_systemtap:BuildRequires:       systemtap-sdt-devel}
 %{?with_tcl:BuildRequires:     tcl-devel >= 8.4.3}
 %{?with_tests:BuildRequires:   tzdata}
 BuildRequires: zlib-devel
@@ -93,9 +97,10 @@ Requires(pre):       /usr/sbin/groupadd
 Requires(pre): /usr/sbin/useradd
 Requires(triggerpostun):       /bin/id
 Requires(triggerpostun):       /usr/sbin/usermod
-Requires:      %{name}-clients = %{version}-%{release}
+Requires:      %{name}-clients >= %{version}-%{release}
 Requires:      %{name}-libs = %{version}-%{release}
 Requires:      rc-scripts >= 0.4.3.0
+Requires:      systemd-units >= 38
 Requires:      tzdata
 Obsoletes:     postgresql-module-plpgsql
 Obsoletes:     postgresql-module-tsearch2
@@ -109,9 +114,9 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                _ulibdir        /usr/lib
 
 # omitted contribs:
-# dummy_seclabel, pg_test_fsync, spi and test_parser - examples/tests
+# spi, test_decoding, worker_spi - examples/tests
 # tsearch2 - old module for compatibility only
-%define        contrib_modules adminpack auth_delay auto_explain btree_gin btree_gist chkpass citext cube dblink dict_int dict_xsyn earthdistance file_fdw fuzzystrmatch hstore intagg intarray isn lo ltree oid2name pageinspect passwordcheck pg_archivecleanup pg_buffercache pg_freespacemap pg_standby pg_stat_statements pg_trgm pg_upgrade pg_upgrade_support pgbench pgcrypto pgrowlocks pgstattuple seg %{?with_selinux:sepgsql} sslinfo tablefunc unaccent uuid-ossp vacuumlo xml2
+%define        contrib_modules adminpack auth_delay auto_explain bloom btree_gin btree_gist chkpass citext cube dblink dict_int dict_xsyn earthdistance file_fdw fuzzystrmatch hstore %{?with_perl:hstore_plperl} %{?with_python:hstore_plpython} intagg intarray isn lo ltree %{?with_python:ltree_plpython} oid2name pageinspect passwordcheck pg_buffercache pg_freespacemap pg_prewarm pg_standby pg_stat_statements pg_trgm pg_visibility pgcrypto pgrowlocks pgstattuple postgres_fdw seg %{?with_selinux:sepgsql} sslinfo tablefunc tcn tsm_system_rows tsm_system_time unaccent uuid-ossp vacuumlo xml2
 
 %description
 PostgreSQL Data Base Management System (formerly known as Postgres,
@@ -335,20 +340,6 @@ California, Berkeley.
 PostgreSQL працює на Solaris, SunOS, HPUX, AIX, Linux, Irix, FreeBSD
 та більшості інших різновидів Unix.
 
-%package upstart
-Summary:       Upstart job description for PostgreSQL server
-Summary(pl.UTF-8):     Opis zadania Upstart dla serwera PostgreSQL
-Group:         Daemons
-Requires:      %{name} = %{version}-%{release}
-Requires:      upstart >= 0.6
-Conflicts:     syslog-ng < 3.2.4-1
-
-%description upstart
-Upstart job description for PostgreSQL.
-
-%description upstart -l pl.UTF-8
-Opis zadania Upstart dla PostgreSQL.
-
 %package devel
 Summary:       PostgreSQL development header files and libraries
 Summary(de.UTF-8):     PostgreSQL-Entwicklungs-Header-Dateien und Libraries
@@ -725,7 +716,7 @@ Summary:    PostgreSQL external security provider using SELinux
 Summary(pl.UTF-8):     Zewnętrzny moduł bezpieczeństwa PostgreSQL-a wykorzystujący SELinuksa
 Group:         Applications/Databases
 Requires:      %{name} = %{version}-%{release}
-Requires:      libselinux >= 2.0.93
+Requires:      libselinux >= 2.1.10
 
 %description module-sepgsql
 PostgreSQL external security provider using SELinux.
@@ -750,6 +741,7 @@ Summary:    XML-handling functions for PostgreSQL
 Summary(pl.UTF-8):     Funkcje do obsługi XML-a dla PostgreSQL-a
 Group:         Applications/Databases
 Requires:      %{name} = %{version}-%{release}
+Requires:      libxml2 >= 1:2.6.23
 
 %description module-xml2
 Module with XML functions provides both XPath querying and XSLT
@@ -773,41 +765,15 @@ Miscellaneous PostgreSQL contrib modules.
 %description contrib -l pl.UTF-8
 Różne moduły dołączone do PostgreSQL-a.
 
-%package upgrade
-Summary:       Support for upgrading from the previous major release
-Summary(pl.UTF-8):     Wsparcie
-Group:         Applications/Databases
-Requires:      %{name} = %{version}-%{release}
-
-%description upgrade
-The postgresql-upgrade package contains the pg_upgrade utility and supporting
-files needed for upgrading a PostgreSQL database from the previous major
-version of PostgreSQL.
-
-
-%description upgrade -l pl.UTF-8
-The postgresql-upgrade package contains the pg_upgrade utility and supporting
-files needed for upgrading a PostgreSQL database from the previous major
-version of PostgreSQL.
-
 %prep
-%setup -q -a 7
+%setup -q
 %patch0 -p1
 %{?with_absolute_dbpaths:%patch1 -p1}
 %patch2 -p1
-%patch3 -p1
-%patch4 -p1
-%patch5 -p1
 
-cd postgresql-%{prevver}
-
-%patch0 -p1
-%{?with_absolute_dbpaths:%patch1 -p1}
-%patch2 -p1
 %patch4 -p1
 %patch5 -p1
 %patch6 -p1
-cd ..
 
 # force rebuild of bison/flex files
 find src -name \*.l -o -name \*.y | xargs touch
@@ -818,26 +784,29 @@ find src -name \*.l -o -name \*.y | xargs touch
 %build
 %{__aclocal} -I config
 %{__autoconf}
+%{__autoheader}
 %configure \
        CFLAGS="%{rpmcflags} -DNEED_REENTRANT_FUNCS `uuid-config --cflags`" \
        --disable-rpath \
        --enable-depend \
+       %{?with_systemtap:--enable-dtrace} \
        --enable-integer-datetimes \
-       --with-system-tzdata=%{_datadir}/zoneinfo \
        --enable-nls \
        --enable-thread-safety \
+       %{?with_bonjour:--with-bonjour} \
        %{?with_kerberos5:--with-gssapi} \
-       %{?with_kerberos5:--with-krb5} \
        %{?with_ldap:--with-ldap} \
-       --with-openssl \
-       --with-pam \
        --with-libxml \
        --with-libxslt \
+       --with-openssl \
+       --with-pam \
        %{?with_perl:--with-perl} \
        %{?with_python:--with-python} \
        %{?with_selinux:--with-selinux} \
+       --with-system-tzdata=%{_datadir}/zoneinfo \
+       %{?with_systemd:--with-systemd} \
        %{?with_tcl:--with-tcl --with-tclconfig=%{_ulibdir}} \
-       --with-ossp-uuid \
+       --with-uuid=e2fs
 
 %{__make}
 
@@ -855,41 +824,13 @@ done
 %{?with_tests:%{__make} -j1 check}
 %endif
 
-cd postgresql-%{prevver}
-%{__aclocal} -I config
-%{__autoconf}
-
-./configure \
-       CFLAGS="%{rpmcflags} -DNEED_REENTRANT_FUNCS `uuid-config --cflags`" \
-       --prefix=%{_libdir}/pgsql/postgresql-%{prevmver} \
-       --disable-rpath \
-       --enable-depend \
-       --enable-integer-datetimes \
-       --with-system-tzdata=%{_datadir}/zoneinfo \
-       --enable-nls \
-       --enable-thread-safety \
-       %{?with_kerberos5:--with-gssapi} \
-       %{?with_kerberos5:--with-krb5} \
-       %{?with_ldap:--with-ldap} \
-       --with-openssl \
-       --with-pam \
-       --with-libxml \
-       --with-libxslt \
-       %{?with_perl:--with-perl} \
-       %{?with_python:--with-python} \
-       %{?with_selinux:--with-selinux} \
-       %{?with_tcl:--with-tcl --with-tclconfig=%{_ulibdir}} \
-       --with-ossp-uuid \
-
-%{__make}
-cd ..
-
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{rc.d/init.d,sysconfig,init/%{name}}} \
+install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{rc.d/init.d,sysconfig}} \
        $RPM_BUILD_ROOT{/var/{lib/pgsql,log},%{_pgsqldir}} \
        $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version} \
        $RPM_BUILD_ROOT%{_mandir} \
+       $RPM_BUILD_ROOT{%{systemdunitdir},/etc/systemd/system/%{name}.target.requires} \
        $RPM_BUILD_ROOT/home/services/postgres
 
 install src/tutorial/*.sql $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
@@ -914,8 +855,9 @@ touch $RPM_BUILD_ROOT/var/log/pgsql
 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/postgresql
 install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/postgresql
 
-install %{SOURCE5} $RPM_BUILD_ROOT/etc/init/%{name}.conf
-install %{SOURCE6} $RPM_BUILD_ROOT/etc/init/%{name}/instance.conf
+install %{SOURCE4} $RPM_BUILD_ROOT%{systemdunitdir}/%{name}@.service
+install %{SOURCE5} $RPM_BUILD_ROOT%{systemdunitdir}/%{name}.service
+install %{SOURCE6} $RPM_BUILD_ROOT%{systemdunitdir}/%{name}.target
 
 install -d howto
 tar zxf %{SOURCE2} -C howto
@@ -926,13 +868,13 @@ tar zxf %{SOURCE2} -C howto
 %endif
 
 # find locales
-for f in libpq5 pg_basebackup pg_controldata pg_dump pg_resetxlog pgscripts postgres psql initdb pg_ctl pg_config plpgsql ecpg ecpglib6 %{?with_perl:plperl} plpgsql %{?with_python: plpython}; do
+for f in libpq5 pg_basebackup pg_controldata pg_dump pg_resetxlog pg_rewind pgscripts postgres psql initdb pg_ctl pg_config plpgsql ecpg ecpglib6 %{?with_perl:plperl} plpgsql %{?with_python: plpython}; do
        %find_lang $f-%{mver}
 done
 # merge locales
 cat pgscripts-%{mver}.lang pg_resetxlog-%{mver}.lang \
     postgres-%{mver}.lang pg_controldata-%{mver}.lang \
-    plpgsql-%{mver}.lang \
+    plpgsql-%{mver}.lang pg_rewind-%{mver}.lang \
     pg_basebackup-%{mver}.lang \
     > main-%{mver}.lang
 cat pg_dump-%{mver}.lang psql-%{mver}.lang initdb-%{mver}.lang \
@@ -953,49 +895,8 @@ install src/pl/plperl/ppport.h $RPM_BUILD_ROOT%{_includedir}/postgresql/server/
 # package it...?  nah, why bother.
 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/doc/postgresql/html
 
-cd postgresql-%{prevver}
-%{__make} install \
-        DESTDIR=$RPM_BUILD_ROOT/postgresql-%{prevmver}
-cd $RPM_BUILD_ROOT/postgresql-%{prevmver}%{_libdir}/pgsql/postgresql-%{prevmver}
-       rm bin/clusterdb
-       rm bin/createdb
-       rm bin/createlang
-       rm bin/createuser
-       rm bin/dropdb
-       rm bin/droplang
-       rm bin/dropuser
-       rm bin/ecpg
-       rm bin/initdb
-       rm bin/pg_basebackup
-       rm bin/pg_config
-       rm bin/pg_controldata
-       rm bin/pg_dump
-       rm bin/pg_dumpall
-       rm bin/pg_restore
-       rm bin/psql
-       rm bin/reindexdb
-       rm bin/vacuumdb
-       rm -rf include
-       rm lib/dict_snowball.so
-       rm lib/libecpg*
-       rm lib/libpg*
-       rm lib/libpq*
-       rm -rf lib/pgxs
-       rm lib/plpgsql.so
-       rm -rf share/doc
-       rm -rf share/man
-       rm -rf share/tsearch_data
-       rm share/*.bki
-       rm share/*description
-       rm share/*.sample
-       rm share/*.sql
-       rm share/*.txt
-       mkdir -p $RPM_BUILD_ROOT%{_libdir}/postgresql-%{prevmver}
-       cp -ra $RPM_BUILD_ROOT/postgresql-%{prevmver}%{_libdir}/pgsql/postgresql-%{prevmver}/* $RPM_BUILD_ROOT%{_libdir}/postgresql-%{prevmver}
-cd $RPM_BUILD_ROOT
-
 %clean
-#rm -rf $RPM_BUILD_ROOT
+rm -rf $RPM_BUILD_ROOT
 
 %pre
 PG_DB_CLUSTERS=""
@@ -1008,7 +909,7 @@ fi
 foundold=0
 for pgdir in $PG_DB_CLUSTERS; do
        if [ -f $pgdir/PG_VERSION ]; then
-               if [ $(cat $pgdir/PG_VERSION) != '9.1' ]; then
+               if [ $(cat $pgdir/PG_VERSION) != '%{mver}' ]; then
                        echo "Found database(s) in older, incompatible format in cluster $pgdir."
                        foundold=1
                fi
@@ -1045,18 +946,43 @@ fi
 %post
 /sbin/chkconfig --add postgresql
 %service postgresql restart "postgresql server"
+if [ "$1" -eq "1" ]; then
+       PG_DB_CLUSTERS=""
+       [ -f /etc/sysconfig/postgresql ] && . /etc/sysconfig/postgresql
+       export SYSTEMD_LOG_LEVEL=warning SYSTEMD_LOG_TARGET=syslog
+       for pgdir in $PG_DB_CLUSTERS; do
+               instance="$(echo "$pgdir" | sed -e 's/^\///;s/-/\\x2d/g;s/@/\\x40/g;s/\//-/g')"
+               /bin/systemctl --quiet enable "postgresql@$instance.service" || :
+       done
+fi
+%systemd_post postgresql.service
 
 %preun
 if [ "$1" = "0" ]; then
        %service postgresql stop
        /sbin/chkconfig --del postgresql
+
+       PG_DB_CLUSTERS=""
+       [ -f /etc/sysconfig/postgresql ] && . /etc/sysconfig/postgresql
+       export SYSTEMD_LOG_LEVEL=warning SYSTEMD_LOG_TARGET=syslog
+       for pgdir in $PG_DB_CLUSTERS; do
+               instance="$(echo "$pgdir" | sed -e 's/^\///;s/-/\\x2d/g;s/@/\\x40/g;s/\//-/g')"
+               /bin/systemctl --quiet disable "postgresql@$instance.service" || :
+       done
 fi
+%systemd_preun postgresql.service
 
-%post upstart
-%upstart_post postgresql
+%postun
+%systemd_reload
 
-%postun upstart
-%upstart_postun postgresql
+%triggerpostun -- %{name} < 9.3.3-2
+PG_DB_CLUSTERS=""
+[ -f /etc/sysconfig/postgresql ] && . /etc/sysconfig/postgresql
+for pgdir in $PG_DB_CLUSTERS; do
+       instance="$(echo "$pgdir" | sed -e 's/^\///;s/-/\\x2d/g;s/@/\\x40/g;s/\//-/g')"
+       /bin/systemctl --quiet enable "postgresql@$instance.service" || :
+done
+%systemd_trigger postgresql.service
 
 %post  libs -p /sbin/ldconfig
 %postun        libs -p /sbin/ldconfig
@@ -1069,6 +995,10 @@ fi
 %doc COPYRIGHT README HISTORY doc/{bug.template,KNOWN_BUGS,MISSING_FEATURES,TODO}
 %attr(754,root,root) /etc/rc.d/init.d/postgresql
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/postgresql
+%{systemdunitdir}/%{name}.service
+%{systemdunitdir}/%{name}@.service
+%{systemdunitdir}/%{name}.target
+%dir /etc/systemd/system/%{name}.target.requires
 
 %attr(755,root,root) %{_bindir}/initdb
 %attr(755,root,root) %{_bindir}/pg_basebackup
@@ -1076,6 +1006,13 @@ fi
 %attr(755,root,root) %{_bindir}/pg_ctl
 %attr(755,root,root) %{_bindir}/pg_resetxlog
 %attr(755,root,root) %{_bindir}/pg_receivexlog
+%attr(755,root,root) %{_bindir}/pg_recvlogical
+%attr(755,root,root) %{_bindir}/pg_rewind
+%attr(755,root,root) %{_bindir}/pg_test_fsync
+%attr(755,root,root) %{_bindir}/pg_test_timing
+%attr(755,root,root) %{_bindir}/pg_upgrade
+%attr(755,root,root) %{_bindir}/pg_xlogdump
+%attr(755,root,root) %{_bindir}/pgbench
 %attr(755,root,root) %{_bindir}/postgres
 %attr(755,root,root) %{_bindir}/postmaster
 
@@ -1116,25 +1053,16 @@ fi
 %{_mandir}/man1/pg_controldata.1*
 %{_mandir}/man1/pg_ctl.1*
 %{_mandir}/man1/pg_resetxlog.1*
+%{_mandir}/man1/pg_receivexlog.1*
+%{_mandir}/man1/pg_recvlogical.1*
+%{_mandir}/man1/pg_rewind.1*
+%{_mandir}/man1/pg_xlogdump.1*
+%{_mandir}/man1/pg_test_fsync.1*
+%{_mandir}/man1/pg_test_timing.1*
+%{_mandir}/man1/pg_upgrade.1*
+%{_mandir}/man1/pgbench.1*
 %{_mandir}/man1/postgres.1*
 %{_mandir}/man1/postmaster.1*
-%{_mandir}/man1/oid2name.1.gz
-%{_mandir}/man1/pg_archivecleanup.1.gz
-%{_mandir}/man1/pg_receivexlog.1.gz
-%{_mandir}/man1/pg_standby.1.gz
-%{_mandir}/man1/pg_test_fsync.1.gz
-%{_mandir}/man1/pg_test_timing.1.gz
-%{_mandir}/man1/pgbench.1.gz
-%{_mandir}/man1/vacuumlo.1.gz
-
-
-%if "%{pld_release}" != "ti"
-%files upstart
-%defattr(644,root,root,755)
-%config(noreplace) %verify(not md5 mtime size) /etc/init/postgresql.conf
-%dir /etc/init/postgresql
-%config(noreplace) %verify(not md5 mtime size) /etc/init/postgresql/instance.conf
-%endif
 
 %files doc
 %defattr(644,root,root,755)
@@ -1164,6 +1092,9 @@ fi
 %attr(755,root,root) %{_libdir}/libecpg_compat.so
 %attr(755,root,root) %{_libdir}/libpgtypes.so
 %{_includedir}/ecpg*
+%{_pkgconfigdir}/libecpg.pc
+%{_pkgconfigdir}/libecpg_compat.pc
+%{_pkgconfigdir}/libpgtypes.pc
 
 %files devel -f pg_config-%{mver}.lang
 %defattr(644,root,root,755)
@@ -1173,6 +1104,7 @@ fi
 %{_includedir}/libpq-events.h
 %{_includedir}/libpq-fe.h
 %{_includedir}/pg_config.h
+%{_includedir}/pg_config_ext.h
 %{_includedir}/pg_config_manual.h
 %{_includedir}/pg_config_os.h
 %{_includedir}/postgres_ext.h
@@ -1184,6 +1116,7 @@ fi
 %{_includedir}/postgresql/internal/pqexpbuffer.h
 %{_includedir}/postgresql/internal/libpq
 %{_includedir}/libpq
+%{_pkgconfigdir}/libpq.pc
 %{_mandir}/man1/pg_config.1*
 
 %files backend-devel
@@ -1199,6 +1132,8 @@ fi
 %{_libdir}/libecpg.a
 %{_libdir}/libecpg_compat.a
 %{_libdir}/libpq.a
+%{_libdir}/libpgcommon.a
+%{_libdir}/libpgfeutils.a
 %{_libdir}/libpgtypes.a
 %{_libdir}/libpgport.a
 
@@ -1211,8 +1146,10 @@ fi
 %attr(755,root,root) %{_bindir}/dropdb
 %attr(755,root,root) %{_bindir}/droplang
 %attr(755,root,root) %{_bindir}/dropuser
+%attr(755,root,root) %{_bindir}/pg_archivecleanup
 %attr(755,root,root) %{_bindir}/pg_dump
 %attr(755,root,root) %{_bindir}/pg_dumpall
+%attr(755,root,root) %{_bindir}/pg_isready
 %attr(755,root,root) %{_bindir}/pg_restore
 %attr(755,root,root) %{_bindir}/psql
 %attr(755,root,root) %{_bindir}/reindexdb
@@ -1225,8 +1162,10 @@ fi
 %{_mandir}/man1/dropdb.1*
 %{_mandir}/man1/droplang.1*
 %{_mandir}/man1/dropuser.1*
+%{_mandir}/man1/pg_archivecleanup.1*
 %{_mandir}/man1/pg_dump.1*
 %{_mandir}/man1/pg_dumpall.1*
+%{_mandir}/man1/pg_isready.1*
 %{_mandir}/man1/pg_restore.1*
 %{_mandir}/man1/psql.1*
 %{_mandir}/man1/reindexdb.1*
@@ -1286,10 +1225,12 @@ fi
 %{_pgsqldir}/pgcrypto--*.sql
 %{_pgsqldir}/pgcrypto.control
 
+%if %{with selinux}
 %files module-sepgsql
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_pgmoduledir}/sepgsql.so
 %{_pgsqldir}/sepgsql.sql
+%endif
 
 %files module-tablefunc
 %defattr(644,root,root,755)
@@ -1307,14 +1248,13 @@ fi
 %defattr(644,root,root,755)
 %doc contrib/README
 %attr(755,root,root) %{_bindir}/oid2name
-%attr(755,root,root) %{_bindir}/pg_archivecleanup
 %attr(755,root,root) %{_bindir}/pg_standby
-%attr(755,root,root) %{_bindir}/pgbench
 %attr(755,root,root) %{_bindir}/vacuumlo
 %attr(755,root,root) %{_pgmoduledir}/_int.so
 %attr(755,root,root) %{_pgmoduledir}/adminpack.so
 %attr(755,root,root) %{_pgmoduledir}/auth_delay.so
 %attr(755,root,root) %{_pgmoduledir}/auto_explain.so
+%attr(755,root,root) %{_pgmoduledir}/bloom.so
 %attr(755,root,root) %{_pgmoduledir}/btree_gin.so
 %attr(755,root,root) %{_pgmoduledir}/btree_gist.so
 %attr(755,root,root) %{_pgmoduledir}/chkpass.so
@@ -1330,15 +1270,23 @@ fi
 %attr(755,root,root) %{_pgmoduledir}/passwordcheck.so
 %attr(755,root,root) %{_pgmoduledir}/pg_buffercache.so
 %attr(755,root,root) %{_pgmoduledir}/pg_freespacemap.so
+%attr(755,root,root) %{_pgmoduledir}/pg_prewarm.so
 %attr(755,root,root) %{_pgmoduledir}/pg_stat_statements.so
+%attr(755,root,root) %{_pgmoduledir}/pg_visibility.so
 %attr(755,root,root) %{_pgmoduledir}/pgrowlocks.so
 %attr(755,root,root) %{_pgmoduledir}/pgstattuple.so
+%attr(755,root,root) %{_pgmoduledir}/postgres_fdw.so
 %attr(755,root,root) %{_pgmoduledir}/seg.so
 %attr(755,root,root) %{_pgmoduledir}/sslinfo.so
+%attr(755,root,root) %{_pgmoduledir}/tcn.so
+%attr(755,root,root) %{_pgmoduledir}/tsm_system_rows.so
+%attr(755,root,root) %{_pgmoduledir}/tsm_system_time.so
 %attr(755,root,root) %{_pgmoduledir}/unaccent.so
 %attr(755,root,root) %{_pgmoduledir}/uuid-ossp.so
 %{_pgsqldir}/adminpack--*.sql
 %{_pgsqldir}/adminpack.control
+%{_pgsqldir}/bloom--*.sql
+%{_pgsqldir}/bloom.control
 %{_pgsqldir}/btree_gin--*.sql
 %{_pgsqldir}/btree_gin.control
 %{_pgsqldir}/btree_gist--*.sql
@@ -1375,24 +1323,55 @@ fi
 %{_pgsqldir}/pg_buffercache.control
 %{_pgsqldir}/pg_freespacemap--*.sql
 %{_pgsqldir}/pg_freespacemap.control
+%{_pgsqldir}/pg_prewarm--*.sql
+%{_pgsqldir}/pg_prewarm.control
 %{_pgsqldir}/pg_stat_statements--*.sql
 %{_pgsqldir}/pg_stat_statements.control
+%{_pgsqldir}/pg_visibility--*.sql
+%{_pgsqldir}/pg_visibility.control
 %{_pgsqldir}/pgrowlocks--*.sql
 %{_pgsqldir}/pgrowlocks.control
 %{_pgsqldir}/pgstattuple--*.sql
 %{_pgsqldir}/pgstattuple.control
+%{_pgsqldir}/postgres_fdw--*.sql
+%{_pgsqldir}/postgres_fdw.control
 %{_pgsqldir}/seg--*.sql
 %{_pgsqldir}/seg.control
 %{_pgsqldir}/sslinfo--*.sql
 %{_pgsqldir}/sslinfo.control
+%{_pgsqldir}/tcn--*.sql
+%{_pgsqldir}/tcn.control
+%{_pgsqldir}/tsm_system_rows--*.sql
+%{_pgsqldir}/tsm_system_rows.control
+%{_pgsqldir}/tsm_system_time--*.sql
+%{_pgsqldir}/tsm_system_time.control
 %{_pgsqldir}/unaccent--*.sql
 %{_pgsqldir}/unaccent.control
 %{_pgsqldir}/uuid-ossp--*.sql
 %{_pgsqldir}/uuid-ossp.control
-
-%files upgrade
-%attr(755,root,root) %{_bindir}/pg_upgrade
-%attr(755,root,root) %{_pgmoduledir}/pg_upgrade_support.so
-%dir %{_libdir}/postgresql-%{prevmver}
-%{_libdir}/postgresql-%{prevmver}
-%{_mandir}/man1/pg_upgrade.1.gz
+%if %{with perl}
+%attr(755,root,root) %{_pgmoduledir}/hstore_plperl.so
+%{_pgsqldir}/hstore_plperl--*.sql
+%{_pgsqldir}/hstore_plperl.control
+%{_pgsqldir}/hstore_plperlu--*.sql
+%{_pgsqldir}/hstore_plperlu.control
+%endif
+%if %{with python}
+%attr(755,root,root) %{_pgmoduledir}/hstore_plpython2.so
+%attr(755,root,root) %{_pgmoduledir}/ltree_plpython2.so
+%{_pgsqldir}/hstore_plpythonu--*.sql
+%{_pgsqldir}/hstore_plpythonu.control
+%{_pgsqldir}/hstore_plpython2u--*.sql
+%{_pgsqldir}/hstore_plpython2u.control
+%{_pgsqldir}/hstore_plpython3u--*.sql
+%{_pgsqldir}/hstore_plpython3u.control
+%{_pgsqldir}/ltree_plpythonu--*.sql
+%{_pgsqldir}/ltree_plpythonu.control
+%{_pgsqldir}/ltree_plpython2u--*.sql
+%{_pgsqldir}/ltree_plpython2u.control
+%{_pgsqldir}/ltree_plpython3u--*.sql
+%{_pgsqldir}/ltree_plpython3u.control
+%endif
+%{_mandir}/man1/oid2name.1*
+%{_mandir}/man1/pg_standby.1*
+%{_mandir}/man1/vacuumlo.1*
This page took 0.423342 seconds and 4 git commands to generate.