]> git.pld-linux.org Git - packages/postfix.git/blob - postfix.spec
ffe982dbecfbfe953b0fbd274f75e9f8e69f3cc7
[packages/postfix.git] / postfix.spec
1 #
2 # Conditional build:
3 %bcond_without  ldap    # without LDAP map module
4 %bcond_without  mysql   # without MySQL map module
5 %bcond_without  pgsql   # without PostgreSQL map module
6 %bcond_without  sqlite  # without SQLite map module
7 %bcond_without  sasl    # without SMTP AUTH support
8 %bcond_without  ssl     # without SSL/TLS support
9 %bcond_without  cdb     # without cdb map support
10 %bcond_without  lmdb    # without lmdb map support
11 %bcond_with     vda     # with VDA patch
12 %bcond_with     hir     # with Beeth's header_if_reject patch
13 %bcond_with     tcp     # with unofficial tcp: lookup table
14 %if "%{pld_release}" == "ac"
15 %bcond_with             epoll   # enable epoll for 2.6 kernels
16 # there didn't exist x86_64 2.4 kernel in PLD, so can safely enable epoll
17 %ifarch %{x8664}
18 %define         with_epoll      1
19 %endif
20 %else
21 %bcond_without  epoll   # disable epoll for 2.4 kernels
22 %endif
23
24 %define         vda_ver v13-2.10.0
25 Summary:        Postfix Mail Transport Agent
26 Summary(cs.UTF-8):      Postfix - program pro přepravu pošty (MTA)
27 Summary(es.UTF-8):      Postfix - Un MTA (Mail Transport Agent) de alto desempeño
28 Summary(fr.UTF-8):      Agent de transport de courrier Postfix
29 Summary(pl.UTF-8):      Serwer SMTP Postfix
30 Summary(pt_BR.UTF-8):   Postfix - Um MTA (Mail Transport Agent) de alto desempenho
31 Summary(sk.UTF-8):      Agent prenosu pošty Postfix
32 Name:           postfix
33 Version:        3.3.1
34 Release:        1
35 Epoch:          2
36 License:        distributable
37 Group:          Networking/Daemons/SMTP
38 Source0:        ftp://ftp.porcupine.org/mirrors/postfix-release/official/%{name}-%{version}.tar.gz
39 # Source0-md5:  4381c6492f415e4a69cf5099d4acea76
40 Source1:        %{name}.aliases
41 Source2:        %{name}.cron
42 Source3:        %{name}.init
43 Source4:        %{name}.sysconfig
44 Source5:        %{name}.sasl
45 Source6:        %{name}.pamd
46 Source7:        %{name}-vda.patch
47 #Source7:       http://vda.sourceforge.net/VDA/%{name}-vda-%{vda_ver}.patch
48 # -ource7-md5:  01e1b031d79b85f3cb67d98ceddd775d
49 Source8:        %{name}-bounce.cf.pl
50 # http://postfix.state-of-mind.de/bounce-templates/bounce.de-DE.cf
51 Source9:        %{name}-bounce.cf.de
52 Source10:       %{name}.monitrc
53 Source11:       %{name}-vda-bigquota.patch
54 #Source11:      http://vda.sourceforge.net/VDA/%{name}-%{vda_ver}-vda-ng-bigquota.patch.gz
55 # -ource11-md5: d46103195b43ec5784ea2c166b238f71
56 Source12:       %{name}.service
57 Patch0:         %{name}-config.patch
58
59 Patch3:         %{name}-master.cf_cyrus.patch
60 # from http://akson.sgh.waw.pl/~chopin/unix/postfix-2.1.5-header_if_reject.diff
61 Patch4:         %{name}-header_if_reject.patch
62
63 Patch7:         %{name}-conf.patch
64 Patch8:         %{name}-dictname.patch
65
66 Patch11:        %{name}-scache_clnt.patch
67 Patch12:        format-security.patch
68 URL:            http://www.postfix.org/
69 %{?with_sasl:BuildRequires:     cyrus-sasl-devel}
70 BuildRequires:  db-devel
71 # getifaddrs() with IPv6 support
72 BuildRequires:  glibc-devel >= 6:2.3.4
73 %{?with_lmbd:BuildRequires:     lmdb-devel}
74 %{?with_mysql:BuildRequires:    mysql-devel}
75 %{?with_ldap:BuildRequires:     openldap-devel >= 2.0.12}
76 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.7l}
77 BuildRequires:  pcre-devel
78 BuildRequires:  perl-base
79 %{?with_pgsql:BuildRequires:    postgresql-devel}
80 BuildRequires:  rpm >= 4.4.9-56
81 BuildRequires:  rpmbuild(macros) >= 1.644
82 BuildRequires:  sed >= 4.0
83 %{?with_sqlite:BuildRequires:   sqlite3-devel}
84 %{?with_cdb:BuildRequires:      tinycdb-devel}
85 %{?with_mysql:BuildRequires:    zlib-devel}
86 Requires(post): /bin/hostname
87 Requires(post,postun):  /sbin/ldconfig
88 Requires(post,preun):   /sbin/chkconfig
89 Requires(postun):       /usr/sbin/groupdel
90 Requires(postun):       /usr/sbin/userdel
91 Requires(pre):  /bin/id
92 Requires(pre):  /usr/bin/getgid
93 Requires(pre):  /usr/sbin/groupadd
94 Requires(pre):  /usr/sbin/useradd
95 Requires:       /sbin/chkconfig
96 Requires:       diffutils
97 Requires:       findutils
98 Requires:       rc-scripts
99 Requires:       sed
100 %{?with_cdb:Requires:tinycdb}
101 Requires:       systemd-units >= 38
102 Suggests:       cyrus-sasl-saslauthd
103 Provides:       group(postfix)
104 Provides:       smtpdaemon
105 Provides:       user(postfix)
106 Obsoletes:      smtpdaemon
107 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
108
109 %description
110 Postfix is attempt to provide an alternative to the widely-used
111 Sendmail program. Postfix attempts to be fast, easy to administer, and
112 hopefully secure, while at the same time being sendmail compatible
113 enough to not upset your users. This version has IPv6 support.
114
115 %description -l es.UTF-8
116 Postfix es una alternativa para el mundialmente utilizado sendmail. Si
117 desea tener un servidor SMTP *rápido*, debe instalar este paquete.
118
119 %description -l fr.UTF-8
120 Postfix (voir http://www.postfix.org/) se veut une alternative à
121 sendmail, responsable de l'acheminement de 70% des courriers
122 électroniques sur Internet. IBM en a suppotré le développement, mais
123 ne contrôle pas son évolution. Le but est d'installer Postfix sur le
124 plus grand nombre de systèmes possible. Dans cette optique, il a été
125 écrit pour être totalement sous le contrôle de l'utilisateur.
126
127 %description -l it.UTF-8
128 Postfix (http://www.postfix.org/) e' un'alternativa al programma
129 sendmail utilizzato per la gestione del 70 per cento della posta
130 Internet.
131
132 Seppur IBM supporti lo sviluppo di Postfix, non controlla la sua
133 evoluzione.
134
135 Consultate la pagine web http://www.moongroup.com/how-to.phtml nella
136 quale troverete le indicazioni per una corretta installazione e
137 configurazione di questo programma.
138
139 %description -l pl.UTF-8
140 Postfix jest próbą dostarczenia alternatywnego MTA w stosunku do
141 szeroko używanego sendmaila. Postfix w zamierzeniu ma być szybki,
142 łatwy w administrowaniu, bezpieczny oraz ma być na tyle kompatybilny z
143 sendmailem by nie denerwować użytkowników. Ta wersja obsługuje IPv6.
144
145 %description -l pt_BR.UTF-8
146 O Postfix é uma alternativa para o mundialmente utilizado sendmail. Se
147 você deseja um servidor SMTP *rápido*, instale este pacote.
148
149 %description -l sk.UTF-8
150 Postfix (pozri http://www.postfix.org/) má za cieľ byť alternatívou k
151 široko rozšírenému programu sendmail, zodpovednému za 70% všetkej
152 elektronickej pošty doručenej na Internete.
153
154 Aj keď IBM podporovala vývoj Postfixu, zdržiava sa vplyvu na jeho
155 vývoj. Cieľom je inštalácia Postfixu na čo najväčšom počte systémov.
156 Do tohoto momentu je softvér poskytovaný bez ovplyvňovania, takže sa
157 môže vyvíjať podľa jeho používateľov.
158
159 Určite si prečítajte http://www.moongroup.com/how-to.phtml, kde sú
160 popísané kroky potrebné pred a po inštalácii Postfixu.
161
162 %package devel
163 Summary:        Postfix loadable modules development package
164 Summary(pl.UTF-8):      Pakiet dla programistów ładowanych modułów do postfiksa
165 Group:          Development/Libraries
166 Requires:       %{name} = %{epoch}:%{version}-%{release}
167
168 %description devel
169 Header files to build additional map types for Postfix.
170
171 %description devel -l pl.UTF-8
172 Pliki nagłówkowe do tworzenia dodatkowych typów map dla Postfiksa.
173
174 %package dict-ldap
175 Summary:        LDAP map support for Postfix
176 Summary(pl.UTF-8):      Obsługa map LDAP dla Postfiksa
177 Group:          Networking/Daemons/SMTP
178 Requires:       %{name} = %{epoch}:%{version}-%{release}
179 Requires:       openldap >= 2.3.6
180
181 %description dict-ldap
182 This package provides support for LDAP maps in Postfix.
183
184 %description dict-ldap -l pl.UTF-8
185 Ten pakiet dodaje obsługę map LDAP do Postfiksa.
186
187 %package dict-mysql
188 Summary:        MySQL map support for Postfix
189 Summary(pl.UTF-8):      Obsługa map MySQL dla Postfiksa
190 Group:          Networking/Daemons/SMTP
191 Requires:       %{name} = %{epoch}:%{version}-%{release}
192
193 %description dict-mysql
194 This package provides support for MySQL maps in Postfix.
195
196 %description dict-mysql -l pl.UTF-8
197 Ten pakiet dodaje obsługę map MySQL do Postfiksa.
198
199 %package dict-pcre
200 Summary:        PCRE map support for Postfix
201 Summary(pl.UTF-8):      Obsługa map PCRE dla Postfiksa
202 Group:          Networking/Daemons/SMTP
203 Requires:       %{name} = %{epoch}:%{version}-%{release}
204
205 %description dict-pcre
206 This package provides support for PCRE maps in Postfix.
207
208 %description dict-pcre -l pl.UTF-8
209 Ten pakiet dodaje obsługę map PCRE do Postfiksa.
210
211 %package dict-pgsql
212 Summary:        PostgreSQL map support for Postfix
213 Summary(pl.UTF-8):      Obsługa map PostgreSQL dla Postfiksa
214 Group:          Networking/Daemons/SMTP
215 Requires:       %{name} = %{epoch}:%{version}-%{release}
216
217 %description dict-pgsql
218 This package provides support for PostgreSQL maps in Postfix.
219
220 %description dict-pgsql -l pl.UTF-8
221 Ten pakiet dodaje obsługę map PostgreSQL do Postfiksa.
222
223 %package dict-sqlite
224 Summary:        SQLite map support for Postfix
225 Summary(pl.UTF-8):      Obsługa map SQLite dla Postfiksa
226 Group:          Networking/Daemons/SMTP
227 Requires:       %{name} = %{epoch}:%{version}-%{release}
228
229 %description dict-sqlite
230 This package provides support for SQLite maps in Postfix.
231
232 %description dict-sqlite -l pl.UTF-8
233 Ten pakiet dodaje obsługę map SQLite do Postfiksa.
234
235 %package dict-lmdb
236 Summary:        LMDB map support for Postfix
237 Summary(pl.UTF-8):      Obsługa map LMDB dla Postfiksa
238 Group:          Networking/Daemons/SMTP
239 Requires:       %{name} = %{epoch}:%{version}-%{release}
240
241 %description dict-lmdb
242 This package provides support for LMDB maps in Postfix.
243
244 %description dict-lmdb -l pl.UTF-8
245 Ten pakiet dodaje obsługę map LMDB do Postfiksa.
246
247 %package dict-cdb
248 Summary:        CDB map support for Postfix
249 Summary(pl.UTF-8):      Obsługa map CDB dla Postfiksa
250 Group:          Networking/Daemons/SMTP
251 Requires:       %{name} = %{epoch}:%{version}-%{release}
252
253 %description dict-cdb
254 This package provides support for CDB maps in Postfix.
255
256 %description dict-cdb -l pl.UTF-8
257 Ten pakiet dodaje obsługę map CDB do Postfiksa.
258
259 %package qshape
260 Summary:        qshape - Print Postfix queue domain and age distribution
261 Summary(pl.UTF-8):      qshape - wypisywanie rozkładu domen i wieku z kolejki Postfiksa
262 Group:          Networking/Daemons/SMTP
263 Requires:       %{name} = %{epoch}:%{version}-%{release}
264
265 %description qshape
266 The qshape program helps the administrator understand the Postfix
267 queue message distribution in time and by sender domain or recipient
268 domain. The program needs read access to the queue directories and
269 queue files, so it must run as the superuser or the mail_owner
270 specified in main.cf (typically postfix).
271
272 %description qshape -l pl.UTF-8
273 Program qshape pomaga administratorowi zrozumieć rozkład kolejki
274 wiadomości Postfiksa w czasie i w zależności od domeny nadawcy lub
275 adresata. Program wymaga prawa odczytu do katalogów kolejki i plików
276 kolejki, więc musi być uruchamiany przez superużytkownika lub
277 użytkownika mail_owner podanego w main.cf (zwykle nazywającego się
278 postfix).
279
280 %package -n monit-rc-%{name}
281 Summary:        monit support for Postfix
282 Summary(pl.UTF-8):      Wsparcie monita dla Postfiksa
283 Group:          Applications/System
284 Requires:       %{name} = %{epoch}:%{version}-%{release}
285 Requires:       monit
286
287 %description -n monit-rc-%{name}
288 monitrc file for monitoring Postfix.
289
290 %description -n monit-rc-%{name} -l pl.UTF-8
291 Plik monitrc do monitorowania serwera Postfix.
292
293 %prep
294 %setup -q
295 %if %{with vda}
296 cat %{SOURCE7} | %{__patch} -p1 -s
297 cat %{SOURCE11} | %{__patch} -p1 -s
298 %endif
299
300 find -type f | xargs sed -i -e 's|/etc/postfix|/etc/mail|g'
301
302 %patch0 -p1
303
304 %patch3 -p1
305 %{?with_hir:%patch4 -p0}
306
307 sed -i '/scache_clnt_create/s/server/var_scache_service/' src/global/scache_clnt.c
308 %patch7 -p1
309 %patch8 -p1
310
311 %patch11 -p1
312 %if %{with vda}
313 %patch12 -p1
314 %endif
315
316 %if %{with tcp}
317 sed -i 's/ifdef SNAPSHOT/if 1/' src/util/dict_open.c
318 %endif
319
320 %build
321 # export, as the same variables must be passed both to 'make makefiles' and 'make'
322 export CCARGS="%{!?with_epoll:-DNO_EPOLL} %{?with_ldap:-DHAS_LDAP} -DHAS_PCRE %{?with_sasl:-DUSE_SASL_AUTH -DUSE_CYRUS_SASL -I/usr/include/sasl} %{?with_mysql:-DHAS_MYSQL -I/usr/include/mysql} %{?with_pgsql:-DHAS_PGSQL} %{?with_ssl:-DUSE_TLS} -DMAX_DYNAMIC_MAPS %{?with_cdb:-DHAS_CDB} %{?with_sqlite:-DHAS_SQLITE} %{?with_lmdb:-DHAS_LMDB} -LHAS_SDBM"
323 export AUXLIBS="%{rpmldflags} -lsasl -lssl -lcrypto -ldb -lresolv"
324 export AUXLIBS_CDB="%{?with_cdb:-lcdb}"
325 export AUXLIBS_LDAP="%{?with_ldap:-lldap -llber}"
326 export AUXLIBS_LMDB="%{?with_lmdb:-llmdb}"
327 export AUXLIBS_MYSQL="%{?with_mysql:-lmysqlclient}"
328 export AUXLIBS_PCRE="-lpcre"
329 export AUXLIBS_PGSQL="%{?with_pgsql:-lpq}"
330 export AUXLIBS_SQLITE="%{?with_sqlite:-lsqlite3}"
331
332 export CC="%{__cc}"
333 %{__make} makefiles \
334         shared=yes dynamicmaps=yes \
335         daemon_directory="%{_libdir}/postfix" \
336         shlib_directory="%{_libdir}/postfix" \
337         manpage_directory="%{_mandir}"
338
339 %{__make} -j1 \
340         DEBUG="" \
341         OPT="%{rpmcflags} %{rpmcppflags} -D_FILE_OFFSET_BITS=64"
342
343 %install
344 rm -rf $RPM_BUILD_ROOT
345 install -d $RPM_BUILD_ROOT/etc/{cron.daily,rc.d/init.d,sysconfig,pam.d,security,monit} \
346         $RPM_BUILD_ROOT%{_sysconfdir}/{mail,sasl} \
347         $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_libdir}/postfix,/usr/lib}\
348         $RPM_BUILD_ROOT{%{_includedir}/postfix,%{_mandir}} \
349         $RPM_BUILD_ROOT%{_var}/spool/postfix/{active,corrupt,deferred,maildrop,private,saved,bounce,defer,incoming,pid,public} \
350         $RPM_BUILD_ROOT%{_var}/lib/postfix \
351         $RPM_BUILD_ROOT%{systemdunitdir}
352
353 %{__make} non-interactive-package \
354        install_root=$RPM_BUILD_ROOT
355
356 #cp -a conf/* $RPM_BUILD_ROOT%{_sysconfdir}/mail
357 sed -e's,^daemon_directory = .*,daemon_directory = %{_libdir}/postfix,' \
358         conf/main.cf > $RPM_BUILD_ROOT%{_sysconfdir}/mail/main.cf
359
360 cp -a include/*.h $RPM_BUILD_ROOT%{_includedir}/postfix
361
362 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/mail/aliases
363 install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.daily/postfix
364 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/postfix
365 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/postfix
366 cp -a %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/sasl/smtpd.conf
367 cp -a %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/smtp
368 cp -a %{SOURCE8} $RPM_BUILD_ROOT%{_sysconfdir}/mail/bounce.cf.pl
369 cp -a %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/mail/bounce.cf.de
370 cp -a %{SOURCE10} $RPM_BUILD_ROOT/etc/monit/%{name}.monitrc
371 cp -a %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}/%{name}.service
372 install -p auxiliary/rmail/rmail $RPM_BUILD_ROOT%{_bindir}/rmail
373 install -p auxiliary/qshape/qshape.pl $RPM_BUILD_ROOT%{_bindir}/qshape
374
375 ln -sf %{_sbindir}/sendmail $RPM_BUILD_ROOT%{_bindir}/mailq
376 ln -sf %{_sbindir}/sendmail $RPM_BUILD_ROOT%{_bindir}/newaliases
377 ln -sf %{_sbindir}/sendmail $RPM_BUILD_ROOT/usr/lib/sendmail
378
379 touch $RPM_BUILD_ROOT%{_sysconfdir}/mail/\
380         {aliases,access,canonical,relocated,transport,virtual}{,.db}
381
382 touch $RPM_BUILD_ROOT/etc/security/blacklist.smtp
383
384 > $RPM_BUILD_ROOT/var/spool/postfix/.nofinger
385
386 %{__rm} -r $RPM_BUILD_ROOT%{_sysconfdir}/mail/makedefs.out
387 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/mail/{,TLS_}LICENSE
388
389 %clean
390 rm -rf $RPM_BUILD_ROOT
391
392 %pre
393 %groupadd -g 62 postfix
394 %groupadd -g 63 maildrop
395 %useradd -u 62 -d /var/spool/postfix -s /bin/false -c "Postfix User" -g postfix postfix
396
397 %post
398 /sbin/ldconfig
399 if ! grep -q "^postmaster:" %{_sysconfdir}/mail/aliases; then
400         echo "Adding Entry for postmaster in %{_sysconfdir}/mail/aliases" >&2
401         echo "postmaster: root" >>%{_sysconfdir}/mail/aliases
402 fi
403 if [ "$1" = "1" ]; then
404         # only on installation, not upgrade; set sane defaults
405         # postfix expects gethostname() to return FQDN, which is obviously wrong
406         if ! grep -qE "^my(domain|hostname)" %{_sysconfdir}/mail/main.cf; then
407                 domain=$(/bin/hostname -d 2>/dev/null)
408                 [ -n "$domain" -a "$domain" != 'localdomain' ] && \
409                         postconf -e mydomain="$domain"
410         fi
411 else
412         %{_sbindir}/postfix upgrade-configuration
413 fi
414
415 %{_bindir}/newaliases
416 /sbin/chkconfig --add postfix
417 %service postfix restart "Postfix Daemon"
418 %systemd_post postfix.service
419
420 %preun
421 if [ "$1" = "0" ]; then
422         %service postfix stop
423         /sbin/chkconfig --del postfix
424 fi
425 %systemd_preun postfix.service
426
427 %postun
428 /sbin/ldconfig
429 if [ "$1" = "0" ]; then
430         %groupremove maildrop
431         %userremove postfix
432         %groupremove postfix
433 fi
434 %systemd_reload
435
436 %triggerpostun -- postfix < 2:2.9.4-4
437 %systemd_trigger postfix.service
438
439 %files
440 %defattr(644,root,root,755)
441 %doc html COMPATIBILITY HISTORY LICENSE RELEASE_NOTES* TLS_*
442 %doc README_FILES/*README
443 %doc examples/smtpd-policy
444 %dir %{_sysconfdir}/mail
445 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/access
446 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/aliases
447 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/bounce.cf.default
448 %lang(de) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/bounce.cf.de
449 %lang(pl) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/bounce.cf.pl
450 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/canonical
451 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/generic
452 #%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/regexp_table
453 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/relocated
454 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/transport
455 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/virtual
456 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/header_checks
457 #%ghost %{_sysconfdir}/mail/*.db
458 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/dynamicmaps.cf
459 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/main.cf
460 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/main.cf.default
461 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/main.cf.proto
462 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/master.cf
463 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/master.cf.proto
464 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/postfix-files
465 %attr(740,root,root) /etc/cron.daily/postfix
466 %attr(754,root,root) /etc/rc.d/init.d/postfix
467 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/postfix
468 %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/smtp
469 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.smtp
470 %{?with_sasl:%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sasl/smtpd.conf}
471 %attr(755,root,root) %{_bindir}/mailq
472 %attr(755,root,root) %{_bindir}/newaliases
473 %attr(755,root,root) %{_bindir}/rmail
474 %attr(755,root,root) %{_sbindir}/s*
475 %attr(755,root,root) %{_sbindir}/postfix
476 %attr(755,root,root) %{_sbindir}/postalias
477 %attr(755,root,root) %{_sbindir}/postkick
478 %attr(755,root,root) %{_sbindir}/postl*
479 %attr(755,root,root) %{_sbindir}/postc*
480 %attr(755,root,root) %{_sbindir}/postmap
481 %attr(755,root,root) %{_sbindir}/postmulti
482 %attr(2755,root,maildrop) %{_sbindir}/postqueue
483 %attr(755,root,root) %{_sbindir}/postsuper
484 %attr(2755,root,maildrop) %{_sbindir}/postdrop
485 %attr(755,root,root) /usr/lib/sendmail
486 %dir %{_libdir}/postfix
487 %attr(755,root,root) %{_libdir}/postfix/anvil
488 %attr(755,root,root) %{_libdir}/postfix/bounce
489 %attr(755,root,root) %{_libdir}/postfix/cleanup
490 %attr(755,root,root) %{_libdir}/postfix/discard
491 %attr(755,root,root) %{_libdir}/postfix/dnsblog
492 %attr(755,root,root) %{_libdir}/postfix/error
493 %attr(755,root,root) %{_libdir}/postfix/flush
494 %attr(755,root,root) %{_libdir}/postfix/libpostfix-dns.so
495 %attr(755,root,root) %{_libdir}/postfix/libpostfix-global.so
496 %attr(755,root,root) %{_libdir}/postfix/libpostfix-master.so
497 %attr(755,root,root) %{_libdir}/postfix/libpostfix-tls.so
498 %attr(755,root,root) %{_libdir}/postfix/libpostfix-util.so
499 %attr(755,root,root) %{_libdir}/postfix/lmtp
500 %attr(755,root,root) %{_libdir}/postfix/local
501 %attr(755,root,root) %{_libdir}/postfix/master
502 %attr(755,root,root) %{_libdir}/postfix/nqmgr
503 %attr(755,root,root) %{_libdir}/postfix/oqmgr
504 %attr(755,root,root) %{_libdir}/postfix/pickup
505 %attr(755,root,root) %{_libdir}/postfix/pipe
506 %attr(755,root,root) %{_libdir}/postfix/postfix-script
507 %attr(755,root,root) %{_libdir}/postfix/postfix-tls-script
508 %attr(755,root,root) %{_libdir}/postfix/postfix-wrapper
509 %attr(755,root,root) %{_libdir}/postfix/post-install
510 %attr(755,root,root) %{_libdir}/postfix/postmulti-script
511 %attr(755,root,root) %{_libdir}/postfix/postscreen
512 %attr(755,root,root) %{_libdir}/postfix/proxymap
513 %attr(755,root,root) %{_libdir}/postfix/qmgr
514 %attr(755,root,root) %{_libdir}/postfix/qmqpd
515 %attr(755,root,root) %{_libdir}/postfix/scache
516 %attr(755,root,root) %{_libdir}/postfix/showq
517 %attr(755,root,root) %{_libdir}/postfix/smtp
518 %attr(755,root,root) %{_libdir}/postfix/smtpd
519 %attr(755,root,root) %{_libdir}/postfix/spawn
520 %attr(755,root,root) %{_libdir}/postfix/tlsmgr
521 %attr(755,root,root) %{_libdir}/postfix/tlsproxy
522 %attr(755,root,root) %{_libdir}/postfix/trivial-rewrite
523 %attr(755,root,root) %{_libdir}/postfix/verify
524 %attr(755,root,root) %{_libdir}/postfix/virtual
525 %attr(755,root,root) %dir %{_var}/spool/postfix
526 %attr(700,postfix,root) %dir %{_var}/spool/postfix/active
527 %attr(700,postfix,root) %dir %{_var}/spool/postfix/bounce
528 %attr(700,postfix,root) %dir %{_var}/spool/postfix/corrupt
529 %attr(700,postfix,root) %dir %{_var}/spool/postfix/defer
530 %attr(700,postfix,root) %dir %{_var}/spool/postfix/deferred
531 %attr(700,postfix,root) %dir %{_var}/spool/postfix/incoming
532 %attr(1730,postfix,maildrop) %dir %{_var}/spool/postfix/maildrop
533 %attr(755,root,root) %dir %{_var}/spool/postfix/pid
534 %attr(700,postfix,root) %dir %{_var}/spool/postfix/private
535 %attr(710,postfix,maildrop) %dir %{_var}/spool/postfix/public
536 %attr(700,postfix,root) %dir %{_var}/spool/postfix/saved
537 %attr(644,postfix,root) %{_var}/spool/postfix/.nofinger
538 %attr(700,postfix,root) %{_var}/lib/postfix
539 %{_mandir}/man1/mailq.1*
540 %{_mandir}/man1/newaliases.1*
541 %{_mandir}/man1/post*.1*
542 %{_mandir}/man1/sendmail.1*
543 %{_mandir}/man5/access.5*
544 %{_mandir}/man5/aliases.5*
545 %{_mandir}/man5/body_checks.5*
546 %{_mandir}/man5/bounce.5*
547 %{_mandir}/man5/canonical.5*
548 %{_mandir}/man5/cidr_table.5*
549 %{_mandir}/man5/generic.5*
550 %{_mandir}/man5/header_checks.5*
551 %{_mandir}/man5/master.5*
552 %{_mandir}/man5/memcache_table.5*
553 %{_mandir}/man5/nisplus_table.5*
554 %{_mandir}/man5/postconf.5*
555 %{_mandir}/man5/postfix-wrapper.5*
556 %{_mandir}/man5/regexp_table.5*
557 %{_mandir}/man5/relocated.5*
558 %{_mandir}/man5/socketmap_table.5*
559 %{_mandir}/man5/tcp_table.5*
560 %{_mandir}/man5/transport.5*
561 %{_mandir}/man5/virtual.5*
562 %{_mandir}/man8/*.8*
563 %{systemdunitdir}/%{name}.service
564
565 %files devel
566 %defattr(644,root,root,755)
567 %{_includedir}/postfix
568
569 %if %{with ldap}
570 %files dict-ldap
571 %defattr(644,root,root,755)
572 %attr(755,root,root) %{_libdir}/postfix/postfix-ldap.so
573 %{_mandir}/man5/ldap_table.5*
574 %endif
575
576 %if %{with mysql}
577 %files dict-mysql
578 %defattr(644,root,root,755)
579 %attr(755,root,root) %{_libdir}/postfix/postfix-mysql.so
580 %{_mandir}/man5/mysql_table.5*
581 %endif
582
583 %files dict-pcre
584 %defattr(644,root,root,755)
585 %attr(755,root,root) %{_libdir}/postfix/postfix-pcre.so
586 #%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/pcre_table
587 %{_mandir}/man5/pcre_table.5*
588
589 %if %{with pgsql}
590 %files dict-pgsql
591 %defattr(644,root,root,755)
592 %attr(755,root,root) %{_libdir}/postfix/postfix-pgsql.so
593 %{_mandir}/man5/pgsql_table.5*
594 %endif
595
596 %if %{with sqlite}
597 %files dict-sqlite
598 %defattr(644,root,root,755)
599 %attr(755,root,root) %{_libdir}/postfix/postfix-sqlite.so
600 %{_mandir}/man5/sqlite_table.5*
601 %endif
602
603 %if %{with lmdb}
604 %files dict-lmdb
605 %defattr(644,root,root,755)
606 %attr(755,root,root) %{_libdir}/postfix/postfix-lmdb.so
607 %{_mandir}/man5/lmdb_table.5*
608 %endif
609
610 %if %{with cdb}
611 %files dict-cdb
612 %attr(755,root,root) %{_libdir}/postfix/postfix-cdb.so
613 %endif
614
615 %files qshape
616 %defattr(644,root,root,755)
617 %attr(755,root,root) %{_bindir}/qshape
618
619 %files -n monit-rc-%{name}
620 %defattr(644,root,root,755)
621 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}.monitrc
This page took 0.085044 seconds and 2 git commands to generate.