]> git.pld-linux.org Git - packages/postfix.git/blob - postfix.spec
- icu 67 rebuild
[packages/postfix.git] / postfix.spec
1 #
2 # Conditional build:
3 %bcond_without  ldap    # without LDAP map module
4 %bcond_without  mysql   # without MySQL map module
5 %bcond_without  pgsql   # without PostgreSQL map module
6 %bcond_without  sqlite  # without SQLite map module
7 %bcond_without  sasl    # without SMTP AUTH support
8 %bcond_without  ssl     # without SSL/TLS support
9 %bcond_without  cdb     # without cdb map support
10 %bcond_without  lmdb    # without lmdb map support
11 %bcond_with     vda     # with VDA patch
12 %bcond_with     hir     # with Beeth's header_if_reject patch
13 %bcond_with     tcp     # with unofficial tcp: lookup table
14 %if "%{pld_release}" == "ac"
15 %bcond_with             epoll   # enable epoll for 2.6 kernels
16 # there didn't exist x86_64 2.4 kernel in PLD, so can safely enable epoll
17 %ifarch %{x8664}
18 %define         with_epoll      1
19 %endif
20 %else
21 %bcond_without  epoll   # disable epoll for 2.4 kernels
22 %endif
23
24 %define         vda_ver v13-2.10.0
25 Summary:        Postfix Mail Transport Agent
26 Summary(cs.UTF-8):      Postfix - program pro přepravu pošty (MTA)
27 Summary(es.UTF-8):      Postfix - Un MTA (Mail Transport Agent) de alto desempeño
28 Summary(fr.UTF-8):      Agent de transport de courrier Postfix
29 Summary(pl.UTF-8):      Serwer SMTP Postfix
30 Summary(pt_BR.UTF-8):   Postfix - Um MTA (Mail Transport Agent) de alto desempenho
31 Summary(sk.UTF-8):      Agent prenosu pošty Postfix
32 Name:           postfix
33 Version:        3.5.0
34 Release:        2
35 Epoch:          2
36 License:        distributable
37 Group:          Networking/Daemons/SMTP
38 Source0:        ftp://ftp.porcupine.org/mirrors/postfix-release/official/%{name}-%{version}.tar.gz
39 # Source0-md5:  f6a48f369cf8d693d7b0f8ab51f0fc9b
40 Source1:        %{name}.aliases
41 Source2:        %{name}.cron
42 Source3:        %{name}.init
43 Source4:        %{name}.sysconfig
44 Source5:        %{name}.sasl
45 Source6:        %{name}.pamd
46 Source7:        %{name}-vda.patch
47 #Source7:       http://vda.sourceforge.net/VDA/%{name}-vda-%{vda_ver}.patch
48 # -ource7-md5:  01e1b031d79b85f3cb67d98ceddd775d
49 Source8:        %{name}-bounce.cf.pl
50 # http://postfix.state-of-mind.de/bounce-templates/bounce.de-DE.cf
51 Source9:        %{name}-bounce.cf.de
52 Source10:       %{name}.monitrc
53 Source11:       %{name}-vda-bigquota.patch
54 #Source11:      http://vda.sourceforge.net/VDA/%{name}-%{vda_ver}-vda-ng-bigquota.patch.gz
55 # -ource11-md5: d46103195b43ec5784ea2c166b238f71
56 Source12:       %{name}.service
57 Patch0:         %{name}-config.patch
58
59 Patch3:         %{name}-master.cf_cyrus.patch
60 # from http://akson.sgh.waw.pl/~chopin/unix/postfix-2.1.5-header_if_reject.diff
61 Patch4:         %{name}-header_if_reject.patch
62
63 Patch7:         %{name}-conf.patch
64 Patch8:         %{name}-dictname.patch
65
66 Patch11:        %{name}-scache_clnt.patch
67 Patch12:        format-security.patch
68 URL:            http://www.postfix.org/
69 %{?with_sasl:BuildRequires:     cyrus-sasl-devel}
70 BuildRequires:  db-devel
71 # getifaddrs() with IPv6 support
72 BuildRequires:  glibc-devel >= 6:2.3.4
73 BuildRequires:  libicu-devel
74 %{?with_lmbd:BuildRequires:     lmdb-devel}
75 %{?with_mysql:BuildRequires:    mysql-devel}
76 %{?with_ldap:BuildRequires:     openldap-devel >= 2.0.12}
77 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.7l}
78 BuildRequires:  pcre-devel
79 BuildRequires:  perl-base
80 %{?with_pgsql:BuildRequires:    postgresql-devel}
81 BuildRequires:  rpm >= 4.4.9-56
82 BuildRequires:  rpmbuild(macros) >= 1.644
83 BuildRequires:  sed >= 4.0
84 %{?with_sqlite:BuildRequires:   sqlite3-devel}
85 %{?with_cdb:BuildRequires:      tinycdb-devel}
86 %{?with_mysql:BuildRequires:    zlib-devel}
87 Requires(post): /bin/hostname
88 Requires(post,postun):  /sbin/ldconfig
89 Requires(post,preun):   /sbin/chkconfig
90 Requires(postun):       /usr/sbin/groupdel
91 Requires(postun):       /usr/sbin/userdel
92 Requires(pre):  /bin/id
93 Requires(pre):  /usr/bin/getgid
94 Requires(pre):  /usr/sbin/groupadd
95 Requires(pre):  /usr/sbin/useradd
96 Requires:       /sbin/chkconfig
97 Requires:       diffutils
98 Requires:       findutils
99 Requires:       rc-scripts
100 Requires:       sed
101 %{?with_cdb:Requires:tinycdb}
102 Requires:       systemd-units >= 38
103 Suggests:       cyrus-sasl-saslauthd
104 Provides:       group(postfix)
105 Provides:       smtpdaemon
106 Provides:       user(postfix)
107 Obsoletes:      smtpdaemon
108 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
109
110 %description
111 Postfix is attempt to provide an alternative to the widely-used
112 Sendmail program. Postfix attempts to be fast, easy to administer, and
113 hopefully secure, while at the same time being sendmail compatible
114 enough to not upset your users. This version has IPv6 support.
115
116 %description -l es.UTF-8
117 Postfix es una alternativa para el mundialmente utilizado sendmail. Si
118 desea tener un servidor SMTP *rápido*, debe instalar este paquete.
119
120 %description -l fr.UTF-8
121 Postfix (voir http://www.postfix.org/) se veut une alternative à
122 sendmail, responsable de l'acheminement de 70% des courriers
123 électroniques sur Internet. IBM en a suppotré le développement, mais
124 ne contrôle pas son évolution. Le but est d'installer Postfix sur le
125 plus grand nombre de systèmes possible. Dans cette optique, il a été
126 écrit pour être totalement sous le contrôle de l'utilisateur.
127
128 %description -l it.UTF-8
129 Postfix (http://www.postfix.org/) e' un'alternativa al programma
130 sendmail utilizzato per la gestione del 70 per cento della posta
131 Internet.
132
133 Seppur IBM supporti lo sviluppo di Postfix, non controlla la sua
134 evoluzione.
135
136 Consultate la pagine web http://www.moongroup.com/how-to.phtml nella
137 quale troverete le indicazioni per una corretta installazione e
138 configurazione di questo programma.
139
140 %description -l pl.UTF-8
141 Postfix jest próbą dostarczenia alternatywnego MTA w stosunku do
142 szeroko używanego sendmaila. Postfix w zamierzeniu ma być szybki,
143 łatwy w administrowaniu, bezpieczny oraz ma być na tyle kompatybilny z
144 sendmailem by nie denerwować użytkowników. Ta wersja obsługuje IPv6.
145
146 %description -l pt_BR.UTF-8
147 O Postfix é uma alternativa para o mundialmente utilizado sendmail. Se
148 você deseja um servidor SMTP *rápido*, instale este pacote.
149
150 %description -l sk.UTF-8
151 Postfix (pozri http://www.postfix.org/) má za cieľ byť alternatívou k
152 široko rozšírenému programu sendmail, zodpovednému za 70% všetkej
153 elektronickej pošty doručenej na Internete.
154
155 Aj keď IBM podporovala vývoj Postfixu, zdržiava sa vplyvu na jeho
156 vývoj. Cieľom je inštalácia Postfixu na čo najväčšom počte systémov.
157 Do tohoto momentu je softvér poskytovaný bez ovplyvňovania, takže sa
158 môže vyvíjať podľa jeho používateľov.
159
160 Určite si prečítajte http://www.moongroup.com/how-to.phtml, kde sú
161 popísané kroky potrebné pred a po inštalácii Postfixu.
162
163 %package devel
164 Summary:        Postfix loadable modules development package
165 Summary(pl.UTF-8):      Pakiet dla programistów ładowanych modułów do postfiksa
166 Group:          Development/Libraries
167 Requires:       %{name} = %{epoch}:%{version}-%{release}
168
169 %description devel
170 Header files to build additional map types for Postfix.
171
172 %description devel -l pl.UTF-8
173 Pliki nagłówkowe do tworzenia dodatkowych typów map dla Postfiksa.
174
175 %package dict-ldap
176 Summary:        LDAP map support for Postfix
177 Summary(pl.UTF-8):      Obsługa map LDAP dla Postfiksa
178 Group:          Networking/Daemons/SMTP
179 Requires:       %{name} = %{epoch}:%{version}-%{release}
180 Requires:       openldap >= 2.3.6
181
182 %description dict-ldap
183 This package provides support for LDAP maps in Postfix.
184
185 %description dict-ldap -l pl.UTF-8
186 Ten pakiet dodaje obsługę map LDAP do Postfiksa.
187
188 %package dict-mysql
189 Summary:        MySQL map support for Postfix
190 Summary(pl.UTF-8):      Obsługa map MySQL dla Postfiksa
191 Group:          Networking/Daemons/SMTP
192 Requires:       %{name} = %{epoch}:%{version}-%{release}
193
194 %description dict-mysql
195 This package provides support for MySQL maps in Postfix.
196
197 %description dict-mysql -l pl.UTF-8
198 Ten pakiet dodaje obsługę map MySQL do Postfiksa.
199
200 %package dict-pcre
201 Summary:        PCRE map support for Postfix
202 Summary(pl.UTF-8):      Obsługa map PCRE dla Postfiksa
203 Group:          Networking/Daemons/SMTP
204 Requires:       %{name} = %{epoch}:%{version}-%{release}
205
206 %description dict-pcre
207 This package provides support for PCRE maps in Postfix.
208
209 %description dict-pcre -l pl.UTF-8
210 Ten pakiet dodaje obsługę map PCRE do Postfiksa.
211
212 %package dict-pgsql
213 Summary:        PostgreSQL map support for Postfix
214 Summary(pl.UTF-8):      Obsługa map PostgreSQL dla Postfiksa
215 Group:          Networking/Daemons/SMTP
216 Requires:       %{name} = %{epoch}:%{version}-%{release}
217
218 %description dict-pgsql
219 This package provides support for PostgreSQL maps in Postfix.
220
221 %description dict-pgsql -l pl.UTF-8
222 Ten pakiet dodaje obsługę map PostgreSQL do Postfiksa.
223
224 %package dict-sqlite
225 Summary:        SQLite map support for Postfix
226 Summary(pl.UTF-8):      Obsługa map SQLite dla Postfiksa
227 Group:          Networking/Daemons/SMTP
228 Requires:       %{name} = %{epoch}:%{version}-%{release}
229
230 %description dict-sqlite
231 This package provides support for SQLite maps in Postfix.
232
233 %description dict-sqlite -l pl.UTF-8
234 Ten pakiet dodaje obsługę map SQLite do Postfiksa.
235
236 %package dict-lmdb
237 Summary:        LMDB map support for Postfix
238 Summary(pl.UTF-8):      Obsługa map LMDB dla Postfiksa
239 Group:          Networking/Daemons/SMTP
240 Requires:       %{name} = %{epoch}:%{version}-%{release}
241
242 %description dict-lmdb
243 This package provides support for LMDB maps in Postfix.
244
245 %description dict-lmdb -l pl.UTF-8
246 Ten pakiet dodaje obsługę map LMDB do Postfiksa.
247
248 %package dict-cdb
249 Summary:        CDB map support for Postfix
250 Summary(pl.UTF-8):      Obsługa map CDB dla Postfiksa
251 Group:          Networking/Daemons/SMTP
252 Requires:       %{name} = %{epoch}:%{version}-%{release}
253
254 %description dict-cdb
255 This package provides support for CDB maps in Postfix.
256
257 %description dict-cdb -l pl.UTF-8
258 Ten pakiet dodaje obsługę map CDB do Postfiksa.
259
260 %package qshape
261 Summary:        qshape - Print Postfix queue domain and age distribution
262 Summary(pl.UTF-8):      qshape - wypisywanie rozkładu domen i wieku z kolejki Postfiksa
263 Group:          Networking/Daemons/SMTP
264 Requires:       %{name} = %{epoch}:%{version}-%{release}
265
266 %description qshape
267 The qshape program helps the administrator understand the Postfix
268 queue message distribution in time and by sender domain or recipient
269 domain. The program needs read access to the queue directories and
270 queue files, so it must run as the superuser or the mail_owner
271 specified in main.cf (typically postfix).
272
273 %description qshape -l pl.UTF-8
274 Program qshape pomaga administratorowi zrozumieć rozkład kolejki
275 wiadomości Postfiksa w czasie i w zależności od domeny nadawcy lub
276 adresata. Program wymaga prawa odczytu do katalogów kolejki i plików
277 kolejki, więc musi być uruchamiany przez superużytkownika lub
278 użytkownika mail_owner podanego w main.cf (zwykle nazywającego się
279 postfix).
280
281 %package -n monit-rc-%{name}
282 Summary:        monit support for Postfix
283 Summary(pl.UTF-8):      Wsparcie monita dla Postfiksa
284 Group:          Applications/System
285 Requires:       %{name} = %{epoch}:%{version}-%{release}
286 Requires:       monit
287
288 %description -n monit-rc-%{name}
289 monitrc file for monitoring Postfix.
290
291 %description -n monit-rc-%{name} -l pl.UTF-8
292 Plik monitrc do monitorowania serwera Postfix.
293
294 %prep
295 %setup -q
296 %if %{with vda}
297 cat %{SOURCE7} | %{__patch} -p1 -s
298 cat %{SOURCE11} | %{__patch} -p1 -s
299 %endif
300
301 find -type f | xargs sed -i -e 's|/etc/postfix|/etc/mail|g'
302
303 %patch0 -p1
304
305 %patch3 -p1
306 %{?with_hir:%patch4 -p0}
307
308 sed -i '/scache_clnt_create/s/server/var_scache_service/' src/global/scache_clnt.c
309 %patch7 -p1
310 %patch8 -p1
311
312 %patch11 -p1
313 %if %{with vda}
314 %patch12 -p1
315 %endif
316
317 %if %{with tcp}
318 sed -i 's/ifdef SNAPSHOT/if 1/' src/util/dict_open.c
319 %endif
320
321 %build
322 # export, as the same variables must be passed both to 'make makefiles' and 'make'
323 export CCARGS="%{!?with_epoll:-DNO_EPOLL} %{?with_ldap:-DHAS_LDAP} -DHAS_PCRE %{?with_sasl:-DUSE_SASL_AUTH -DUSE_CYRUS_SASL -I/usr/include/sasl} %{?with_mysql:-DHAS_MYSQL -I/usr/include/mysql} %{?with_pgsql:-DHAS_PGSQL} %{?with_ssl:-DUSE_TLS} -DMAX_DYNAMIC_MAPS %{?with_cdb:-DHAS_CDB} %{?with_sqlite:-DHAS_SQLITE} %{?with_lmdb:-DHAS_LMDB} -LHAS_SDBM"
324 export AUXLIBS="%{rpmldflags} -lsasl -lssl -lcrypto -ldb -lresolv"
325 export AUXLIBS_CDB="%{?with_cdb:-lcdb}"
326 export AUXLIBS_LDAP="%{?with_ldap:-lldap -llber}"
327 export AUXLIBS_LMDB="%{?with_lmdb:-llmdb}"
328 export AUXLIBS_MYSQL="%{?with_mysql:-lmysqlclient}"
329 export AUXLIBS_PCRE="-lpcre"
330 export AUXLIBS_PGSQL="%{?with_pgsql:-lpq}"
331 export AUXLIBS_SQLITE="%{?with_sqlite:-lsqlite3}"
332
333 export CC="%{__cc}"
334 %{__make} makefiles \
335         shared=yes dynamicmaps=yes \
336         daemon_directory="%{_libdir}/postfix" \
337         shlib_directory="%{_libdir}/postfix" \
338         manpage_directory="%{_mandir}"
339
340 %{__make} -j1 \
341         DEBUG="" \
342         OPT="%{rpmcflags} %{rpmcppflags} -D_FILE_OFFSET_BITS=64"
343
344 %install
345 rm -rf $RPM_BUILD_ROOT
346 install -d $RPM_BUILD_ROOT/etc/{cron.daily,rc.d/init.d,sysconfig,pam.d,security,monit} \
347         $RPM_BUILD_ROOT%{_sysconfdir}/{mail,sasl} \
348         $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_libdir}/postfix,/usr/lib}\
349         $RPM_BUILD_ROOT{%{_includedir}/postfix,%{_mandir}} \
350         $RPM_BUILD_ROOT%{_var}/spool/postfix/{active,corrupt,deferred,maildrop,private,saved,bounce,defer,incoming,pid,public} \
351         $RPM_BUILD_ROOT%{_var}/lib/postfix \
352         $RPM_BUILD_ROOT%{systemdunitdir}
353
354 %{__make} non-interactive-package \
355        install_root=$RPM_BUILD_ROOT
356
357 #cp -a conf/* $RPM_BUILD_ROOT%{_sysconfdir}/mail
358 sed -e's,^daemon_directory = .*,daemon_directory = %{_libdir}/postfix,' \
359         conf/main.cf > $RPM_BUILD_ROOT%{_sysconfdir}/mail/main.cf
360
361 cp -a include/*.h $RPM_BUILD_ROOT%{_includedir}/postfix
362
363 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/mail/aliases
364 install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.daily/postfix
365 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/postfix
366 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/postfix
367 cp -a %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/sasl/smtpd.conf
368 cp -a %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/smtp
369 cp -a %{SOURCE8} $RPM_BUILD_ROOT%{_sysconfdir}/mail/bounce.cf.pl
370 cp -a %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/mail/bounce.cf.de
371 cp -a %{SOURCE10} $RPM_BUILD_ROOT/etc/monit/%{name}.monitrc
372 cp -a %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}/%{name}.service
373 install -p auxiliary/rmail/rmail $RPM_BUILD_ROOT%{_bindir}/rmail
374 install -p auxiliary/qshape/qshape.pl $RPM_BUILD_ROOT%{_bindir}/qshape
375
376 ln -sf %{_sbindir}/sendmail $RPM_BUILD_ROOT%{_bindir}/mailq
377 ln -sf %{_sbindir}/sendmail $RPM_BUILD_ROOT%{_bindir}/newaliases
378 ln -sf %{_sbindir}/sendmail $RPM_BUILD_ROOT/usr/lib/sendmail
379
380 touch $RPM_BUILD_ROOT%{_sysconfdir}/mail/\
381         {aliases,access,canonical,relocated,transport,virtual}{,.db}
382
383 touch $RPM_BUILD_ROOT/etc/security/blacklist.smtp
384
385 > $RPM_BUILD_ROOT/var/spool/postfix/.nofinger
386
387 %{__rm} -r $RPM_BUILD_ROOT%{_sysconfdir}/mail/makedefs.out
388 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/mail/{,TLS_}LICENSE
389
390 %clean
391 rm -rf $RPM_BUILD_ROOT
392
393 %pre
394 %groupadd -g 62 postfix
395 %groupadd -g 63 maildrop
396 %useradd -u 62 -d /var/spool/postfix -s /bin/false -c "Postfix User" -g postfix postfix
397
398 %post
399 /sbin/ldconfig
400 if ! grep -q "^postmaster:" %{_sysconfdir}/mail/aliases; then
401         echo "Adding Entry for postmaster in %{_sysconfdir}/mail/aliases" >&2
402         echo "postmaster: root" >>%{_sysconfdir}/mail/aliases
403 fi
404 if [ "$1" = "1" ]; then
405         # only on installation, not upgrade; set sane defaults
406         # postfix expects gethostname() to return FQDN, which is obviously wrong
407         if ! grep -qE "^my(domain|hostname)" %{_sysconfdir}/mail/main.cf; then
408                 domain=$(/bin/hostname -d 2>/dev/null)
409                 [ -n "$domain" -a "$domain" != 'localdomain' ] && \
410                         postconf -e mydomain="$domain"
411         fi
412 else
413         %{_sbindir}/postfix upgrade-configuration
414 fi
415
416 %{_bindir}/newaliases
417 /sbin/chkconfig --add postfix
418 %service postfix restart "Postfix Daemon"
419 %systemd_post postfix.service
420
421 %preun
422 if [ "$1" = "0" ]; then
423         %service postfix stop
424         /sbin/chkconfig --del postfix
425 fi
426 %systemd_preun postfix.service
427
428 %postun
429 /sbin/ldconfig
430 if [ "$1" = "0" ]; then
431         %groupremove maildrop
432         %userremove postfix
433         %groupremove postfix
434 fi
435 %systemd_reload
436
437 %triggerpostun -- postfix < 2:2.9.4-4
438 %systemd_trigger postfix.service
439
440 %files
441 %defattr(644,root,root,755)
442 %doc html COMPATIBILITY HISTORY LICENSE RELEASE_NOTES* TLS_*
443 %doc README_FILES/*README
444 %doc examples/smtpd-policy
445 %dir %{_sysconfdir}/mail
446 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/access
447 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/aliases
448 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/bounce.cf.default
449 %lang(de) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/bounce.cf.de
450 %lang(pl) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/bounce.cf.pl
451 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/canonical
452 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/generic
453 #%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/regexp_table
454 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/relocated
455 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/transport
456 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/virtual
457 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/header_checks
458 #%ghost %{_sysconfdir}/mail/*.db
459 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/dynamicmaps.cf
460 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/main.cf
461 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/main.cf.default
462 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/main.cf.proto
463 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/master.cf
464 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/master.cf.proto
465 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/postfix-files
466 %attr(740,root,root) /etc/cron.daily/postfix
467 %attr(754,root,root) /etc/rc.d/init.d/postfix
468 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/postfix
469 %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/smtp
470 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.smtp
471 %{?with_sasl:%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sasl/smtpd.conf}
472 %attr(755,root,root) %{_bindir}/mailq
473 %attr(755,root,root) %{_bindir}/newaliases
474 %attr(755,root,root) %{_bindir}/rmail
475 %attr(755,root,root) %{_sbindir}/s*
476 %attr(755,root,root) %{_sbindir}/postfix
477 %attr(755,root,root) %{_sbindir}/postalias
478 %attr(755,root,root) %{_sbindir}/postkick
479 %attr(755,root,root) %{_sbindir}/postl*
480 %attr(755,root,root) %{_sbindir}/postc*
481 %attr(755,root,root) %{_sbindir}/postmap
482 %attr(755,root,root) %{_sbindir}/postmulti
483 %attr(2755,root,maildrop) %{_sbindir}/postqueue
484 %attr(755,root,root) %{_sbindir}/postsuper
485 %attr(2755,root,maildrop) %{_sbindir}/postdrop
486 %attr(755,root,root) /usr/lib/sendmail
487 %dir %{_libdir}/postfix
488 %attr(755,root,root) %{_libdir}/postfix/anvil
489 %attr(755,root,root) %{_libdir}/postfix/bounce
490 %attr(755,root,root) %{_libdir}/postfix/cleanup
491 %attr(755,root,root) %{_libdir}/postfix/discard
492 %attr(755,root,root) %{_libdir}/postfix/dnsblog
493 %attr(755,root,root) %{_libdir}/postfix/error
494 %attr(755,root,root) %{_libdir}/postfix/flush
495 %attr(755,root,root) %{_libdir}/postfix/libpostfix-dns.so
496 %attr(755,root,root) %{_libdir}/postfix/libpostfix-global.so
497 %attr(755,root,root) %{_libdir}/postfix/libpostfix-master.so
498 %attr(755,root,root) %{_libdir}/postfix/libpostfix-tls.so
499 %attr(755,root,root) %{_libdir}/postfix/libpostfix-util.so
500 %attr(755,root,root) %{_libdir}/postfix/lmtp
501 %attr(755,root,root) %{_libdir}/postfix/local
502 %attr(755,root,root) %{_libdir}/postfix/master
503 %attr(755,root,root) %{_libdir}/postfix/nqmgr
504 %attr(755,root,root) %{_libdir}/postfix/oqmgr
505 %attr(755,root,root) %{_libdir}/postfix/pickup
506 %attr(755,root,root) %{_libdir}/postfix/pipe
507 %attr(755,root,root) %{_libdir}/postfix/postfix-script
508 %attr(755,root,root) %{_libdir}/postfix/postfix-tls-script
509 %attr(755,root,root) %{_libdir}/postfix/postlogd
510 %attr(755,root,root) %{_libdir}/postfix/postfix-wrapper
511 %attr(755,root,root) %{_libdir}/postfix/post-install
512 %attr(755,root,root) %{_libdir}/postfix/postmulti-script
513 %attr(755,root,root) %{_libdir}/postfix/postscreen
514 %attr(755,root,root) %{_libdir}/postfix/proxymap
515 %attr(755,root,root) %{_libdir}/postfix/qmgr
516 %attr(755,root,root) %{_libdir}/postfix/qmqpd
517 %attr(755,root,root) %{_libdir}/postfix/scache
518 %attr(755,root,root) %{_libdir}/postfix/showq
519 %attr(755,root,root) %{_libdir}/postfix/smtp
520 %attr(755,root,root) %{_libdir}/postfix/smtpd
521 %attr(755,root,root) %{_libdir}/postfix/spawn
522 %attr(755,root,root) %{_libdir}/postfix/tlsmgr
523 %attr(755,root,root) %{_libdir}/postfix/tlsproxy
524 %attr(755,root,root) %{_libdir}/postfix/trivial-rewrite
525 %attr(755,root,root) %{_libdir}/postfix/verify
526 %attr(755,root,root) %{_libdir}/postfix/virtual
527 %attr(755,root,root) %dir %{_var}/spool/postfix
528 %attr(700,postfix,root) %dir %{_var}/spool/postfix/active
529 %attr(700,postfix,root) %dir %{_var}/spool/postfix/bounce
530 %attr(700,postfix,root) %dir %{_var}/spool/postfix/corrupt
531 %attr(700,postfix,root) %dir %{_var}/spool/postfix/defer
532 %attr(700,postfix,root) %dir %{_var}/spool/postfix/deferred
533 %attr(700,postfix,root) %dir %{_var}/spool/postfix/incoming
534 %attr(1730,postfix,maildrop) %dir %{_var}/spool/postfix/maildrop
535 %attr(755,root,root) %dir %{_var}/spool/postfix/pid
536 %attr(700,postfix,root) %dir %{_var}/spool/postfix/private
537 %attr(710,postfix,maildrop) %dir %{_var}/spool/postfix/public
538 %attr(700,postfix,root) %dir %{_var}/spool/postfix/saved
539 %attr(644,postfix,root) %{_var}/spool/postfix/.nofinger
540 %attr(700,postfix,root) %{_var}/lib/postfix
541 %{_mandir}/man1/mailq.1*
542 %{_mandir}/man1/newaliases.1*
543 %{_mandir}/man1/post*.1*
544 %{_mandir}/man1/sendmail.1*
545 %{_mandir}/man5/access.5*
546 %{_mandir}/man5/aliases.5*
547 %{_mandir}/man5/body_checks.5*
548 %{_mandir}/man5/bounce.5*
549 %{_mandir}/man5/canonical.5*
550 %{_mandir}/man5/cidr_table.5*
551 %{_mandir}/man5/generic.5*
552 %{_mandir}/man5/header_checks.5*
553 %{_mandir}/man5/master.5*
554 %{_mandir}/man5/memcache_table.5*
555 %{_mandir}/man5/nisplus_table.5*
556 %{_mandir}/man5/postconf.5*
557 %{_mandir}/man5/postfix-wrapper.5*
558 %{_mandir}/man5/regexp_table.5*
559 %{_mandir}/man5/relocated.5*
560 %{_mandir}/man5/socketmap_table.5*
561 %{_mandir}/man5/tcp_table.5*
562 %{_mandir}/man5/transport.5*
563 %{_mandir}/man5/virtual.5*
564 %{_mandir}/man8/*.8*
565 %{systemdunitdir}/%{name}.service
566
567 %files devel
568 %defattr(644,root,root,755)
569 %{_includedir}/postfix
570
571 %if %{with ldap}
572 %files dict-ldap
573 %defattr(644,root,root,755)
574 %attr(755,root,root) %{_libdir}/postfix/postfix-ldap.so
575 %{_mandir}/man5/ldap_table.5*
576 %endif
577
578 %if %{with mysql}
579 %files dict-mysql
580 %defattr(644,root,root,755)
581 %attr(755,root,root) %{_libdir}/postfix/postfix-mysql.so
582 %{_mandir}/man5/mysql_table.5*
583 %endif
584
585 %files dict-pcre
586 %defattr(644,root,root,755)
587 %attr(755,root,root) %{_libdir}/postfix/postfix-pcre.so
588 #%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/pcre_table
589 %{_mandir}/man5/pcre_table.5*
590
591 %if %{with pgsql}
592 %files dict-pgsql
593 %defattr(644,root,root,755)
594 %attr(755,root,root) %{_libdir}/postfix/postfix-pgsql.so
595 %{_mandir}/man5/pgsql_table.5*
596 %endif
597
598 %if %{with sqlite}
599 %files dict-sqlite
600 %defattr(644,root,root,755)
601 %attr(755,root,root) %{_libdir}/postfix/postfix-sqlite.so
602 %{_mandir}/man5/sqlite_table.5*
603 %endif
604
605 %if %{with lmdb}
606 %files dict-lmdb
607 %defattr(644,root,root,755)
608 %attr(755,root,root) %{_libdir}/postfix/postfix-lmdb.so
609 %{_mandir}/man5/lmdb_table.5*
610 %endif
611
612 %if %{with cdb}
613 %files dict-cdb
614 %attr(755,root,root) %{_libdir}/postfix/postfix-cdb.so
615 %endif
616
617 %files qshape
618 %defattr(644,root,root,755)
619 %attr(755,root,root) %{_bindir}/qshape
620
621 %files -n monit-rc-%{name}
622 %defattr(644,root,root,755)
623 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}.monitrc
This page took 0.096034 seconds and 3 git commands to generate.