]> git.pld-linux.org Git - packages/postfix.git/blame_incremental - postfix.spec
/var/spool/postfix/pid should be owned by root
[packages/postfix.git] / postfix.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without ldap # without LDAP map module
4%bcond_without mysql # without MySQL map module
5%bcond_without pgsql # without PostgreSQL map module
6%bcond_without sqlite # without SQLite map module
7%bcond_without sasl # without SMTP AUTH support
8%bcond_without ssl # without SSL/TLS support
9%bcond_without cdb # without cdb map support
10%bcond_without lmdb # without lmdb map support
11%bcond_with vda # with VDA patch
12%bcond_with hir # with Beeth's header_if_reject patch
13%bcond_with tcp # with unofficial tcp: lookup table
14%if "%{pld_release}" == "ac"
15%bcond_with epoll # enable epoll for 2.6 kernels
16# there didn't exist x86_64 2.4 kernel in PLD, so can safely enable epoll
17%ifarch %{x8664}
18%define with_epoll 1
19%endif
20%else
21%bcond_without epoll # disable epoll for 2.4 kernels
22%endif
23
24%define vda_ver v13-2.10.0
25Summary: Postfix Mail Transport Agent
26Summary(cs.UTF-8): Postfix - program pro přepravu pošty (MTA)
27Summary(es.UTF-8): Postfix - Un MTA (Mail Transport Agent) de alto desempeño
28Summary(fr.UTF-8): Agent de transport de courrier Postfix
29Summary(pl.UTF-8): Serwer SMTP Postfix
30Summary(pt_BR.UTF-8): Postfix - Um MTA (Mail Transport Agent) de alto desempenho
31Summary(sk.UTF-8): Agent prenosu pošty Postfix
32Name: postfix
33Version: 3.3.1
34Release: 1
35Epoch: 2
36License: distributable
37Group: Networking/Daemons/SMTP
38Source0: ftp://ftp.porcupine.org/mirrors/postfix-release/official/%{name}-%{version}.tar.gz
39# Source0-md5: 4381c6492f415e4a69cf5099d4acea76
40Source1: %{name}.aliases
41Source2: %{name}.cron
42Source3: %{name}.init
43Source4: %{name}.sysconfig
44Source5: %{name}.sasl
45Source6: %{name}.pamd
46Source7: %{name}-vda.patch
47#Source7: http://vda.sourceforge.net/VDA/%{name}-vda-%{vda_ver}.patch
48# -ource7-md5: 01e1b031d79b85f3cb67d98ceddd775d
49Source8: %{name}-bounce.cf.pl
50# http://postfix.state-of-mind.de/bounce-templates/bounce.de-DE.cf
51Source9: %{name}-bounce.cf.de
52Source10: %{name}.monitrc
53Source11: %{name}-vda-bigquota.patch
54#Source11: http://vda.sourceforge.net/VDA/%{name}-%{vda_ver}-vda-ng-bigquota.patch.gz
55# -ource11-md5: d46103195b43ec5784ea2c166b238f71
56Source12: %{name}.service
57Patch0: %{name}-config.patch
58
59Patch3: %{name}-master.cf_cyrus.patch
60# from http://akson.sgh.waw.pl/~chopin/unix/postfix-2.1.5-header_if_reject.diff
61Patch4: %{name}-header_if_reject.patch
62
63Patch7: %{name}-conf.patch
64Patch8: %{name}-dictname.patch
65
66Patch11: %{name}-scache_clnt.patch
67Patch12: format-security.patch
68Patch13: %{name}-no_cdb.patch
69URL: http://www.postfix.org/
70%{?with_sasl:BuildRequires: cyrus-sasl-devel}
71BuildRequires: db-devel
72# getifaddrs() with IPv6 support
73BuildRequires: glibc-devel >= 6:2.3.4
74%{?with_lmbd:BuildRequires: lmdb-devel}
75%{?with_mysql:BuildRequires: mysql-devel}
76%{?with_ldap:BuildRequires: openldap-devel >= 2.0.12}
77%{?with_ssl:BuildRequires: openssl-devel >= 0.9.7l}
78BuildRequires: pcre-devel
79BuildRequires: perl-base
80%{?with_pgsql:BuildRequires: postgresql-devel}
81BuildRequires: rpm >= 4.4.9-56
82BuildRequires: rpmbuild(macros) >= 1.644
83BuildRequires: sed >= 4.0
84%{?with_sqlite:BuildRequires: sqlite3-devel}
85%{?with_cdb:BuildRequires: tinycdb-devel}
86%{?with_mysql:BuildRequires: zlib-devel}
87Requires(post): /bin/hostname
88Requires(post,postun): /sbin/ldconfig
89Requires(post,preun): /sbin/chkconfig
90Requires(postun): /usr/sbin/groupdel
91Requires(postun): /usr/sbin/userdel
92Requires(pre): /bin/id
93Requires(pre): /usr/bin/getgid
94Requires(pre): /usr/sbin/groupadd
95Requires(pre): /usr/sbin/useradd
96Requires: /sbin/chkconfig
97Requires: diffutils
98Requires: findutils
99Requires: rc-scripts
100Requires: sed
101%{?with_cdb:Requires:tinycdb}
102Requires: systemd-units >= 38
103Suggests: cyrus-sasl-saslauthd
104Provides: group(postfix)
105Provides: smtpdaemon
106Provides: user(postfix)
107Obsoletes: smtpdaemon
108BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
109
110%description
111Postfix is attempt to provide an alternative to the widely-used
112Sendmail program. Postfix attempts to be fast, easy to administer, and
113hopefully secure, while at the same time being sendmail compatible
114enough to not upset your users. This version has IPv6 support.
115
116%description -l es.UTF-8
117Postfix es una alternativa para el mundialmente utilizado sendmail. Si
118desea tener un servidor SMTP *rápido*, debe instalar este paquete.
119
120%description -l fr.UTF-8
121Postfix (voir http://www.postfix.org/) se veut une alternative à
122sendmail, responsable de l'acheminement de 70% des courriers
123électroniques sur Internet. IBM en a suppotré le développement, mais
124ne contrôle pas son évolution. Le but est d'installer Postfix sur le
125plus grand nombre de systèmes possible. Dans cette optique, il a été
126écrit pour être totalement sous le contrôle de l'utilisateur.
127
128%description -l it.UTF-8
129Postfix (http://www.postfix.org/) e' un'alternativa al programma
130sendmail utilizzato per la gestione del 70 per cento della posta
131Internet.
132
133Seppur IBM supporti lo sviluppo di Postfix, non controlla la sua
134evoluzione.
135
136Consultate la pagine web http://www.moongroup.com/how-to.phtml nella
137quale troverete le indicazioni per una corretta installazione e
138configurazione di questo programma.
139
140%description -l pl.UTF-8
141Postfix jest próbą dostarczenia alternatywnego MTA w stosunku do
142szeroko używanego sendmaila. Postfix w zamierzeniu ma być szybki,
143łatwy w administrowaniu, bezpieczny oraz ma być na tyle kompatybilny z
144sendmailem by nie denerwować użytkowników. Ta wersja obsługuje IPv6.
145
146%description -l pt_BR.UTF-8
147O Postfix é uma alternativa para o mundialmente utilizado sendmail. Se
148você deseja um servidor SMTP *rápido*, instale este pacote.
149
150%description -l sk.UTF-8
151Postfix (pozri http://www.postfix.org/) má za cieľ byť alternatívou k
152široko rozšírenému programu sendmail, zodpovednému za 70% všetkej
153elektronickej pošty doručenej na Internete.
154
155Aj keď IBM podporovala vývoj Postfixu, zdržiava sa vplyvu na jeho
156vývoj. Cieľom je inštalácia Postfixu na čo najväčšom počte systémov.
157Do tohoto momentu je softvér poskytovaný bez ovplyvňovania, takže sa
158môže vyvíjať podľa jeho používateľov.
159
160Určite si prečítajte http://www.moongroup.com/how-to.phtml, kde sú
161popísané kroky potrebné pred a po inštalácii Postfixu.
162
163%package devel
164Summary: Postfix loadable modules development package
165Summary(pl.UTF-8): Pakiet dla programistów ładowanych modułów do postfiksa
166Group: Development/Libraries
167Requires: %{name} = %{epoch}:%{version}-%{release}
168
169%description devel
170Header files to build additional map types for Postfix.
171
172%description devel -l pl.UTF-8
173Pliki nagłówkowe do tworzenia dodatkowych typów map dla Postfiksa.
174
175%package dict-ldap
176Summary: LDAP map support for Postfix
177Summary(pl.UTF-8): Obsługa map LDAP dla Postfiksa
178Group: Networking/Daemons/SMTP
179Requires: %{name} = %{epoch}:%{version}-%{release}
180Requires: openldap >= 2.3.6
181
182%description dict-ldap
183This package provides support for LDAP maps in Postfix.
184
185%description dict-ldap -l pl.UTF-8
186Ten pakiet dodaje obsługę map LDAP do Postfiksa.
187
188%package dict-mysql
189Summary: MySQL map support for Postfix
190Summary(pl.UTF-8): Obsługa map MySQL dla Postfiksa
191Group: Networking/Daemons/SMTP
192Requires: %{name} = %{epoch}:%{version}-%{release}
193
194%description dict-mysql
195This package provides support for MySQL maps in Postfix.
196
197%description dict-mysql -l pl.UTF-8
198Ten pakiet dodaje obsługę map MySQL do Postfiksa.
199
200%package dict-pcre
201Summary: PCRE map support for Postfix
202Summary(pl.UTF-8): Obsługa map PCRE dla Postfiksa
203Group: Networking/Daemons/SMTP
204Requires: %{name} = %{epoch}:%{version}-%{release}
205
206%description dict-pcre
207This package provides support for PCRE maps in Postfix.
208
209%description dict-pcre -l pl.UTF-8
210Ten pakiet dodaje obsługę map PCRE do Postfiksa.
211
212%package dict-pgsql
213Summary: PostgreSQL map support for Postfix
214Summary(pl.UTF-8): Obsługa map PostgreSQL dla Postfiksa
215Group: Networking/Daemons/SMTP
216Requires: %{name} = %{epoch}:%{version}-%{release}
217
218%description dict-pgsql
219This package provides support for PostgreSQL maps in Postfix.
220
221%description dict-pgsql -l pl.UTF-8
222Ten pakiet dodaje obsługę map PostgreSQL do Postfiksa.
223
224%package dict-sqlite
225Summary: SQLite map support for Postfix
226Summary(pl.UTF-8): Obsługa map SQLite dla Postfiksa
227Group: Networking/Daemons/SMTP
228Requires: %{name} = %{epoch}:%{version}-%{release}
229
230%description dict-sqlite
231This package provides support for SQLite maps in Postfix.
232
233%description dict-sqlite -l pl.UTF-8
234Ten pakiet dodaje obsługę map SQLite do Postfiksa.
235
236%package dict-lmdb
237Summary: LMDB map support for Postfix
238Summary(pl.UTF-8): Obsługa map LMDB dla Postfiksa
239Group: Networking/Daemons/SMTP
240Requires: %{name} = %{epoch}:%{version}-%{release}
241
242%description dict-lmdb
243This package provides support for LMDB maps in Postfix.
244
245%description dict-lmdb -l pl.UTF-8
246Ten pakiet dodaje obsługę map LMDB do Postfiksa.
247
248%package qshape
249Summary: qshape - Print Postfix queue domain and age distribution
250Summary(pl.UTF-8): qshape - wypisywanie rozkładu domen i wieku z kolejki Postfiksa
251Group: Networking/Daemons/SMTP
252Requires: %{name} = %{epoch}:%{version}-%{release}
253
254%description qshape
255The qshape program helps the administrator understand the Postfix
256queue message distribution in time and by sender domain or recipient
257domain. The program needs read access to the queue directories and
258queue files, so it must run as the superuser or the mail_owner
259specified in main.cf (typically postfix).
260
261%description qshape -l pl.UTF-8
262Program qshape pomaga administratorowi zrozumieć rozkład kolejki
263wiadomości Postfiksa w czasie i w zależności od domeny nadawcy lub
264adresata. Program wymaga prawa odczytu do katalogów kolejki i plików
265kolejki, więc musi być uruchamiany przez superużytkownika lub
266użytkownika mail_owner podanego w main.cf (zwykle nazywającego się
267postfix).
268
269%package -n monit-rc-%{name}
270Summary: monit support for Postfix
271Summary(pl.UTF-8): Wsparcie monita dla Postfiksa
272Group: Applications/System
273Requires: %{name} = %{epoch}:%{version}-%{release}
274Requires: monit
275
276%description -n monit-rc-%{name}
277monitrc file for monitoring Postfix.
278
279%description -n monit-rc-%{name} -l pl.UTF-8
280Plik monitrc do monitorowania serwera Postfix.
281
282%prep
283%setup -q
284%if %{with vda}
285cat %{SOURCE7} | %{__patch} -p1 -s
286cat %{SOURCE11} | %{__patch} -p1 -s
287%endif
288
289find -type f | xargs sed -i -e 's|/etc/postfix|/etc/mail|g'
290
291%patch0 -p1
292
293%patch3 -p1
294%{?with_hir:%patch4 -p0}
295
296sed -i '/scache_clnt_create/s/server/var_scache_service/' src/global/scache_clnt.c
297%patch7 -p1
298%patch8 -p1
299
300%patch11 -p1
301%if %{with vda}
302%patch12 -p1
303%endif
304%{!?with_cdb:%patch13 -p1}
305
306%if %{with tcp}
307sed -i 's/ifdef SNAPSHOT/if 1/' src/util/dict_open.c
308%endif
309
310%build
311export CCARGS="%{!?with_epoll:-DNO_EPOLL} %{?with_ldap:-DHAS_LDAP} -DHAS_PCRE %{?with_sasl:-DUSE_SASL_AUTH -DUSE_CYRUS_SASL -I/usr/include/sasl} %{?with_mysql:-DHAS_MYSQL -I/usr/include/mysql} %{?with_pgsql:-DHAS_PGSQL} %{?with_ssl:-DUSE_TLS} -DMAX_DYNAMIC_MAPS %{?with_cdb:-DHAS_CDB} %{?with_sqlite:-DHAS_SQLITE} %{?with_lmdb:-DHAS_LMDB} -LHAS_SDBM"
312export AUXLIBS="-ldb -lresolv %{?with_mysql:-lmysqlclient} %{?with_pgsql:-lpq} %{?with_sasl:-lsasl} %{?with_ssl:-lssl -lcrypto} %{?with_cdb:-lcdb} -lpcre %{?with_ldap:-lldap -llber}"
313export CC="%{__cc}"
314%{__make} makefiles \
315 shared=yes dynamicmaps=yes \
316 daemon_directory="%{_libdir}/postfix" \
317 shlib_directory="%{_libdir}/postfix" \
318 manpage_directory="%{_mandir}"
319
320%{__make} -j1 \
321 DEBUG="" \
322 OPT="%{rpmcflags} %{rpmcppflags} -D_FILE_OFFSET_BITS=64"
323
324%install
325rm -rf $RPM_BUILD_ROOT
326install -d $RPM_BUILD_ROOT/etc/{cron.daily,rc.d/init.d,sysconfig,pam.d,security,monit} \
327 $RPM_BUILD_ROOT%{_sysconfdir}/{mail,sasl} \
328 $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_libdir}/postfix,/usr/lib}\
329 $RPM_BUILD_ROOT{%{_includedir}/postfix,%{_mandir}} \
330 $RPM_BUILD_ROOT%{_var}/spool/postfix/{active,corrupt,deferred,maildrop,private,saved,bounce,defer,incoming,pid,public} \
331 $RPM_BUILD_ROOT%{_var}/lib/postfix \
332 $RPM_BUILD_ROOT%{systemdunitdir}
333
334%{__make} non-interactive-package \
335 install_root=$RPM_BUILD_ROOT
336
337#cp -a conf/* $RPM_BUILD_ROOT%{_sysconfdir}/mail
338sed -e's,^daemon_directory = .*,daemon_directory = %{_libdir}/postfix,' \
339 conf/main.cf > $RPM_BUILD_ROOT%{_sysconfdir}/mail/main.cf
340
341cp -a include/*.h $RPM_BUILD_ROOT%{_includedir}/postfix
342
343cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/mail/aliases
344install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.daily/postfix
345install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/postfix
346cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/postfix
347cp -a %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/sasl/smtpd.conf
348cp -a %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/smtp
349cp -a %{SOURCE8} $RPM_BUILD_ROOT%{_sysconfdir}/mail/bounce.cf.pl
350cp -a %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/mail/bounce.cf.de
351cp -a %{SOURCE10} $RPM_BUILD_ROOT/etc/monit/%{name}.monitrc
352cp -a %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}/%{name}.service
353install -p auxiliary/rmail/rmail $RPM_BUILD_ROOT%{_bindir}/rmail
354install -p auxiliary/qshape/qshape.pl $RPM_BUILD_ROOT%{_bindir}/qshape
355
356ln -sf %{_sbindir}/sendmail $RPM_BUILD_ROOT%{_bindir}/mailq
357ln -sf %{_sbindir}/sendmail $RPM_BUILD_ROOT%{_bindir}/newaliases
358ln -sf %{_sbindir}/sendmail $RPM_BUILD_ROOT/usr/lib/sendmail
359
360touch $RPM_BUILD_ROOT%{_sysconfdir}/mail/\
361 {aliases,access,canonical,relocated,transport,virtual}{,.db}
362
363touch $RPM_BUILD_ROOT/etc/security/blacklist.smtp
364
365> $RPM_BUILD_ROOT/var/spool/postfix/.nofinger
366
367%{__rm} -r $RPM_BUILD_ROOT%{_sysconfdir}/mail/makedefs.out
368%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/mail/{,TLS_}LICENSE
369
370%clean
371rm -rf $RPM_BUILD_ROOT
372
373%pre
374%groupadd -g 62 postfix
375%groupadd -g 63 maildrop
376%useradd -u 62 -d /var/spool/postfix -s /bin/false -c "Postfix User" -g postfix postfix
377
378%post
379/sbin/ldconfig
380if ! grep -q "^postmaster:" %{_sysconfdir}/mail/aliases; then
381 echo "Adding Entry for postmaster in %{_sysconfdir}/mail/aliases" >&2
382 echo "postmaster: root" >>%{_sysconfdir}/mail/aliases
383fi
384if [ "$1" = "1" ]; then
385 # only on installation, not upgrade; set sane defaults
386 # postfix expects gethostname() to return FQDN, which is obviously wrong
387 if ! grep -qE "^my(domain|hostname)" %{_sysconfdir}/mail/main.cf; then
388 domain=$(/bin/hostname -d 2>/dev/null)
389 [ -n "$domain" -a "$domain" != 'localdomain' ] && \
390 postconf -e mydomain="$domain"
391 fi
392else
393 %{_sbindir}/postfix upgrade-configuration
394fi
395
396%{_bindir}/newaliases
397/sbin/chkconfig --add postfix
398%service postfix restart "Postfix Daemon"
399%systemd_post postfix.service
400
401%preun
402if [ "$1" = "0" ]; then
403 %service postfix stop
404 /sbin/chkconfig --del postfix
405fi
406%systemd_preun postfix.service
407
408%postun
409/sbin/ldconfig
410if [ "$1" = "0" ]; then
411 %groupremove maildrop
412 %userremove postfix
413 %groupremove postfix
414fi
415%systemd_reload
416
417%triggerpostun -- postfix < 2:2.9.4-4
418%systemd_trigger postfix.service
419
420%files
421%defattr(644,root,root,755)
422%doc html COMPATIBILITY HISTORY LICENSE RELEASE_NOTES* TLS_*
423%doc README_FILES/*README
424%doc examples/smtpd-policy
425%dir %{_sysconfdir}/mail
426%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/access
427%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/aliases
428%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/bounce.cf.default
429%lang(de) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/bounce.cf.de
430%lang(pl) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/bounce.cf.pl
431%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/canonical
432%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/generic
433#%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/regexp_table
434%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/relocated
435%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/transport
436%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/virtual
437%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/header_checks
438#%ghost %{_sysconfdir}/mail/*.db
439%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/dynamicmaps.cf
440%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/main.cf
441%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/main.cf.default
442%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/main.cf.proto
443%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/master.cf
444%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/master.cf.proto
445%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/postfix-files
446%attr(740,root,root) /etc/cron.daily/postfix
447%attr(754,root,root) /etc/rc.d/init.d/postfix
448%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/postfix
449%config(noreplace) %verify(not md5 mtime size) /etc/pam.d/smtp
450%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.smtp
451%{?with_sasl:%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sasl/smtpd.conf}
452%attr(755,root,root) %{_bindir}/mailq
453%attr(755,root,root) %{_bindir}/newaliases
454%attr(755,root,root) %{_bindir}/rmail
455%attr(755,root,root) %{_sbindir}/s*
456%attr(755,root,root) %{_sbindir}/postfix
457%attr(755,root,root) %{_sbindir}/postalias
458%attr(755,root,root) %{_sbindir}/postkick
459%attr(755,root,root) %{_sbindir}/postl*
460%attr(755,root,root) %{_sbindir}/postc*
461%attr(755,root,root) %{_sbindir}/postmap
462%attr(755,root,root) %{_sbindir}/postmulti
463%attr(2755,root,maildrop) %{_sbindir}/postqueue
464%attr(755,root,root) %{_sbindir}/postsuper
465%attr(2755,root,maildrop) %{_sbindir}/postdrop
466%attr(755,root,root) /usr/lib/sendmail
467%dir %{_libdir}/postfix
468%attr(755,root,root) %{_libdir}/postfix/anvil
469%attr(755,root,root) %{_libdir}/postfix/bounce
470%attr(755,root,root) %{_libdir}/postfix/cleanup
471%attr(755,root,root) %{_libdir}/postfix/discard
472%attr(755,root,root) %{_libdir}/postfix/dnsblog
473%attr(755,root,root) %{_libdir}/postfix/error
474%attr(755,root,root) %{_libdir}/postfix/flush
475%attr(755,root,root) %{_libdir}/postfix/libpostfix-dns.so
476%attr(755,root,root) %{_libdir}/postfix/libpostfix-global.so
477%attr(755,root,root) %{_libdir}/postfix/libpostfix-master.so
478%attr(755,root,root) %{_libdir}/postfix/libpostfix-tls.so
479%attr(755,root,root) %{_libdir}/postfix/libpostfix-util.so
480%attr(755,root,root) %{_libdir}/postfix/lmtp
481%attr(755,root,root) %{_libdir}/postfix/local
482%attr(755,root,root) %{_libdir}/postfix/master
483%attr(755,root,root) %{_libdir}/postfix/nqmgr
484%attr(755,root,root) %{_libdir}/postfix/oqmgr
485%attr(755,root,root) %{_libdir}/postfix/pickup
486%attr(755,root,root) %{_libdir}/postfix/pipe
487%attr(755,root,root) %{_libdir}/postfix/postfix-cdb.so
488%attr(755,root,root) %{_libdir}/postfix/postfix-script
489%attr(755,root,root) %{_libdir}/postfix/postfix-tls-script
490%attr(755,root,root) %{_libdir}/postfix/postfix-wrapper
491%attr(755,root,root) %{_libdir}/postfix/post-install
492%attr(755,root,root) %{_libdir}/postfix/postmulti-script
493%attr(755,root,root) %{_libdir}/postfix/postscreen
494%attr(755,root,root) %{_libdir}/postfix/proxymap
495%attr(755,root,root) %{_libdir}/postfix/qmgr
496%attr(755,root,root) %{_libdir}/postfix/qmqpd
497%attr(755,root,root) %{_libdir}/postfix/scache
498%attr(755,root,root) %{_libdir}/postfix/showq
499%attr(755,root,root) %{_libdir}/postfix/smtp
500%attr(755,root,root) %{_libdir}/postfix/smtpd
501%attr(755,root,root) %{_libdir}/postfix/spawn
502%attr(755,root,root) %{_libdir}/postfix/tlsmgr
503%attr(755,root,root) %{_libdir}/postfix/tlsproxy
504%attr(755,root,root) %{_libdir}/postfix/trivial-rewrite
505%attr(755,root,root) %{_libdir}/postfix/verify
506%attr(755,root,root) %{_libdir}/postfix/virtual
507%attr(755,root,root) %dir %{_var}/spool/postfix
508%attr(700,postfix,root) %dir %{_var}/spool/postfix/active
509%attr(700,postfix,root) %dir %{_var}/spool/postfix/bounce
510%attr(700,postfix,root) %dir %{_var}/spool/postfix/corrupt
511%attr(700,postfix,root) %dir %{_var}/spool/postfix/defer
512%attr(700,postfix,root) %dir %{_var}/spool/postfix/deferred
513%attr(700,postfix,root) %dir %{_var}/spool/postfix/incoming
514%attr(1730,postfix,maildrop) %dir %{_var}/spool/postfix/maildrop
515%attr(755,root,root) %dir %{_var}/spool/postfix/pid
516%attr(700,postfix,root) %dir %{_var}/spool/postfix/private
517%attr(710,postfix,maildrop) %dir %{_var}/spool/postfix/public
518%attr(700,postfix,root) %dir %{_var}/spool/postfix/saved
519%attr(644,postfix,root) %{_var}/spool/postfix/.nofinger
520%attr(700,postfix,root) %{_var}/lib/postfix
521%{_mandir}/man1/mailq.1*
522%{_mandir}/man1/newaliases.1*
523%{_mandir}/man1/post*.1*
524%{_mandir}/man1/sendmail.1*
525%{_mandir}/man5/access.5*
526%{_mandir}/man5/aliases.5*
527%{_mandir}/man5/body_checks.5*
528%{_mandir}/man5/bounce.5*
529%{_mandir}/man5/canonical.5*
530%{_mandir}/man5/cidr_table.5*
531%{_mandir}/man5/generic.5*
532%{_mandir}/man5/header_checks.5*
533%{_mandir}/man5/master.5*
534%{_mandir}/man5/memcache_table.5*
535%{_mandir}/man5/nisplus_table.5*
536%{_mandir}/man5/postconf.5*
537%{_mandir}/man5/postfix-wrapper.5*
538%{_mandir}/man5/regexp_table.5*
539%{_mandir}/man5/relocated.5*
540%{_mandir}/man5/socketmap_table.5*
541%{_mandir}/man5/tcp_table.5*
542%{_mandir}/man5/transport.5*
543%{_mandir}/man5/virtual.5*
544%{_mandir}/man8/*.8*
545%{systemdunitdir}/%{name}.service
546
547%files devel
548%defattr(644,root,root,755)
549%{_includedir}/postfix
550
551%if %{with ldap}
552%files dict-ldap
553%defattr(644,root,root,755)
554%attr(755,root,root) %{_libdir}/postfix/postfix-ldap.so
555%{_mandir}/man5/ldap_table.5*
556%endif
557
558%if %{with mysql}
559%files dict-mysql
560%defattr(644,root,root,755)
561%attr(755,root,root) %{_libdir}/postfix/postfix-mysql.so
562%{_mandir}/man5/mysql_table.5*
563%endif
564
565%files dict-pcre
566%defattr(644,root,root,755)
567%attr(755,root,root) %{_libdir}/postfix/postfix-pcre.so
568#%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/pcre_table
569%{_mandir}/man5/pcre_table.5*
570
571%if %{with pgsql}
572%files dict-pgsql
573%defattr(644,root,root,755)
574%attr(755,root,root) %{_libdir}/postfix/postfix-pgsql.so
575%{_mandir}/man5/pgsql_table.5*
576%endif
577
578%if %{with sqlite}
579%files dict-sqlite
580%defattr(644,root,root,755)
581%attr(755,root,root) %{_libdir}/postfix/postfix-sqlite.so
582%{_mandir}/man5/sqlite_table.5*
583%endif
584
585%if %{with lmdb}
586%files dict-lmdb
587%defattr(644,root,root,755)
588%attr(755,root,root) %{_libdir}/postfix/postfix-lmdb.so
589%{_mandir}/man5/lmdb_table.5*
590%endif
591
592%files qshape
593%defattr(644,root,root,755)
594%attr(755,root,root) %{_bindir}/qshape
595
596%files -n monit-rc-%{name}
597%defattr(644,root,root,755)
598%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}.monitrc
This page took 0.035303 seconds and 4 git commands to generate.