]> git.pld-linux.org Git - packages/poldek.git/commitdiff
- add support for resolving uname() deps with rpm.org
authorJan Rękorajski <baggins@pld-linux.org>
Thu, 22 Oct 2020 07:07:10 +0000 (09:07 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Thu, 22 Oct 2020 07:07:10 +0000 (09:07 +0200)
- remove always false ifdef, index type must also be set for rpm.org

db-index-format.patch [new file with mode: 0644]
poldek.spec
rpm4-uname-deps.patch [new file with mode: 0644]

diff --git a/db-index-format.patch b/db-index-format.patch
new file mode 100644 (file)
index 0000000..76d9de0
--- /dev/null
@@ -0,0 +1,12 @@
+--- poldek-0.42.2/pm/rpmorg/rpmdb_depdirs.c~   2020-10-21 15:02:08.000000000 +0200
++++ poldek-0.42.2/pm/rpmorg/rpmdb_depdirs.c    2020-10-21 15:02:22.244854642 +0200
+@@ -74,9 +74,7 @@
+     
+     index = "Requirename";
+-#ifdef HAVE_RPM_5
+     dbtype = DB_BTREE; /* XXX: should be detected at runtime */
+-#endif
+     if (rootdir == NULL)
+         rootdir = "/";
+     
index 78cb6d336608cdd152f9998eb4750d4c8f763757..9db273202845411bd32011b8ebdcc6534b9b17c1 100644 (file)
@@ -58,6 +58,8 @@ Patch3:               %{name}-pc.patch
 Patch4:                %{name}-info.patch
 Patch5:                %{name}-multiarch-x32.patch
 Patch6:                rpm-4.15.patch
+Patch7:                db-index-format.patch
+Patch8:                rpm4-uname-deps.patch
 URL:           http://poldek.pld-linux.org/
 BuildRequires: %{db_pkg}-devel >= %{ver_db}
 BuildRequires: autoconf >= 2.63
@@ -238,6 +240,8 @@ Moduły języka Python dla poldka.
 %patch4 -p1
 %patch5 -p1
 %patch6 -p1
+%patch7 -p1
+%patch8 -p1
 
 %{__rm} doc/poldek.info
 %{__rm} m4/libtool.m4 m4/lt*.m4
diff --git a/rpm4-uname-deps.patch b/rpm4-uname-deps.patch
new file mode 100644 (file)
index 0000000..611c0ed
--- /dev/null
@@ -0,0 +1,12 @@
+--- poldek-0.42.2/pm/rpmorg/misc.c~    2020-01-25 22:59:59.000000000 +0100
++++ poldek-0.42.2/pm/rpmorg/misc.c     2020-10-22 08:56:32.637093626 +0200
+@@ -76,6 +76,9 @@
+     int       i;
+     rpmcap_fn functions[] = {
+         rpmdsRpmlib,
++#ifdef HAVE_RPMDSUNAME
++        (rpmcap_fn)rpmdsUname,
++#endif
+         NULL,
+     };
This page took 0.090038 seconds and 4 git commands to generate.