]> git.pld-linux.org Git - packages/poldek.git/commitdiff
- add cpuinfo() deps support for rpm.org
authorJan Rękorajski <baggins@pld-linux.org>
Sun, 15 Nov 2020 09:32:40 +0000 (10:32 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Sun, 15 Nov 2020 09:32:40 +0000 (10:32 +0100)
- disable directory dependencies for rpm.org, unsupported by rpm

poldek.spec
rpm4-cpuinfo-deps.patch [new file with mode: 0644]
rpm4-no-dir-deps.patch [new file with mode: 0644]

index 8a955800b0325111751d215d36d3107ee8ccecd3..0ccd2328bf19fe74d995011f23d6abe28aebf965 100644 (file)
@@ -61,6 +61,8 @@ Patch6:               rpm-4.15.patch
 Patch7:                db-index-format.patch
 Patch8:                rpm4-uname-deps.patch
 Patch9:                sqlite-rpmdb.patch
+Patch10:       rpm4-cpuinfo-deps.patch
+Patch11:       rpm4-no-dir-deps.patch
 URL:           http://poldek.pld-linux.org/
 BuildRequires: %{db_pkg}-devel >= %{ver_db}
 BuildRequires: autoconf >= 2.63
diff --git a/rpm4-cpuinfo-deps.patch b/rpm4-cpuinfo-deps.patch
new file mode 100644 (file)
index 0000000..feab6a8
--- /dev/null
@@ -0,0 +1,12 @@
+--- poldek-0.42.2/pm/rpmorg/misc.c~    2020-11-01 10:27:32.000000000 +0100
++++ poldek-0.42.2/pm/rpmorg/misc.c     2020-11-15 10:30:02.296719845 +0100
+@@ -79,6 +79,9 @@
+ #ifdef HAVE_RPMDSUNAME
+         (rpmcap_fn)rpmdsUname,
+ #endif
++#ifdef HAVE_RPMDSCPUINFO
++        (rpmcap_fn)rpmdsCpuinfo,
++#endif
+         NULL,
+     };
diff --git a/rpm4-no-dir-deps.patch b/rpm4-no-dir-deps.patch
new file mode 100644 (file)
index 0000000..ae6db7d
--- /dev/null
@@ -0,0 +1,21 @@
+--- poldek-0.42.2/pm/rpmorg/Makefile.am~       2020-01-25 23:03:28.000000000 +0100
++++ poldek-0.42.2/pm/rpmorg/Makefile.am        2020-11-15 10:28:44.040052400 +0100
+@@ -8,7 +8,6 @@
+ libpm_rpm_la_SOURCES =                        \
+       mod.c                           \
+       rpmdb_it.c                      \
+-      rpmdb_depdirs.c                 \
+       install.c                       \
+       signature.c                     \
+       misc.c                          \
+--- poldek-0.42.2/pm/rpmorg/mod.c~     2020-01-25 22:59:59.000000000 +0100
++++ poldek-0.42.2/pm/rpmorg/mod.c      2020-11-15 10:28:21.190049426 +0100
+@@ -26,7 +26,7 @@
+     pm_rpm_satisfies,
+     pm_rpm_dbpath, 
+     pm_rpm_dbmtime,
+-    pm_rpm_dbdepdirs,
++    NULL,                       /* pm_rpm_dbdepdirs */
+     
+ (void *(*)(void *, void *, const char *, const char *, mode_t, tn_hash *))pm_rpm_opendb,
+     (void (*)(void *))pm_rpm_closedb,
This page took 0.595477 seconds and 4 git commands to generate.