]> git.pld-linux.org Git - packages/poldek.git/blobdiff - poldek.spec
- lazy evaluate 'or' deps
[packages/poldek.git] / poldek.spec
index d6b06a6aa0b3fcbea5ed944d85d93c3ec4f82d5a..dd2135401d5cc10a4243000eb7409eca235953c7 100644 (file)
 %bcond_with    tests   # tests
 
 # current snapshot name
-%define                SNAP    2020
+%define                SNAP    2021
 
 # required versions (forced to avoid SEGV with mixed db used by rpm and poldek)
-%if %{without rpm5}
-%define                db_pkg          db
-%define                ver_db          5.3
-%define                ver_rpm         1:4.14
-%define                ver_db_devel    %(rpm -q --qf '%|E?{%{E}:}|%{V}-%{R}' --what-provides db-devel)
-%else
+%if %{with rpm5}
 %define                ver_db          %(rpm -q --provides rpm-lib | awk 'BEGIN { v="RPM_TOO_OLD" } /^rpm-db-ver = [.0-9]+$/ { v=$3 } END { print v }')
 %define                db_pkg          db%{ver_db}
 %define                ver_rpm         5.4.10
+%else
+%define                ver_rpm         1:4.14
 %endif
 
-%define                rel     8
+%define                rel     11
 Summary:       RPM packages management helper tool
 Summary(hu.UTF-8):     RPM csomagkezelést segítő eszköz
 Summary(pl.UTF-8):     Pomocnicze narzędzie do zarządzania pakietami RPM
@@ -70,8 +67,10 @@ Patch15:     skip-buildid-obsoletes.patch
 Patch16:       verify-signature.patch
 Patch17:       %{name}-rsa_sig_rpmorg.patch
 Patch18:       no-bdb-for-rpm-org.patch
+Patch19:       more-trace.patch
+Patch20:       boolean-deps.patch
 URL:           http://poldek.pld-linux.org/
-BuildRequires: %{db_pkg}-devel >= %{ver_db}
+%{?with_rpm5:BuildRequires:    %{db_pkg}-devel >= %{ver_db}}
 BuildRequires: autoconf >= 2.63
 BuildRequires: automake >= 1:1.11
 BuildRequires: bzip2-devel
@@ -102,7 +101,7 @@ BuildRequires:      xz
 BuildRequires: zlib-devel
 BuildRequires: zstd-devel
 %if %{with static}
-BuildRequires: %{db_pkg}-static >= %{ver_db}
+%{?with_rpm5:BuildRequires:    %{db_pkg}-static >= %{ver_db}}
 BuildRequires: bzip2-static
 BuildRequires: glibc-static
 BuildRequires: libxml2-static
@@ -117,9 +116,7 @@ BuildRequires:      zstd-static
 %endif
 Requires(postun):      awk
 Requires(postun):      sed >= 4.0
-%if %{without rpm5}
-Requires:      %{db_pkg} >= %{ver_db_devel}
-%else
+%if %{with rpm5}
 Requires:      %{db_pkg} >= %{ver_db}
 Requires:      rpm-db-ver = %{ver_db}
 %endif
@@ -265,6 +262,8 @@ cd ..
 %patch16 -p1
 %patch17 -p1
 %patch18 -p1
+%patch19 -p1
+%patch20 -p1
 
 %{__rm} doc/poldek.info
 %{__rm} m4/libtool.m4 m4/lt*.m4
This page took 0.033323 seconds and 4 git commands to generate.