]> git.pld-linux.org Git - packages/poldek.git/blobdiff - poldek.spec
- release 2 (by relup.sh)
[packages/poldek.git] / poldek.spec
index af37042c3f852168eed7bf476fbc260a03e7a010..8318366d7e677a79c1cb57086529385306be0e0f 100644 (file)
@@ -4,28 +4,36 @@
 %bcond_without imode   # don't build interactive mode
 %bcond_without python  # don't build python bindings
 %bcond_with    snap    # install configs for official Th snapshot
+%bcond_with    db60    # DB 6.0 instead of 5.2
 
 # current snapshot name
-%define                SNAP    2012
+%define                SNAP    2014
 
 # required versions (forced to avoid SEGV with mixed db used by rpm and poldek)
+# NOTE: poldek links with "system db" (-ldb) anyway if it exists
+%if %{with db60}
+%define                db_pkg          db6.0
+%define                ver_db          6.0
+%define                ver_db_rel      1
+%else
+%define                db_pkg          db5.2
 %define                ver_db          5.2
 %define                ver_db_rel      3
+%endif
 %define                ver_rpm         5.4.10
 
-%define                snap    rc6
-%define                rel     4%{?with_snap:.%{SNAP}}
+%define                rel     2
 Summary:       RPM packages management helper tool
 Summary(hu.UTF-8):     RPM csomagkezelést segítő eszköz
 Summary(pl.UTF-8):     Pomocnicze narzędzie do zarządzania pakietami RPM
 Name:          poldek
-Version:       0.30
-Release:       1.%{snap}.%{rel}
+Version:       0.30.1
+Release:       %{rel}%{?with_snap:.%{SNAP}}
 License:       GPL v2
 Group:         Applications/System
 #Source0:      http://poldek.pld-linux.org/download/snapshots/%{name}-%{version}-cvs%{snap}.tar.bz2
-Source0:       http://carme.pld-linux.org/~megabajt/snaps/poldek/%{name}-%{version}%{snap}.tar.xz
-# Source0-md5: 4b528ad356b02efdd72b81f1ecaceb83
+Source0:       http://carme.pld-linux.org/~megabajt/releases/poldek/%{name}-%{version}.tar.xz
+# Source0-md5: e569c8454df0932df53b09cee9998927
 Source1:       %{name}.conf
 Source2:       %{name}-multilib.conf
 Source5:       %{name}-aliases.conf
@@ -38,20 +46,14 @@ Source11:   %{name}-archive.conf
 Source100:     %{name}-snap.conf
 Source101:     %{name}-multilib-snap.conf
 Source102:     %{name}-debuginfo-snap.conf
-Patch0:                %{name}-vserver-packages.patch
+Patch0:                %{name}-size-type.patch
 Patch1:                %{name}-config.patch
-Patch2:                %{name}-size-type.patch
-Patch3:                %{name}-Os-fail-workaround.patch
-Patch4:                %{name}-link-rpmio.patch
-Patch5:                %{name}-vrpmlog.patch
-Patch6:                %{name}-git.patch
-Patch7:                %{name}-db52.patch
 URL:           http://poldek.pld-linux.org/
+BuildRequires: %{db_pkg}-devel >= %{ver_db}-%{ver_db_rel}
 BuildRequires: autoconf
-BuildRequires: automake
+BuildRequires: automake >= 1:1.11
 BuildRequires: bzip2-devel
 BuildRequires: check-devel
-BuildRequires: db-devel >= %{ver_db}-%{ver_db_rel}
 BuildRequires: docbook-dtd412-xml
 BuildRequires: gettext-devel
 BuildRequires: libtool
@@ -66,13 +68,14 @@ BuildRequires:      readline-devel >= 5.0
 BuildRequires: rpm-devel >= %{ver_rpm}
 %{?with_python:BuildRequires:  rpm-pythonprov}
 BuildRequires: swig-python
+BuildRequires: tar >= 1:1.22
 BuildRequires: xmlto
+BuildRequires: xz
 BuildRequires: zlib-devel
 %if %{with static}
+BuildRequires: %{db_pkg}-static >= %{ver_db}-%{ver_db_rel}
 BuildRequires: bzip2-static
-BuildRequires: db-static >= %{ver_db}-%{ver_db_rel}
 BuildRequires: glibc-static
-BuildRequires: libselinux-static
 BuildRequires: libxml2-static
 BuildRequires: ncurses-static
 BuildRequires: openssl-static
@@ -84,8 +87,8 @@ BuildRequires:        zlib-static
 %endif
 Requires(triggerpostun):       awk
 Requires(triggerpostun):       sed >= 4.0
+Requires:      %{db_pkg} >= %{ver_db}-%{ver_db_rel}
 Requires:      %{name}-libs = %{version}-%{release}
-Requires:      db >= %{ver_db}-%{ver_db_rel}
 Requires:      rpm >= %{ver_rpm}
 Requires:      rpm-db-ver = %{ver_db}
 #Requires:     rpm-lib = %(rpm -q --qf '%{V}' rpm-lib)
@@ -94,6 +97,8 @@ Requires:     rpm-lib >= 5.4.10
 Requires:      sed
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                _libexecdir     %{_prefix}/lib/%{name}
+
 %description
 poldek is an RPM package management tool which allows you to easily
 perform package verification, installation (including system
@@ -191,7 +196,7 @@ Summary(hu.UTF-8):  Python modulok poldek-hez
 Summary(pl.UTF-8):     Moduły języka Python dla poldka
 Group:         Libraries/Python
 Requires:      %{name}-libs = %{version}-%{release}
-%pyrequires_eq python-libs
+Requires:      python-libs
 
 %description -n python-poldek
 Python modules for poldek.
@@ -206,12 +211,6 @@ Moduły języka Python dla poldka.
 %setup -q
 %patch0 -p1
 %patch1 -p1
-%patch2 -p1
-%patch3 -p1
-%patch4 -p1
-%patch5 -p1
-%patch6 -p1
-%patch7 -p1
 
 %{__rm} m4/libtool.m4 m4/lt*.m4
 
@@ -220,6 +219,7 @@ find . '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
 chmod u+x ./configure ./doc/conf-xml2.sh
 
 %build
+%{__gettextize}
 %{__libtoolize}
 %{__aclocal} -I m4
 %{__autoheader}
@@ -239,10 +239,11 @@ cd ../trurlib
 %{__automake}
 cd ..
 
-CPPFLAGS="%{rpmcppflags} -std=gnu99"
+CPPFLAGS="%{rpmcppflags} -std=gnu99 -fgnu89-inline"
 %configure \
        %{?with_static:--enable-static --disable-shared} \
        %{!?with_imode:--disable-imode} \
+       --with-pkglibdir=%{_libexecdir} \
        --enable-nls \
        %{?with_python:--with-python}
 %{__make} -j1
@@ -462,8 +463,8 @@ fi
 %attr(755,root,root) %{_bindir}/ipoldek
 %attr(755,root,root) %{_bindir}/poldek
 %attr(755,root,root) %{_bindir}/rpmvercmp
-%dir %{_libdir}/%{name}
-%attr(755,root,root) %{_libdir}/%{name}/*
+%dir %{_libexecdir}
+%attr(755,root,root) %{_libexecdir}/*
 %{_mandir}/man1/%{name}*.1*
 %lang(pl) %{_mandir}/pl/man1/%{name}*
 %{_infodir}/poldek.info*
@@ -507,6 +508,7 @@ fi
 %{_includedir}/trurl
 %{_includedir}/vfile
 %{_pkgconfigdir}/tndb.pc
+%{_pkgconfigdir}/trurlib.pc
 
 %files static
 %defattr(644,root,root,755)
This page took 0.382469 seconds and 4 git commands to generate.