]> git.pld-linux.org Git - packages/poldek.git/blobdiff - poldek.spec
- 2021 snap
[packages/poldek.git] / poldek.spec
index fb02541601b1481452b03d93d015fa65e4e07308..5fbd409614edd2f5af64d698698c3ff2ffde688d 100644 (file)
@@ -5,27 +5,24 @@
 # Conditional build:
 %bcond_with    static  # don't use shared libraries
 %bcond_without imode   # don't build interactive mode
-%bcond_without python  # don't build python bindings
+%bcond_with    python  # don't build python bindings
 %bcond_with    snap    # install configs for official Th snapshot
-%bcond_with    rpm4    # use rpm4 instead of rpm5
+%bcond_with    rpm5    # use rpm5 instead of rpm4
 %bcond_with    tests   # tests
 
 # current snapshot name
-%define                SNAP    2019
+%define                SNAP    2021
 
 # required versions (forced to avoid SEGV with mixed db used by rpm and poldek)
-%if %{with rpm4}
-%define                db_pkg          db
-%define                ver_db          5.3
-%define                ver_rpm         1:4.14
-%define                ver_db_devel    %(rpm -q --qf '%|E?{%{E}:}|%{V}-%{R}' --what-provides db-devel)
-%else
+%if %{with rpm5}
 %define                ver_db          %(rpm -q --provides rpm-lib | awk 'BEGIN { v="RPM_TOO_OLD" } /^rpm-db-ver = [.0-9]+$/ { v=$3 } END { print v }')
 %define                db_pkg          db%{ver_db}
 %define                ver_rpm         5.4.10
+%else
+%define                ver_rpm         1:4.14
 %endif
 
-%define                rel     3
+%define                rel     8
 Summary:       RPM packages management helper tool
 Summary(hu.UTF-8):     RPM csomagkezelést segítő eszköz
 Summary(pl.UTF-8):     Pomocnicze narzędzie do zarządzania pakietami RPM
@@ -57,8 +54,21 @@ Patch2:              %{name}-ext-down-enable.patch
 Patch3:                %{name}-pc.patch
 Patch4:                %{name}-info.patch
 Patch5:                %{name}-multiarch-x32.patch
+Patch6:                rpm-4.15.patch
+Patch7:                db-index-format.patch
+Patch8:                rpm4-uname-deps.patch
+Patch9:                sqlite-rpmdb.patch
+Patch10:       rpm4-cpuinfo-deps.patch
+Patch11:       rpm4-no-dir-deps.patch
+Patch12:       rpm4-rpmvercmp.patch
+Patch13:       trurlib-shared.patch
+Patch14:       rpm4-script-req-workaround.patch
+Patch15:       skip-buildid-obsoletes.patch
+Patch16:       verify-signature.patch
+Patch17:       %{name}-rsa_sig_rpmorg.patch
+Patch18:       no-bdb-for-rpm-org.patch
 URL:           http://poldek.pld-linux.org/
-BuildRequires: %{db_pkg}-devel >= %{ver_db}
+%{?with_rpm5:BuildRequires:    %{db_pkg}-devel >= %{ver_db}}
 BuildRequires: autoconf >= 2.63
 BuildRequires: automake >= 1:1.11
 BuildRequires: bzip2-devel
@@ -69,9 +79,13 @@ BuildRequires:       gettext-tools >= 0.11.5
 BuildRequires: libgomp-devel
 BuildRequires: libtool
 BuildRequires: libxml2-devel >= 2
+BuildRequires: lua54-devel
 BuildRequires: ncurses-devel
 BuildRequires: openssl-devel >= 0.9.7d
 BuildRequires: pcre-devel
+BuildRequires: perl-XML-Simple
+BuildRequires: perl-base
+BuildRequires: perl-modules
 BuildRequires: pkgconfig
 BuildRequires: popt-devel
 %{?with_python:BuildRequires:  python-devel}
@@ -79,12 +93,13 @@ BuildRequires:      readline-devel >= 5.0
 BuildRequires: rpm-devel >= %{ver_rpm}
 %{?with_python:BuildRequires:  rpm-pythonprov}
 BuildRequires: tar >= 1:1.22
+BuildRequires: texinfo
 BuildRequires: xmlto
 BuildRequires: xz
 BuildRequires: zlib-devel
 BuildRequires: zstd-devel
 %if %{with static}
-BuildRequires: %{db_pkg}-static >= %{ver_db}
+%{?with_rpm5:BuildRequires:    %{db_pkg}-static >= %{ver_db}}
 BuildRequires: bzip2-static
 BuildRequires: glibc-static
 BuildRequires: libxml2-static
@@ -97,11 +112,9 @@ BuildRequires:      rpm-static
 BuildRequires: zlib-static
 BuildRequires: zstd-static
 %endif
-Requires(triggerpostun):       awk
-Requires(triggerpostun):       sed >= 4.0
-%if %{with rpm4}
-Requires:      %{db_pkg} >= %{ver_db_devel}
-%else
+Requires(postun):      awk
+Requires(postun):      sed >= 4.0
+%if %{with rpm5}
 Requires:      %{db_pkg} >= %{ver_db}
 Requires:      rpm-db-ver = %{ver_db}
 %endif
@@ -232,6 +245,21 @@ Moduły języka Python dla poldka.
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
+%patch6 -p1
+%patch7 -p1
+%patch8 -p1
+%patch9 -p1
+%patch10 -p1
+%patch11 -p1
+%patch12 -p1
+cd trurlib
+%patch13 -p1
+cd ..
+%patch14 -p1
+%patch15 -p1
+%patch16 -p1
+%patch17 -p1
+%patch18 -p1
 
 %{__rm} doc/poldek.info
 %{__rm} m4/libtool.m4 m4/lt*.m4
@@ -296,7 +324,7 @@ install -p %{SOURCE3} $RPM_BUILD_ROOT%{_bindir}/poldek-config
 
 %{?with_static:%{__rm} $RPM_BUILD_ROOT%{_bindir}/rpmvercmp}
 
-%ifarch i486 i686 ppc sparc alpha athlon aarch64
+%ifarch i486 i686 ppc sparc alpha athlon aarch64 %{arm}
        %define         ftp_arch        %{_target_cpu}
 %endif
 %ifarch %{x8664}
@@ -449,7 +477,8 @@ fi
 %post  libs -p /sbin/ldconfig
 %postun        libs -p /sbin/ldconfig
 
-%triggerpostun -- poldek < 0.30-0.20080225.00.1
+%triggerpostun -- poldek < 0.30.1-8
+# poldek < 0.30-0.20080225.00.1
 if ! grep -q '^%%includedir repos.d' %{_sysconfdir}/%{name}/poldek.conf; then
        %{__sed} -i -e '/^%%include source.conf/{
                a
@@ -472,8 +501,7 @@ if [ -f %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave ]; then
        %{__mv} -v %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf
 fi
 %endif
-
-%triggerpostun -- poldek < 0.30.1-3
+# poldek < 0.30.1-3
 if [ -f %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf.rpmsave ]; then
        %{__mv} -f %{_sysconfdir}/%{name}/repos.d/pld-%{ftp_alt_arch}.conf{,.rpmnew}
        %{__mv} -v %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-%{ftp_alt_arch}.conf
@@ -482,8 +510,7 @@ if [ -f %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-multilib.conf.rpmsave ]; then
        %{__mv} -f %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-%{ftp_alt_arch}.conf{,.rpmnew}
        %{__mv} -v %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-multilib.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-%{ftp_alt_arch}.conf
 fi
-
-%triggerpostun -- %{name} < 0.30.1-8
+# poldek < 0.30.1-8
 if [ $1 -le 1 ]; then
        # revert change on  --downgrade
        %{__sed} -i -re 's,^pm command = %{pkglibexecdir}/pm-command.sh,#&,' %{_sysconfdir}/%{name}/%{name}.conf
This page took 0.058082 seconds and 4 git commands to generate.