]> git.pld-linux.org Git - packages/poldek.git/blobdiff - poldek.spec
poldek-config: add -c option
[packages/poldek.git] / poldek.spec
index 260dd5880f955e2597065d1823e6968413887ce9..1f53f1dab5eb78d5e5c914646117957de245eb09 100644 (file)
@@ -1,4 +1,7 @@
-#
+# TODO
+# - fix config having escaped html entities:
+#   # package A requires capability foo >= 1.0 while package B provides "foo"
+
 # Conditional build:
 %bcond_with    static  # don't use shared libraries
 %bcond_without imode   # don't build interactive mode
@@ -8,7 +11,7 @@
 %bcond_with    rpm4    # use rpm4/db4.7 instead of rpm5
 
 # current snapshot name
-%define                SNAP    2014
+%define                SNAP    2015
 
 # required versions (forced to avoid SEGV with mixed db used by rpm and poldek)
 # NOTE: poldek links with "system db" (-ldb) anyway if it exists
@@ -23,6 +26,7 @@
 %endif
 
 %if %{with rpm4}
+%define                db_pkg          db4.7
 %define                ver_db          4.7.25
 %define                ver_db_rel      1
 %define                ver_rpm         4.5-49
 %define                ver_rpm         5.4.10
 %endif
 
-%define                rel     9
+%define                rel     3
 Summary:       RPM packages management helper tool
 Summary(hu.UTF-8):     RPM csomagkezelést segítő eszköz
 Summary(pl.UTF-8):     Pomocnicze narzędzie do zarządzania pakietami RPM
 Name:          poldek
-Version:       0.30.1
+Version:       0.32.1
 Release:       %{rel}%{?with_snap:.%{SNAP}}
 License:       GPL v2
 Group:         Applications/System
 #Source0:      http://poldek.pld-linux.org/download/snapshots/%{name}-%{version}-cvs%{snap}.tar.bz2
-Source0:       http://carme.pld-linux.org/~megabajt/releases/poldek/%{name}-%{version}.tar.xz
-# Source0-md5: e569c8454df0932df53b09cee9998927
+Source0:       https://launchpad.net/poldek/0.32/%{version}/+download/%{name}-%{version}.tar.xz
+# Source0-md5: 24794243d0d4573d7159bd924080c83c
 Source1:       %{name}.conf
 Source2:       %{name}-multilib.conf
+Source3:       %{name}-config.sh
 Source5:       %{name}-aliases.conf
 Source6:       %{name}.desktop
 Source7:       %{name}.png
+# Source7-md5: ee487abede50874e9eceb6495d5ee150
 Source8:       %{name}-debuginfo.conf
 Source9:       %{name}-aidath.conf
 Source10:      %{name}-multilib-aidath.conf
@@ -56,9 +62,8 @@ Source101:    %{name}-multilib-snap.conf
 Source102:     %{name}-debuginfo-snap.conf
 Patch0:                %{name}-size-type.patch
 Patch1:                %{name}-config.patch
-Patch2:                %{name}-missing-include.patch
-Patch3:                pm-hooks.patch
-Patch4:                poldek-setenv-null.patch
+Patch2:                pm-hooks.patch
+Patch3:                64k-packages.patch
 URL:           http://poldek.pld-linux.org/
 BuildRequires: %{db_pkg}-devel >= %{ver_db}-%{ver_db_rel}
 BuildRequires: autoconf
@@ -67,9 +72,9 @@ BuildRequires:        bzip2-devel
 BuildRequires: check-devel
 BuildRequires: docbook-dtd412-xml
 BuildRequires: gettext-tools
+BuildRequires: libgomp-devel
 BuildRequires: libtool
 BuildRequires: libxml2-devel
-BuildRequires: neon-devel
 BuildRequires: openssl-devel >= 0.9.7d
 BuildRequires: pcre-devel
 BuildRequires: pkgconfig
@@ -78,7 +83,6 @@ BuildRequires:        popt-devel
 BuildRequires: readline-devel >= 5.0
 BuildRequires: rpm-devel >= %{ver_rpm}
 %{?with_python:BuildRequires:  rpm-pythonprov}
-BuildRequires: swig-python
 BuildRequires: tar >= 1:1.22
 BuildRequires: xmlto
 BuildRequires: xz
@@ -224,7 +228,6 @@ Moduły języka Python dla poldka.
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
-%patch4 -p1
 
 %{__rm} m4/libtool.m4 m4/lt*.m4
 
@@ -270,6 +273,8 @@ install -d $RPM_BUILD_ROOT/var/cache/%{name}
 %{__make} install -j1 \
        DESTDIR=$RPM_BUILD_ROOT
 
+install -p %{SOURCE3} $RPM_BUILD_ROOT%{_bindir}/poldek-config
+
 %if %{with python}
 %{__make} -C python -j1 install \
        DESTDIR=$RPM_BUILD_ROOT \
@@ -487,6 +492,7 @@ fi
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/repos.d/*.conf
 %attr(755,root,root) %{_bindir}/ipoldek
 %attr(755,root,root) %{_bindir}/poldek
+%attr(755,root,root) %{_bindir}/poldek-config
 %attr(755,root,root) %{_bindir}/rpmvercmp
 %dir %{_libexecdir}
 %attr(755,root,root) %{_libexecdir}/pm-command.sh
This page took 0.154167 seconds and 4 git commands to generate.