]> git.pld-linux.org Git - packages/pokerth.git/commitdiff
- one more fix in boost patch; release 6 (boost 1.73) auto/th/pokerth-1.1.2-6
authorJakub Bogusz <qboosh@pld-linux.org>
Fri, 31 Jul 2020 19:39:03 +0000 (21:39 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Fri, 31 Jul 2020 19:39:03 +0000 (21:39 +0200)
pokerth-boost.patch
pokerth.spec

index 7e02dd55510579102011ad4dee3d97b12fb5db2b..0aec30b6557f2a815c4d8f3560c0f12f78d53741 100644 (file)
                        acceptedSocket->set_option(typename P::no_delay(true));
                        acceptedSocket->set_option(boost::asio::socket_base::keep_alive(true));
                        boost::shared_ptr<SessionData> sessionData(new SessionData(acceptedSocket, m_lobbyThread->GetNextSessionId(), m_lobbyThread->GetSessionDataCallback(), *m_ioService));
+--- pokerth-1.1.2-rc/src/net/common/serveracceptwebhelper.cpp.orig     2017-08-16 14:24:03.000000000 +0200
++++ pokerth-1.1.2-rc/src/net/common/serveracceptwebhelper.cpp  2020-07-31 21:14:47.238374433 +0200
+@@ -58,10 +58,10 @@
+       m_webSocketServer->init_asio(m_ioService.get());
+-      m_webSocketServer->set_validate_handler(boost::bind(boost::mem_fn(&ServerAcceptWebHelper::validate), this, _1));
+-      m_webSocketServer->set_open_handler(boost::bind(boost::mem_fn(&ServerAcceptWebHelper::on_open), this, _1));
+-      m_webSocketServer->set_close_handler(boost::bind(boost::mem_fn(&ServerAcceptWebHelper::on_close), this, _1));
+-      m_webSocketServer->set_message_handler(boost::bind(boost::mem_fn(&ServerAcceptWebHelper::on_message), this, _1, _2));
++      m_webSocketServer->set_validate_handler(boost::bind(boost::mem_fn(&ServerAcceptWebHelper::validate), this, boost::placeholders::_1));
++      m_webSocketServer->set_open_handler(boost::bind(boost::mem_fn(&ServerAcceptWebHelper::on_open), this, boost::placeholders::_1));
++      m_webSocketServer->set_close_handler(boost::bind(boost::mem_fn(&ServerAcceptWebHelper::on_close), this, boost::placeholders::_1));
++      m_webSocketServer->set_message_handler(boost::bind(boost::mem_fn(&ServerAcceptWebHelper::on_message), this, boost::placeholders::_1, boost::placeholders::_2));
+       m_webSocketServer->listen(serverPort);
+       m_webSocketServer->start_accept();
index 01f193a58c9400f5fead949d186caa12e8eaec03..464783da7a92b9b6dd1eedbe5ad8ca7140d30368 100644 (file)
@@ -2,7 +2,7 @@ Summary:        The Open Source Texas-Holdem Poker Engine
 Summary(pl.UTF-8):     Silnik gry Texas-Holdem poker
 Name:          pokerth
 Version:       1.1.2
-Release:       5
+Release:       6
 License:       AGPL v3+
 Group:         X11/Applications/Games
 Source0:       http://downloads.sourceforge.net/pokerth/pokerth-%{version}.tar.gz
This page took 0.061521 seconds and 4 git commands to generate.