]> git.pld-linux.org Git - packages/pokerth.git/blame - pokerth.spec
boost rebuild
[packages/pokerth.git] / pokerth.spec
CommitLineData
c98f7e6a
AG
1Summary: The Open Source Texas-Holdem Poker Engine
2Summary(pl.UTF-8): Silnik gry Texas-Holdem poker
3Name: pokerth
b5517f57 4Version: 1.1.2
2acecc37 5Release: 10
b5517f57 6License: AGPL v3+
c98f7e6a 7Group: X11/Applications/Games
b5517f57
JB
8Source0: http://downloads.sourceforge.net/pokerth/pokerth-%{version}.tar.gz
9# Source0-md5: 8fd7d7fc7ece17315e58aa3240dd4586
bc1371f4 10Patch0: x32.patch
b5517f57
JB
11Patch1: system-qtsingleapp.patch
12Patch2: moc.patch
13Patch3: %{name}-protobuf.patch
14Patch4: %{name}-boost.patch
15# from https://github.com/zaphoyd/websocketpp/pull/814/commits/c769c9238ad62178f506038178714a1c35aa2769.patch
16Patch5: %{name}-websocketpp-boost.patch
c98f7e6a 17URL: http://www.pokerth.net/
b5517f57
JB
18BuildRequires: QtCore-devel >= 4.4.3
19BuildRequires: QtGui-devel >= 4.4.3
20BuildRequires: QtNetwork-devel >= 4.4.3
072aff66 21BuildRequires: QtSingleApplication-devel
b5517f57
JB
22BuildRequires: QtSql-devel >= 4.4.3
23BuildRequires: SDL-devel
c98f7e6a 24BuildRequires: SDL_mixer-devel
b5517f57 25BuildRequires: boost-devel >= 1.49
c98f7e6a
AG
26BuildRequires: curl-devel >= 7.16
27BuildRequires: gnutls-devel
b5517f57
JB
28BuildRequires: gsasl-devel >= 1.4
29BuildRequires: libircclient-devel >= 1.3
30BuildRequires: libstdc++-devel >= 6:4.7
31BuildRequires: protobuf-devel >= 2.3.0
c98f7e6a
AG
32BuildRequires: qt4-build >= 4.3.1
33BuildRequires: qt4-qmake >= 4.3.1
4a178bf3 34BuildRequires: sed >= 4.0
b5517f57 35BuildRequires: sqlite3-devel >= 3
8482ca5a 36BuildRequires: tinyxml-devel
c98f7e6a
AG
37BuildRequires: zlib-devel >= 1.2.3
38BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40%description
4a178bf3 41PokerTH is a poker game written in C++/Qt4. You can play the popular
c98f7e6a
AG
42"Texas Hold'em" poker variant against up to six computer-opponents or
43play network games with people all over the world. This poker engine
4a178bf3 44is available for Linux, Windows, and MacOS X.
c98f7e6a
AG
45
46%description -l pl.UTF-8
4a178bf3 47PokerTH to komputerowa gra w pokera napisana w C++/Qt4. Umożliwia ona
c98f7e6a
AG
48grę w popularny wariant "Texas Hold'em" przeciwko maksymalnie sześciu
49komputerowym przeciwnikom lub sieciową grę z innymi zawodnikami.
4a178bf3 50Silnik gry dostępny jest na platformy Linux, Windows oraz MacOS X.
c98f7e6a
AG
51
52%prep
b5517f57 53%setup -q -n pokerth-%{version}-rc
2a63ac07 54%patch0 -p1
d89f6892 55%patch1 -p1
072aff66
JR
56%patch2 -p1
57%patch3 -p1
58%patch4 -p1
59%patch5 -p1
072aff66
JR
60
61%{__rm} -r src/third_party/qtsingleapplication
4a178bf3 62
c98f7e6a 63%build
b5517f57
JB
64install -d build-client build-server
65cd build-server
66qmake-qt4 ../pokerth.pro \
4a178bf3 67 QMAKE_CXX="%{__cxx}" \
b5517f57
JB
68 QMAKE_CXXFLAGS_RELEASE="%{rpmcxxflags}" \
69 QMAKE_LFLAGS_RELEASE="%{rpmldflags}"
70%{__make}
71
72cd ../build-client
73qmake-qt4 ../pokerth.pro \
74 CONFIG+=client \
75 QMAKE_CXX="%{__cxx}" \
76 QMAKE_CXXFLAGS_RELEASE="%{rpmcxxflags}" \
4a178bf3 77 QMAKE_LFLAGS_RELEASE="%{rpmldflags}"
c98f7e6a
AG
78%{__make}
79
80%install
81rm -rf $RPM_BUILD_ROOT
b5517f57
JB
82install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1}
83
84%{__make} -C build-client install \
c98f7e6a
AG
85 INSTALL_ROOT=$RPM_BUILD_ROOT
86
b5517f57
JB
87install build-client/pokerth build-server/bin/pokerth_server $RPM_BUILD_ROOT%{_bindir}
88cp -p docs/pokerth.1 $RPM_BUILD_ROOT%{_mandir}/man1
c98f7e6a
AG
89
90%clean
91rm -rf $RPM_BUILD_ROOT
92
93%files
94%defattr(644,root,root,755)
95%doc COPYING ChangeLog TODO
b5517f57
JB
96%attr(755,root,root) %{_bindir}/pokerth
97%attr(755,root,root) %{_bindir}/pokerth_server
98%{_desktopdir}/pokerth.desktop
99%{_pixmapsdir}/pokerth.png
100%{_datadir}/pokerth
101%{_mandir}/man1/pokerth.1*
This page took 0.05823 seconds and 4 git commands to generate.