]> git.pld-linux.org Git - packages/podman.git/commitdiff
up to 3.3.0
authorJan Palus <atler@pld-linux.org>
Sun, 22 Aug 2021 19:20:36 +0000 (21:20 +0200)
committerJan Palus <atler@pld-linux.org>
Sun, 22 Aug 2021 19:20:36 +0000 (21:20 +0200)
podman-seccomp_32bit.patch [deleted file]
podman.spec

diff --git a/podman-seccomp_32bit.patch b/podman-seccomp_32bit.patch
deleted file mode 100644 (file)
index f210a48..0000000
+++ /dev/null
@@ -1,164 +0,0 @@
-From 619da3b9581020e84c48edcae99ac817037a2b2f Mon Sep 17 00:00:00 2001
-From: Jan Palus <jpalus@fastmail.com>
-Date: Tue, 1 Jun 2021 17:57:27 +0200
-Subject: [PATCH] seccomp: allow more *_time64 syscalls
-
-add missing equivalents of already allowed syscalls for 32-bit platforms
-with 64-bit time for countering Y2038
-
-Fixes #593
-
-Signed-off-by: Jan Palus <jpalus@fastmail.com>
----
- pkg/seccomp/default_linux.go | 7 +++++++
- pkg/seccomp/seccomp.json     | 7 +++++++
- 2 files changed, 14 insertions(+)
-
-diff --git a/pkg/seccomp/default_linux.go b/pkg/seccomp/default_linux.go
-index f86f3e2..6bbb80b 100644
---- a/pkg/seccomp/default_linux.go
-+++ b/pkg/seccomp/default_linux.go
-@@ -128,6 +128,7 @@ func DefaultProfile() *Seccomp {
-                               "ftruncate",
-                               "ftruncate64",
-                               "futex",
-+                              "futex_time64",
-                               "futimesat",
-                               "get_robust_list",
-                               "get_thread_area",
-@@ -212,7 +213,9 @@ func DefaultProfile() *Seccomp {
-                               "mq_notify",
-                               "mq_open",
-                               "mq_timedreceive",
-+                              "mq_timedreceive_time64",
-                               "mq_timedsend",
-+                              "mq_timedsend_time64",
-                               "mq_unlink",
-                               "mremap",
-                               "msgctl",
-@@ -259,6 +262,7 @@ func DefaultProfile() *Seccomp {
-                               "recv",
-                               "recvfrom",
-                               "recvmmsg",
-+                              "recvmmsg_time64",
-                               "recvmsg",
-                               "remap_file_pages",
-                               "removexattr",
-@@ -274,6 +278,7 @@ func DefaultProfile() *Seccomp {
-                               "rt_sigreturn",
-                               "rt_sigsuspend",
-                               "rt_sigtimedwait",
-+                              "rt_sigtimedwait_time64",
-                               "rt_tgsigqueueinfo",
-                               "sched_get_priority_max",
-                               "sched_get_priority_min",
-@@ -282,6 +287,7 @@ func DefaultProfile() *Seccomp {
-                               "sched_getparam",
-                               "sched_getscheduler",
-                               "sched_rr_get_interval",
-+                              "sched_rr_get_interval_time64",
-                               "sched_setaffinity",
-                               "sched_setattr",
-                               "sched_setparam",
-@@ -293,6 +299,7 @@ func DefaultProfile() *Seccomp {
-                               "semget",
-                               "semop",
-                               "semtimedop",
-+                              "semtimedop_time64",
-                               "send",
-                               "sendfile",
-                               "sendfile64",
-diff --git a/pkg/seccomp/seccomp.json b/pkg/seccomp/seccomp.json
-index 8d799fd..cf81ca4 100644
---- a/pkg/seccomp/seccomp.json
-+++ b/pkg/seccomp/seccomp.json
-@@ -132,6 +132,7 @@
-                               "ftruncate",
-                               "ftruncate64",
-                               "futex",
-+                              "futex_time64",
-                               "futimesat",
-                               "get_robust_list",
-                               "get_thread_area",
-@@ -216,7 +217,9 @@
-                               "mq_notify",
-                               "mq_open",
-                               "mq_timedreceive",
-+                              "mq_timedreceive_time64",
-                               "mq_timedsend",
-+                              "mq_timedsend_time64",
-                               "mq_unlink",
-                               "mremap",
-                               "msgctl",
-@@ -263,6 +266,7 @@
-                               "recv",
-                               "recvfrom",
-                               "recvmmsg",
-+                              "recvmmsg_time64",
-                               "recvmsg",
-                               "remap_file_pages",
-                               "removexattr",
-@@ -278,6 +282,7 @@
-                               "rt_sigreturn",
-                               "rt_sigsuspend",
-                               "rt_sigtimedwait",
-+                              "rt_sigtimedwait_time64",
-                               "rt_tgsigqueueinfo",
-                               "sched_get_priority_max",
-                               "sched_get_priority_min",
-@@ -286,6 +291,7 @@
-                               "sched_getparam",
-                               "sched_getscheduler",
-                               "sched_rr_get_interval",
-+                              "sched_rr_get_interval_time64",
-                               "sched_setaffinity",
-                               "sched_setattr",
-                               "sched_setparam",
-@@ -297,6 +303,7 @@
-                               "semget",
-                               "semop",
-                               "semtimedop",
-+                              "semtimedop_time64",
-                               "send",
-                               "sendfile",
-                               "sendfile64",
--- 
-2.31.1
-
-From 42d1db16bfc0dbaee5781d230dc2bcbaa0849c6e Mon Sep 17 00:00:00 2001
-From: Jan Palus <jpalus@fastmail.com>
-Date: Mon, 14 Jun 2021 12:53:14 +0200
-Subject: [PATCH] seccomp: allow timer_settime64
-
-allow time64 variant of timer_settime which was missed in 4e31f66
-
-Signed-off-by: Jan Palus <jpalus@fastmail.com>
----
- pkg/seccomp/default_linux.go | 1 +
- pkg/seccomp/seccomp.json     | 1 +
- 2 files changed, 2 insertions(+)
-
-diff --git a/pkg/seccomp/default_linux.go b/pkg/seccomp/default_linux.go
-index 6bbb80b5..423c983f 100644
---- a/pkg/seccomp/default_linux.go
-+++ b/pkg/seccomp/default_linux.go
-@@ -368,6 +368,7 @@ func DefaultProfile() *Seccomp {
-                               "timer_gettime",
-                               "timer_gettime64",
-                               "timer_settime",
-+                              "timer_settime64",
-                               "timerfd_create",
-                               "timerfd_gettime",
-                               "timerfd_gettime64",
-diff --git a/pkg/seccomp/seccomp.json b/pkg/seccomp/seccomp.json
-index cf81ca41..a87f7352 100644
---- a/pkg/seccomp/seccomp.json
-+++ b/pkg/seccomp/seccomp.json
-@@ -372,6 +372,7 @@
-                               "timer_gettime",
-                               "timer_gettime64",
-                               "timer_settime",
-+                              "timer_settime64",
-                               "timerfd_create",
-                               "timerfd_gettime",
-                               "timerfd_gettime64",
index 38fb4a529d1d02a0623020ec2c626c6e54b8a0e0..f44497c2d3a418e82811d6f0ca8a1f9c3a22c9ba 100644 (file)
@@ -1,15 +1,14 @@
 Summary:       A tool for managing OCI containers and pods
 Name:          podman
-Version:       3.2.3
+Version:       3.3.0
 Release:       1
 License:       Apache v2.0
 Group:         Applications/System
 #Source0Download: https://github.com/containers/podman/releases
 Source0:       https://github.com/containers/podman/archive/v%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: 18148c3fce515cd43a4bb91eb85e79de
+# Source0-md5: eb3daf249395191df0f6424300046026
 Source1:       policy.json
 Source2:       registries.conf
-Patch0:                %{name}-seccomp_32bit.patch
 URL:           https://github.com/containers/podman
 BuildRequires: device-mapper-devel
 BuildRequires: go-md2man
@@ -68,8 +67,6 @@ Zsh completion for podman command.
 
 %prep
 %setup -q
-cd vendor/github.com/containers/common
-%patch0 -p1
 
 %build
 %{__make} \
@@ -116,7 +113,6 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc README.md changelog.txt
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cni/net.d/87-podman-bridge.conflist
 %dir %{_sysconfdir}/containers
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/containers/policy.json
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/containers/registries.conf
@@ -126,12 +122,13 @@ rm -rf $RPM_BUILD_ROOT
 %{systemdunitdir}/podman.socket
 %{systemdunitdir}/podman-auto-update.service
 %{systemdunitdir}/podman-auto-update.timer
+%{systemdunitdir}/podman-restart.service
 %{systemduserunitdir}/podman.service
 %{systemduserunitdir}/podman.socket
 %{systemduserunitdir}/podman-auto-update.service
 %{systemduserunitdir}/podman-auto-update.timer
+%{systemduserunitdir}/podman-restart.service
 %{_mandir}/man1/podman*.1*
-%{_mandir}/man5/containers-mounts.conf.5*
 %{_mandir}/man5/oci-hooks.5*
 /usr/lib/tmpfiles.d/podman.conf
 
This page took 0.577728 seconds and 4 git commands to generate.