]> git.pld-linux.org Git - packages/pipewire.git/commitdiff
upstream fix for spa headers not conforming to c90 standard; rel 2 auto/th/pipewire-0.3.50-2
authorJan Palus <atler@pld-linux.org>
Mon, 25 Apr 2022 22:08:08 +0000 (00:08 +0200)
committerJan Palus <atler@pld-linux.org>
Mon, 25 Apr 2022 22:08:58 +0000 (00:08 +0200)
c90_headers.patch [new file with mode: 0644]
pipewire.spec

diff --git a/c90_headers.patch b/c90_headers.patch
new file mode 100644 (file)
index 0000000..5328279
--- /dev/null
@@ -0,0 +1,45 @@
+From d3ea3142e1a4de206e616bc18f63a529e6b4986a Mon Sep 17 00:00:00 2001
+From: psykose <alice@ayaya.dev>
+Date: Wed, 13 Apr 2022 21:57:49 +0000
+Subject: [PATCH] spa: fix c90 header include
+
+placing declarations after code is invalid under ISO c90
+
+Fixes !1211
+---
+ spa/include/spa/utils/string.h | 6 ++++--
+ 1 file changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/spa/include/spa/utils/string.h b/spa/include/spa/utils/string.h
+index e80434537..43d19616c 100644
+--- a/spa/include/spa/utils/string.h
++++ b/spa/include/spa/utils/string.h
+@@ -276,10 +276,11 @@ static inline int spa_scnprintf(char *buffer, size_t size, const char *format, .
+ static inline float spa_strtof(const char *str, char **endptr)
+ {
+       static locale_t locale = NULL;
++      locale_t prev;
+       float v;
+       if (SPA_UNLIKELY(locale == NULL))
+               locale = newlocale(LC_ALL_MASK, "C", NULL);
+-      locale_t prev = uselocale(locale);
++      prev = uselocale(locale);
+       v = strtof(str, endptr);
+       uselocale(prev);
+       return v;
+@@ -319,10 +320,11 @@ static inline bool spa_atof(const char *str, float *val)
+ static inline double spa_strtod(const char *str, char **endptr)
+ {
+       static locale_t locale = NULL;
++      locale_t prev;
+       double v;
+       if (SPA_UNLIKELY(locale == NULL))
+               locale = newlocale(LC_ALL_MASK, "C", NULL);
+-      locale_t prev = uselocale(locale);
++      prev = uselocale(locale);
+       v = strtod(str, endptr);
+       uselocale(prev);
+       return v;
+-- 
+GitLab
+
index 7ceec090b5079d383b3323c49c8ac46903d5a59c..8267447782c52fb5192ecb1ba591685325a7db3c 100644 (file)
@@ -14,13 +14,14 @@ Summary:    PipeWire - server and user space API to deal with multimedia pipelines
 Summary(pl.UTF-8):     PipeWire - serwer i API przestrzeni użytkownika do obsługi potoków multimedialnych
 Name:          pipewire
 Version:       0.3.50
-Release:       1
+Release:       2
 License:       MIT, LGPL v2+, GPL v2
 Group:         Libraries
 #Source0Download: https://github.com/PipeWire/pipewire/releases
 Source0:       https://github.com/PipeWire/pipewire/archive/%{version}/%{name}-%{version}.tar.gz
 # Source0-md5: 3d86ae8629a86aaf6c92d200688421c2
 Patch0:                %{name}-gcc.patch
+Patch1:                c90_headers.patch
 URL:           https://pipewire.org/
 %if %{with jack}
 BuildRequires: SDL2-devel >= 2
@@ -296,6 +297,7 @@ Wtyczka udostępniająca źródło i cel obrazu PipeWire dla GStreamera.
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 
 %build
 %meson build \
This page took 0.511057 seconds and 4 git commands to generate.