]> git.pld-linux.org Git - packages/pipewire.git/commitdiff
up to 0.3.54 auto/th/pipewire-0.3.54-1
authorJan Palus <atler@pld-linux.org>
Thu, 7 Jul 2022 09:07:00 +0000 (11:07 +0200)
committerJan Palus <atler@pld-linux.org>
Thu, 7 Jul 2022 09:07:00 +0000 (11:07 +0200)
name-prop.patch [deleted file]
pipewire.spec

diff --git a/name-prop.patch b/name-prop.patch
deleted file mode 100644 (file)
index 51361a4..0000000
+++ /dev/null
@@ -1,88 +0,0 @@
-From 76350cebefe9bdabe24e9d043b83737547c225d8 Mon Sep 17 00:00:00 2001
-From: Wim Taymans <wtaymans@redhat.com>
-Date: Tue, 5 Jul 2022 20:41:01 +0200
-Subject: [PATCH] audioconvert: fix PROP_INFO
-
-The description needs to be set. The name is the unique name of the
-property and the id the predefined property id.
-
-Fixes #2488
----
- spa/plugins/audioconvert/audioconvert.c | 16 ++++++++--------
- 1 file changed, 8 insertions(+), 8 deletions(-)
-
-diff --git a/spa/plugins/audioconvert/audioconvert.c b/spa/plugins/audioconvert/audioconvert.c
-index 9f8097b01..6df4d7ef7 100644
---- a/spa/plugins/audioconvert/audioconvert.c
-+++ b/spa/plugins/audioconvert/audioconvert.c
-@@ -437,21 +437,21 @@ static int impl_node_enum_params(void *object, int seq,
-                       param = spa_pod_builder_add_object(&b,
-                               SPA_TYPE_OBJECT_PropInfo, id,
-                               SPA_PROP_INFO_id,   SPA_POD_Id(SPA_PROP_volume),
--                              SPA_PROP_INFO_name, SPA_POD_String("Volume"),
-+                              SPA_PROP_INFO_description, SPA_POD_String("Volume"),
-                               SPA_PROP_INFO_type, SPA_POD_CHOICE_RANGE_Float(p->volume, 0.0, 10.0));
-                       break;
-               case 1:
-                       param = spa_pod_builder_add_object(&b,
-                               SPA_TYPE_OBJECT_PropInfo, id,
-                               SPA_PROP_INFO_id,   SPA_POD_Id(SPA_PROP_mute),
--                              SPA_PROP_INFO_name, SPA_POD_String("Mute"),
-+                              SPA_PROP_INFO_description, SPA_POD_String("Mute"),
-                               SPA_PROP_INFO_type, SPA_POD_CHOICE_Bool(p->channel.mute));
-                       break;
-               case 2:
-                       param = spa_pod_builder_add_object(&b,
-                               SPA_TYPE_OBJECT_PropInfo, id,
-                               SPA_PROP_INFO_id,   SPA_POD_Id(SPA_PROP_channelVolumes),
--                              SPA_PROP_INFO_name, SPA_POD_String("Channel Volumes"),
-+                              SPA_PROP_INFO_description, SPA_POD_String("Channel Volumes"),
-                               SPA_PROP_INFO_type, SPA_POD_CHOICE_RANGE_Float(p->volume, 0.0, 10.0),
-                               SPA_PROP_INFO_container, SPA_POD_Id(SPA_TYPE_Array));
-                       break;
-@@ -459,7 +459,7 @@ static int impl_node_enum_params(void *object, int seq,
-                       param = spa_pod_builder_add_object(&b,
-                               SPA_TYPE_OBJECT_PropInfo, id,
-                               SPA_PROP_INFO_id,   SPA_POD_Id(SPA_PROP_channelMap),
--                              SPA_PROP_INFO_name, SPA_POD_String("Channel Map"),
-+                              SPA_PROP_INFO_description, SPA_POD_String("Channel Map"),
-                               SPA_PROP_INFO_type, SPA_POD_Id(SPA_AUDIO_CHANNEL_UNKNOWN),
-                               SPA_PROP_INFO_container, SPA_POD_Id(SPA_TYPE_Array));
-                       break;
-@@ -467,14 +467,14 @@ static int impl_node_enum_params(void *object, int seq,
-                       param = spa_pod_builder_add_object(&b,
-                               SPA_TYPE_OBJECT_PropInfo, id,
-                               SPA_PROP_INFO_id,   SPA_POD_Id(SPA_PROP_monitorMute),
--                              SPA_PROP_INFO_name, SPA_POD_String("Monitor Mute"),
-+                              SPA_PROP_INFO_description, SPA_POD_String("Monitor Mute"),
-                               SPA_PROP_INFO_type, SPA_POD_CHOICE_Bool(p->monitor.mute));
-                       break;
-               case 5:
-                       param = spa_pod_builder_add_object(&b,
-                               SPA_TYPE_OBJECT_PropInfo, id,
-                               SPA_PROP_INFO_id,   SPA_POD_Id(SPA_PROP_monitorVolumes),
--                              SPA_PROP_INFO_name, SPA_POD_String("Monitor Volumes"),
-+                              SPA_PROP_INFO_description, SPA_POD_String("Monitor Volumes"),
-                               SPA_PROP_INFO_type, SPA_POD_CHOICE_RANGE_Float(p->volume, 0.0, 10.0),
-                               SPA_PROP_INFO_container, SPA_POD_Id(SPA_TYPE_Array));
-                       break;
-@@ -482,14 +482,14 @@ static int impl_node_enum_params(void *object, int seq,
-                       param = spa_pod_builder_add_object(&b,
-                               SPA_TYPE_OBJECT_PropInfo, id,
-                               SPA_PROP_INFO_id,   SPA_POD_Id(SPA_PROP_softMute),
--                              SPA_PROP_INFO_name, SPA_POD_String("Soft Mute"),
-+                              SPA_PROP_INFO_description, SPA_POD_String("Soft Mute"),
-                               SPA_PROP_INFO_type, SPA_POD_CHOICE_Bool(p->soft.mute));
-                       break;
-               case 7:
-                       param = spa_pod_builder_add_object(&b,
-                               SPA_TYPE_OBJECT_PropInfo, id,
-                               SPA_PROP_INFO_id,   SPA_POD_Id(SPA_PROP_softVolumes),
--                              SPA_PROP_INFO_name, SPA_POD_String("Soft Volumes"),
-+                              SPA_PROP_INFO_description, SPA_POD_String("Soft Volumes"),
-                               SPA_PROP_INFO_type, SPA_POD_CHOICE_RANGE_Float(p->volume, 0.0, 10.0),
-                               SPA_PROP_INFO_container, SPA_POD_Id(SPA_TYPE_Array));
-                       break;
--- 
-GitLab
-
index bb228ef5fcafaa72bd3251ce6f69febbed9f45d7..c2aca27d039e47729831836b62f0e27318a2223f 100644 (file)
 Summary:       PipeWire - server and user space API to deal with multimedia pipelines
 Summary(pl.UTF-8):     PipeWire - serwer i API przestrzeni użytkownika do obsługi potoków multimedialnych
 Name:          pipewire
-Version:       0.3.53
-Release:       2
+Version:       0.3.54
+Release:       1
 License:       MIT, LGPL v2+, GPL v2
 Group:         Libraries
 #Source0Download: https://github.com/PipeWire/pipewire/releases
 Source0:       https://github.com/PipeWire/pipewire/archive/%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: 655786201c376a0dcaa64bb5fe3ebb4b
+# Source0-md5: 1f35e7452422d3fb547e3b95b8c24be0
 Patch0:                %{name}-gcc.patch
-Patch1:                name-prop.patch
 URL:           https://pipewire.org/
 %if %{with jack}
 BuildRequires: SDL2-devel >= 2
@@ -297,7 +296,6 @@ Wtyczka udostępniająca źródło i cel obrazu PipeWire dla GStreamera.
 %prep
 %setup -q
 %patch0 -p1
-%patch1 -p1
 
 %build
 %meson build \
This page took 0.43393 seconds and 4 git commands to generate.