]> git.pld-linux.org Git - packages/pipewire.git/commitdiff
up to 0.3.38
authorJan Palus <atler@pld-linux.org>
Thu, 30 Sep 2021 10:59:49 +0000 (12:59 +0200)
committerJan Palus <atler@pld-linux.org>
Thu, 30 Sep 2021 11:01:55 +0000 (13:01 +0200)
- upstream fix for build failure on arm
- require readline version with working pkgconfig file

arm_build.patch [new file with mode: 0644]
pipewire.spec

diff --git a/arm_build.patch b/arm_build.patch
new file mode 100644 (file)
index 0000000..ab410b0
--- /dev/null
@@ -0,0 +1,25 @@
+From f8817b439433798bd7217dc4ae72197887b0fc96 Mon Sep 17 00:00:00 2001
+From: Wim Taymans <wtaymans@redhat.com>
+Date: Thu, 30 Sep 2021 11:12:27 +0200
+Subject: [PATCH] cpu: fix compilation on ARM
+
+---
+ spa/plugins/support/cpu-arm.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/spa/plugins/support/cpu-arm.c b/spa/plugins/support/cpu-arm.c
+index d80b8ad87..de07ebf41 100644
+--- a/spa/plugins/support/cpu-arm.c
++++ b/spa/plugins/support/cpu-arm.c
+@@ -80,7 +80,7 @@ arm_init(struct impl *impl)
+       int arch;
+       if (!(cpuinfo = get_cpuinfo())) {
+-              spa_log_warn(impl->log, NAME " %p: Can't read cpuinfo", impl);
++              spa_log_warn(impl->log, "%p: Can't read cpuinfo", impl);
+               return 1;
+       }
+-- 
+GitLab
+
index 18b86b523270c511cb6cbd1aed1b37cde9fb2b38..0d90cb75449916550115e37c3e6586ee420aea15 100644 (file)
 Summary:       PipeWire - server and user space API to deal with multimedia pipelines
 Summary(pl.UTF-8):     PipeWire - serwer i API przestrzeni użytkownika do obsługi potoków multimedialnych
 Name:          pipewire
-Version:       0.3.37
+Version:       0.3.38
 Release:       1
 License:       MIT, LGPL v2+, GPL v2
 Group:         Libraries
 #Source0Download: https://github.com/PipeWire/pipewire/releases
 Source0:       https://github.com/PipeWire/pipewire/archive/%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: d4c7ed5edab55b944d8e0570856aa60a
+# Source0-md5: a66a2b856bede375c12091f5468d06c7
 Patch0:                %{name}-gcc.patch
+Patch1:                arm_build.patch
 URL:           https://pipewire.org/
 %if %{with jack}
 BuildRequires: SDL2-devel >= 2
@@ -60,6 +61,7 @@ BuildRequires:        ncurses-devel
 BuildRequires: ninja >= 1.5
 BuildRequires: pkgconfig
 BuildRequires: pulseaudio-devel
+BuildRequires: readline-devel >= 8.1.1-2
 BuildRequires: rpmbuild(macros) >= 2.007
 BuildRequires: sbc-devel
 BuildRequires: systemd-devel
@@ -250,6 +252,7 @@ Wtyczka udostępniająca źródło i cel obrazu PipeWire dla GStreamera.
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 
 %build
 %meson build \
This page took 0.47052 seconds and 4 git commands to generate.