]> git.pld-linux.org Git - packages/pipewire.git/blob - pipewire-gcc.patch
up to 0.3.61
[packages/pipewire.git] / pipewire-gcc.patch
1 AVX code uses _mm256_setr_m128i() which requires gcc 8
2 --- pipewire-0.3.24/meson.build.orig    2021-04-03 20:16:48.559894581 +0200
3 +++ pipewire-0.3.24/meson.build 2021-04-03 20:17:56.916756919 +0200
4 @@ -110,8 +110,8 @@
5  have_ssse3 = cc.has_argument(ssse3_args)
6  have_sse41 = cc.has_argument(sse41_args)
7  have_fma = cc.has_argument(fma_args)
8 -have_avx = cc.has_argument(avx_args)
9 -have_avx2 = cc.has_argument(avx2_args)
10 +have_avx = cc.has_argument(avx_args) and not ((cc.get_id() == 'gcc') and cc.version().version_compare('< 8'))
11 +have_avx2 = cc.has_argument(avx2_args) and not ((cc.get_id() == 'gcc') and cc.version().version_compare('< 8'))
12  
13  have_neon = false
14  if host_machine.cpu_family() == 'aarch64'
This page took 0.097967 seconds and 4 git commands to generate.