]> git.pld-linux.org Git - packages/php4.git/blame - php4.spec
- fix extension_dir in php.ini
[packages/php4.git] / php4.spec
CommitLineData
95decd1b 1#
8d03ce31 2# TODO:
bdcd0995
JB
3# - make sure that session-unregister patch is no longer needed
4# (any crash reports related to session modules?)
8d03ce31 5#
b6f861c7
JB
6# Conditional build:
7%bcond_with db3 # use db3 packages instead of db (4.x) for Berkeley DB support
9ee9d278 8%bcond_with fdf # with FDF (PDF forms) module (BR: proprietary lib)
b6f861c7
JB
9%bcond_with interbase_inst # use InterBase install., not Firebird (BR: proprietary libs)
10%bcond_with java # with Java extension module (BR: jdk)
11%bcond_with oci8 # with Oracle oci8 extension module (BR: proprietary libs)
12%bcond_with oracle # with oracle extension module (BR: proprietary libs)
13%bcond_without cpdf # without cpdf extension module
14%bcond_without curl # without CURL extension module
15%bcond_without domxslt # without DOM XSLT/EXSLT support in DOM XML extension module
9ee9d278 16%bcond_without fribidi # without FriBiDi extension module
b6f861c7
JB
17%bcond_without imap # without IMAP extension module
18%bcond_without interbase # without InterBase extension module
19%bcond_without ldap # without LDAP extension module
20%bcond_without mhash # without mhash extension module
21%bcond_without ming # without ming extension module
22%bcond_without mm # without mm support for session storage
23%bcond_without mnogosearch # without mnogosearch extension module
24%bcond_without msession # without msession extension module
25%bcond_without mssql # without MS SQL extension module
26%bcond_without odbc # without ODBC extension module
27%bcond_without openssl # without OpenSSL support and OpenSSL extension (module)
28%bcond_without pcre # without PCRE extension module
9ee9d278 29%bcond_without pdf # without PDF extension module
b6f861c7 30%bcond_without pgsql # without PostgreSQL extension module
11f81df6 31%bcond_without pspell # without pspell extension module
b6f861c7 32%bcond_without recode # without recode extension module
ff5548f5 33%bcond_without qtdom # without Qt DOM extension module
b6f861c7 34%bcond_without snmp # without SNMP extension module
9ee9d278 35%bcond_without sybase # without Sybase and Sybase-CT extension modules
b6f861c7
JB
36%bcond_without wddx # without WDDX extension module
37%bcond_without xmlrpc # without XML-RPC extension module
38%bcond_without xml # without XML and DOMXML extension modules
39%bcond_without xslt # without XSLT extension module
9ee9d278 40%bcond_without yaz # without YAZ extension module
b6f861c7 41#
7f2d8ce7 42%define _apache2 %(rpm -q apache-devel 2> /dev/null | grep -Eq '\\-2\\.[0-9]+\\.' && echo 1 || echo 0)
0aad949a 43%define apxs /usr/sbin/apxs
b6f861c7 44# some problems with apache 2.x
b65cb5d0 45%if %{_apache2}
9ee9d278 46%undefine with_recode
b6f861c7 47%undefine with_mm
b65cb5d0 48%endif
0cc95751 49%ifnarch %{ix86} amd64 sparc sparcv9 ppc
b6f861c7 50%undefine with_interbase
ffb7a641 51%endif
9ee9d278 52# x86-only lib
ffb7a641 53%ifnarch %{ix86}
b6f861c7 54%undefine with_msession
7f2d8ce7 55%endif
b6f861c7 56%include /usr/lib/rpm/macros.php
5b453425 57Summary: The PHP HTML-embedded scripting language for use with Apache
58Summary(fr): Le langage de script embarque-HTML PHP pour Apache
59