]> git.pld-linux.org Git - packages/php4.git/blame - php4.spec
- %service -q, because only apache package should say to start apache, not php packages
[packages/php4.git] / php4.spec
CommitLineData
95decd1b 1#
d04affdd
JR
2# Do NOT build openssl as shared module or
3# fsockopen('tls://host',...) will not work!
4#
e5798a47
JB
5# TODO:
6# - make additional headers added by mail patch configurable
5db1f7fc 7# - /var/run/php group not owned
e5798a47 8#
b6f861c7
JB
9# Conditional build:
10%bcond_with db3 # use db3 packages instead of db (4.x) for Berkeley DB support
9ee9d278 11%bcond_with fdf # with FDF (PDF forms) module (BR: proprietary lib)
75ebc985 12%bcond_with hardening # build with hardening patch applied (http://www.hardened-php.net/)
b6f861c7
JB
13%bcond_with interbase_inst # use InterBase install., not Firebird (BR: proprietary libs)
14%bcond_with java # with Java extension module (BR: jdk)
15%bcond_with oci8 # with Oracle oci8 extension module (BR: proprietary libs)
16%bcond_with oracle # with oracle extension module (BR: proprietary libs)
17%bcond_without cpdf # without cpdf extension module
18%bcond_without curl # without CURL extension module
19%bcond_without domxslt # without DOM XSLT/EXSLT support in DOM XML extension module
9ee9d278 20%bcond_without fribidi # without FriBiDi extension module
b6f861c7
JB
21%bcond_without imap # without IMAP extension module
22%bcond_without interbase # without InterBase extension module
23%bcond_without ldap # without LDAP extension module
24%bcond_without mhash # without mhash extension module
25%bcond_without ming # without ming extension module
26%bcond_without mm # without mm support for session storage
27%bcond_without mnogosearch # without mnogosearch extension module
28%bcond_without msession # without msession extension module
29%bcond_without mssql # without MS SQL extension module
30%bcond_without odbc # without ODBC extension module
31%bcond_without openssl # without OpenSSL support and OpenSSL extension (module)
32%bcond_without pcre # without PCRE extension module
9ee9d278 33%bcond_without pdf # without PDF extension module
b6f861c7 34%bcond_without pgsql # without PostgreSQL extension module
11f81df6 35%bcond_without pspell # without pspell extension module
b6f861c7 36%bcond_without recode # without recode extension module
ff5548f5 37%bcond_without qtdom # without Qt DOM extension module
b6f861c7 38%bcond_without snmp # without SNMP extension module
9ee9d278 39%bcond_without sybase # without Sybase and Sybase-CT extension modules
b6f861c7
JB
40%bcond_without wddx # without WDDX extension module
41%bcond_without xmlrpc # without XML-RPC extension module
42%bcond_without xml # without XML and DOMXML extension modules
43%bcond_without xslt # without XSLT extension module
9ee9d278 44%bcond_without yaz # without YAZ extension module
74c09513
ER
45%bcond_without apache1 # disable building apache 1.3.x module
46%bcond_without apache2 # disable building apache 2.x module
47%bcond_with zts # enable-experimental-zts
285c3089 48
74c09513
ER
49%define apxs1 /usr/sbin/apxs1
50%define apxs2 /usr/sbin/apxs
285c3089 51
74c09513
ER
52# mm is not thread safe
53# ext/session/mod_mm.c:37:3: #error mm is not thread-safe
54%if %{with zts}
b6f861c7 55%undefine with_mm
b65cb5d0 56%endif
285c3089 57
41670838 58%ifnarch %{ix86} %{x8664} sparc sparcv9 alpha ppc
b6f861c7 59%undefine with_interbase
ffb7a641 60%endif
285c3089 61
9ee9d278 62# x86-only lib
ffb7a641 63%ifnarch %{ix86}
b6f861c7 64%undefine with_msession
7f2d8ce7 65%endif
285c3089 66
b6f861c7 67%include /usr/lib/rpm/macros.php
5b453425 68Summary: The PHP HTML-embedded scripting language for use with Apache
69Summary(fr): Le langage de script embarque-HTML PHP pour Apache
7e581113 70