]> git.pld-linux.org Git - packages/php4.git/blame - php4.spec
- drop also %post/%postun of session
[packages/php4.git] / php4.spec
CommitLineData
95decd1b 1#
d04affdd
JR
2# Do NOT build openssl as shared module or
3# fsockopen('tls://host',...) will not work!
4#
e5798a47
JB
5# TODO:
6# - make additional headers added by mail patch configurable
7443f062
ER
7#11:26:36 <@glen> php4-common-4.4.0-14 marks heimdal-libs-0.7.1-1 (cap heimdal-libs)
8#11:26:36 <@glen> heimdal-libs-0.7.1-1 marks openldap-libs-2.2.29-1 (cap liblber-2.2.so.7()(64bit))
9#11:26:36 <@glen> openldap-libs-2.2.29-1 marks cyrus-sasl-2.1.21-3 (cap cyrus-sasl)
10#11:27:00 <@glen> php5-common doesn't have such deps
cbf32ad2 11# - above is caused by openssl linked in statically as openssl links with kerberos
e5798a47 12#
b6f861c7
JB
13# Conditional build:
14%bcond_with db3 # use db3 packages instead of db (4.x) for Berkeley DB support
9ee9d278 15%bcond_with fdf # with FDF (PDF forms) module (BR: proprietary lib)
75ebc985 16%bcond_with hardening # build with hardening patch applied (http://www.hardened-php.net/)
b6f861c7
JB
17%bcond_with interbase_inst # use InterBase install., not Firebird (BR: proprietary libs)
18%bcond_with java # with Java extension module (BR: jdk)
19%bcond_with oci8 # with Oracle oci8 extension module (BR: proprietary libs)
20%bcond_with oracle # with oracle extension module (BR: proprietary libs)
21%bcond_without cpdf # without cpdf extension module
960d2ad2 22%bcond_without curl # without CURL extension module
b6f861c7 23%bcond_without domxslt # without DOM XSLT/EXSLT support in DOM XML extension module
9ee9d278 24%bcond_without fribidi # without FriBiDi extension module
b6f861c7
JB
25%bcond_without imap # without IMAP extension module
26%bcond_without interbase # without InterBase extension module
27%bcond_without ldap # without LDAP extension module
28%bcond_without mhash # without mhash extension module
29%bcond_without ming # without ming extension module
30%bcond_without mm # without mm support for session storage
31%bcond_without mnogosearch # without mnogosearch extension module
32%bcond_without msession # without msession extension module
33%bcond_without mssql # without MS SQL extension module
34%bcond_without odbc # without ODBC extension module
35%bcond_without openssl # without OpenSSL support and OpenSSL extension (module)
36%bcond_without pcre # without PCRE extension module
9ee9d278 37%bcond_without pdf # without PDF extension module
b6f861c7 38%bcond_without pgsql # without PostgreSQL extension module
11f81df6 39%bcond_without pspell # without pspell extension module
ff5548f5 40%bcond_without qtdom # without Qt DOM extension module
960d2ad2 41%bcond_without recode # without recode extension module
b6f861c7 42%bcond_without snmp # without SNMP extension module
9ee9d278 43%bcond_without sybase # without Sybase and Sybase-CT extension modules
b6f861c7 44%bcond_without wddx # without WDDX extension module
b6f861c7 45%bcond_without xml # without XML and DOMXML extension modules
960d2ad2 46%bcond_without xmlrpc # without XML-RPC extension module
b6f861c7 47%bcond_without xslt # without XSLT extension module
9ee9d278 48%bcond_without yaz # without YAZ extension module
74c09513
ER
49%bcond_without apache1 # disable building apache 1.3.x module
50%bcond_without apache2 # disable building apache 2.x module
7a419765 51%bcond_without fcgi # disable building FCGI SAPI
02f996b3 52%bcond_without zts # disable experimental-zts
b33eec5f 53%bcond_with versioning # build with experimental versioning (to load php4/php5 into same apache)
960d2ad2 54
74c09513
ER
55%define apxs1 /usr/sbin/apxs1
56%define apxs2 /usr/sbin/apxs
285c3089 57
74c09513
ER
58# mm is not thread safe
59# ext/session/mod_mm.c:37:3: #error mm is not thread-safe
be4aca3a 60%if %{with zts}
b6f861c7 61%undefine with_mm
b65cb5d0 62%endif
285c3089 63
70fe1e82 64%ifnarch %{ix86} %{x8664} sparc sparcv9 alpha
b6f861c7 65%undefine with_interbase
ffb7a641 66%endif
285c3089 67
9ee9d278 68# x86-only lib
ffb7a641 69%ifnarch %{ix86}
b6f861c7 70%undefine with_msession
7f2d8ce7 71%endif
285c3089 72
b2435197 73%define _rel 6
c3df63c9 74Summary: PHP: Hypertext Preprocessor
0fa5c59b
JB
75Summary(fr): Le langage de script embarque-HTML PHP
76