]> git.pld-linux.org Git - packages/php.git/commitdiff
- up to 7.3.12 auto/th/php73-7.3.12-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 18 Dec 2019 18:59:47 +0000 (19:59 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 18 Dec 2019 18:59:47 +0000 (19:59 +0100)
pcre-shared.patch
php.spec

index 384b23d25075650dd2aae0abded79db0767527ce..85237a7c27f7c83f2999ed8741faa4787690a0b7 100644 (file)
  PHPAPI pcre2_code* pcre_get_compiled_regex(zend_string *regex, uint32_t *capture_count, uint32_t *options);
  PHPAPI pcre2_code* pcre_get_compiled_regex_ex(zend_string *regex, uint32_t *capture_count, uint32_t *preg_options, uint32_t *coptions);
  
-@@ -45,14 +67,18 @@
+@@ -71,18 +71,23 @@ extern zend_module_entry pcre_module_ent
  
  typedef struct _pcre_cache_entry pcre_cache_entry;
  
 +PCRE_EXTERN
  PHPAPI pcre_cache_entry* pcre_get_compiled_regex_cache(zend_string *regex);
+ PHPAPI pcre_cache_entry* pcre_get_compiled_regex_cache_ex(zend_string *regex, int locale_aware);
  
 +PCRE_EXTERN
  PHPAPI void  php_pcre_match_impl(  pcre_cache_entry *pce, char *subject, size_t subject_len, zval *return_value,
  PHPAPI void  php_pcre_split_impl(  pcre_cache_entry *pce, zend_string *subject_str, zval *return_value,
        zend_long limit_val, zend_long flags);
  
++PCRE_EXTERN
+ PHPAPI void  php_pcre_grep_impl(   pcre_cache_entry *pce, zval *input, zval *return_value,
+       zend_long flags);
 --- php-7.3.0beta3/ext/pcre/php_pcre.c~        2018-09-11 11:43:27.000000000 +0300
 +++ php-7.3.0beta3/ext/pcre/php_pcre.c 2018-09-11 11:43:30.747506034 +0300
 @@ -21,6 +21,9 @@
index 09abc61b721a9dca2869b88df2ee6478c34691f7..215aa142ed87a33afa2bbf7704e338ce1f8cbdde 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -156,7 +156,7 @@ Summary(pt_BR.UTF-8):       A linguagem de script PHP
 Summary(ru.UTF-8):     PHP Версии 7 - язык препроцессирования HTML-файлов, выполняемый на сервере
 Summary(uk.UTF-8):     PHP Версії 7 - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          %{orgname}%{php_suffix}
-Version:       7.3.11
+Version:       7.3.12
 Release:       1
 Epoch:         4
 # All files licensed under PHP version 3.01, except
@@ -166,7 +166,7 @@ License:    PHP 3.01 and Zend and BSD
 Group:         Libraries
 #Source0:      https://downloads.php.net/~cmb/php-%{version}%{subver}.tar.xz
 Source0:       https://php.net/distributions/%{orgname}-%{version}.tar.xz
-# Source0-md5: b62a1e6f82e2646c01a7151492699d93
+# Source0-md5: e52a0dc6e7d94024989d0a3746070487
 Source1:       opcache.ini
 Source2:       %{orgname}-mod_php.conf
 Source3:       %{orgname}-cgi-fcgi.ini
This page took 0.459998 seconds and 4 git commands to generate.