]> git.pld-linux.org Git - packages/php.git/commitdiff
update to php-7.4 snapshot; WIP
authorElan Ruusamäe <glen@pld-linux.org>
Sun, 5 May 2019 21:27:21 +0000 (00:27 +0300)
committerElan Ruusamäe <glen@pld-linux.org>
Sat, 11 May 2019 07:56:56 +0000 (10:56 +0300)
some patches updated

13 files changed:
extension-shared-optional-dep.patch
fix-test-run.patch
intl-stdc++.patch
opcache.ini
pcre-shared.patch
php-both-apxs.patch
php-ini.patch
php-link-libs.patch
php-shared.patch
php-stupidapache_version.patch
php-use-prog_sendmail.patch
php.spec
spl-shared.patch

index be4597f71d98682043307229e4ee7138bd4b6611..6925c72c65c62caf89bf8ce4cf767945d06f5535 100644 (file)
@@ -1,5 +1,5 @@
---- php-5.2.11/acinclude.m4~   2009-09-21 22:31:13.000000000 +0300
-+++ php-5.2.11/acinclude.m4    2009-09-21 22:32:11.001106977 +0300
+--- php-5.2.11/build/php.m4~   2009-09-21 22:31:13.000000000 +0300
++++ php-5.2.11/build/php.m4    2009-09-21 22:32:11.001106977 +0300
 @@ -1019,7 +1019,7 @@
    is_it_shared=$[PHP_]translit($2,a-z_-,A-Z__)[_SHARED]
    is_it_enabled=$[PHP_]translit($2,a-z_-,A-Z__)
index bd3c3d7df0a98473f9eede0135cb1a9744eb7830..fcdbc7178c831ddabbab1a90657fded0139261ad 100644 (file)
@@ -12,8 +12,8 @@
  PHP_SUBST_OLD(PHP_INSTALLED_SAPIS)
  
  PHP_SUBST(PHP_EXECUTABLE)
---- php-5.5.11/Makefile.global 2014-04-27 15:05:38.963814051 +0300
-+++ php-5.5.11/Makefile.global 2014-04-27 15:09:54.438443707 +0300
+--- php-5.5.11/build/Makefile.global   2014-04-27 15:05:38.963814051 +0300
++++ php-5.5.11/build/Makefile.global   2014-04-27 15:09:54.438443707 +0300
 @@ -81,8 +81,15 @@
                done; \
        fi
index f762c9b1e6d646823face55b762d58b6800915ee..7c180641f40c3b01420b61d23cdc766dc8cc5a21 100644 (file)
@@ -4,8 +4,8 @@ it's needed for ext/intl
 but it requires icu which already links with stdc++
 so just omit PHP_ADD_LIBRARY(stdc++)
 
---- php-7.0.6/acinclude.m4~    2016-05-16 18:31:11.000000000 +0300
-+++ php-7.0.6/acinclude.m4     2016-05-16 18:50:34.614991634 +0300
+--- php-7.0.6/build/php.m4~    2016-05-16 18:31:11.000000000 +0300
++++ php-7.0.6/build/php.m4     2016-05-16 18:50:34.614991634 +0300
 @@ -762,7 +762,6 @@
    if test -z "$php_cxx_done"; then
      AC_PROG_CXX
index 2cc841dc67331f77a48b84f903de92dcbb64f43a..9f414a03a90c836ce9d0fef8e902e5d4a4445924 100644 (file)
@@ -126,3 +126,16 @@ zend_extension=opcache.so
 ; If specified, it produces opcode dumps for debugging different stages of
 ; optimizations.
 ;opcache.opt_debug_level=0
+
+; Specifies a PHP script that is going to be compiled and executed at server
+; start-up.
+; http://php.net/opcache.preload
+;opcache.preload=
+
+; Prevents caching files that are less than this number of seconds old. It
+; protects from caching of incompletely updated files. In case all file updates
+; on your site are atomic, you may increase performance by setting it to "0".
+;opcache.file_update_protection=2
+
+; Absolute path used to store shared lockfiles (for *nix only).
+;opcache.lockfile_path=/tmp
index 384b23d25075650dd2aae0abded79db0767527ce..b57e59eafd77f5e794886932f1617e39f78a4f66 100644 (file)
@@ -1,18 +1,18 @@
---- php-7.3.0RC5/ext/pcre/config0.m4~  2018-11-06 12:22:53.000000000 +0200
-+++ php-7.3.0RC5/ext/pcre/config0.m4   2018-11-12 13:30:52.805036671 +0200
-@@ -84,8 +84,9 @@
-       ])
-     fi
--    PHP_NEW_EXTENSION(pcre, php_pcre.c, no,, -DZEND_ENABLE_STATIC_TSRMLS_CACHE=1)
-+    PHP_NEW_EXTENSION(pcre, php_pcre.c, $ext_shared,, -DZEND_ENABLE_STATIC_TSRMLS_CACHE=1)
-     PHP_INSTALL_HEADERS([ext/pcre], [php_pcre.h])
-+    EXTRA_LIBS="$EXTRA_LIBS -lpcre2-8"
  else
-     AC_MSG_CHECKING([for PCRE library to use])
-     AC_MSG_RESULT([bundled])
---- php-7.3.0alpha3/ext/pcre/php_pcre.h~       2018-07-03 15:56:43.000000000 +0300
-+++ php-7.3.0alpha3/ext/pcre/php_pcre.h        2018-07-10 11:11:55.739017013 +0300
+--- php-src-PHP-7.4/ext/pcre/config0.m4~       2019-05-04 15:24:15.000000000 +0300
++++ php-src-PHP-7.4/ext/pcre/config0.m4        2019-05-05 18:48:35.524688151 +0300
+@@ -58,8 +58,9 @@
+       fi
+   fi
+-  PHP_NEW_EXTENSION(pcre, php_pcre.c, no,, -DZEND_ENABLE_STATIC_TSRMLS_CACHE=1)
++  PHP_NEW_EXTENSION(pcre, php_pcre.c, $ext_shared,, -DZEND_ENABLE_STATIC_TSRMLS_CACHE=1)
+   PHP_INSTALL_HEADERS([ext/pcre], [php_pcre.h])
++  EXTRA_LIBS="$EXTRA_LIBS -lpcre2-8"
+ else
+   AC_MSG_CHECKING([for PCRE library to use])
+   AC_MSG_RESULT([bundled])
+--- php-7.3.0beta3/ext/pcre/php_pcre.h~        2018-09-11 11:41:50.000000000 +0300
++++ php-7.3.0beta3/ext/pcre/php_pcre.h 2018-09-11 11:41:54.865778887 +0300
 @@ -33,7 +33,29 @@
  #include <locale.h>
  #endif
index 8e7bd89e6dda54b81c52f1bf963994f3d10d7a31..3cba2ae4f1b8d1fcc3f2c41a21c43837c04dfc01 100644 (file)
@@ -1,5 +1,5 @@
---- php-5.2.4/Makefile.global~ 2007-08-31 19:35:54.000000000 +0300
-+++ php-5.2.4/Makefile.global  2007-08-31 19:40:18.287528480 +0300
+--- php-5.2.4/build/Makefile.global~   2007-08-31 19:35:54.000000000 +0300
++++ php-5.2.4/build/Makefile.global    2007-08-31 19:40:18.287528480 +0300
 @@ -21,6 +21,12 @@
        $(LIBTOOL) --mode=link $(CC) -rpath $(phptempdir) $(EXTRA_LDFLAGS) $(LDFLAGS) $(PHP_RPATHS) $(phptempdir)/libphp_common.la $(PHP_SAPI_OBJS) $(EXTRA_LIBS) $(ZEND_EXTRA_LIBS) -o $@
        -@$(LIBTOOL) --silent --mode=install cp $@ $(phptempdir)/$@ >/dev/null 2>&1
index 570f94de0dfb456ed4592e66ea14b7f72a284bb2..b094643347a3816a522e4f4da62d9e4ac02615ab 100644 (file)
@@ -1,5 +1,5 @@
---- php-7.3.0alpha3/php.ini~   2018-07-09 13:40:12.000000000 +0300
-+++ php-7.3.0alpha3/php.ini    2018-07-09 17:27:47.804465246 +0300
+--- php-src-PHP-7.4/php.ini~   2019-05-05 01:01:58.000000000 +0300
++++ php-src-PHP-7.4/php.ini    2019-05-05 01:02:49.674577615 +0300
 @@ -82,6 +82,20 @@
  ; much more verbose when it comes to errors. We recommending using the
  ; development version only in development environments as errors shown to
  ;;;;;;;;;;;;;;;;
  ; File Uploads ;
  ;;;;;;;;;;;;;;;;
-@@ -844,49 +844,9 @@
+@@ -847,47 +847,8 @@
  ; deprecated in a future PHP major version. So, when it is possible, please
  ; move to the new ('extension=<ext>) syntax.
  ;
 -; Notes for Windows environments :
-+; Ideally in PLD Linux you should install appropriate php73-<extension> or
-+; php73-pecl-<extension> package.
- ;
+-;
 -; - Many DLL files are located in the extensions/ (PHP 4) or ext/ (PHP 5+)
 -;   extension folders as well as the separate PECL DLL download (PHP 5+).
 -;   Be sure to appropriately set the extension_dir directive.
 -;extension=gmp
 -;extension=intl
 -;extension=imap
--;extension=interbase
 -;extension=ldap
 -;extension=mbstring
 -;extension=exif      ; Must be after mbstring as it depends on it
 -;extension=tidy
 -;extension=xmlrpc
 -;extension=xsl
--
++; Ideally in PLD Linux you should install appropriate php74-<extension> or
++; php74-pecl-<extension> package.
  ;;;;;;;;;;;;;;;;;;;
  ; Module Settings ;
- ;;;;;;;;;;;;;;;;;;;
 @@ -923,19 +883,19 @@
  ; Use of this INI entry is deprecated, use global input_encoding instead.
  ; If empty, default_charset or input_encoding or iconv.input_encoding is used.
  
  [intl]
  ;intl.default_locale =
-@@ -1191,6 +1104,9 @@
- ; http://php.net/mysqli.default-socket
- mysqli.default_socket =
-+; The name of the character set to use as the default character set.
-+;mysqli.connect_charset=utf8
-+
- ; Default host for mysql_connect() (doesn't apply in safe mode).
- ; http://php.net/mysqli.default-host
- mysqli.default_host =
 @@ -1357,7 +1273,7 @@
  
  [browscap]
  
  ; (time to live) Sets the number of second while cached file will be used
  ; instead of original one.
-@@ -1670,133 +1670,6 @@
+@@ -1666,147 +1666,7 @@
  [dba]
  ;dba.default_handler=
+-
 -[opcache]
 -; Determines if Zend OPCache is enabled
 -;opcache.enable=1
 -; optimizations.
 -;opcache.opt_debug_level=0
 -
+-; Specifies a PHP script that is going to be compiled and executed at server
+-; start-up.
+-; http://php.net/opcache.preload
+-;opcache.preload=
+-
+-; Prevents caching files that are less than this number of seconds old. It
+-; protects from caching of incompletely updated files. In case all file updates
+-; on your site are atomic, you may increase performance by setting it to "0".
+-;opcache.file_update_protection=2
+-
+-; Absolute path used to store shared lockfiles (for *nix only).
+-;opcache.lockfile_path=/tmp
+-
++;
  [curl]
  ; A default value for the CURLOPT_CAINFO option. This is required to be an
  ; absolute path.
index 9a37701f90787b252412b43464ffe3c24a9b90ab..56232e5b13b824060c7854bcd99b985e4a1fc2a0 100644 (file)
@@ -8,8 +8,8 @@
  
  PHP_CHECK_FUNC(dlopen, dl)
  if test "$ac_cv_func_dlopen" = "yes"; then
---- php-7.3.0beta3/acinclude.m4~       2018-08-28 13:26:36.000000000 +0300
-+++ php-7.3.0beta3/acinclude.m4        2018-09-05 18:56:49.744106256 +0300
+--- php-7.3.0beta3/build/php.m4~       2018-08-28 13:26:36.000000000 +0300
++++ php-7.3.0beta3/build/php.m4        2018-09-05 18:56:49.744106256 +0300
 @@ -1829,18 +1829,18 @@
  dnl Wrapper for AC_CHECK_LIB
  dnl
index 24c6848ebef867b9e829892c1bd3dd41ed4b38d8..9b426c264f2308933d6615498f5a781ea10253eb 100644 (file)
@@ -10,8 +10,8 @@
  dnl Checks for some support/generator progs
  PHP_PROG_AWK
  PHP_PROG_BISON
---- php-5.2.4/Makefile.global~ 2007-08-31 19:13:58.000000000 +0300
-+++ php-5.2.4/Makefile.global  2007-08-31 19:19:33.799017413 +0300
+--- php-5.2.4/build/Makefile.global~   2007-08-31 19:13:58.000000000 +0300
++++ php-5.2.4/build/Makefile.global    2007-08-31 19:19:33.799017413 +0300
 @@ -13,8 +13,12 @@
        
  build-modules: $(PHP_MODULES)
index 100ec4f748257ac5185cf75b024dfb3f3fa5f028..ab1d8e05c44059593770ec72e138f41136098360 100644 (file)
@@ -1,5 +1,5 @@
---- php-5.4.0alpha2/acinclude.m4       2011-08-07 21:13:21.581133944 +0300
-+++ php-5.4.0alpha2/acinclude.m4       2011-08-07 21:10:21.766717150 +0300
+--- php-5.4.0alpha2/build/php.m4       2011-08-07 21:13:21.581133944 +0300
++++ php-5.4.0alpha2/build/php.m4       2011-08-07 21:10:21.766717150 +0300
 @@ -2607,7 +2609,14 @@
  dnl version for apache1/2.
  dnl
index 5f4af4eebfc3606454b60706d15aff77eb7192ac..161e4460d79ad5c0a08b2b714fd4b2d668c33dcb 100644 (file)
@@ -1,5 +1,5 @@
---- php-5.2.6/acinclude.m4~    2008-10-15 13:44:25.000000000 +0300
-+++ php-5.2.6/acinclude.m4     2008-10-15 13:55:05.359850285 +0300
+--- php-5.2.6/build/php.m4~    2008-10-15 13:44:25.000000000 +0300
++++ php-5.2.6/build/php.m4     2008-10-15 13:55:05.359850285 +0300
 @@ -2037,8 +2037,10 @@
  dnl Search for the sendmail binary
  dnl
index 2f4022931f9e149ac61e1e6a077d46fde0e0a263..f8c899af465ab9df23bdb7c9434d743c7f95c5dc 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -1,5 +1,8 @@
 # NOTES
 # - mysqlnd driver doesn't support reconnect: https://bugs.php.net/bug.php?id=52561
+# TODO 7.4:
+# - follow upstream: drop spl, pcre, hash subpackages (tired of maintaining them)
+# - handle acinclude.m4 -> build/php.m4 rename
 # TODO 7.3:
 # - branch php-7.2 and merge dev-7.3 into head once official announcement ready
 # TODO 7.2:
 
 %define                subver %{nil}
 %define                orgname php
-%define                ver_suffix 73
+%define                ver_suffix 74
 %define                php_suffix %{!?with_default_php:%{ver_suffix}}
 Summary:       PHP: Hypertext Preprocessor
 Summary(fr.UTF-8):     Le langage de script embarque-HTML PHP
@@ -156,8 +159,8 @@ Summary(pt_BR.UTF-8):       A linguagem de script PHP
 Summary(ru.UTF-8):     PHP Версии 7 - язык препроцессирования HTML-файлов, выполняемый на сервере
 Summary(uk.UTF-8):     PHP Версії 7 - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          %{orgname}%{php_suffix}
-Version:       7.3.4
-Release:       2
+Version:       7.4.0
+Release:       0.1
 Epoch:         4
 # All files licensed under PHP version 3.01, except
 # Zend is licensed under Zend
@@ -165,8 +168,9 @@ Epoch:              4
 License:       PHP 3.01 and Zend and BSD
 Group:         Libraries
 #Source0:      https://downloads.php.net/~cmb/php-%{version}%{subver}.tar.xz
-Source0:       https://php.net/distributions/%{orgname}-%{version}.tar.xz
-# Source0-md5: eb860e97b4be43c1aad056fa7dde1157
+#Source0:      https://php.net/distributions/%{orgname}-%{version}.tar.xz
+Source0:       https://github.com/php/php-src/archive/PHP-7.4/%{orgname}-%{version}.tar.gz
+# Source0-md5: e54970ae767eae731995f5bb2b4e0f43
 Source1:       opcache.ini
 Source2:       %{orgname}-mod_php.conf
 Source3:       %{orgname}-cgi-fcgi.ini
@@ -323,7 +327,7 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                pharver         %{version}
 %define                sqlite3ver      %{version}
 %define                zipver          1.15.4
-%define                phpdbgver       0.5.0
+%define                phpdbgver       %{version}
 %define                sodiumver       %{version}
 
 %define                _zend_zts               %{!?with_zts:0}%{?with_zts:1}
@@ -1976,7 +1980,11 @@ compression support to PHP.
 Moduł PHP umożliwiający używanie kompresji zlib.
 
 %prep
+%if 0
 %setup -q -n %{orgname}-%{version}%{?subver}
+%else
+%setup -q -n php-src-PHP-7.4
+%endif
 cp -p php.ini-production php.ini
 %patch0 -p1
 %patch1 -p1
@@ -2194,8 +2202,8 @@ if test "$ver" != "%{jsonver}"; then
        : Update the jsonver macro and rebuild.
        exit 1
 fi
-ver=$(sed -n '/#define PHPDBG_VERSION /{s/.* "//;s/".*$//;p}' sapi/phpdbg/phpdbg.h)
-if test "$ver" != "%{phpdbgver}"; then
+ver=$(get_version PHPDBG_VERSION sapi/phpdbg/phpdbg.h)
+if test "$ver" != "PHP_VERSION"; then
        : Error: Upstream phpdbg version is now ${ver}, expecting %{phpdbgver}.
        : Update the phpdbgver macro and rebuild.
        exit 1
index d51ca9bf85b39d224478ff6748cf98c44d13b9a2..eb121c21c05d6478789922515e8d5c543ae8608e 100644 (file)
@@ -1,9 +1,8 @@
---- php-7.3.0beta3/ext/spl/config.m4~  2018-08-28 13:26:31.000000000 +0300
-+++ php-7.3.0beta3/ext/spl/config.m4   2018-09-05 19:06:13.737232662 +0300
-@@ -1,6 +1,6 @@
+--- php-src-PHP-7.4/ext/spl/config.m4~ 2019-05-04 15:24:15.000000000 +0300
++++ php-src-PHP-7.4/ext/spl/config.m4  2019-05-05 18:45:49.109324631 +0300
+@@ -1,5 +1,5 @@
  dnl config.m4 for extension SPL
  
-   AC_DEFINE(HAVE_SPL, 1, [Whether you want SPL (Standard PHP Library) support])
 -  PHP_NEW_EXTENSION(spl, php_spl.c spl_functions.c spl_engine.c spl_iterators.c spl_array.c spl_directory.c spl_exceptions.c spl_observer.c spl_dllist.c spl_heap.c spl_fixedarray.c, no,, -DZEND_ENABLE_STATIC_TSRMLS_CACHE=1)
 +  PHP_NEW_EXTENSION(spl, php_spl.c spl_functions.c spl_engine.c spl_iterators.c spl_array.c spl_directory.c spl_exceptions.c spl_observer.c spl_dllist.c spl_heap.c spl_fixedarray.c, $ext_shared,, -DZEND_ENABLE_STATIC_TSRMLS_CACHE=1)
    PHP_INSTALL_HEADERS([ext/spl], [php_spl.h spl_array.h spl_directory.h spl_engine.h spl_exceptions.h spl_functions.h spl_iterators.h spl_observer.h spl_dllist.h spl_heap.h spl_fixedarray.h])
This page took 0.159404 seconds and 4 git commands to generate.