]> git.pld-linux.org Git - packages/php.git/commitdiff
- use system tzdata (fedora patch)
authorElan Ruusamäe <glen@pld-linux.org>
Mon, 10 Oct 2011 21:18:20 +0000 (21:18 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    php-systzdata.patch -> 1.1.4.1
    php.spec -> 1.805.2.94

php-systzdata.patch
php.spec

index 6247aeadf4baaf5add2d8ba9e04662d1ba6f3bab..abeac3307c9648fd6f8a13e108dca3b77eca1eb1 100644 (file)
@@ -3,20 +3,32 @@ Add support for use of the system timezone database, rather
 than embedding a copy.  Discussed upstream but was not desired.
 
 History:
-r7: improve check for valid timezone id to exclude directories
-r6: fix fd leak in r5, fix country code/BC flag use in 
-    timezone_identifiers_list() using system db,
-    fix use of PECL timezonedb to override system db,
-r5: reverts addition of "System/Localtime" fake tzname.
-    updated for 5.3.0, parses zone.tab to pick up mapping between
-    timezone name, country code and long/lat coords
-r4: added "System/Localtime" tzname which uses /etc/localtime
 r3: fix a crash if /usr/share/zoneinfo doesn't exist (Raphael Geissert)
 r2: add filesystem trawl to set up name alias index
 r1: initial revision
 
---- php-5.3.1/ext/date/lib/parse_tz.c.systzdata
-+++ php-5.3.1/ext/date/lib/parse_tz.c
+--- php-5.2.5/ext/date/lib/timelib.m4.systzdata
++++ php-5.2.5/ext/date/lib/timelib.m4
+@@ -78,3 +78,17 @@ stdlib.h
+ dnl Check for strtoll, atoll
+ AC_CHECK_FUNCS(strtoll atoll strftime)
++
++PHP_ARG_WITH(system-tzdata, for use of system timezone data,
++[  --with-system-tzdata[=DIR]      to specify use of system timezone data],
++no, no)
++
++if test "$PHP_SYSTEM_TZDATA" != "no"; then
++   AC_DEFINE(HAVE_SYSTEM_TZDATA, 1, [Define if system timezone data is used])
++
++   if test "$PHP_SYSTEM_TZDATA" != "yes"; then
++      AC_DEFINE_UNQUOTED(HAVE_SYSTEM_TZDATA_PREFIX, "$PHP_SYSTEM_TZDATA",
++                         [Define for location of system timezone data])
++   fi
++fi
++
+--- php-5.2.5/ext/date/lib/parse_tz.c.systzdata
++++ php-5.2.5/ext/date/lib/parse_tz.c
 @@ -20,6 +20,16 @@
  
  #include "timelib.h"
@@ -34,7 +46,7 @@ r1: initial revision
  #include <stdio.h>
  
  #ifdef HAVE_LOCALE_H
-@@ -31,7 +41,12 @@
+@@ -31,7 +41,10 @@
  #else
  #include <strings.h>
  #endif
@@ -42,34 +54,13 @@ r1: initial revision
 +#ifndef HAVE_SYSTEM_TZDATA
  #include "timezonedb.h"
 +#endif
-+
-+#include <ctype.h>
  
  #if (defined(__APPLE__) || defined(__APPLE_CC__)) && (defined(__BIG_ENDIAN__) || defined(__LITTLE_ENDIAN__))
  # if defined(__LITTLE_ENDIAN__)
-@@ -51,9 +66,14 @@
- static void read_preamble(const unsigned char **tzf, timelib_tzinfo *tz)
- {
--      /* skip ID */
--      *tzf += 4;
--      
-+        if (memcmp(tzf, "TZif", 4) == 0) {
-+                *tzf += 20;
-+                return;
-+        }
-+        
-+        /* skip ID */
-+        *tzf += 4;
-+                
-       /* read BC flag */
-       tz->bc = (**tzf == '\1');
-       *tzf += 1;
-@@ -253,7 +273,397 @@ void timelib_dump_tzinfo(timelib_tzinfo 
+@@ -206,6 +219,195 @@ void timelib_dump_tzinfo(timelib_tzinfo 
        }
  }
  
--static int seek_to_tz_position(const unsigned char **tzf, char *timezone, const timelib_tzdb *tzdb)
 +#ifdef HAVE_SYSTEM_TZDATA
 +
 +#ifdef HAVE_SYSTEM_TZDATA_PREFIX
@@ -78,202 +69,8 @@ r1: initial revision
 +#define ZONEINFO_PREFIX "/usr/share/zoneinfo"
 +#endif
 +
-+/* System timezone database pointer. */
 +static const timelib_tzdb *timezonedb_system = NULL;
 +
-+/* Hash table entry for the cache of the zone.tab mapping table. */
-+struct location_info {
-+        char code[2];
-+        double latitude, longitude;
-+        char name[64];
-+        char *comment;
-+        struct location_info *next;
-+};
-+
-+/* Cache of zone.tab. */
-+static struct location_info **system_location_table;
-+
-+/* Size of the zone.tab hash table; a random-ish prime big enough to
-+ * prevent too many collisions. */
-+#define LOCINFO_HASH_SIZE (1021)
-+
-+static uint32_t tz_hash(const char *str)
-+{
-+    const unsigned char *p = (const unsigned char *)str;
-+    uint32_t hash = 5381;
-+    int c;
-+    
-+    while ((c = *p++) != '\0') {
-+        hash = (hash << 5) ^ hash ^ c;
-+    }
-+    
-+    return hash % LOCINFO_HASH_SIZE;
-+}
-+
-+/* Parse an ISO-6709 date as used in zone.tab. Returns end of the
-+ * parsed string on success, or NULL on parse error.  On success,
-+ * writes the parsed number to *result. */
-+static char *parse_iso6709(char *p, double *result)
-+{
-+    double v, sign;
-+    char *pend;
-+    size_t len;
-+
-+    if (*p == '+')
-+        sign = 1.0;
-+    else if (*p == '-')
-+        sign = -1.0;
-+    else
-+        return NULL;
-+
-+    p++;
-+    for (pend = p; *pend >= '0' && *pend <= '9'; pend++)
-+        ;;
-+
-+    /* Annoying encoding used by zone.tab has no decimal point, so use
-+     * the length to determine the format:
-+     * 
-+     * 4 = DDMM
-+     * 5 = DDDMM
-+     * 6 = DDMMSS
-+     * 7 = DDDMMSS
-+     */
-+    len = pend - p;
-+    if (len < 4 || len > 7) {
-+        return NULL;
-+    }
-+
-+    /* p => [D]DD */
-+    v = (p[0] - '0') * 10.0 + (p[1] - '0');
-+    p += 2;
-+    if (len == 5 || len == 7)
-+        v = v * 10.0 + (*p++ - '0');
-+    /* p => MM[SS] */
-+    v += (10.0 * (p[0] - '0')
-+          + p[1] - '0') / 60.0;
-+    p += 2;
-+    /* p => [SS] */
-+    if (len > 5) {
-+        v += (10.0 * (p[0] - '0')
-+              + p[1] - '0') / 3600.0;
-+        p += 2;
-+    }
-+
-+    /* Round to five decimal place, not because it's a good idea,
-+     * but, because the builtin data uses rounded data, so, match
-+     * that. */
-+    *result = round(v * sign * 100000.0) / 100000.0;
-+
-+    return p;
-+}
-+
-+/* This function parses the zone.tab file to build up the mapping of
-+ * timezone to country code and geographic location, and returns a
-+ * hash table.  The hash table is indexed by the function:
-+ *
-+ *   tz_hash(timezone-name)
-+ */
-+static struct location_info **create_location_table(void)
-+{
-+    struct location_info **li, *i;
-+    char zone_tab[PATH_MAX];
-+    char line[512];
-+    FILE *fp;
-+
-+    strncpy(zone_tab, ZONEINFO_PREFIX "/zone.tab", sizeof zone_tab);
-+
-+    fp = fopen(zone_tab, "r");
-+    if (!fp) {
-+        return NULL;
-+    }
-+
-+    li = calloc(LOCINFO_HASH_SIZE, sizeof *li);
-+
-+    while (fgets(line, sizeof line, fp)) {
-+        char *p = line, *code, *name, *comment;
-+        uint32_t hash;
-+        double latitude, longitude;
-+
-+        while (isspace(*p))
-+            p++;
-+
-+        if (*p == '#' || *p == '\0' || *p == '\n')
-+            continue;
-+        
-+        if (!isalpha(p[0]) || !isalpha(p[1]) || p[2] != '\t')
-+            continue;
-+        
-+        /* code => AA */
-+        code = p;
-+        p[2] = 0;
-+        p += 3;
-+
-+        /* coords => [+-][D]DDMM[SS][+-][D]DDMM[SS] */
-+        p = parse_iso6709(p, &latitude);
-+        if (!p) {
-+            continue;
-+        }
-+        p = parse_iso6709(p, &longitude);
-+        if (!p) {
-+            continue;
-+        }
-+
-+        if (!p || *p != '\t') {
-+            continue;
-+        }
-+
-+        /* name = string */
-+        name = ++p;
-+        while (*p != '\t' && *p && *p != '\n')
-+            p++;
-+
-+        *p++ = '\0';
-+
-+        /* comment = string */
-+        comment = p;
-+        while (*p != '\t' && *p && *p != '\n')
-+            p++;
-+
-+        if (*p == '\n' || *p == '\t')
-+            *p = '\0';
-+        
-+        hash = tz_hash(name);
-+        i = malloc(sizeof *i);
-+        memcpy(i->code, code, 2);
-+        strncpy(i->name, name, sizeof i->name);
-+        i->comment = strdup(comment);
-+        i->longitude = longitude;
-+        i->latitude = latitude;
-+        i->next = li[hash];
-+        li[hash] = i;
-+        /* printf("%s [%u, %f, %f]\n", name, hash, latitude, longitude); */
-+    }
-+
-+    fclose(fp);
-+
-+    return li;
-+}
-+
-+/* Return location info from hash table, using given timezone name.
-+ * Returns NULL if the name could not be found. */
-+const struct location_info *find_zone_info(struct location_info **li, 
-+                                           const char *name)
-+{
-+    uint32_t hash = tz_hash(name);
-+    const struct location_info *l;
-+
-+    if (!li) {
-+        return NULL;
-+    }
-+
-+    for (l = li[hash]; l; l = l->next) {
-+        if (strcasecmp(l->name, name) == 0)
-+            return l;
-+    }
-+
-+    return NULL;
-+}    
-+
 +/* Filter out some non-tzdata files and the posix/right databases, if
 + * present. */
 +static int index_filter(const struct dirent *ent)
@@ -286,14 +83,6 @@ r1: initial revision
 +              && strstr(ent->d_name, ".tab") == NULL;
 +}
 +
-+static int sysdbcmp(const void *first, const void *second)
-+{
-+        const timelib_tzdb_index_entry *alpha = first, *beta = second;
-+
-+        return strcmp(alpha->id, beta->id);
-+}
-+
-+
 +/* Create the zone identifier index by trawling the filesystem. */
 +static void create_zone_index(timelib_tzdb *db)
 +{
@@ -356,7 +145,8 @@ r1: initial revision
 +                                                                 index_size * sizeof *db_index);
 +                                      }
 +
-+                                      db_index[index_next++].id = strdup(name);
++                                      db_index[index_next].id = strdup(name);
++                                      db_index[index_next++].pos = 0;
 +                              }
 +                      }
 +
@@ -367,67 +157,12 @@ r1: initial revision
 +              free(top);
 +      } while (dirstack_top);
 +
-+        qsort(db_index, index_next, sizeof *db_index, sysdbcmp);
-+
 +      db->index = db_index;
 +      db->index_size = index_next;
 +
 +      free(dirstack);
 +}
 +
-+#define FAKE_HEADER "1234\0??\1??"
-+#define FAKE_UTC_POS (7 - 4)
-+
-+/* Create a fake data segment for database 'sysdb'. */
-+static void fake_data_segment(timelib_tzdb *sysdb,
-+                              struct location_info **info)
-+{
-+        size_t n;
-+        char *data, *p;
-+        
-+        data = malloc(3 * sysdb->index_size + 7);
-+
-+        p = mempcpy(data, FAKE_HEADER, sizeof(FAKE_HEADER) - 1);
-+
-+        for (n = 0; n < sysdb->index_size; n++) {
-+                const struct location_info *li;
-+                timelib_tzdb_index_entry *ent;
-+
-+                ent = (timelib_tzdb_index_entry *)&sysdb->index[n];
-+
-+                /* Lookup the timezone name in the hash table. */
-+                if (strcmp(ent->id, "UTC") == 0) {
-+                        ent->pos = FAKE_UTC_POS;
-+                        continue;
-+                }
-+
-+                li = find_zone_info(info, ent->id);
-+                if (li) {
-+                        /* If found, append the BC byte and the
-+                         * country code; set the position for this
-+                         * section of timezone data.  */
-+                        ent->pos = (p - data) - 4;
-+                        *p++ = '\1';
-+                        *p++ = li->code[0];
-+                        *p++ = li->code[1];
-+                }
-+                else {
-+                        /* If not found, the timezone data can
-+                         * point at the header. */
-+                        ent->pos = 0;
-+                }
-+        }
-+        
-+        sysdb->data = (unsigned char *)data;
-+}
-+
-+/* Returns true if the passed-in stat structure describes a
-+ * probably-valid timezone file. */
-+static int is_valid_tzfile(const struct stat *st)
-+{
-+      return S_ISREG(st->st_mode) && st->st_size > 20;
-+}
-+
 +/* Return the mmap()ed tzfile if found, else NULL.  On success, the
 + * length of the mapped data is placed in *length. */
 +static char *map_tzfile(const char *timezone, size_t *length)
@@ -437,7 +172,7 @@ r1: initial revision
 +      char *p;
 +      int fd;
 +      
-+      if (timezone[0] == '\0' || strstr(timezone, "..") != NULL) {
++      if (strstr(timezone, "..") != NULL) {
 +              return NULL;
 +      }
 +
@@ -446,7 +181,7 @@ r1: initial revision
 +      fd = open(fname, O_RDONLY);
 +      if (fd == -1) {
 +              return NULL;
-+      } else if (fstat(fd, &st) != 0 || !is_valid_tzfile(&st)) {
++      } else if (fstat(fd, &st) != 0 || st.st_size < 21) {
 +              close(fd);
 +              return NULL;
 +      }
@@ -458,158 +193,71 @@ r1: initial revision
 +      return p != MAP_FAILED ? p : NULL;
 +}
 +
-+#endif
-+
-+static int inmem_seek_to_tz_position(const unsigned char **tzf, char *timezone, const timelib_tzdb *tzdb)
- {
-       int left = 0, right = tzdb->index_size - 1;
- #ifdef HAVE_SETLOCALE
-@@ -292,36 +702,125 @@ static int seek_to_tz_position(const uns
-       return 0;
- }
-+static int seek_to_tz_position(const unsigned char **tzf, char *timezone, 
-+                             char **map, size_t *maplen,
-+                             const timelib_tzdb *tzdb)
++const timelib_tzdb *timelib_builtin_db(void)
 +{
-+      if (tzdb == timezonedb_system) {
-+              char *orig;
-+
-+              orig = map_tzfile(timezone, maplen);
-+              if (orig == NULL) {
-+                      return 0;
-+              }
-+              
-+              (*tzf) = (unsigned char *)orig ;
-+              *map = orig;
-+                
-+                return 1;
-+      }
-+      else {
-+              return inmem_seek_to_tz_position(tzf, timezone, tzdb);
-+      }
-+}
-+
- const timelib_tzdb *timelib_builtin_db(void)
- {
-+#ifdef HAVE_SYSTEM_TZDATA
 +      if (timezonedb_system == NULL) {
 +              timelib_tzdb *tmp = malloc(sizeof *tmp);
 +
 +              tmp->version = "0.system";
 +              tmp->data = NULL;
 +              create_zone_index(tmp);
-+              system_location_table = create_location_table();
-+                fake_data_segment(tmp, system_location_table);
 +              timezonedb_system = tmp;
 +      }
-+
 +                      
 +      return timezonedb_system;
-+#else
-       return &timezonedb_builtin;
-+#endif
- }
- const timelib_tzdb_index_entry *timelib_timezone_builtin_identifiers_list(int *count)
- {
-+#ifdef HAVE_SYSTEM_TZDATA
++}
++
++const timelib_tzdb_index_entry *timelib_timezone_builtin_identifiers_list(int *count)
++{
 +      *count = timezonedb_system->index_size;
 +      return timezonedb_system->index;
-+#else
-       *count = sizeof(timezonedb_idx_builtin) / sizeof(*timezonedb_idx_builtin);
-       return timezonedb_idx_builtin;
-+#endif
- }
- int timelib_timezone_id_is_valid(char *timezone, const timelib_tzdb *tzdb)
- {
-       const unsigned char *tzf;
--      return (seek_to_tz_position(&tzf, timezone, tzdb));
++}
 +
-+#ifdef HAVE_SYSTEM_TZDATA
-+        if (tzdb == timezonedb_system) {
-+            char fname[PATH_MAX];
-+            struct stat st;
++int timelib_timezone_id_is_valid(char *timezone, const timelib_tzdb *tzdb)
++{
++      char fname[PATH_MAX];
 +
-+            if (timezone[0] == '\0' || strstr(timezone, "..") != NULL) {
++      if (strstr(timezone, "..") != NULL) {
 +              return 0;
-+            }
-+            
-+            snprintf(fname, sizeof fname, ZONEINFO_PREFIX "/%s", timezone);
-+            
-+            return stat(fname, &st) == 0 && is_valid_tzfile(&st);
-+        }
-+#endif
++      }
++      
++      snprintf(fname, sizeof fname, ZONEINFO_PREFIX "/%s", timezone);
 +
-+      return (inmem_seek_to_tz_position(&tzf, timezone, tzdb));
- }
- timelib_tzinfo *timelib_parse_tzfile(char *timezone, const timelib_tzdb *tzdb)
- {
-       const unsigned char *tzf;
-+      char *memmap = NULL;
-+      size_t maplen;
-       timelib_tzinfo *tmp;
--      if (seek_to_tz_position(&tzf, timezone, tzdb)) {
-+      if (seek_to_tz_position(&tzf, timezone, &memmap, &maplen, tzdb)) {
-               tmp = timelib_tzinfo_ctor(timezone);
-               read_preamble(&tzf, tmp);
-               read_header(&tzf, tmp);
-               read_transistions(&tzf, tmp);
-               read_types(&tzf, tmp);
--              read_location(&tzf, tmp);
++      return access(fname, R_OK) == 0 ? 1 : 0;
++}
 +
-+#ifdef HAVE_SYSTEM_TZDATA
-+              if (memmap) {
-+                      const struct location_info *li;
-+
-+                      /* TZif-style - grok the location info from the system database,
-+                       * if possible. */
-+
-+                      if ((li = find_zone_info(system_location_table, timezone)) != NULL) {
-+                              tmp->location.comments = strdup(li->comment);
-+                                strncpy(tmp->location.country_code, li->code, 2);
-+                              tmp->location.longitude = li->longitude;
-+                              tmp->location.latitude = li->latitude;
-+                              tmp->bc = 1;
-+                      }
-+                      else {
-+                              strcpy(tmp->location.country_code, "??");
-+                              tmp->bc = 0;
-+                              tmp->location.comments = strdup("");
-+                      }
++timelib_tzinfo *timelib_parse_tzfile(char *timezone, const timelib_tzdb *tzdb)
++{
++      char *tzf, *orig;
++      timelib_tzinfo *tmp;
++      size_t len;
 +
-+                      /* Now done with the mmap segment - discard it. */
-+                      munmap(memmap, maplen);
-+#endif
-+              }
-+              else {
-+                      /* PHP-style - use the embedded info. */
-+                      read_location(&tzf, tmp);
-+              }
-       } else {
-               tmp = NULL;
-       }
---- php-5.3.1/ext/date/lib/timelib.m4.systzdata
-+++ php-5.3.1/ext/date/lib/timelib.m4
-@@ -78,3 +78,17 @@ stdlib.h
- dnl Check for strtoll, atoll
- AC_CHECK_FUNCS(strtoll atoll strftime)
++      orig = map_tzfile(timezone, &len);
++      if (orig == NULL) {
++              return NULL;
++      }
 +
-+PHP_ARG_WITH(system-tzdata, for use of system timezone data,
-+[  --with-system-tzdata[=DIR]      to specify use of system timezone data],
-+no, no)
++      tmp = timelib_tzinfo_ctor(timezone);
 +
-+if test "$PHP_SYSTEM_TZDATA" != "no"; then
-+   AC_DEFINE(HAVE_SYSTEM_TZDATA, 1, [Define if system timezone data is used])
++      tzf = orig + 20;
++      read_header(&tzf, tmp);
++      read_transistions(&tzf, tmp);
++      read_types(&tzf, tmp);
 +
-+   if test "$PHP_SYSTEM_TZDATA" != "yes"; then
-+      AC_DEFINE_UNQUOTED(HAVE_SYSTEM_TZDATA_PREFIX, "$PHP_SYSTEM_TZDATA",
-+                         [Define for location of system timezone data])
-+   fi
-+fi
++      munmap(orig, len);
++
++      return tmp;
++}
++#else /* !HAVE_SYSTEM_TZDATA */
 +
+ static int seek_to_tz_position(const unsigned char **tzf, char *timezone, const timelib_tzdb *tzdb)
+ {
+       int left = 0, right = tzdb->index_size - 1;
+@@ -279,6 +481,7 @@ timelib_tzinfo *timelib_parse_tzfile(cha
+       return tmp;
+ }
++#endif
+ static ttinfo* fetch_timezone_offset(timelib_tzinfo *tz, timelib_sll ts, timelib_sll *transition_time)
+ {
index e948b8818735fcf85c2baf8792cafce96c008954..09c7b7d9217348e1ce321eefeda6d28675c82bc6 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -191,6 +191,7 @@ Patch55:    bug-52078-fileinode.patch
 Patch56:       %{name}-krb5.patch
 Patch57:       php-php_dl.patch
 Patch58:       php-svn-281516.patch
+Patch59:       %{name}-systzdata.patch
 # http://spot.fedorapeople.org/php-5.3.6-libzip.patch
 Patch65:       system-libzip.patch
 # CENTALT patches
@@ -523,6 +524,7 @@ Group:              Libraries
 Requires:      glibc >= 6:2.3.5
 Requires:      php-dirs
 Requires:      rpm-whiteout >= 1.28
+Requires:      tzdata
 Provides:      php(date)
 Provides:      php(ereg)
 Provides:      php(libxml)
@@ -1935,6 +1937,7 @@ done
 %patch56 -p1
 %patch57 -p1
 %patch58 -p4
+%patch59 -p1
 %patch65 -p1
 
 %patch201 -p1 -b .CVE-2011-2202
@@ -2118,6 +2121,7 @@ for sapi in $sapis; do
        --with-config-file-path=%{_sysconfdir} \
        --with-config-file-scan-dir=%{_sysconfdir}/conf.d \
        --with-exec-dir=%{_bindir} \
+       --with-system-tzdata \
        --%{!?debug:dis}%{?debug:en}able-debug \
        %{?with_zts:--enable-maintainer-zts} \
        %{?with_suhosin:--enable-suhosin} \
This page took 0.644496 seconds and 4 git commands to generate.