]> git.pld-linux.org Git - packages/php.git/commitdiff
drop php-pear.patch; no longer needed
authorElan Ruusamäe <glen@pld-linux.org>
Wed, 19 Jun 2019 20:59:23 +0000 (23:59 +0300)
committerElan Ruusamäe <glen@pld-linux.org>
Wed, 19 Jun 2019 22:19:20 +0000 (01:19 +0300)
/usr/share/pear is include path anyway

php-pear.patch [deleted file]
php.spec

diff --git a/php-pear.patch b/php-pear.patch
deleted file mode 100644 (file)
index 2772cd1..0000000
+++ /dev/null
@@ -1,45 +0,0 @@
---- php-7.3.0beta3/configure.ac~       2018-09-05 19:02:49.000000000 +0300
-+++ php-7.3.0beta3/configure.ac        2018-09-05 19:04:13.237533903 +0300
-@@ -934,11 +934,6 @@
-   with_pear=no
- fi
--# If CLI is disabled -> disable PEAR
--if test "$PHP_CLI" = "no"; then
--  with_pear=no
--fi
--
- PHP_ARG_WITH(pear, [whether to install PEAR],
- [  --with-pear=DIR         Install PEAR in DIR [PREFIX/lib/php]
-   --without-pear          Do not install PEAR], DEFAULT, yes)
-@@ -1137,19 +1137,6 @@
-   --without-pear          Do not install PEAR], DEFAULT, yes)
- if test "$PHP_PEAR" != "no"; then
--
--  dnl
--  dnl PEAR dependencies
--  dnl
--  if test "$PHP_XML" = "no"; then
--    pear_error_msg="$pear_error_msg
--                    PEAR requires XML to be enabled.     Add --enable-xml to the configure line. (or --without-pear)"
--  fi
--
--  if test "$pear_error_msg"; then
--    AC_MSG_ERROR([$pear_error_msg])
--  fi
--
-   install_pear="install-pear"
-   PEAR_INSTALLDIR=$PHP_PEAR
---- php-5.2.6/sapi/cli/config.m4~      2008-11-16 18:35:31.000000000 +0200
-+++ php-5.2.6/sapi/cli/config.m4       2008-11-20 19:04:12.585061299 +0200
-@@ -4,7 +4,7 @@
- PHP_ARG_ENABLE(cli,,
- [  --disable-cli           Disable building CLI version of PHP
--                          (this forces --without-pear)], yes, no)
-+                          ], yes, no)
- AC_MSG_CHECKING(for CLI build)
- if test "$PHP_CLI" != "no"; then
index 2b4de4f00aab41741739c68b25de88c15e6d2d55..c12213bffbccf1be69625442493c78c940bcfca3 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -203,7 +203,6 @@ Patch22:    %{orgname}-both-apxs.patch
 Patch23:       %{orgname}-builddir.patch
 Patch24:       %{orgname}-zlib-for-getimagesize.patch
 Patch25:       %{orgname}-stupidapache_version.patch
-Patch26:       %{orgname}-pear.patch
 Patch27:       %{orgname}-config-dir.patch
 Patch29:       %{orgname}-fcgi-graceful.patch
 Patch31:       %{orgname}-fcgi-error_log-no-newlines.patch
@@ -1915,7 +1914,6 @@ cp -p php.ini-production php.ini
 %patch23 -p1
 %patch24 -p1
 %patch25 -p1
-%patch26 -p1
 %patch27 -p1
 %patch29 -p1
 %patch31 -p1
@@ -2138,6 +2136,11 @@ if test "$ver" != "PHP_VERSION"; then
 fi
 
 export EXTENSION_DIR="%{php_extensiondir}"
+
+# Set PEAR_INSTALLDIR to ensure that the hard-coded include_path
+# includes the PEAR directory even though pear is packaged separately.
+export PEAR_INSTALLDIR=%{php_pear_dir}
+
 # configure once (for faster debugging purposes)
 if [ ! -f _built-conf ]; then
        # now remove Makefile copies
@@ -2317,7 +2320,6 @@ for sapi in $sapis; do
        %{__with_without pcre pcre-regex /usr} \
        %{?with_pcre:--with-external-pcre} \
        %{__enable_disable filter filter shared} \
-       --with-pear=%{php_pear_dir} \
        %{__with_without pgsql pgsql shared,/usr} \
        %{__enable_disable phar phar shared} \
        --with-png-dir=/usr \
This page took 1.225399 seconds and 4 git commands to generate.