]> git.pld-linux.org Git - packages/php.git/commitdiff
- mysqlnd requires hash now auto/th/php72-7.2.9-1
authorJan Rękorajski <baggins@pld-linux.org>
Tue, 21 Aug 2018 05:59:53 +0000 (05:59 +0000)
committerJan Rękorajski <baggins@pld-linux.org>
Tue, 21 Aug 2018 05:59:53 +0000 (05:59 +0000)
dep-tests.sh
php.spec

index 18ea66c08896491196fea4c4516eb55fe8dc7a2e..3d1a3983661e80ef308689363121d27303d3d3ea 100755 (executable)
@@ -7,8 +7,9 @@ dep_spl="pcre simplexml"
 dep_session="spl $dep_spl"
 dep_filter='pcre'
 dep_eaccelerator='session'
-dep_mysql="$with_mysqlnd"
-dep_mysqli="$dep_spl spl $with_mysqlnd"
+dep_mysqlnd='hash'
+dep_mysql="$dep_mysqlnd $with_mysqlnd"
+dep_mysqli="$dep_spl spl $dep_mysqlnd $with_mysqlnd"
 dep_pdo="$dep_spl spl"
 dep_pdo_sqlite="$dep_pdo pdo"
 dep_pdo_pgsql="$dep_pdo pdo"
@@ -16,7 +17,7 @@ dep_pdo_oci="$dep_pdo pdo"
 dep_pdo_odbc="$dep_pdo pdo"
 dep_pdo_firebird="$dep_pdo pdo"
 dep_pdo_dblib="$dep_pdo pdo"
-dep_pdo_mysql="$dep_pdo pdo $with_mysqlnd"
+dep_pdo_mysql="$dep_pdo pdo $dep_mysqlnd $with_mysqlnd"
 dep_simplexml="$dep_spl spl"
 dep_imap="pcre"
 dep_phar="$dep_spl spl hash"
index a5554350ba26ceb54cbc90a410b32a1833cf176a..d2c3c4ad2fe895b42955ccba84bf6f80220b328a 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -2484,6 +2484,8 @@ generate_inifiles() {
                [ "$mod" = "spl" ] && conf="SPL.ini"
                # session needs to be loaded before php-pecl-http, php-pecl-memcache, php-pecl-session_mysql
                [ "$mod" = "session" ] && conf="Session.ini"
+               # hash needs to be loaded before mysqlnd
+               [ "$mod" = "hash" ] && conf="Hash.ini"
                # mysqlnd needs to be loaded before mysqli,pdo_mysqli
                [ "$mod" = "mysqlnd" ] && conf="MySQLND.ini"
                echo "+ $conf"
@@ -3131,7 +3133,7 @@ fi
 %files hash
 %defattr(644,root,root,755)
 %doc ext/hash/{CREDITS,README}
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/hash.ini
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/Hash.ini
 %attr(755,root,root) %{php_extensiondir}/hash.so
 %endif
 
This page took 0.752682 seconds and 4 git commands to generate.