]> git.pld-linux.org Git - packages/php.git/commitdiff
- rel 13; fix php bug 68486 visible under apache 2.4 auto/th/php52-5.2.17-20130717.13
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Fri, 2 Oct 2015 07:43:15 +0000 (09:43 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Fri, 2 Oct 2015 07:43:15 +0000 (09:43 +0200)
php-bug-68486.patch [new file with mode: 0644]
php.spec

diff --git a/php-bug-68486.patch b/php-bug-68486.patch
new file mode 100644 (file)
index 0000000..ad70f8f
--- /dev/null
@@ -0,0 +1,18 @@
+commit af1cd45d171fbb06712f846cec7bf69438db8ec2
+Author: Stanislav Malyshev <stas@php.net>
+Date:   Sat Apr 4 15:03:46 2015 -0700
+
+    Fix bug #68486 and bug #69218 (segfault in apache2handler with apache 2.4)
+
+diff --git a/sapi/apache2handler/sapi_apache2.c b/sapi/apache2handler/sapi_apache2.c
+index e97f11c..cfebc5f 100644
+--- a/sapi/apache2handler/sapi_apache2.c
++++ b/sapi/apache2handler/sapi_apache2.c
+@@ -688,6 +688,7 @@ zend_first_try {
+ } zend_end_try();
+               }
+               apr_brigade_cleanup(brigade);
++              apr_pool_cleanup_run(r->pool, (void *)&SG(server_context), php_server_context_cleanup);
+       } else {
+               ctx->r = parent_req;
+       }
index 5ac19d5ca5513b353dbf64547cd850ddae7db408..ddaf16f8ee970a0f24218883904b0ea0a92b8998 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -112,7 +112,7 @@ ERROR: You need to select at least one Apache SAPI to build shared modules.
 %define                magic_mime      /usr/share/misc/magic.mime
 %endif
 
-%define                rel     12
+%define                rel     13
 %define                orgname php
 %define                ver_suffix 52
 %define                php_suffix %{!?with_default_php:%{ver_suffix}}
@@ -222,6 +222,7 @@ Patch74:    CVE-2013-4073.patch
 Patch75:       php-secbug-67498.patch
 Patch76:       CVE-2015-0232.patch
 Patch77:       x32.patch
+Patch78:       php-bug-68486.patch
 # CENTALT patches
 # Backport from 5.3.6
 Patch311:      php-5.3.6-bug-47435.patch
@@ -1947,6 +1948,7 @@ done
 %patch75 -p1
 %patch76 -p1
 %patch77 -p1
+%patch78 -p1
 
 # Bugfix backport from 5.3.6
 %patch311 -p1 -b .bug-47435
This page took 0.989724 seconds and 4 git commands to generate.