]> git.pld-linux.org Git - packages/php.git/commitdiff
use /usr/sbin/php-fpm as other branches
authorElan Ruusamäe <glen@delfi.ee>
Wed, 1 Aug 2012 22:42:47 +0000 (01:42 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Wed, 1 Aug 2012 22:42:47 +0000 (01:42 +0300)
php-fpm.init
php.spec

index ee84590b3aa6fa4d6ebd859469504202c2ec6558..bb664a4ce4a9ac7763a6a405d9be11e931b99d97 100644 (file)
@@ -6,7 +6,7 @@
 #
 # description: PHP FastCGI Process Manager
 #
-# processname: php.fpm
+# processname: php-fpm
 # config:      /etc/php/fpm.conf
 # pidfile:     /var/run/php/fpm.pid
 #
@@ -28,7 +28,7 @@ start() {
        fi
 
        msg_starting "PHP FastCGI Process Manager"
-       daemon --pidfile $pidfile /usr/sbin/php.fpm --fpm-config /etc/php/php-fpm.conf
+       daemon --pidfile $pidfile /usr/sbin/php-fpm --fpm-config /etc/php/php-fpm.conf
        RETVAL=$?
        [ $RETVAL -eq 0 ] && touch $lockfile
 }
@@ -57,7 +57,7 @@ reload() {
        fi
 
        msg_reloading "PHP FastCGI Process Manager"
-       killproc --pidfile $pidfile php.fpm -$sig
+       killproc --pidfile $pidfile php-fpm -$sig
        RETVAL=$?
 }
 
@@ -95,7 +95,7 @@ case "$1" in
        reload USR1 0
        ;;
   status)
-       status php-fpm php.fpm
+       status php-fpm
        RETVAL=$?
        ;;
   *)
index 75dfda5191958e08eb5453b64bf77d903778d0a7..4d621a403b318c0f746e951efe1cee91bb2cb2f1 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -2452,7 +2452,7 @@ libtool --silent --mode=install install sapi/fcgi/php-cgi $RPM_BUILD_ROOT%{_bind
 
 # install FCGI PM
 %if %{with fpm}
-libtool --silent --mode=install install sapi/fpm/php-cgi $RPM_BUILD_ROOT%{_bindir}/php.fpm
+libtool --silent --mode=install install sapi/fpm/php-cgi $RPM_BUILD_ROOT%{_sbindir}/php.fpm
 %{__make} install-fpm -f Makefile.fpm \
        INSTALL_ROOT=$RPM_BUILD_ROOT
 install %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/php-fpm
@@ -2736,7 +2736,7 @@ fi
 %files fpm
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fpm.conf
-%attr(755,root,root) %{_bindir}/php.fpm
+%attr(755,root,root) %{_sbindir}/php-fpm
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/php-fpm
 %attr(754,root,root) /etc/rc.d/init.d/php-fpm
 %endif
This page took 0.459449 seconds and 4 git commands to generate.