]> git.pld-linux.org Git - packages/php.git/commitdiff
restore sqlite3 version check
authorElan Ruusamäe <glen@pld-linux.org>
Sat, 28 Oct 2017 18:51:16 +0000 (21:51 +0300)
committerElan Ruusamäe <glen@pld-linux.org>
Sat, 28 Oct 2017 18:51:27 +0000 (21:51 +0300)
refs f2e9281

php.spec

index 24d406581968b3ca6a0dc3f61978408488bbc39d..f955189a112030b7a0b7e51d76ae7a5cc79ff10d 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -2163,12 +2163,12 @@ if test "$ver" != "%{pharver}"; then
        : Update the pharver macro and rebuild.
        exit 1
 fi
-#ver=$(sed -n '/#define PHP_SQLITE3_VERSION/{s/.* "//;s/".*$//;p}' ext/sqlite3/php_sqlite3.h)
-#if test "$ver" != "%{sqlite3ver}"; then
-#      : Error: Upstream Sqlite3 version is now ${ver}, expecting %{sqlite3ver}.
-#      : Update the sqlite3ver macro and rebuild.
-#      exit 1
-#fi
+ver=$(awk '/#define PHP_SQLITE3_VERSION/ {print $3}' ext/sqlite3/php_sqlite3.h | xargs)
+if test "$ver" != "PHP_VERSION"; then
+       : Error: Upstream Sqlite3 version is now ${ver}, expecting %{sqlite3ver}.
+       : Update the sqlite3ver macro and rebuild.
+       exit 1
+fi
 ver=$(sed -n '/#define PHP_ZIP_VERSION /{s/.* "//;s/".*$//;p}' ext/zip/php_zip.h)
 if test "$ver" != "%{zipver}"; then
        : Error: Upstream ZIP version is now ${ver}, expecting %{zipver}.
This page took 0.053106 seconds and 4 git commands to generate.