]> git.pld-linux.org Git - packages/php.git/commitdiff
- updated to 7.2.12
authorAdam Gołębiowski <adamg@pld-linux.org>
Tue, 6 Nov 2018 20:22:03 +0000 (21:22 +0100)
committerAdam Gołębiowski <adamg@pld-linux.org>
Tue, 6 Nov 2018 20:22:03 +0000 (21:22 +0100)
- release 0.1 - no official announce yet, in theory tarball might change

bug-52078-fileinode.patch
pcre-shared.patch
php-link-libs.patch
php-pear.patch
php.spec
spl-shared.patch

index 0fd016326bb1f7ddddf78907c28fd3aefb2dce0e..419be68ad1481ec5b560928a3e5e8e171a3bead6 100644 (file)
@@ -72,7 +72,7 @@
 @@ -30,17 +30,17 @@
  echo "Done\n";
  ?>
- --EXPECTF--   
+ --EXPECTF--
 +int(%i)
  int(%d)
  int(%d)
index 4eee40e58b60f743a662224142894572d0791e16..8bb03e442f1ca8fa7b4b946a4ac5661c7038a67f 100644 (file)
@@ -24,7 +24,7 @@
      ])
 -    PHP_ADD_LIBRARY_WITH_PATH(pcre, $PCRE_LIBDIR)
 +    PHP_ADD_LIBRARY_WITH_PATH(pcre, $PCRE_LIBDIR, PCRE_SHARED_LIBADD)
-     
      AC_DEFINE(HAVE_PCRE, 1, [ ])
      PHP_ADD_INCLUDE($PCRE_INCDIR)
 -    PHP_NEW_EXTENSION(pcre, php_pcre.c, no,, -DZEND_ENABLE_STATIC_TSRMLS_CACHE=1)
index c20149ebbfcea3f0cb8070170f69df9b7f3c4241..e65166a8beb0a177e763e5265654b14a5bb7c190 100644 (file)
  if test "$ac_cv_func_dlopen" = "yes"; then
 --- php-5.2.0/acinclude.m4.orig        2006-12-22 21:52:13.766461055 +0100
 +++ php-5.2.0/acinclude.m4     2006-12-22 21:52:37.159794165 +0100
-@@ -1740,18 +1740,18 @@
+@@ -1834,18 +1834,18 @@
  dnl Wrapper for AC_CHECK_LIB
  dnl
  AC_DEFUN([PHP_CHECK_LIBRARY], [
 -  save_old_LDFLAGS=$LDFLAGS
 +  save_old_LIBS=$LIBS
    ac_stuff="$5"
-   
    save_ext_shared=$ext_shared
    ext_shared=yes
 -  PHP_EVAL_LIBLINE([$]ac_stuff, LDFLAGS)
index 74a03d64e51f65c26745b302985fdfd6a5c3d8d7..b198776990a7e26d9a97afb31993a6c997805de3 100644 (file)
  PHP_ARG_WITH(pear, [whether to install PEAR],
  [  --with-pear=DIR         Install PEAR in DIR [PREFIX/lib/php]
    --without-pear          Do not install PEAR], DEFAULT, yes)
-@@ -1023,11 +1023,11 @@
+@@ -1111,11 +1111,11 @@
    dnl
    dnl PEAR dependancies
    dnl
 -  if test "$PHP_XML" = "no"; then
--    pear_error_msg="$pear_error_msg 
+-    pear_error_msg="$pear_error_msg
 -                    PEAR requires XML to be enabled.     Add --enable-xml to the configure line. (or --without-pear)"
 -  fi
 -
 +dnl  if test "$PHP_XML" = "no"; then
-+dnl    pear_error_msg="$pear_error_msg 
++dnl    pear_error_msg="$pear_error_msg
 +dnl                    PEAR requires XML to be enabled.     Add --enable-xml to the configure line. (or --without-pear)"
 +dnl  fi
 +dnl
  dnl
  dnl  if test "$PHP_XMLRPC" = "no"; then
- dnl    pear_error_msg="$pear_error_msg 
+ dnl    pear_error_msg="$pear_error_msg
 --- php-5.2.6/sapi/cli/config.m4~      2008-11-16 18:35:31.000000000 +0200
 +++ php-5.2.6/sapi/cli/config.m4       2008-11-20 19:04:12.585061299 +0200
 @@ -4,7 +4,7 @@
index 43854dc60727c7b5bfacd39068ea3fb0ff9e8cf6..0e21551d27664c37c6c9794573433299eb14cd4c 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -154,8 +154,8 @@ Summary(pt_BR.UTF-8):       A linguagem de script PHP
 Summary(ru.UTF-8):     PHP Версии 7 - язык препроцессирования HTML-файлов, выполняемый на сервере
 Summary(uk.UTF-8):     PHP Версії 7 - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          %{orgname}%{php_suffix}
-Version:       7.2.11
-Release:       1
+Version:       7.2.12
+Release:       0.1
 Epoch:         4
 # All files licensed under PHP version 3.01, except
 # Zend is licensed under Zend
@@ -163,7 +163,7 @@ Epoch:              4
 License:       PHP 3.01 and Zend and BSD
 Group:         Libraries
 Source0:       https://php.net/distributions/%{orgname}-%{version}.tar.xz
-# Source0-md5: 28c3d5310a64799fd54c5e49e4982cf9
+# Source0-md5: 6be4a00ca29dd9a63a26f79a2e8752c8
 Source1:       opcache.ini
 Source2:       %{orgname}-mod_php.conf
 Source3:       %{orgname}-cgi-fcgi.ini
@@ -319,7 +319,7 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                jsonver         1.6.0
 %define                pharver         2.0.2
 %define                sqlite3ver      %{version}
-%define                zipver          1.15.3
+%define                zipver          1.15.4
 %define                phpdbgver       0.5.0
 %define                sodiumver       %{version}
 
index a928d0cad36a22d788a1661cc49e6d03f1aa2693..96805303f4012f9682be42b51926398a1302d8ba 100644 (file)
@@ -1,9 +1,9 @@
 --- php-7.0/ext/spl/config.m4~ 2015-05-21 17:57:06.000000000 +0300
 +++ php-7.0/ext/spl/config.m4  2015-05-23 11:25:19.609715006 +0300
-@@ -22,6 +22,6 @@
-   CPPFLAGS=$old_CPPFLAGS
-   AC_DEFINE_UNQUOTED(HAVE_PACKED_OBJECT_VALUE, $ac_result, [Whether struct _zend_object_value is packed])
-   AC_DEFINE(HAVE_SPL, 1, [Whether you want SPL (Standard PHP Library) support]) 
+@@ -2,6 +2,6 @@
+ dnl config.m4 for extension SPL
+   AC_DEFINE(HAVE_SPL, 1, [Whether you want SPL (Standard PHP Library) support])
 -  PHP_NEW_EXTENSION(spl, php_spl.c spl_functions.c spl_engine.c spl_iterators.c spl_array.c spl_directory.c spl_exceptions.c spl_observer.c spl_dllist.c spl_heap.c spl_fixedarray.c, no,, -DZEND_ENABLE_STATIC_TSRMLS_CACHE=1)
 +  PHP_NEW_EXTENSION(spl, php_spl.c spl_functions.c spl_engine.c spl_iterators.c spl_array.c spl_directory.c spl_exceptions.c spl_observer.c spl_dllist.c spl_heap.c spl_fixedarray.c, $ext_shared,, -DZEND_ENABLE_STATIC_TSRMLS_CACHE=1)
    PHP_INSTALL_HEADERS([ext/spl], [php_spl.h spl_array.h spl_directory.h spl_engine.h spl_exceptions.h spl_functions.h spl_iterators.h spl_observer.h spl_dllist.h spl_heap.h spl_fixedarray.h])
This page took 0.942045 seconds and 4 git commands to generate.