]> git.pld-linux.org Git - packages/php.git/commitdiff
This commit was manufactured by cvs2git to create branch 'RA- php-4_4_0-1
authorcvs2git <feedback@pld-linux.org>
Tue, 8 Nov 2005 18:33:40 +0000 (18:33 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
branch_general'.

Cherrypick from master 2005-11-08 18:33:40 UTC Elan Ruusamäe <glen@pld-linux.org> '- fix from bug #35009: ZTS: Persistent resource destruct crashes when extension is compiled as shared':
    php-bug-35009.patch -> 1.1
    php-install_gd_headers.patch -> 1.1
Cherrypick from RA-branch 2005-08-05 14:53:46 UTC hawk <hawk@pld-linux.org> '- backport from PHP CVS to fix compilation with PostgreSQL 7.2.x':
    php-lib.patch -> 1.1.2.1
    php-pgsql-fix.patch -> 1.1.2.1

php-bug-35009.patch [new file with mode: 0644]
php-install_gd_headers.patch [new file with mode: 0644]
php-lib.patch [new file with mode: 0644]
php-pgsql-fix.patch [new file with mode: 0644]

diff --git a/php-bug-35009.patch b/php-bug-35009.patch
new file mode 100644 (file)
index 0000000..ef08ed8
--- /dev/null
@@ -0,0 +1,35 @@
+
+===================================================================
+RCS file: /repository/ZendEngine2/zend.c,v
+retrieving revision 1.287.2.12
+retrieving revision 1.287.2.14
+diff -p --unified=3 -r1.287.2.12 -r1.287.2.14
+--- ./Zend/zend.c      2005/07/22 07:33:27     1.287.2.12
++++ ./Zend/zend.c      2005/11/07 12:25:21     1.287.2.14
+@@ -17,7 +17,7 @@
+    +----------------------------------------------------------------------+
+ */
+
+-/* $Id$ */
++/* $Id$ */
+
+ #include "zend.h"
+ #include "zend_extensions.h"
+@@ -693,9 +693,7 @@ void zend_shutdown(TSRMLS_D)
+ #ifdef ZEND_WIN32
+       zend_shutdown_timeout_thread();
+ #endif
+-#ifndef ZTS
+       zend_destroy_rsrc_list(&EG(persistent_list) TSRMLS_CC);
+-#endif
+       zend_hash_graceful_reverse_destroy(&module_registry);
+
+       zend_hash_destroy(GLOBAL_FUNCTION_TABLE);
+@@ -711,7 +709,6 @@ void zend_shutdown(TSRMLS_D)
+       free(GLOBAL_FUNCTION_TABLE);
+       free(GLOBAL_CLASS_TABLE);
+ #ifdef ZTS
+-      zend_destroy_rsrc_list(&EG(persistent_list) TSRMLS_CC);
+       zend_hash_destroy(GLOBAL_CONSTANTS_TABLE);
+       free(GLOBAL_CONSTANTS_TABLE);
+       GLOBAL_FUNCTION_TABLE = NULL;
diff --git a/php-install_gd_headers.patch b/php-install_gd_headers.patch
new file mode 100644 (file)
index 0000000..47f3c76
--- /dev/null
@@ -0,0 +1,12 @@
+diff -burN php-5.0.3.orig/scripts/Makefile.frag php-5.0.3/scripts/Makefile.frag
+--- php-5.0.3.orig/scripts/Makefile.frag       2005-02-10 07:43:48.406281496 +0100
++++ php-5.0.3/scripts/Makefile.frag    2005-02-10 07:44:19.768513712 +0100
+@@ -30,6 +30,8 @@
+       main/ \
+       main/streams/ \
+       regex/ \
++      ext/gd \
++      ext/gd/libgd/ \
+       ext/iconv/ \
+       ext/libxml/ \
+       ext/standard/ \
diff --git a/php-lib.patch b/php-lib.patch
new file mode 100644 (file)
index 0000000..f494655
--- /dev/null
@@ -0,0 +1,23 @@
+diff -urN php-4.4.0.org/scripts/Makefile.frag php-4.4.0/scripts/Makefile.frag
+--- php-4.4.0.org/scripts/Makefile.frag        2005-06-08 12:34:41.000000000 +0200
++++ php-4.4.0/scripts/Makefile.frag    2005-07-13 13:25:55.095198152 +0200
+@@ -4,7 +4,7 @@
+ #
+ phpincludedir = $(includedir)/php
+-phpbuilddir = $(libdir)/build
++phpbuilddir = $(libdir)/php/build
+ BUILD_FILES = \
+       scripts/phpize.m4 \
+diff -urN php-4.4.0.org/scripts/phpize.in php-4.4.0/scripts/phpize.in
+--- php-4.4.0.org/scripts/phpize.in    2005-06-15 19:13:52.000000000 +0200
++++ php-4.4.0/scripts/phpize.in        2005-07-13 13:26:32.475515480 +0200
+@@ -3,7 +3,7 @@
+ # Variable declaration
+ prefix='@prefix@'
+ exec_prefix="`eval echo @exec_prefix@`"
+-phpdir="`eval echo @libdir@`/build"
++phpdir="`eval echo @libdir@`/php/build"
+ includedir="`eval echo @includedir@`/php"
+ builddir="`pwd`"
diff --git a/php-pgsql-fix.patch b/php-pgsql-fix.patch
new file mode 100644 (file)
index 0000000..1ae20d5
--- /dev/null
@@ -0,0 +1,105 @@
+--- php-4.4.0.orig/ext/pgsql/config.m4 Fri Jul  1 11:10:14 2005
++++ php-4.4.0/ext/pgsql/config.m4      Fri Aug  5 15:13:53 2005
+@@ -1,56 +1,37 @@
+ dnl
+-dnl $Id$
++dnl $Id$
+ dnl
+-AC_DEFUN([PHP_PGSQL_CHECK_FUNCTIONS],[
+-])
+-
+ PHP_ARG_WITH(pgsql,for PostgreSQL support,
+ [  --with-pgsql[=DIR]      Include PostgreSQL support.  DIR is the PostgreSQL
+-                          base install directory or the path to pg_config])
++                          base install directory, defaults to /usr/local/pgsql.])
+ if test "$PHP_PGSQL" != "no"; then
+   PHP_EXPAND_PATH($PGSQL_INCLUDE, PGSQL_INCLUDE)
+-  AC_MSG_CHECKING(for pg_config)
+-  for i in $PHP_PGSQL $PHP_PGSQL/bin /usr/local/pgsql/bin /usr/local/bin /usr/bin ""; do
+-      if test -x $i/pg_config; then
+-      PG_CONFIG="$i/pg_config"
+-      break;
+-    fi
+-  done
+-
+-  if test -n "$PG_CONFIG"; then
+-    AC_MSG_RESULT([$PG_CONFIG])
+-    PGSQL_INCLUDE=`$PG_CONFIG --includedir`
+-    PGSQL_LIBDIR=`$PG_CONFIG --libdir`
+-    AC_DEFINE(HAVE_PG_CONFIG_H,1,[Whether to have pg_config.h])
++  if test "$PHP_PGSQL" = "yes"; then
++    PGSQL_SEARCH_PATHS="/usr /usr/local /usr/local/pgsql"
+   else
+-    AC_MSG_RESULT(not found)
+-    if test "$PHP_PGSQL" = "yes"; then
+-      PGSQL_SEARCH_PATHS="/usr /usr/local /usr/local/pgsql"
+-    else
+-      PGSQL_SEARCH_PATHS=$PHP_PGSQL
+-    fi
++    PGSQL_SEARCH_PATHS=$PHP_PGSQL
++  fi
+   
+-    for i in $PGSQL_SEARCH_PATHS; do
+-      for j in include include/pgsql include/postgres include/postgresql ""; do
+-        if test -r "$i/$j/libpq-fe.h"; then
+-          PGSQL_INC_BASE=$i
+-          PGSQL_INCLUDE=$i/$j
+-          if test -r "$i/$j/pg_config.h"; then
+-            AC_DEFINE(HAVE_PG_CONFIG_H,1,[Whether to have pg_config.h])
+-          fi
++  for i in $PGSQL_SEARCH_PATHS; do
++    for j in include include/pgsql include/postgres include/postgresql ""; do
++      if test -r "$i/$j/libpq-fe.h"; then
++        PGSQL_INC_BASE=$i
++        PGSQL_INCLUDE=$i/$j
++        if test -r "$i/$j/pg_config.h"; then
++          AC_DEFINE(HAVE_PG_CONFIG_H,1,[Whether to have pg_config.h])
+         fi
+-      done
++      fi
++    done
+-      for j in $PHP_LIBDIR $PHP_LIBDIR/pgsql $PHP_LIBDIR/postgres $PHP_LIBDIR/postgresql ""; do
+-        if test -f "$i/$j/libpq.so" || test -f "$i/$j/libpq.a"; then 
+-          PGSQL_LIBDIR=$i/$j
+-        fi
+-      done
++    for j in lib lib/pgsql lib/postgres lib/postgresql ""; do
++      if test -f "$i/$j/libpq.so" || test -f "$i/$j/libpq.a"; then 
++        PGSQL_LIBDIR=$i/$j
++      fi
+     done
+-  fi
++  done
+   if test -z "$PGSQL_INCLUDE"; then
+     AC_MSG_ERROR(Cannot find libpq-fe.h. Please specify correct PostgreSQL installation path)
+@@ -69,25 +50,10 @@
+   old_LDFLAGS=$LDFLAGS
+   LDFLAGS="$LDFLAGS -L$PGSQL_LIBDIR"
+   AC_CHECK_LIB(pq, PQescapeString,AC_DEFINE(HAVE_PQESCAPE,1,[PostgreSQL 7.2.0 or later]))
+-  AC_CHECK_LIB(pq, PQunescapeBytea,AC_DEFINE(HAVE_PQUNESCAPEBYTEA,1,[PostgreSQL 7.3.0 or later]))
+   AC_CHECK_LIB(pq, PQsetnonblocking,AC_DEFINE(HAVE_PQSETNONBLOCKING,1,[PostgreSQL 7.0.x or later]))
+   AC_CHECK_LIB(pq, PQcmdTuples,AC_DEFINE(HAVE_PQCMDTUPLES,1,[Broken libpq under windows]))
+   AC_CHECK_LIB(pq, PQoidValue,AC_DEFINE(HAVE_PQOIDVALUE,1,[Older PostgreSQL]))
+   AC_CHECK_LIB(pq, PQclientEncoding,AC_DEFINE(HAVE_PQCLIENTENCODING,1,[PostgreSQL 7.0.x or later]))
+-  AC_CHECK_LIB(pq, PQparameterStatus,AC_DEFINE(HAVE_PQPARAMETERSTATUS,1,[PostgreSQL 7.4 or later]))
+-  AC_CHECK_LIB(pq, PQprotocolVersion,AC_DEFINE(HAVE_PQPROTOCOLVERSION,1,[PostgreSQL 7.4 or later]))
+-  AC_CHECK_LIB(pq, PQtransactionStatus,AC_DEFINE(HAVE_PGTRANSACTIONSTATUS,1,[PostgreSQL 7.4 or later]))
+-  AC_CHECK_LIB(pq, PQexecParams,AC_DEFINE(HAVE_PQEXECPARAMS,1,[PostgreSQL 7.4 or later]))
+-  AC_CHECK_LIB(pq, PQprepare,AC_DEFINE(HAVE_PQPREPARE,1,[PostgreSQL 7.4 or later]))
+-  AC_CHECK_LIB(pq, PQexecPrepared,AC_DEFINE(HAVE_PQEXECPREPARED,1,[PostgreSQL 7.4 or later]))
+-  AC_CHECK_LIB(pq, PQresultErrorField,AC_DEFINE(HAVE_PQRESULTERRORFIELD,1,[PostgreSQL 7.4 or later]))
+-  AC_CHECK_LIB(pq, PQsendQueryParams,AC_DEFINE(HAVE_PQSENDQUERYPARAMS,1,[PostgreSQL 7.4 or later]))
+-  AC_CHECK_LIB(pq, PQsendPrepare,AC_DEFINE(HAVE_PQSENDPREPARE,1,[PostgreSQL 7.4 or later]))
+-  AC_CHECK_LIB(pq, PQsendQueryPrepared,AC_DEFINE(HAVE_PQSENDQUERYPREPARED,1,[PostgreSQL 7.4 or later]))
+-  AC_CHECK_LIB(pq, PQputCopyData,AC_DEFINE(HAVE_PQPUTCOPYDATA,1,[PostgreSQL 7.4 or later]))
+-  AC_CHECK_LIB(pq, PQputCopyEnd,AC_DEFINE(HAVE_PQPUTCOPYEND,1,[PostgreSQL 7.4 or later]))
+-  AC_CHECK_LIB(pq, PQgetCopyData,AC_DEFINE(HAVE_PQGETCOPYDATA,1,[PostgreSQL 7.4 or later]))
+-  AC_CHECK_LIB(pq, PQsetErrorVerbosity,AC_DEFINE(HAVE_PQSETERRORVERBOSITY,1,[PostgreSQL 7.4 or later]))
+   AC_CHECK_LIB(pq, pg_encoding_to_char,AC_DEFINE(HAVE_PGSQL_WITH_MULTIBYTE_SUPPORT,1,[Whether libpq is compiled with --enable-multibyte]))
+   LIBS=$old_LIBS
+   LDFLAGS=$old_LDFLAGS
This page took 0.136984 seconds and 4 git commands to generate.