]> git.pld-linux.org Git - packages/php.git/commitdiff
up to php-7.3.0RC5 auto/th/php73-7.3.0-1.RC5.1
authorElan Ruusamäe <glen@pld-linux.org>
Mon, 12 Nov 2018 11:29:01 +0000 (13:29 +0200)
committerElan Ruusamäe <glen@pld-linux.org>
Mon, 12 Nov 2018 12:55:43 +0000 (14:55 +0200)
pcre-shared.patch
php.spec
x32.patch

index fb45863845f11e184dde808d8b1336b3a3c6b306..384b23d25075650dd2aae0abded79db0767527ce 100644 (file)
@@ -1,9 +1,9 @@
---- php-7.3.0alpha3/ext/pcre/config0.m4~       2018-07-03 15:56:43.000000000 +0300
-+++ php-7.3.0alpha3/ext/pcre/config0.m4        2018-07-10 11:09:21.010882573 +0300
-@@ -61,8 +61,9 @@
-     PHP_EVAL_LIBLINE($PCRE2_LIB)
-     AC_DEFINE(HAVE_PCRE, 1, [ ])
-     AC_DEFINE(PCRE2_CODE_UNIT_WIDTH, 8, [ ])
+--- php-7.3.0RC5/ext/pcre/config0.m4~  2018-11-06 12:22:53.000000000 +0200
++++ php-7.3.0RC5/ext/pcre/config0.m4   2018-11-12 13:30:52.805036671 +0200
+@@ -84,8 +84,9 @@
+       ])
+     fi
 -    PHP_NEW_EXTENSION(pcre, php_pcre.c, no,, -DZEND_ENABLE_STATIC_TSRMLS_CACHE=1)
 +    PHP_NEW_EXTENSION(pcre, php_pcre.c, $ext_shared,, -DZEND_ENABLE_STATIC_TSRMLS_CACHE=1)
      PHP_INSTALL_HEADERS([ext/pcre], [php_pcre.h])
index ac25c982a24de1e7e372a643b37bbf30964c9d72..f3e2053d089925aac4cc06cc8d5719e61fc71b28 100644 (file)
--- a/php.spec
+++ b/php.spec
 %undefine      with_filter
 %endif
 
-%define                subver RC4
+%define                subver RC5
 %define                orgname php
 %define                ver_suffix 73
 %define                php_suffix %{!?with_default_php:%{ver_suffix}}
@@ -165,7 +165,7 @@ License:    PHP 3.01 and Zend and BSD
 Group:         Libraries
 #Source0:      https://php.net/distributions/%{orgname}-%{version}.tar.xz
 Source0:       https://downloads.php.net/~cmb/php-%{version}%{subver}.tar.xz
-# Source0-md5: c8d4be9ebd25082365b3488fd6a04a41
+# Source0-md5: 9cc3c9f146b86e813f42555528a27cfe
 Source1:       opcache.ini
 Source2:       %{orgname}-mod_php.conf
 Source3:       %{orgname}-cgi-fcgi.ini
index 9a59ef0cb03a096f204fe8087e83a9748c6bbaab..a56457ae9a2b5cce407c132084f9af2c6a95cc06 100644 (file)
--- a/x32.patch
+++ b/x32.patch
@@ -9,17 +9,17 @@
  ZEND_API zend_bool ZEND_FASTCALL zend_string_equal_val(zend_string *s1, zend_string *s2)
  {
        char *ptr = ZSTR_VAL(s1);
---- php-7.3.0RC3/Zend/zend_string.h~   2018-10-09 11:26:41.000000000 +0200
-+++ php-7.3.0RC3/Zend/zend_string.h    2018-10-24 22:47:14.745614884 +0200
+--- php-7.3.0RC5/Zend/zend_string.h~   2018-11-06 12:22:56.000000000 +0200
++++ php-7.3.0RC5/Zend/zend_string.h    2018-11-12 13:32:37.350520375 +0200
 @@ -294,7 +294,7 @@
        }
  }
  
 -#if defined(__GNUC__) && (defined(__i386__) || defined(__x86_64__))
 +#if defined(__GNUC__) && (defined(__i386__) || (defined(__x86_64__) && !defined(__ILP32__)))
+ BEGIN_EXTERN_C()
  ZEND_API zend_bool ZEND_FASTCALL zend_string_equal_val(zend_string *s1, zend_string *s2);
- #else
- static zend_always_inline zend_bool zend_string_equal_val(zend_string *s1, zend_string *s2)
+ END_EXTERN_C()
 --- php-7.3.0RC3/ext/opcache/zend_accelerator_util_funcs.c~    2018-10-09 11:26:32.000000000 +0200
 +++ php-7.3.0RC3/ext/opcache/zend_accelerator_util_funcs.c     2018-10-24 22:15:44.849117508 +0200
 @@ -719,7 +719,7 @@
This page took 1.111638 seconds and 4 git commands to generate.