]> git.pld-linux.org Git - packages/php.git/commitdiff
up to php-7.4.0alpha1
authorElan Ruusamäe <glen@pld-linux.org>
Sat, 15 Jun 2019 17:54:47 +0000 (20:54 +0300)
committerElan Ruusamäe <glen@pld-linux.org>
Sat, 15 Jun 2019 18:01:52 +0000 (21:01 +0300)
php.spec
spl-shared.patch

index b3eaf0c3db89ff8adc5a14e4e754a169ece15fc7..0d39b6276d9b5756d7609b7159f6bb86b333fa56 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -2,7 +2,6 @@
 # - mysqlnd driver doesn't support reconnect: https://bugs.php.net/bug.php?id=52561
 # TODO 7.4:
 # - follow upstream: drop spl, pcre, hash subpackages (tired of maintaining them)
-# - handle acinclude.m4 -> build/php.m4 rename
 # TODO 7.3:
 # - branch php-7.2 and merge dev-7.3 into head once official announcement ready
 # TODO 7.2:
 %undefine      with_filter
 %endif
 
-%define                subver %{nil}
+%define                subver alpha1
 %define                orgname php
 %define                ver_suffix 74
 %define                php_suffix %{!?with_default_php:%{ver_suffix}}
@@ -165,10 +164,9 @@ Epoch:             4
 # TSRM is licensed under BSD
 License:       PHP 3.01 and Zend and BSD
 Group:         Libraries
-#Source0:      https://downloads.php.net/~cmb/php-%{version}%{subver}.tar.xz
 #Source0:      https://php.net/distributions/%{orgname}-%{version}.tar.xz
-Source0:       https://github.com/php/php-src/archive/PHP-7.4/%{orgname}-%{version}.tar.gz
-# Source0-md5: 5ddd943d45880a2fa7389b6fc4aeec3a
+Source0:       https://downloads.php.net/~derick/php-%{version}%{subver}.tar.xz
+# Source0-md5: 29592e9a73c0ae615c4b7e2b4761184f
 Source1:       opcache.ini
 Source2:       %{orgname}-mod_php.conf
 Source3:       %{orgname}-cgi-fcgi.ini
@@ -309,9 +307,9 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                _sysconfdir                     %{php_sysconfdir}
 
 # must be in sync with source. extra check ensuring that it is so is done in %%build
-%define                php_api_version         20180731
-%define                zend_module_api         20180731
-%define                zend_extension_api      320180731
+%define                php_api_version         20190529
+%define                zend_module_api         %{php_api_version}
+%define                zend_extension_api      3%{zend_module_api}
 %define                php_pdo_api_version     20170320
 
 # Extension versions
@@ -1956,11 +1954,7 @@ compression support to PHP.
 Moduł PHP umożliwiający używanie kompresji zlib.
 
 %prep
-%if 0
 %setup -q -n %{orgname}-%{version}%{?subver}
-%else
-%setup -q -n php-src-PHP-7.4
-%endif
 cp -p php.ini-production php.ini
 %patch0 -p1
 %patch1 -p1
index eb121c21c05d6478789922515e8d5c543ae8608e..72229e7ed60e713b39047eb7ad841fafbf7b885b 100644 (file)
@@ -1,12 +1,10 @@
---- php-src-PHP-7.4/ext/spl/config.m4~ 2019-05-04 15:24:15.000000000 +0300
-+++ php-src-PHP-7.4/ext/spl/config.m4  2019-05-05 18:45:49.109324631 +0300
-@@ -1,5 +1,5 @@
- dnl config.m4 for extension SPL
--  PHP_NEW_EXTENSION(spl, php_spl.c spl_functions.c spl_engine.c spl_iterators.c spl_array.c spl_directory.c spl_exceptions.c spl_observer.c spl_dllist.c spl_heap.c spl_fixedarray.c, no,, -DZEND_ENABLE_STATIC_TSRMLS_CACHE=1)
-+  PHP_NEW_EXTENSION(spl, php_spl.c spl_functions.c spl_engine.c spl_iterators.c spl_array.c spl_directory.c spl_exceptions.c spl_observer.c spl_dllist.c spl_heap.c spl_fixedarray.c, $ext_shared,, -DZEND_ENABLE_STATIC_TSRMLS_CACHE=1)
-   PHP_INSTALL_HEADERS([ext/spl], [php_spl.h spl_array.h spl_directory.h spl_engine.h spl_exceptions.h spl_functions.h spl_iterators.h spl_observer.h spl_dllist.h spl_heap.h spl_fixedarray.h])
-   PHP_ADD_EXTENSION_DEP(spl, pcre, true)
+--- php-src-PHP-7.4/ext/spl/config.m4~ 2019-05-25 12:37:30.000000000 +0300
++++ php-src-PHP-7.4/ext/spl/config.m4  2019-05-26 10:12:09.893194716 +0300
+@@ -1,3 +1,3 @@
+-PHP_NEW_EXTENSION(spl, php_spl.c spl_functions.c spl_engine.c spl_iterators.c spl_array.c spl_directory.c spl_exceptions.c spl_observer.c spl_dllist.c spl_heap.c spl_fixedarray.c, no,, -DZEND_ENABLE_STATIC_TSRMLS_CACHE=1)
++PHP_NEW_EXTENSION(spl, php_spl.c spl_functions.c spl_engine.c spl_iterators.c spl_array.c spl_directory.c spl_exceptions.c spl_observer.c spl_dllist.c spl_heap.c spl_fixedarray.c, $ext_shared,, -DZEND_ENABLE_STATIC_TSRMLS_CACHE=1)
+ PHP_INSTALL_HEADERS([ext/spl], [php_spl.h spl_array.h spl_directory.h spl_engine.h spl_exceptions.h spl_functions.h spl_iterators.h spl_observer.h spl_dllist.h spl_heap.h spl_fixedarray.h])
+ PHP_ADD_EXTENSION_DEP(spl, pcre, true)
 --- php-7.1.0alpha1/ext/pdo/pdo.c~     2016-06-07 23:56:47.000000000 +0300
 +++ php-7.1.0alpha1/ext/pdo/pdo.c      2016-06-13 23:24:51.238259131 +0300
 @@ -117,7 +117,9 @@
This page took 0.05797 seconds and 4 git commands to generate.