]> git.pld-linux.org Git - packages/php.git/commitdiff
Revert "- fix embed install"
authorJan Rękorajski <baggins@pld-linux.org>
Mon, 27 Mar 2017 07:35:33 +0000 (09:35 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Mon, 27 Mar 2017 07:35:33 +0000 (09:35 +0200)
This reverts commit 01ddcba372ebcea9122d6512d80dee4d244d9b4d.

php.spec

index d4acb838198db896439a83fce3ba4a3f2715eefa..afb7e94981a126f7b8a209d81a4ffce244c93969 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -138,7 +138,7 @@ ERROR: You need to select at least one Apache SAPI to build shared modules.
 %undefine      with_filter
 %endif
 
-%define                rel     14
+%define                rel     13
 %define                orgname php
 %define                ver_suffix 54
 %define                php_suffix %{!?with_default_php:%{ver_suffix}}
@@ -2514,10 +2514,9 @@ touch $RPM_BUILD_ROOT%{_sbindir}/php-fpm
 
 # install Embedded API
 %if %{with embed}
+%{__make} -f Makefile.embed install-sapi INSTALL_ROOT=$RPM_BUILD_ROOT
 # we could use install-headers from Makefile.embed, but that would reinstall all headers
-# install-sapi installs to wrong dir, so just do it all manually
 install -d $RPM_BUILD_ROOT%{_includedir}/php/sapi/embed
-install -p libs/libphp5.so $RPM_BUILD_ROOT%{_libdir}
 cp -p sapi/embed/php_embed.h $RPM_BUILD_ROOT%{_includedir}/php/sapi/embed
 %endif
 
@@ -2586,6 +2585,10 @@ cp -a tests/* $RPM_BUILD_ROOT%{php_data_dir}/tests/php
 
 # fix install paths, avoid evil rpaths
 sed -i -e "s|^libdir=.*|libdir='%{_libdir}'|" $RPM_BUILD_ROOT%{_libdir}/libphp_common.la
+%if %{with embed}
+# libphp5.la contains our buildroot in dependency_libs
+sed -i -e "/dependency_libs/ s,/[^ ]*/libs/libphp_common.la,%{_libdir}/libphp_common.la," $RPM_BUILD_ROOT%{_libdir}/libphp5.la
+%endif
 # better solution?
 sed -i -e 's|libphp_common.la|$(libdir)/libphp_common.la|' $RPM_BUILD_ROOT%{_libdir}/%{name}/build/acinclude.m4
 
@@ -2820,7 +2823,7 @@ fi
 %if %{with embed}
 %files embedded
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libphp5.so
+%attr(755,root,root) %{_libdir}/libphp5-%{version}.so
 %endif
 
 %files cli
@@ -2872,6 +2875,11 @@ fi
 %{_libdir}/%{name}/build
 %{_mandir}/man1/php-config.1*
 %{_mandir}/man1/phpize.1*
+%if %{with embed}
+# embedded
+%{_libdir}/libphp5.so
+%{_libdir}/libphp5.la
+%endif
 
 %files bcmath
 %defattr(644,root,root,755)
This page took 1.377723 seconds and 4 git commands to generate.