]> git.pld-linux.org Git - packages/php.git/commitdiff
improve usability of extensions built with proprietary libs
authorElan Ruusamäe <glen@delfi.ee>
Wed, 21 May 2014 21:07:11 +0000 (00:07 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Wed, 21 May 2014 21:07:14 +0000 (00:07 +0300)
- build such extensions with dependency only on php apis versions
- drop noauoprov, we _do_ want soname dependencies, use _noautoreq instead
- drop oci from release, not useful with "loose" dependencies

this lets catch up distro-wide updates without need to always rebuild locally

php.spec

index f3dc054bb8c202b7b7a53d9dc89a8b2a1f9fd481..e5935a28229d46c38bb13dbf18eaffdaf0b488dd 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -138,7 +138,7 @@ Summary(ru.UTF-8):  PHP Версии 5 - язык препроцессирова
 Summary(uk.UTF-8):     PHP Версії 5 - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          %{orgname}%{php_suffix}
 Version:       5.5.12
-Release:       %{rel}%{?with_type_hints:.th}%{?with_oci8:.oci}
+Release:       %{rel}%{?with_type_hints:.th}
 Epoch:         4
 License:       PHP
 Group:         Libraries
@@ -949,9 +949,12 @@ Summary:   InterBase/Firebird database module for PHP
 Summary(pl.UTF-8):     Moduł bazy danych InterBase/Firebird dla PHP
 Group:         Libraries
 URL:           http://www.php.net/manual/en/book.ibase.php
+%if %{with interbase_inst}
+%{?requires_php_extension}
+%else
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
+%endif
 Provides:      php(interbase)
-%{?with_interbase_inst:Autoreq:        false}
 
 %description interbase
 This is a dynamic shared object (DSO) for PHP that will add InterBase
@@ -1145,9 +1148,8 @@ Summary:  Oracle 8+ database module for PHP
 Summary(pl.UTF-8):     Moduł bazy danych Oracle 8+ dla PHP
 Group:         Libraries
 URL:           http://www.php.net/manual/en/book.oci8.php
-Requires:      %{name}-common = %{epoch}:%{version}-%{release}
+%{?requires_php_extension}
 Provides:      php(oci8)
-AutoReq:       false
 
 %description oci8
 This is a dynamic shared object (DSO) for PHP that will add Oracle 7,
@@ -1324,8 +1326,8 @@ Summary:  PHP Data Objects (PDO) Oracle support
 Summary(pl.UTF-8):     Moduł PHP Data Objects (PDO) z obsługą Oracle'a
 Group:         Libraries
 URL:           http://www.php.net/manual/en/ref.pdo-oci.php
-Requires:      %{name}-common = %{epoch}:%{version}-%{release}
-Requires:      %{name}-pdo = %{epoch}:%{version}-%{release}
+%{?requires_php_extension}
+%{?requires_php_pdo_module}
 Provides:      php(pdo-oci)
 Obsoletes:     php-pecl-PDO_OCI
 
This page took 1.408701 seconds and 4 git commands to generate.