]> git.pld-linux.org Git - packages/php.git/commitdiff
- updated dependencies
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 28 Jan 2017 07:34:48 +0000 (08:34 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Sat, 28 Jan 2017 07:34:48 +0000 (08:34 +0100)
- updated db patch to handle db 6.0-6.2

php-db.patch
php.spec

index fbd0fb712c3bb584c0685e57ff5ea9dab25e7ae8..f6ba5be43a945d7e47f38a4202456daf42c95681 100644 (file)
@@ -1,13 +1,34 @@
---- php-7.0.2/ext/dba/config.m4~       2016-01-11 00:42:48.000000000 +0200
-+++ php-7.0.2/ext/dba/config.m4        2016-01-11 00:43:39.055351157 +0200
-@@ -287,6 +287,14 @@
+--- php-7.1.1/ext/dba/config.m4.orig   2017-01-17 21:44:40.000000000 +0100
++++ php-7.1.1/ext/dba/config.m4        2017-01-27 22:08:45.385645468 +0100
+@@ -245,7 +245,7 @@
+         ],[
+           AC_EGREP_CPP(yes,[
+ #include "$THIS_INCLUDE"
+-#if DB_VERSION_MAJOR == $1 || ($1 == 4 && DB_VERSION_MAJOR == 5)
++#if DB_VERSION_MAJOR == $1 || ($1 == 4 && (DB_VERSION_MAJOR == 5 || DB_VERSION_MAJOR == 6))
+             yes
+ #endif
+           ],[
+@@ -322,10 +322,26 @@
        THIS_PREFIX=$i
        THIS_INCLUDE=$i/db4/db.h
        break
-+    elif test -f "$i/include/db5.3/db.h"; then
++    elif test -f "$i/include/db6.2/db.h"; then
 +      THIS_PREFIX=$i
-+      THIS_INCLUDE=$i/include/db5.3/db.h
++      THIS_INCLUDE=$i/include/db6.2/db.h
 +      break
++    elif test -f "$i/include/db6.1/db.h"; then
++      THIS_PREFIX=$i
++      THIS_INCLUDE=$i/include/db6.1/db.h
++      break
++    elif test -f "$i/include/db6.0/db.h"; then
++      THIS_PREFIX=$i
++      THIS_INCLUDE=$i/include/db6.0/db.h
++      break
+     elif test -f "$i/include/db5.3/db.h"; then
+       THIS_PREFIX=$i
+       THIS_INCLUDE=$i/include/db5.3/db.h
+       break
 +    elif test -f "$i/include/db5.2/db.h"; then
 +      THIS_PREFIX=$i
 +      THIS_INCLUDE=$i/include/db5.2/db.h
      elif test -f "$i/include/db5.1/db.h"; then
        THIS_PREFIX=$i
        THIS_INCLUDE=$i/include/db5.1/db.h
-@@ -376,7 +376,7 @@
+@@ -366,7 +384,7 @@
        break
      fi
    done
 -  PHP_DBA_DB_CHECK(4, db-5.3 db-5.1 db-5.0 db-4.8 db-4.7 db-4.6 db-4.5 db-4.4 db-4.3 db-4.2 db-4.1 db-4.0 db-4 db4 db, [(void)db_create((DB**)0, (DB_ENV*)0, 0)])
-+  PHP_DBA_DB_CHECK(4, db-5.3 db-5.2 db-5.1 db-5.0 db-4.8 db-4.7 db-4.6 db-4.5 db-4.4 db-4.3 db-4.2 db-4.1 db-4.0 db-4 db4 db, [(void)db_create((DB**)0, (DB_ENV*)0, 0)])
++  PHP_DBA_DB_CHECK(4, db-6.2 db-6.1 db-6.0 db-5.3 db-5.2 db-5.1 db-5.0 db-4.8 db-4.7 db-4.6 db-4.5 db-4.4 db-4.3 db-4.2 db-4.1 db-4.0 db-4 db4 db, [(void)db_create((DB**)0, (DB_ENV*)0, 0)])
  fi
  PHP_DBA_STD_RESULT(db4,Berkeley DB4)
  
-
index 56080b7a2d70294b4fa7a4befb87926f458aec0e..6028c1dee97605278b1e2f5c39b2422d6739f128 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -235,11 +235,6 @@ BuildRequires:     db-devel >= 4.0
 BuildRequires: elfutils-devel
 %{?with_enchant:BuildRequires: enchant-devel >= 1.1.3}
 %{?with_kerberos5:BuildRequires:       heimdal-devel}
-%{?with_fpm:BuildRequires:     libapparmor-devel}
-%{?with_system_libzip:BuildRequires:   libzip-devel >= 0.10.1-2}
-%{!?with_mysqlnd:BuildRequires:        mysql-devel}
-BuildRequires: pkgconfig
-BuildRequires: sed >= 4.0
 %if %{with pdo_dblib}
 BuildRequires: freetds-devel >= 0.82
 %endif
@@ -250,6 +245,8 @@ BuildRequires:      gd-devel >= 2.1
 BuildRequires: gdbm-devel
 BuildRequires: gmp-devel >= 4.2
 %{?with_imap:BuildRequires:    imap-devel >= 1:2007e-2}
+%{?with_gcov:BuildRequires:    lcov}
+%{?with_fpm:BuildRequires:     libapparmor-devel}
 %{?with_intl:BuildRequires:    libicu-devel >= 4.4}
 BuildRequires: libjpeg-devel
 BuildRequires: libltdl-devel >= 1.4
@@ -257,7 +254,6 @@ BuildRequires:      libmcrypt-devel >= 2.5.6
 BuildRequires: libpng-devel >= 1.0.8
 %{?with_intl:BuildRequires:    libstdc++-devel}
 %{?with_webp:BuildRequires:    libwebp-devel}
-BuildRequires: tokyocabinet-devel
 %if "%{pld_release}" != "ac"
 BuildRequires: libtool >= 2:2.4.6
 %else
@@ -265,14 +261,16 @@ BuildRequires:    libtool >= 1.4.3
 %endif
 BuildRequires: libxml2-devel >= 1:2.7.6-4
 BuildRequires: libxslt-devel >= 1.1.0
+%{?with_system_libzip:BuildRequires:   libzip-devel >= 0.10.1-2}
+%{?with_snmp:%{?with_tests:BuildRequires:      mibs-net-snmp}}
 %{?with_mm:BuildRequires:      mm-devel >= 1.3.0}
+%{!?with_pdo_mysql:BuildRequires:      mysql-devel}
+%{!?with_mysqli:BuildRequires: mysql-devel >= 4.1.13}
+%{?with_snmp:BuildRequires:    net-snmp-devel >= 5.3}
 %{?with_ldap:BuildRequires:    openldap-devel >= 2.3.0}
 %if %{with openssl} || %{with ldap}
 BuildRequires: openssl-devel >= 1.0.1
 %endif
-%{?with_gcov:BuildRequires:    lcov}
-%{?with_snmp:%{?with_tests:BuildRequires:      mibs-net-snmp}}
-%{?with_snmp:BuildRequires:    net-snmp-devel >= 5.0.7}
 %{?with_oci:%{?with_instantclient:BuildRequires:       oracle-instantclient-devel}}
 BuildRequires: pam-devel
 %{?with_pcre:BuildRequires:    pcre-devel >= 8.10}
@@ -283,16 +281,18 @@ BuildRequires:    readline-devel
 BuildRequires: rpm >= 4.4.9-56
 BuildRequires: rpm-build >= 4.4.0
 BuildRequires: rpmbuild(macros) >= 1.566
-%{?with_systemtap:BuildRequires:       systemtap-sdt-devel}
-BuildRequires: tar >= 1:1.22
-BuildRequires: xz
+BuildRequires: sed >= 4.0
 %if %{with sqlite3} || %{with pdo_sqlite}
 BuildRequires: sqlite3-devel >= 3.3.9
 %endif
+%{?with_systemtap:BuildRequires:       systemtap-sdt-devel}
+BuildRequires: tar >= 1:1.22
 %{?with_tidy:BuildRequires:    tidy-devel}
+BuildRequires: tokyocabinet-devel
 %{?with_odbc:BuildRequires:    unixODBC-devel}
 %{?with_xmlrpc:BuildRequires:  xmlrpc-epi-devel >= 0.54.1}
-BuildRequires: zlib-devel >= 1.0.9
+BuildRequires: xz
+BuildRequires: zlib-devel >= 1.2.0.4
 %if %{with apache2}
 BuildRequires: apache-devel >= 2.0.52-2
 BuildRequires: apr-devel >= 1:1.0.0
@@ -545,6 +545,7 @@ Requires:   glibc >= 6:2.3.5
 Requires:      php-dirs >= 1.4
 Requires:      rpm-whiteout >= 1.28
 Requires:      tzdata
+Requires:      zlib >= 1.2.0.4
 Provides:      %{name}(debug) = %{php_debug}
 Provides:      %{name}(modules_api) = %{php_api_version}
 Provides:      %{name}(thread-safety) = %{_zend_zts}
@@ -1129,6 +1130,7 @@ URL:              http://php.net/manual/en/book.mysqli.php
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
 %{?with_mysqlnd:Requires:      %{name}-mysqlnd = %{epoch}:%{version}-%{release}}
 Requires:      %{name}-spl = %{epoch}:%{version}-%{release}
+Requires:      mysql-libs >= 4.1.13
 Provides:      php(mysqli)
 Obsoletes:     php-mysqli < 4:5.3.28-7
 
@@ -1914,7 +1916,7 @@ Group:            Libraries
 URL:           http://php.net/manual/en/book.xsl.php
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
 Requires:      %{name}-dom = %{epoch}:%{version}-%{release}
-Requires:      libxslt >= 1.0.18
+Requires:      libxslt >= 1.1.0
 Provides:      php(xsl)
 Obsoletes:     php-xsl < 4:5.3.28-7
 # actually not true, functionality is similar, but API differs
This page took 0.056555 seconds and 4 git commands to generate.