]> git.pld-linux.org Git - packages/php.git/commitdiff
Up to php-8.2.0RC2 auto/th/php82-8.2.0-0.RC2.1
authorElan Ruusamäe <glen@pld-linux.org>
Wed, 28 Sep 2022 22:11:25 +0000 (01:11 +0300)
committerElan Ruusamäe <glen@pld-linux.org>
Thu, 29 Sep 2022 13:53:49 +0000 (16:53 +0300)
- https://stitcher.io/blog/new-in-php-82
- https://www.php.net/archive/2022.php#2022-09-15-1

php-fpm-config.patch
php-ini.patch
php-silent-session-cleanup.patch
php-zlib-for-getimagesize.patch
php.spec

index 11b9933f6a1c64a7c0badea7904723838f35c91f..e6ff89fdaa45457216e641c1b2239f853323aa40 100644 (file)
@@ -17,9 +17,9 @@
  
  ; syslog_facility is used to specify what type of program is logging the
  ; message. This lets syslogd specify that messages from different facilities
---- php-5.6.5/sapi/fpm/www.conf.in~    2015-02-04 19:26:16.000000000 +0200
-+++ php-5.6.5/sapi/fpm/www.conf.in     2015-02-04 19:27:25.275218535 +0200
-@@ -32,7 +32,7 @@
+--- php-8.2.0RC2/sapi/fpm/www.conf.in~ 2022-09-29 01:22:09.000000000 +0300
++++ php-8.2.0RC2/sapi/fpm/www.conf.in  2022-09-29 01:23:24.680196092 +0300
+@@ -33,7 +33,7 @@
  ;                            (IPv6 and IPv4-mapped) on a specific port;
  ;   '/path/to/unix/socket' - to listen on a unix socket.
  ; Note: This value is mandatory.
@@ -27,7 +27,7 @@
 +listen = /var/run/php/@processname@.sock
  
  ; Set listen(2) backlog.
- ; Default Value: 511 (-1 on FreeBSD and OpenBSD)
+ ; Default Value: 511 (-1 on Linux, FreeBSD and OpenBSD)
 @@ -46,9 +46,9 @@
  ; and group can be specified either by name or by their numeric IDs.
  ; Default Values: user and group are set as the running user
  ; When POSIX Access Control Lists are supported you can set them using
  ; these options, value is a comma separated list of user/group names.
  ; When set, listen.owner and listen.group are ignored
-@@ -53,7 +53,7 @@
+@@ -60,7 +60,7 @@
  ; must be separated by a comma. If this value is left blank, connections will be
  ; accepted from any ip address.
  ; Default Value: any
 -;listen.allowed_clients = 127.0.0.1
 +listen.allowed_clients = 127.0.0.1
  
- ; Specify the nice(2) priority to apply to the pool processes (only if set)
- ; The value can vary from -19 (highest priority) to 20 (lower priority)
+ ; Set the associated the route table (FIB). FreeBSD only
+ ; Default Value: -1
 @@ -372,7 +372,7 @@
  ; the current environment.
  ; Default Value: clean env
index db8a3f0d619d99e04d8da1fe60e9f95f06e62f11..27cd2120282f542d27c3c96c62c3a933b49a6fa3 100644 (file)
@@ -1,5 +1,5 @@
---- php-8.0.1/php.ini~ 2021-02-04 11:05:51.000000000 +0200
-+++ php-8.0.1/php.ini  2021-02-04 11:08:35.715925882 +0200
+--- php-8.2.0RC2/php.ini~      2022-09-29 01:16:25.000000000 +0300
++++ php-8.2.0RC2/php.ini       2022-09-29 01:18:21.454421061 +0300
 @@ -82,8 +82,19 @@
  ; much more verbose when it comes to errors. We recommend using the
  ; development version only in development environments, as errors shown to
  ;;;;;;;;;;;;;;;;
  ; File Uploads ;
  ;;;;;;;;;;;;;;;;
-@@ -871,45 +871,7 @@
- ;   extension folders as well as the separate PECL DLL download (PHP 5+).
+@@ -863,46 +863,7 @@
+ ;   extension folders as well as the separate PECL DLL download.
  ;   Be sure to appropriately set the extension_dir directive.
  ;
 -;extension=bz2
 -;extension=sqlite3
 -;extension=tidy
 -;extension=xsl
+-;extension=zip
 -
 -;zend_extension=opcache
 +; In PLD Linux you can install appropriate php80-<extension> or php80-pecl-<extension> package.
index 2fdf68eb6910cd45e181522d375ae22eef04d234..1c004a31a5014b8e310355b7b1730f793a549a9b 100644 (file)
@@ -1,10 +1,10 @@
---- php-7.0/ext/session/mod_files.c~   2015-05-21 17:57:06.000000000 +0300
-+++ php-7.0/ext/session/mod_files.c    2015-05-23 11:18:54.466402493 +0300
-@@ -286,7 +286,6 @@
+--- php-8.2.0RC2/ext/session/mod_files.c~      2022-09-14 12:42:49.000000000 +0300
++++ php-8.2.0RC2/ext/session/mod_files.c       2022-09-29 01:26:03.341783642 +0300
+@@ -287,7 +287,6 @@
  
-       dir = opendir(dirname);
+       dir = opendir(ZSTR_VAL(dirname));
        if (!dir) {
--              php_error_docref(NULL, E_NOTICE, "ps_files_cleanup_dir: opendir(%s) failed: %s (%d)", dirname, strerror(errno), errno);
+-              php_error_docref(NULL, E_NOTICE, "ps_files_cleanup_dir: opendir(%s) failed: %s (%d)", ZSTR_VAL(dirname), strerror(errno), errno);
                return (0);
        }
  
index 9f09b2db1deb90bb67cc6c6be5487f186e0d63b9..c09db176599f4624c1af4a597a6c5a69aae25aba 100644 (file)
@@ -2,41 +2,34 @@ make compressed .swf parsing possible,
 link core php with -lz for getimagesize()
 see also http://bugs.php.net/bug.php?id=29611
 
---- php-8.0.0rc1/ext/standard/image.c~ 2020-10-09 18:50:01.000000000 +0300
-+++ php-8.0.0rc1/ext/standard/image.c  2020-10-09 18:53:44.278879164 +0300
-@@ -31,7 +31,7 @@
+upstream: https://github.com/php/php-src/pull/4681
+
+--- php-8.2.0RC2/ext/standard/image.c~ 2022-09-14 12:42:49.000000000 +0300
++++ php-8.2.0RC2/ext/standard/image.c  2022-09-29 01:20:02.719689289 +0300
+@@ -28,7 +28,7 @@
  #endif
  #include "php_image.h"
  
--#if HAVE_ZLIB && !defined(COMPILE_DL_ZLIB)
-+#if HAVE_ZLIB
+-#if defined(HAVE_ZLIB) && !defined(COMPILE_DL_ZLIB)
++#if defined(HAVE_ZLIB)
  #include "zlib.h"
  #endif
  
-@@ -80,7 +80,7 @@
-       REGISTER_LONG_CONSTANT("IMAGETYPE_JP2",     IMAGE_FILETYPE_JP2,     CONST_CS | CONST_PERSISTENT);
-       REGISTER_LONG_CONSTANT("IMAGETYPE_JPX",     IMAGE_FILETYPE_JPX,     CONST_CS | CONST_PERSISTENT);
-       REGISTER_LONG_CONSTANT("IMAGETYPE_JB2",     IMAGE_FILETYPE_JB2,     CONST_CS | CONST_PERSISTENT);
--#if HAVE_ZLIB && !defined(COMPILE_DL_ZLIB)
-+#if HAVE_ZLIB
-       REGISTER_LONG_CONSTANT("IMAGETYPE_SWC",     IMAGE_FILETYPE_SWC,     CONST_CS | CONST_PERSISTENT);
- #endif
-       REGISTER_LONG_CONSTANT("IMAGETYPE_IFF",     IMAGE_FILETYPE_IFF,     CONST_CS | CONST_PERSISTENT);
-@@ -186,7 +186,7 @@
+@@ -156,7 +156,7 @@
  }
  /* }}} */
  
--#if HAVE_ZLIB && !defined(COMPILE_DL_ZLIB)
-+#if HAVE_ZLIB
+-#if defined(HAVE_ZLIB) && !defined(COMPILE_DL_ZLIB)
++#if defined(HAVE_ZLIB)
  /* {{{ php_handle_swc */
  static struct gfxinfo *php_handle_swc(php_stream * stream)
  {
-@@ -1321,7 +1321,7 @@
+@@ -1454,7 +1454,7 @@
                        result = php_handle_swf(stream);
                        break;
                case IMAGE_FILETYPE_SWC:
--#if HAVE_ZLIB && !defined(COMPILE_DL_ZLIB)
-+#if HAVE_ZLIB
+-#if defined(HAVE_ZLIB) && !defined(COMPILE_DL_ZLIB)
++#if defined(HAVE_ZLIB)
                        result = php_handle_swc(stream);
  #else
                        php_error_docref(NULL, E_NOTICE, "The image is a compressed SWF file, but you do not have a static version of the zlib extension enabled");
index d10d4fefa0cd9a809f4ca07ec63a44c8bd3a2a44..9de4f7b73f03baef27001307e113029cc2a99566 100644 (file)
--- a/php.spec
+++ b/php.spec
 %endif
 
 %define                orgname php
-%define                ver_suffix 81
+%define                ver_suffix 82
 %define                php_suffix %{!?with_default_php:%{ver_suffix}}
+%define                subver  RC2
+%define                rel             1
 Summary:       PHP: Hypertext Preprocessor
 Summary(fr.UTF-8):     Le langage de script embarque-HTML PHP
 Summary(pl.UTF-8):     Język skryptowy PHP
@@ -148,16 +150,17 @@ Summary(pt_BR.UTF-8):     A linguagem de script PHP
 Summary(ru.UTF-8):     PHP - язык препроцессирования HTML-файлов, выполняемый на сервере
 Summary(uk.UTF-8):     PHP - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          %{orgname}%{php_suffix}
-Version:       8.1.10
-Release:       1
+Version:       8.2.0
+Release:       0.%{subver}.%{rel}
 Epoch:         4
 # All files licensed under PHP version 3.01, except
 # Zend is licensed under Zend
 # TSRM is licensed under BSD
 License:       PHP 3.01 and Zend and BSD
 Group:         Libraries
-Source0:       https://www.php.net/distributions/%{orgname}-%{version}.tar.xz
-# Source0-md5: 5f14b7827d825f4c698402b111735edb
+#Source0:      https://www.php.net/distributions/%{orgname}-%{version}.tar.xz
+Source0:       https://downloads.php.net/~sergey/php-%{version}%{subver}.tar.xz
+# Source0-md5: c171f249a43872d30006bbffd8469648
 Source1:       opcache.ini
 Source2:       %{orgname}-mod_php.conf
 Source3:       %{orgname}-cgi-fcgi.ini
@@ -283,7 +286,7 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                _sysconfdir                     %{php_sysconfdir}
 
 # must be in sync with source. extra check ensuring that it is so is done in %%build
-%define                php_api_version         20210902
+%define                php_api_version         20220829
 %define                zend_module_api         %{php_api_version}
 %define                zend_extension_api      4%{zend_module_api}
 %define                php_pdo_api_version     20170320
@@ -297,7 +300,7 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                jsonver         %{version}
 %define                pharver         %{version}
 %define                sqlite3ver      %{version}
-%define                zipver          1.19.5
+%define                zipver          1.21.0
 %define                phpdbgver       %{version}
 %define                sodiumver       %{version}
 
@@ -475,6 +478,7 @@ Obsoletes:  php72-program < 4:7.3
 Obsoletes:     php73-program < 4:7.4
 Obsoletes:     php74-program < 4:8
 Obsoletes:     php80-program < 4:8.1
+Obsoletes:     php81-program < 4:8.2
 
 %description program
 Package providing /usr/bin/php symlink to PHP CLI.
@@ -635,6 +639,7 @@ Obsoletes:  php72-devel < 4:7.3
 Obsoletes:     php73-devel < 4:7.4
 Obsoletes:     php74-devel < 4:8
 Obsoletes:     php80-devel < 4:8.1
+Obsoletes:     php81-devel < 4:8.2
 
 %description devel
 The php-devel package lets you compile dynamic extensions to PHP.
@@ -1868,7 +1873,7 @@ cp -p php.ini-production php.ini
 #%patch2 -p1 -b .mail
 %patch3 -p1
 %patch4 -p1
-%patch5 -p1
+#%patch5 -p1 resolved upstream?
 
 %patch7 -p1 -b .sapi-ini-file
 %patch10 -p1 -b .ini
This page took 0.161253 seconds and 4 git commands to generate.