cleanups
authorElan Ruusamäe <glen@delfi.ee>
Tue, 21 Apr 2015 08:39:31 +0000 (11:39 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Tue, 21 Apr 2015 08:39:31 +0000 (11:39 +0300)
checked patches against php-5.3.3-40.el6_6.src.rpm. these 4 new since
php-5.3.3-38.el6.src.rpm are already applied in pld:
- fileinfo: fix out-of-bounds read in elf note headers. CVE-2014-3710
- xmlrpc: fix out-of-bounds read flaw in mkgmtime() CVE-2014-3668
- core: fix integer overflow in unserialize() CVE-2014-3669
- exif: fix heap corruption issue in exif_thumbnail() CVE-2014-3670

php.spec

index 2f500dfbf28fe57d3c8aa0ba4018580033a07f85..f8366c6426b2c09f162f4f8312f13a62c1b45459 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -249,7 +249,6 @@ BuildRequires:      cyrus-sasl-devel
 BuildRequires: db-devel >= 4.0
 BuildRequires: elfutils-devel
 %{?with_enchant:BuildRequires: enchant-devel >= 1.1.3}
-#BuildRequires:        fcgi-devel
 BuildRequires: file
 %{?with_kerberos5:BuildRequires:       heimdal-devel}
 %{?with_system_libzip:BuildRequires:   libzip-devel >= 0.10-3}
@@ -272,13 +271,11 @@ BuildRequires:    libjpeg-devel
 BuildRequires: libltdl-devel >= 1.4
 BuildRequires: libmcrypt-devel >= 2.4.4
 BuildRequires: libpng-devel >= 1.0.8
-#BuildRequires:        libtiff-devel
 %if "%{pld_release}" != "ac"
 BuildRequires: libtool >= 2:2.2
 %else
 BuildRequires: libtool >= 1.4.3
 %endif
-#BuildRequires:        libwrap-devel
 BuildRequires: libxml2-devel >= 1:2.7.6-4
 BuildRequires: libxslt-devel >= 1.1.0
 %{?with_mm:BuildRequires:      mm-devel >= 1.3.0}
@@ -317,9 +314,6 @@ BuildRequires:      apache-devel >= 2.0.52-2
 BuildRequires: apr-devel >= 1:1.0.0
 BuildRequires: apr-util-devel >= 1:1.0.0
 %endif
-%if %{with fpm}
-#BuildRequires:        judy-devel
-%endif
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                php_sysconfdir          /etc/%{name}
This page took 9.798384 seconds and 4 git commands to generate.