]> git.pld-linux.org Git - packages/php.git/commitdiff
add debug bcond to enable zend debug build, do not enable with rpm debug builds
authorElan Ruusamäe <glen@delfi.ee>
Wed, 21 Mar 2018 21:52:57 +0000 (23:52 +0200)
committerElan Ruusamäe <glen@pld-linux.org>
Wed, 21 Mar 2018 21:58:53 +0000 (23:58 +0200)
php.spec

index 7fef23e3468ebdbdf012e1593c103a8f30ceb33b..8e421b57838ff17d32abf640979c7ff5c39acf67 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -36,6 +36,7 @@
 %bcond_with    systemtap       # systemtap/DTrace support
 %bcond_with    tests           # default off; test process very often hangs on builders, approx run time 45m; perform "make test"
 %bcond_with    zts             # Zend Thread Safety
+%bcond_with    debug           # Zend Debug Build
 # - SAPI
 %bcond_without apache2         # disable building Apache 2.x SAPI
 %bcond_without cgi             # disable CGI/FCGI SAPI
@@ -323,7 +324,7 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                sodiumver       %{version}
 
 %define                _zend_zts               %{!?with_zts:0}%{?with_zts:1}
-%define                php_debug               %{!?debug:0}%{?debug:1}
+%define                php_debug               %{!?with_debug:0}%{?with_debug:1}
 
 %if %{with gcov}
 %undefine      with_ccache
@@ -2304,7 +2305,7 @@ for sapi in $sapis; do
        --with-config-file-scan-dir=%{_sysconfdir}/conf.d \
        --with-system-tzdata \
        %{?with_argon2:--with-password-argon2} \
-       --%{!?debug:dis}%{?debug:en}able-debug \
+       --%{!?with_debug:dis}%{?with_debug:en}able-debug \
        %{?with_zts:--enable-maintainer-zts} \
        --enable-inline-optimization \
        %{__enable_disable bcmath bcmath shared} \
This page took 0.70322 seconds and 4 git commands to generate.