]> git.pld-linux.org Git - packages/php.git/commitdiff
- up to 7.2.7; mail.patch is back auto/th/php72-7.2.7-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Mon, 9 Jul 2018 08:29:34 +0000 (10:29 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Mon, 9 Jul 2018 08:29:34 +0000 (10:29 +0200)
php-ini.patch
php-mail.patch
php.spec

index 9b6915c15d17680dbca74a3e88f39d49247ae129..6135fb40c0d80dbfa4353a933d14c0cfd6cb4f6b 100644 (file)
  
  ; (time to live) Sets the number of second while cached file will be used
  ; instead of original one.
-@@ -1681,130 +1681,6 @@ ldap.max_links = -1
+@@ -1681,134 +1681,6 @@ ldap.max_links = -1
  [dba]
  ;dba.default_handler=
  
 -
 -; Prevent name collisions in chroot'ed environment.
 -;opcache.validate_root=0
+-
+-; If specified, it produces opcode dumps for debugging different stages of
+-; optimizations.
+-;opcache.opt_debug_level=0
 -
  [curl]
  ; A default value for the CURLOPT_CAINFO option. This is required to be an
  ; absolute path.
+
index e541727105ef89fb0a03b1483f49aba355b89770..5a80cc22e0be577c9703fb4350860e0b0ded2193 100644 (file)
@@ -1,16 +1,17 @@
---- php-5.2.0/ext/standard/mail.c      2006-12-01 14:20:27.881416250 +0100
-+++ php-5.2.4/ext/standard/mail.c      2007-08-31 19:25:50.777713042 +0300
-@@ -35,6 +37,8 @@
+diff -ur php-7.1.18.org/ext/standard/mail.c php-7.1.18.new/ext/standard/mail.c
+--- php-7.1.18.org/ext/standard/mail.c 2018-05-23 20:14:41.000000000 +0200
++++ php-7.1.18.new/ext/standard/mail.c 2018-07-09 10:06:56.968650606 +0200
+@@ -46,6 +46,8 @@
  #include "php_ini.h"
- #include "safe_mode.h"
+ #include "php_string.h"
  #include "exec.h"
 +#include "zend_operators.h"
 +#include "zend_globals.h"
  
  #ifdef PHP_WIN32
  #include "win32/sendmail.h"
-@@ -107,6 +111,18 @@
-               return;
+@@ -125,6 +127,18 @@
+               MAIL_ASCIIZ_CHECK(ZSTR_VAL(extra_cmd), ZSTR_LEN(extra_cmd));
        }
  
 +    /* search for To: and Subject: headers which should be specified in proper mail() parameters, not in additional headers */
@@ -28,8 +29,8 @@
        if (to_len > 0) {
                to_r = estrndup(to, to_len);
                for (; to_len; to_len--) {
-@@ -231,8 +247,42 @@
-                       return 0;
+@@ -397,8 +411,41 @@
+                       MAIL_RET(0);
                }
  #endif
 -              fprintf(sendmail, "To: %s\n", to);
 +              if ((subject != NULL) && (strlen(subject)!=0)) {
 +                      fprintf(sendmail, "Subject: %s\n", subject);
 +              }
-+              zend_is_auto_global(ZEND_STRL("_SERVER") TSRMLS_CC);
-+              if (PG(http_globals)[TRACK_VARS_SERVER]) {
-+                      zval **remote_addr, **server_name, **server_port,
-+                              **script_name, **http_user_agent;
++              if (Z_TYPE(PG(http_globals)[TRACK_VARS_SERVER]) == IS_ARRAY
++                              || zend_is_auto_global_str(ZEND_STRL("_SERVER"))) {
++                                      zval *remote_addr, *server_name, *server_port, *script_name, *http_user_agent;
++                                      remote_addr = zend_hash_str_find(Z_ARRVAL_P(&PG(http_globals)[TRACK_VARS_SERVER]),
++                                                      "REMOTE_ADDR", sizeof("REMOTE_ADDR")-1);
++                                      server_name = zend_hash_str_find(Z_ARRVAL_P(&PG(http_globals)[TRACK_VARS_SERVER]),
++                                                      "SERVER_NAME", sizeof("SERVER_NAME")-1);
++                                      server_port = zend_hash_str_find(Z_ARRVAL_P(&PG(http_globals)[TRACK_VARS_SERVER]),
++                                                      "SERVER_PORT", sizeof("SERVER_PORT")-1);
++                                      script_name = zend_hash_str_find(Z_ARRVAL_P(&PG(http_globals)[TRACK_VARS_SERVER]),
++                                                      "SCRIPT_NAME", sizeof("SCRIPT_NAME")-1);
++                                      http_user_agent = zend_hash_str_find(Z_ARRVAL_P(&PG(http_globals)[TRACK_VARS_SERVER]),
++                                                      "HTTP_USER_AGENT", sizeof("HTTP_USER_AGENT")-1);
 +
-+                      if (zend_hash_find(PG(http_globals)[TRACK_VARS_SERVER]->value.ht, "REMOTE_ADDR", sizeof("REMOTE_ADDR"), (void **) &remote_addr)==SUCCESS) {
-+                              convert_to_string_ex(remote_addr);
-+                              fprintf(sendmail, "HTTP-Posting-Client: %s\n", Z_STRVAL_PP(remote_addr));
-+                      }
-+                      if (zend_hash_find(PG(http_globals)[TRACK_VARS_SERVER]->value.ht, "SERVER_NAME", sizeof("SERVER_NAME"), (void **) &server_name)==SUCCESS) {
-+                              convert_to_string_ex(server_name);
-+                              fprintf(sendmail, "HTTP-Posting-URI: %s", Z_STRVAL_PP(server_name));
-+                              if (zend_hash_find(PG(http_globals)[TRACK_VARS_SERVER]->value.ht, "SERVER_PORT", sizeof("SERVER_PORT"), (void **) &server_port)==SUCCESS) {
-+                                      convert_to_string_ex(server_port);
-+                                      fprintf(sendmail, ":%s", Z_STRVAL_PP(server_port));
-+                              }
-+                              if (zend_hash_find(PG(http_globals)[TRACK_VARS_SERVER]->value.ht, "SCRIPT_NAME", sizeof("SCRIPT_NAME"), (void **) &script_name)==SUCCESS) {
-+                                      convert_to_string_ex(script_name);
-+                                      fprintf(sendmail, "%s", Z_STRVAL_PP(script_name));
-+                              }
-+                              fprintf(sendmail, "\n");
-+                      }
-+                      if (zend_hash_find(PG(http_globals)[TRACK_VARS_SERVER]->value.ht, "HTTP_USER_AGENT", sizeof("HTTP_USER_AGENT"), (void **) &http_user_agent)==SUCCESS) {
-+                              convert_to_string_ex(http_user_agent);
-+                                      fprintf(sendmail, "HTTP-Posting-User-Agent: %s\n", Z_STRVAL_PP(http_user_agent));
-+                      }
++                                      if (remote_addr && Z_TYPE_P(remote_addr) == IS_STRING)
++                                              fprintf(sendmail, "HTTP-Posting-Client: %s\n", Z_STRVAL_P(remote_addr));
++                                      if (server_name && Z_TYPE_P(server_name) == IS_STRING)
++                                              fprintf(sendmail, "HTTP-Posting-URI: %s", Z_STRVAL_P(server_name));
++                                      if (server_port && Z_TYPE_P(server_port) == IS_STRING)
++                                              fprintf(sendmail, ":%s", Z_STRVAL_P(server_port));
++                                      if (script_name && Z_TYPE_P(script_name) == IS_STRING)
++                                              fprintf(sendmail, "%s", Z_STRVAL_P(script_name));
++                                      fprintf(sendmail, "\n");
++                                      if (http_user_agent && Z_TYPE_P(http_user_agent) == IS_STRING)
++                                              fprintf(sendmail, "HTTP-Posting-User-Agent: %s\n", Z_STRVAL_P(http_user_agent));
 +              }
 +
                if (hdr != NULL) {
index 6414f91e80cd27ad0c52d73ee0926398ec48993f..1c15e5608043649c3295cb9b333762578de1f5a4 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -154,8 +154,8 @@ Summary(pt_BR.UTF-8):       A linguagem de script PHP
 Summary(ru.UTF-8):     PHP Версии 7 - язык препроцессирования HTML-файлов, выполняемый на сервере
 Summary(uk.UTF-8):     PHP Версії 7 - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          %{orgname}%{php_suffix}
-Version:       7.2.6
-Release:       2
+Version:       7.2.7
+Release:       1
 Epoch:         4
 # All files licensed under PHP version 3.01, except
 # Zend is licensed under Zend
@@ -163,7 +163,7 @@ Epoch:              4
 License:       PHP 3.01 and Zend and BSD
 Group:         Libraries
 Source0:       https://php.net/distributions/%{orgname}-%{version}.tar.xz
-# Source0-md5: bdfc00d0ae0155775a3a2b0fc60f8ea7
+# Source0-md5: 3714de04f777c1925abb0f7d6646e99d
 Source1:       opcache.ini
 Source2:       %{orgname}-mod_php.conf
 Source3:       %{orgname}-cgi-fcgi.ini
@@ -1976,7 +1976,7 @@ Moduł PHP umożliwiający używanie kompresji zlib.
 cp -p php.ini-production php.ini
 %patch0 -p1
 %patch1 -p1
-#%patch2 -p1 NEEDS PORTING
+%patch2 -p1
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
This page took 0.28604 seconds and 4 git commands to generate.