]> git.pld-linux.org Git - packages/php.git/commitdiff
- rediffed
authorAdam Gołębiowski <adamg@pld-linux.org>
Thu, 8 Jul 2021 08:43:16 +0000 (08:43 +0000)
committerAdam Gołębiowski <adamg@pld-linux.org>
Thu, 8 Jul 2021 08:43:16 +0000 (08:43 +0000)
20 files changed:
pcre-shared.patch
php-both-apxs.patch
php-bug-71475.patch
php-builddir.patch
php-config-dir.patch
php-fcgi-error_log-no-newlines.patch
php-fcgi-graceful.patch
php-fpm-config.patch
php-ini.patch
php-libtool.patch
php-mail.patch
php-mysql-charsetphpini.patch
php-mysqli-charsetphpini.patch
php-pdo_mysql-charsetphpini.patch
php-pear.patch
php-pldlogo.patch
php-shared.patch
php-tds.patch
php-zlib-for-getimagesize.patch
spl-shared.patch

index 6bb1a70c158bcdd393c0ac94a6ec6fad1afdd149..d024c4b89eb53d375b87c9658dfb800936ed7b19 100644 (file)
@@ -86,8 +86,8 @@
 --- php-5.3.1/ext/standard/browscap.c  2009-06-06 02:40:49.000000000 +0000
 +++ php-5.3.1.pcre/ext/standard/browscap.c     2009-11-30 21:33:00.775241138 +0000
 @@ -31,6 +31,11 @@
- static zval *current_section;
- static char *current_section_name;
+ #define BROWSCAP_G(v) (browscap_globals.v)
+ #endif
  
 +#if COMPILE_DL_PCRE
 +// will be visible in here
index 8e7bd89e6dda54b81c52f1bf963994f3d10d7a31..a3666d1283143aeb205220c291c9342a06b34686 100644 (file)
@@ -1,7 +1,7 @@
 --- php-5.2.4/Makefile.global~ 2007-08-31 19:35:54.000000000 +0300
 +++ php-5.2.4/Makefile.global  2007-08-31 19:40:18.287528480 +0300
 @@ -21,6 +21,12 @@
-       $(LIBTOOL) --mode=link $(CC) -rpath $(phptempdir) $(EXTRA_LDFLAGS) $(LDFLAGS) $(PHP_RPATHS) $(phptempdir)/libphp_common.la $(PHP_SAPI_OBJS) $(EXTRA_LIBS) $(ZEND_EXTRA_LIBS) -o $@
+       $(LIBTOOL) --mode=link $(CC) $(CFLAGS) $(EXTRA_CFLAGS) -rpath $(phptempdir) $(EXTRA_LDFLAGS) $(LDFLAGS) $(PHP_RPATHS) $(phptempdir)/libphp_common.la $(PHP_SAPI_OBJS) $(EXTRA_LIBS) $(ZEND_EXTRA_LIBS) -o $@
        -@$(LIBTOOL) --silent --mode=install cp $@ $(phptempdir)/$@ >/dev/null 2>&1
  
 +$(LIBTOOL_SAPI): libphp_common.la $(PHP_SAPI_OBJS)
index 0a9ed6fca560039e1cdd1beddf40833b8debab6a..d4284f243739a1895409fc64ac9ca04ec6046454 100644 (file)
@@ -16,7 +16,7 @@
 +              if (key_resources[i] == -1 && pkeys[i] != NULL) {
                        EVP_PKEY_free(pkeys[i]);
                }
-               if (eks[i]) { 
+               if (eks[i]) {
 diff --git a/ext/openssl/tests/bug71475.phpt b/ext/openssl/tests/bug71475.phpt
 new file mode 100644
 index 0000000..680753d
index 783dc2bea786979309783fed99a9c217b65d589d..3da610158ea7cee82e3415c81749f5df277d47c0 100644 (file)
@@ -14,11 +14,11 @@ diff -urbB php-5.0.5.org/scripts/phpize.in php-5.0.5/scripts/phpize.in
 --- php-5.0.5.org/scripts/phpize.in    2005-06-15 19:19:41.000000000 +0200
 +++ php-5.0.5/scripts/phpize.in        2005-09-10 21:51:45.523274024 +0200
 @@ -3,7 +3,7 @@
- # Variable declaration
  prefix='@prefix@'
+ datarootdir='@datarootdir@'
  exec_prefix="`eval echo @exec_prefix@`"
 -phpdir="`eval echo @libdir@`/build"
 +phpdir="`eval echo @libdir@`/php/build"
  includedir="`eval echo @includedir@`/php"
  builddir="`pwd`"
+ SED="@SED@"
index b6abad556b3ecf5b1609d9c013ffc65292339ff3..93ca75541002b9e0cd944b891199f69118895043 100644 (file)
@@ -1,13 +1,13 @@
 --- php-5.2.0/scripts/php-config.in    2006-12-14 01:11:33.348180526 +0200
 +++ php-5.2.4/scripts/php-config.in    2007-08-31 19:43:04.061307670 +0300
 @@ -2,6 +2,7 @@
  prefix="@prefix@"
+ datarootdir="@datarootdir@"
  exec_prefix="@exec_prefix@"
 +sysconfdir='@sysconfdir@'
  version="@PHP_VERSION@"
- version_id="@PHP_VERSION_ID@"
- includedir="@includedir@/php"
+ vernum="@PHP_VERSION_ID@"
+ include_dir="@includedir@/php"
 @@ -53,6 +54,8 @@
    echo $extension_dir;;
  --include-dir)
@@ -23,5 +23,5 @@
    --extension-dir     [$extension_dir]
 +  --sysconfdir        [$sysconfdir]
    --include-dir       [$include_dir]
+   --man-dir           [$man_dir]
    --php-binary        [$php_binary]
-   --php-sapis         [$php_sapis]
index e35648e84bfea474782e67f04731ac581a0439df..d9de46b0a0adb9db628c7db69e4cebf575da0a4d 100644 (file)
@@ -2,7 +2,7 @@
 +++ ./sapi/cgi/cgi_main.c      2007-09-05 20:54:19.390089070 +0300
 @@ -558,12 +558,7 @@
                request = (fcgi_request*) SG(server_context);
-               if (request) {                  
+               if (request) {
                        int len = strlen(message);
 -                      char *buf = malloc(len+2);
 -
index 26f86f34a2b3e3ca8cb7c9ecfe5bc567ce1969df..e6cb6679f9492a545a9aaaf5ebe440e29c2144a7 100644 (file)
@@ -27,12 +27,12 @@ echo "end!<br>\n";
 +/* Socket we are listening on incoming connections */
 +static int fcgi_fd = 0;
 +
- /**
-  * Process group
-  */
+ /* Did parent received exit signals SIG_TERM/SIG_INT/SIG_QUIT */
+ static int exit_signal = 0;
 @@ -1221,6 +1224,21 @@
-       exit(0);
  }
+ #endif
  
 +/**
 + * Graceful shutdown. Close listening sockets.
index 353c0120b281c020a29c627695532285e2c33369..44d08e74e5f8de35c70e44f99d23c327621e40fb 100644 (file)
@@ -2,7 +2,7 @@
 +++ php-5.3.17/sapi/fpm/php-fpm.conf.in        2012-10-12 12:35:47.601602945 +0300
 @@ -12,7 +12,7 @@
  ; Relative path can also be used. They will be prefixed by:
- ;  - the global prefix if it's been set (-p arguement)
+ ;  - the global prefix if it's been set (-p argument)
  ;  - @prefix@ otherwise
 -;include=etc/fpm.d/*.conf
 +;include=/etc/php/fpm.d/*.conf
@@ -33,7 +33,7 @@
 -listen = 127.0.0.1:9000
 +listen = /var/run/php/@processname@.sock
  
- ; Set listen(2) backlog. A value of '-1' means unlimited.
+ ; Set listen(2) backlog.
  ; Default Value: 128 (-1 on FreeBSD and OpenBSD)
 @@ -105,7 +105,7 @@
  ; must be separated by a comma. If this value is left blank, connections will be
@@ -42,8 +42,8 @@
 -;listen.allowed_clients = 127.0.0.1
 +listen.allowed_clients = 127.0.0.1
  
- ; Set permissions for unix socket, if one is used. In Linux, read/write
- ; permissions must be set in order to allow connections from a web server. Many
+ ; Specify the nice(2) priority to apply to the pool processes (only if set)
+ ; The value can vary from -19 (highest priority) to 20 (lower priority)
 @@ -277,7 +277,7 @@
  ; the current environment.
  ; Default Value: clean env
index 90a83d93478c90cdf53e8f60789a2ebeace2c915..35e3b1ef229fbe0f57a072e006aa51c094ef8629 100644 (file)
@@ -1,9 +1,9 @@
 --- php-5.4.20/php.ini~        2013-09-27 00:10:56.000000000 +0300
 +++ php-5.4.20/php.ini 2013-09-27 00:12:08.255696371 +0300
 @@ -82,6 +82,20 @@
- ; much more verbose when it comes to errors. We recommending using the
- ; development version only in development environments as errors shown to
  ; application users can inadvertently leak otherwise secure information.
+ ; This is php.ini-production INI file.
 +;
 +; This is the default settings file for new PHP installations from
 +; PLD Linux Distribution.
index f9713d808e36cefd94bf442e9e1ebef78278d5e5..47083d703ceeb40ba5c13b57d362865a8323bba8 100644 (file)
@@ -16,7 +16,7 @@
 +    LIBTOOL_FILES="libtool.m4"
 +fi
  FILES="acinclude.m4 Makefile.global config.sub config.guess ltmain.sh run-tests*.php"
- CLEAN_FILES="$FILES *.o *.lo *.la .deps .libs/ build/ include/ modules/ install-sh \
+ CLEAN_FILES="$FILES *.o *.lo *.la .deps .libs/ build/ modules/ install-sh \
        mkinstalldirs missing config.nice config.sub config.guess configure configure.in \
 @@ -145,8 +151,9 @@ phpize_copy_files()
    test -d build || mkdir build
index 257a9c48487428679ea1ee8ce8659739a68dd3c9..ccf9feb72ddc3010fac3d1cee402594c543bb713 100644 (file)
@@ -8,10 +8,10 @@
 +#include <string.h>
  #include "php.h"
  #include "ext/standard/info.h"
+ #include "ext/standard/php_string.h"
 @@ -35,6 +37,8 @@
  #include "php_ini.h"
- #include "safe_mode.h"
+ #include "php_string.h"
  #include "exec.h"
 +#include "zend_operators.h"
 +#include "zend_globals.h"
@@ -19,7 +19,7 @@
  #ifdef PHP_WIN32
  #include "win32/sendmail.h"
 @@ -107,6 +111,18 @@
-               return;
+               MAIL_ASCIIZ_CHECK(extra_cmd, extra_cmd_len);
        }
  
 +    /* search for To: and Subject: headers which should be specified in proper mail() parameters, not in additional headers */
@@ -38,7 +38,7 @@
                to_r = estrndup(to, to_len);
                for (; to_len; to_len--) {
 @@ -231,8 +247,42 @@
-                       return 0;
+                       MAIL_RET(0);
                }
  #endif
 -              fprintf(sendmail, "To: %s\n", to);
index 1ddb7f9de4fc96716358007ec8720242e0fa8637..d4aa5ad66d7eb5d5823b9843f895d23707682691 100644 (file)
@@ -1,21 +1,21 @@
 --- php-5.4.16/ext/mysql/php_mysql.c~  2013-06-10 14:41:59.000000000 +0300
 +++ php-5.4.16/ext/mysql/php_mysql.c   2013-06-10 14:42:50.048809174 +0300
 @@ -360,6 +360,7 @@
-       PHP_INI_ENTRY("mysql.default_port",                             NULL,   PHP_INI_ALL,            OnMySQLPort)
        STD_PHP_INI_ENTRY("mysql.default_socket",               NULL,   PHP_INI_ALL,            OnUpdateStringUnempty,  default_socket, zend_mysql_globals,             mysql_globals)
+ #endif
        STD_PHP_INI_ENTRY("mysql.connect_timeout",              "60",   PHP_INI_ALL,            OnUpdateLong,           connect_timeout,        zend_mysql_globals,             mysql_globals)
 +      STD_PHP_INI_ENTRY("mysql.connect_charset",              NULL,   PHP_INI_ALL,            OnUpdateString,         connect_charset,        zend_mysql_globals,             mysql_globals)
        STD_PHP_INI_BOOLEAN("mysql.trace_mode",                 "0",    PHP_INI_ALL,            OnUpdateLong,           trace_mode,             zend_mysql_globals,             mysql_globals)
+       STD_PHP_INI_BOOLEAN("mysql.allow_local_infile", "1",    PHP_INI_SYSTEM,         OnUpdateLong,           allow_local_infile, zend_mysql_globals,         mysql_globals)
  PHP_INI_END()
- /* }}} */
 @@ -376,6 +377,7 @@
        mysql_globals->connect_errno = 0;
        mysql_globals->connect_error = NULL;
        mysql_globals->connect_timeout = 0;
 +      mysql_globals->connect_charset = NULL;
        mysql_globals->trace_mode = 0;
+       mysql_globals->allow_local_infile = 1;
        mysql_globals->result_allocated = 0;
- }
 @@ -723,6 +723,7 @@
  {
        char *user=NULL, *passwd=NULL, *host_and_port=NULL, *socket=NULL, *tmp=NULL, *host=NULL;
@@ -25,7 +25,7 @@
        int hashed_details_length, port = MYSQL_PORT;
        long client_flags = 0;
 @@ -527,6 +530,7 @@
+ #endif
  
        connect_timeout = MySG(connect_timeout);
 +      connect_charset = MySG(connect_charset);
@@ -46,7 +46,7 @@
                        if (mysql_real_connect(mysql->conn, host, user, passwd, NULL, port, socket, client_flags)==NULL)
  #else
 @@ -826,6 +830,8 @@
- #endif        
+ #endif
                        if (mysql_ping(mysql->conn)) {
                                if (mysql_errno(mysql->conn) == 2006) {
 +                                      if (connect_charset != NULL)
                                        if (mysql_real_connect(mysql->conn, host, user, passwd, NULL, port, socket, client_flags)==NULL)
  #else
 @@ -898,6 +904,9 @@
-               if (connect_timeout != -1)
-                               mysql_options(mysql->conn, MYSQL_OPT_CONNECT_TIMEOUT, (const char *)&connect_timeout);
+                       mysql_options(mysql->conn, MYSQL_OPT_CONNECT_TIMEOUT, (const char *)&connect_timeout);
+               }
  
 +              if (connect_charset != NULL)
 +                      mysql_options(mysql->conn, MYSQL_SET_CHARSET_NAME, connect_charset);
 +
  #ifndef MYSQL_USE_MYSQLND
-               if (mysql_real_connect(mysql->conn, host, user, passwd, NULL, port, socket, client_flags)==NULL) 
+               if (mysql_real_connect(mysql->conn, host, user, passwd, NULL, port, socket, client_flags)==NULL)
  #else
 --- php-5.2.5_p20080206.orig/ext/mysql/php_mysql_structs.h     2008-02-06 14:22:57.510605687 +0100
 +++ php-5.2.5_p20080206/ext/mysql/php_mysql_structs.h  2008-02-06 14:23:27.764590355 +0100
index 895a1a7097b39dc2e6b5a1a40360994e17c079b1..216fc8ac4777289c444dc0b73c3ccacf1f7d190b 100644 (file)
@@ -7,7 +7,7 @@
 +      STD_PHP_INI_ENTRY("mysqli.connect_charset",                     NULL,   PHP_INI_ALL,            OnUpdateString,         connect_charset,        zend_mysqli_globals,            mysqli_globals)
        STD_PHP_INI_BOOLEAN("mysqli.reconnect",                         "0",    PHP_INI_SYSTEM,         OnUpdateLong,           reconnect,                      zend_mysqli_globals,            mysqli_globals)
        STD_PHP_INI_BOOLEAN("mysqli.allow_local_infile",        "1",    PHP_INI_SYSTEM,         OnUpdateLong,           allow_local_infile,     zend_mysqli_globals,            mysqli_globals)
- #ifdef MYSQLI_USE_MYSQLND
+ PHP_INI_END()
 @@ -475,6 +476,7 @@
        mysqli_globals->default_user = NULL;
        mysqli_globals->default_pw = NULL;
@@ -38,8 +38,8 @@
 +      }
 +
  #if !defined(MYSQLI_USE_MYSQLND)
-       if (mysql_real_connect(mysql->mysql, hostname, username, passwd, dbname, port, socket, CLIENT_MULTI_RESULTS) == NULL)
- #else
+       /* BC for prior to bug fix #53425 */
+       flags |= CLIENT_MULTI_RESULTS;
 --- php-5.3.1/ext/mysqli/php_mysqli_structs.h~ 2009-10-14 16:51:25.000000000 +0300
 +++ php-5.3.1/ext/mysqli/php_mysqli_structs.h  2010-02-20 01:04:56.512214846 +0200
 @@ -358,6 +358,7 @@
index 36a7c95da77f370d65bcc0f61cc2cde8887ad696..32e859aa86da5fcc07ef145f467ff05a74cf8b87 100644 (file)
@@ -24,7 +24,7 @@ small.
 +      }
 +
        if (mysqlnd_connect(H->server, host, dbh->username, dbh->password, password_len, dbname, dbname_len,
-                                               port, unix_socket, connect_opts, PDO_MYSQL_G(mysqlnd_thd_zval_cache) TSRMLS_CC) == NULL) {
+                                               port, unix_socket, connect_opts TSRMLS_CC) == NULL) {
  #else
 --- php-5.3.3/ext/pdo_mysql/pdo_mysql.c~       2010-07-24 19:23:14.000000000 +0300
 +++ php-5.3.3/ext/pdo_mysql/pdo_mysql.c        2010-07-24 19:24:48.363581841 +0300
index 400359d4e47458f60ab22f71a7c7315f1ddc303c..9af0edabb70c16a9227bdacaae68e4dd3c9a553c 100644 (file)
@@ -10,7 +10,7 @@
 -fi
 -
  PHP_ARG_WITH(pear, [whether to install PEAR],
- [  --with-pear=DIR         Install PEAR in DIR [PREFIX/lib/php]
+ [  --with-pear=DIR         Install PEAR in DIR @<:@PREFIX/lib/php@:>@
    --without-pear          Do not install PEAR], DEFAULT, yes)
 @@ -1023,11 +1023,11 @@
    dnl
index 2b67aac7a50a642a08473ad2de150df8a8361fdc..4e7c11004a10a7ec3648a5665c9955f2a17a6bee 100644 (file)
@@ -1,8 +1,8 @@
 --- php-4.3.3RC3/ext/standard/info.c.orig      2003-06-19 18:43:41.000000000 +0200
 +++ php-4.3.3RC3/ext/standard/info.c   2003-08-16 21:37:18.705836072 +0200
 @@ -518,6 +518,21 @@
-               PUTS(!sapi_module.phpinfo_as_text?"<br />":"\n");
-               PUTS(zend_version);
+                       zend_html_puts(zend_version, strlen(zend_version) TSRMLS_CC);
+               }
                php_info_print_box_end();
 +              /* PLD Linux */
 +              php_info_print_box_start(0);
@@ -31,12 +31,14 @@ diff -urN php-4.2.1RC2.org/ext/standard/info.h php-4.2.1RC2/ext/standard/info.h
  #define PHP_CREDITS_GUID  "PHPB8B5F2A0-3C92-11d3-A3A9-4C7B08C10000"
 +#define PLD_LOGO_GUID "PHPE9568F40-D428-11d2-A769-00AA001ACF42"
  
+ BEGIN_EXTERN_C()
  PHP_FUNCTION(phpversion);
- PHP_FUNCTION(phpinfo);
 --- php-4.3.0.org/main/logos.h Sat May 11 20:49:24 2002
 +++ php-4.3.0/main/logos.h     Sat May 11 20:50:32 2002
-@@ -1503,1 +1503,127 @@
-       249, 249, 207, 233,   5,   4,   0,  59 };
+@@ -1503,3 +1503,127 @@
+        54, 240,   3,  66, 148,   6, 228, 178,  11, 192, 
+       192,   4, 236, 158, 239,   2,  17,  16,   0,  59};
 +
 +
 +unsigned char pld_logo[] = {
index 2aaa1d5b3301e9d35b9d01afd6452cded07fb851..8d981643b96be11362390982ec37d4313c5f2108 100644 (file)
@@ -1,8 +1,8 @@
 --- php-5.2.4/Makefile.global~ 2007-08-31 19:13:58.000000000 +0300
 +++ php-5.2.4/Makefile.global  2007-08-31 19:19:33.799017413 +0300
 @@ -13,8 +13,12 @@
-       
- build-modules: $(PHP_MODULES)
+ build-binaries: $(PHP_BINARIES)
  
 -libphp$(PHP_MAJOR_VERSION).la: $(PHP_GLOBAL_OBJS) $(PHP_SAPI_OBJS)
 -      $(LIBTOOL) --mode=link $(CC) $(CFLAGS) $(EXTRA_CFLAGS) -rpath $(phptempdir) $(EXTRA_LDFLAGS) $(LDFLAGS) $(PHP_RPATHS) $(PHP_GLOBAL_OBJS) $(PHP_SAPI_OBJS) $(EXTRA_LIBS) $(ZEND_EXTRA_LIBS) -o $@
index ef036a71d8255d8c1c8b328c90b15b89471e0fdd..d476a8d0c595720664ef887087c59bb1d0187558 100644 (file)
@@ -1,11 +1,11 @@
 --- php-5.3.3/ext/sybase_ct/config.m4~ 2010-07-07 13:15:24.000000000 +0300
 +++ php-5.3.3/ext/sybase_ct/config.m4  2010-07-24 19:21:13.897144810 +0300
 @@ -31,7 +31,7 @@
-   fi
-   
+   AC_MSG_CHECKING([Checking for Sybase platform libraries])
    PHP_ADD_LIBPATH($SYBASE_CT_LIBDIR, SYBASE_CT_SHARED_LIBADD)
 -  if test -f $SYBASE_CT_INCDIR/tds.h || test -f $SYBASE_CT_INCDIR/tds_sysdep_public.h; then
 +  if test -f $SYBASE_CT_INCDIR/tds.h || test -f $SYBASE_CT_INCDIR/tds_sysdep_public.h || test -f $SYBASE_CT_INCDIR/sybdb.h; then
      PHP_ADD_LIBRARY(ct,, SYBASE_CT_SHARED_LIBADD)
      SYBASE_CT_LIBS="-L$SYBASE_CT_LIBDIR -lct"
-   elif test -f $SYBASE_CT_INCDIR/libsybct64; then
+     AC_MSG_RESULT([FreeTDS: $SYBASE_CT_LIBS])
index 9a2bc9d2820c1bc14b8ebf758c9e72003e8b8ef7..3869f0b4dd23ef812d555104d1e4352f6df57969 100644 (file)
@@ -5,8 +5,8 @@ see also http://bugs.php.net/bug.php?id=29611
 --- php-4.4.1/ext/standard/image.c     2005-07-27 14:22:36.000000000 +0300
 +++ /tmp/image.c       2006-01-06 19:14:00.000000000 +0200
 @@ -31,7 +31,7 @@
+ #include "win32/php_stdint.h"
  #endif
- #include "php_image.h"
  
 -#if HAVE_ZLIB && !defined(COMPILE_DL_ZLIB)
 +#if HAVE_ZLIB
@@ -39,4 +39,4 @@ see also http://bugs.php.net/bug.php?id=29611
 +#if HAVE_ZLIB
                        result = php_handle_swc(stream TSRMLS_CC);
  #else
-                       php_error_docref(NULL TSRMLS_CC, E_NOTICE, "The image is a compressed SWF file, but you do not have a static version of the zlib extension enabled.");
+                       php_error_docref(NULL TSRMLS_CC, E_NOTICE, "The image is a compressed SWF file, but you do not have a static version of the zlib extension enabled");
index 8c102771b3cf3014005e0f5c7221201eda2c7a39..dc87f60a2dfa3f24d903898c20cb620a7a7699d9 100644 (file)
@@ -72,7 +72,7 @@
 +#ifdef HAVE_SPL && !COMPILE_DL_SPL
        ZEND_MOD_REQUIRED("spl")
  #endif
-       {NULL, NULL, NULL}
+       ZEND_MOD_END
 --- php-5.3.1/ext/phar/Makefile.frag~  2009-07-23 15:48:04.000000000 +0000
 +++ php-5.3.1/ext/phar/Makefile.frag   2009-11-30 16:10:29.687175948 +0000
 @@ -10,7 +10,7 @@
This page took 0.082173 seconds and 4 git commands to generate.