]> git.pld-linux.org Git - packages/php.git/commitdiff
up to 7.4.0RC3 auto/th/php74-7.4.0-2.RC3.1
authorElan Ruusamäe <glen@pld-linux.org>
Fri, 4 Oct 2019 11:05:50 +0000 (14:05 +0300)
committerElan Ruusamäe <glen@pld-linux.org>
Thu, 10 Oct 2019 10:57:38 +0000 (13:57 +0300)
disable broken Embedded API build

php-shared.patch
php.spec

index d30fcba9bf2b2a86aefd66678c9490d59595d517..548262460cfe097c4ad4a3901d3812fa8362f26f 100644 (file)
  dnl Checks for some support/generator progs.
  PHP_PROG_AWK
  PHP_PROG_BISON([3.0.0])
---- php-5.2.4/build/Makefile.global~   2007-08-31 19:13:58.000000000 +0300
-+++ php-5.2.4/build/Makefile.global    2007-08-31 19:19:33.799017413 +0300
-@@ -13,8 +13,12 @@
-       
- build-modules: $(PHP_MODULES)
+--- php-7.4.0RC3/build/Makefile.global~        2019-10-04 16:11:24.000000000 +0300
++++ php-7.4.0RC3/build/Makefile.global 2019-10-09 15:21:11.198544363 +0300
+@@ -15,8 +15,11 @@
+ build-binaries: $(PHP_BINARIES)
  
 -libphp$(PHP_MAJOR_VERSION).la: $(PHP_GLOBAL_OBJS) $(PHP_SAPI_OBJS)
--      $(LIBTOOL) --mode=link $(CC) $(CFLAGS) $(EXTRA_CFLAGS) -rpath $(phptempdir) $(EXTRA_LDFLAGS) $(LDFLAGS) $(PHP_RPATHS) $(PHP_GLOBAL_OBJS) $(PHP_SAPI_OBJS) $(EXTRA_LIBS) $(ZEND_EXTRA_LIBS) -o $@
-+libphp_common.la: $(PHP_GLOBAL_OBJS)
-+      $(LIBTOOL) --mode=link $(CC) $(CFLAGS) $(EXTRA_CFLAGS) -rpath $(phptempdir) -avoid-version $(LDFLAGS) $(PHP_RPATHS) $(PHP_GLOBAL_OBJS) $(EXTRA_LIBS) $(ZEND_EXTRA_LIBS) -o $@ -release $(PHP_VERSION)
-+      -@$(LIBTOOL) --silent --mode=install cp $@ $(phptempdir)/$@ >/dev/null 2>&1
-+
+-      $(LIBTOOL) --mode=link --tag=disable-static $(CC) $(CFLAGS) $(EXTRA_CFLAGS) -rpath $(phptempdir) $(EXTRA_LDFLAGS) $(LDFLAGS) $(PHP_RPATHS) $(PHP_GLOBAL_OBJS) $(PHP_SAPI_OBJS) $(EXTRA_LIBS) $(ZEND_EXTRA_LIBS) -o $@
 +libphp$(PHP_MAJOR_VERSION).la: libphp_common.la $(PHP_SAPI_OBJS)
-+      $(LIBTOOL) --mode=link $(CC) $(CFLAGS) $(EXTRA_CFLAGS) -rpath $(phptempdir) $(EXTRA_LDFLAGS) $(LDFLAGS) $(PHP_RPATHS) $(phptempdir)/libphp_common.la $(PHP_SAPI_OBJS) $(EXTRA_LIBS) $(ZEND_EXTRA_LIBS) -o $@
++      $(LIBTOOL) --mode=link --tag=disable-static $(CC) $(CFLAGS) $(EXTRA_CFLAGS) -rpath $(phptempdir) $(EXTRA_LDFLAGS) $(LDFLAGS) $(PHP_RPATHS) $(phptempdir)/libphp_common.la $(EXTRA_LIBS) $(ZEND_EXTRA_LIBS) -o $@
++
++libphp_common.la: $(PHP_GLOBAL_OBJS)
++      $(LIBTOOL) --mode=link --tag=disable-static $(CC) $(CFLAGS) $(EXTRA_CFLAGS) -rpath $(phptempdir) -avoid-version $(LDFLAGS) $(PHP_RPATHS) $(PHP_GLOBAL_OBJS) $(EXTRA_LIBS) $(ZEND_EXTRA_LIBS) -o $@ -release $(PHP_VERSION)
        -@$(LIBTOOL) --silent --mode=install cp $@ $(phptempdir)/$@ >/dev/null 2>&1
  
  libs/libphp$(PHP_MAJOR_VERSION).bundle: $(PHP_GLOBAL_OBJS) $(PHP_SAPI_OBJS)
index 9f5286164a894adfa5568ed7f1eb2fcc9936a3f3..5fe2ff35f73980e3bf64ef330d6a8c31fcc64024 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -14,7 +14,7 @@
 %bcond_without alternatives    # use alternatives system to select default phar and php-fpm
 %bcond_with    default_php     # build this PHP as default PHP in system (disables alternatives)
 # - General options:
-%bcond_without embed           # disable building Embedded API
+%bcond_with    embed           # disable building Embedded API
 %bcond_with    gcov            # Enable Code coverage reporting
 %bcond_without kerberos5       # without Kerberos5 support
 %bcond_with    systemtap       # systemtap/DTrace support
 %undefine      with_pdo_sqlite
 %endif
 
-%define                subver RC2
+%define                subver RC3
 %define                rel     1
 %define                orgname php
 %define                ver_suffix 74
@@ -161,7 +161,7 @@ License:    PHP 3.01 and Zend and BSD
 Group:         Libraries
 #Source0:      https://php.net/distributions/%{orgname}-%{version}.tar.xz
 Source0:       https://downloads.php.net/~derick/php-%{version}%{subver}.tar.xz
-# Source0-md5: ce70af5947ae2228b3408952f8c71be8
+# Source0-md5: 16bab715ced5f8af92344c4400d7bed5
 Source1:       opcache.ini
 Source2:       %{orgname}-mod_php.conf
 Source3:       %{orgname}-cgi-fcgi.ini
This page took 0.059105 seconds and 4 git commands to generate.