]> git.pld-linux.org Git - packages/php.git/commitdiff
- rel 6; fixed icu build auto/th/php56-5.6.40-6
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Sat, 19 Oct 2019 19:50:22 +0000 (21:50 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Sat, 19 Oct 2019 19:50:22 +0000 (21:50 +0200)
php-icu64.patch
php.spec

index 63f56f90b154865e6b112a0a9f1d956f7eb02e2e..c5154fa4a1857eb9e6ff9cdccf1e8f4623cf4ab4 100644 (file)
  #endif
  
  #include <unicode/calendar.h>
-+#include <unicode/gregocal.h>
++
 +#include <unicode/datefmt.h>
  
  extern "C" {
  
 +using icu::Locale;
 +using icu::Calendar;
-+using icu::GregorianCalendar;
++
 +using icu::DateFormat;
 +
  int datefmt_process_calendar_arg(zval* calendar_zv,
  U_CFUNC PHP_METHOD(IntlTimeZone, __construct)
  {
        zend_throw_exception( NULL,
+
+--- php-7.0.33/ext/intl/dateformat/dateformat_helpers.cpp~     2018-12-04 18:22:53.000000000 +0100
++++ php-7.0.33/ext/intl/dateformat/dateformat_helpers.cpp      2019-10-19 21:29:32.416045611 +0200
+@@ -28,6 +28,8 @@ extern "C" {
+ #include "../calendar/calendar_class.h"
+ }
++using icu::GregorianCalendar;
++
+ int datefmt_process_calendar_arg(zval* calendar_zv,
+                                                                Locale const& locale,
+                                                                const char *func_name,
index fce09354cae62048a3d2227af55c5049d0efccde..98a3cf326793e6476869281fff08ddc5ec2a2de0 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -155,7 +155,7 @@ ERROR: You need to select at least one Apache SAPI to build shared modules.
 %undefine      with_filter
 %endif
 
-%define                rel     5
+%define                rel     6
 %define                orgname php
 %define                ver_suffix 56
 %define                php_suffix %{!?with_default_php:%{ver_suffix}}
This page took 0.766997 seconds and 4 git commands to generate.