]> git.pld-linux.org Git - packages/php.git/commitdiff
keep backups and original files whenever it's so easy
authorTomasz Pala <gotar@pld-linux.org>
Sun, 31 May 2015 12:23:59 +0000 (14:23 +0200)
committerElan Ruusamäe <glen@delfi.ee>
Sun, 31 May 2015 14:03:19 +0000 (17:03 +0300)
php.spec

index 632429d577f24458ca31a955b1d05101a8c098a5..7f7dc2d667a1344d2fc0122c6eed5d0cdf1b5b58 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -2715,7 +2715,7 @@ fi
 %service %{name}-fpm restart
 
 %preun fpm
-if [ "$1" = 0 ]; then
+if [ "$1" = "0" ]; then
        %service %{name}-fpm stop
        /sbin/chkconfig --del %{name}-fpm
 fi
@@ -2765,8 +2765,8 @@ for f in /etc/php/*.ini.rpmsave /etc/php/*.d/*.ini.rpmsave; do
        fn=${fn%.rpmsave}
        nf=%{_sysconfdir}/$dn/$fn
        test -f "$nf" || continue
-       cp -vf $nf{,.rpmnew}
-       mv -vf $f $nf
+       cp -vfb $nf{,.rpmnew}
+       cp -vfb $f $nf
        %{__sed} -i -e '
                s#%{_libdir}/php#%{_libdir}/%{name}#
                s#/etc/php#%{_sysconfdir}#
This page took 0.799384 seconds and 4 git commands to generate.