]> git.pld-linux.org Git - packages/php.git/blobdiff - suhosin.patch
- rel 14; update libmagic from php5.6 (as our old 5.3 bundled libmagic segfaults...
[packages/php.git] / suhosin.patch
index f8298ef01d5d09e2bb243932981586da3c24f475..f132c0d89cec131da3bdb02df3d3c40b9e7a6573 100644 (file)
@@ -4504,37 +4504,6 @@ diff -Nura php-5.3.9/Zend/zend_variables.c suhosin-patch-5.3.9-0.9.10/Zend/zend_
                        break;
                case IS_ARRAY:
                case IS_CONSTANT_ARRAY:
-diff -Nura php-5.3.9/configure suhosin-patch-5.3.9-0.9.10/configure
---- php-5.3.9/configure        2012-01-10 14:37:04.000000000 +0100
-+++ suhosin-patch-5.3.9-0.9.10/configure       2012-01-11 19:29:07.000000000 +0100
-@@ -19371,6 +19371,9 @@
- fi
-+cat >> confdefs.h <<\EOF
-+#define SUHOSIN_PATCH 1
-+EOF
-   echo $ac_n "checking for declared timezone""... $ac_c" 1>&6
- echo "configure:19377: checking for declared timezone" >&5
-@@ -115830,7 +115833,7 @@
-        php_ini.c SAPI.c rfc1867.c php_content_types.c strlcpy.c \
-        strlcat.c mergesort.c reentrancy.c php_variables.c php_ticks.c \
-        network.c php_open_temporary_file.c php_logos.c \
--       output.c getopt.c; do
-+       output.c getopt.c suhosin_patch.c ; do
-   
-       IFS=.
-       set $ac_src
-@@ -116034,7 +116037,7 @@
-     zend_list.c zend_indent.c zend_builtin_functions.c zend_sprintf.c \
-     zend_ini.c zend_qsort.c zend_multibyte.c zend_ts_hash.c zend_stream.c \
-     zend_iterators.c zend_interfaces.c zend_exceptions.c zend_strtod.c zend_gc.c \
--    zend_closures.c zend_float.c; do
-+    zend_closures.c zend_float.c zend_canary.c zend_alloc_canary.c ; do
-   
-       IFS=.
-       set $ac_src
 diff -Nura php-5.3.9/configure.in suhosin-patch-5.3.9-0.9.10/configure.in
 --- php-5.3.9/configure.in     2012-01-10 12:21:57.000000000 +0100
 +++ suhosin-patch-5.3.9-0.9.10/configure.in    2012-01-11 19:29:07.000000000 +0100
@@ -5706,15 +5675,15 @@ diff -Nura php-5.3.9/sapi/cgi/cgi_main.c suhosin-patch-5.3.9-0.9.10/sapi/cgi/cgi
                                                        }
 +#if SUHOSIN_PATCH
 +#if ZEND_DEBUG
-+                                                      php_printf("PHP %s with Suhosin-Patch (%s) (built: %s %s) (DEBUG)\nCopyright (c) 1997-2012 The PHP Group\n%s", PHP_VERSION, sapi_module.name, __DATE__, __TIME__, get_zend_version());
++                                                      php_printf("PHP %s with Suhosin-Patch (%s) (built: %s %s) (DEBUG)\nCopyright (c) 1997-2014 The PHP Group\n%s", PHP_VERSION, sapi_module.name, __DATE__, __TIME__, get_zend_version());
 +#else
-+                                                      php_printf("PHP %s with Suhosin-Patch (%s) (built: %s %s)\nCopyright (c) 1997-2012 The PHP Group\n%s", PHP_VERSION, sapi_module.name, __DATE__, __TIME__, get_zend_version());
++                                                      php_printf("PHP %s with Suhosin-Patch (%s) (built: %s %s)\nCopyright (c) 1997-2014 The PHP Group\n%s", PHP_VERSION, sapi_module.name, __DATE__, __TIME__, get_zend_version());
 +#endif
 +#else
  #if ZEND_DEBUG
-                                                       php_printf("PHP %s (%s) (built: %s %s) (DEBUG)\nCopyright (c) 1997-2012 The PHP Group\n%s", PHP_VERSION, sapi_module.name, __DATE__, __TIME__, get_zend_version());
+                                                       php_printf("PHP %s (%s) (built: %s %s) (DEBUG)\nCopyright (c) 1997-2014 The PHP Group\n%s", PHP_VERSION, sapi_module.name, __DATE__, __TIME__, get_zend_version());
  #else
-                                                       php_printf("PHP %s (%s) (built: %s %s)\nCopyright (c) 1997-2012 The PHP Group\n%s", PHP_VERSION, sapi_module.name, __DATE__, __TIME__, get_zend_version());
+                                                       php_printf("PHP %s (%s) (built: %s %s)\nCopyright (c) 1997-2014 The PHP Group\n%s", PHP_VERSION, sapi_module.name, __DATE__, __TIME__, get_zend_version());
  #endif
 +#endif
                                                        php_request_shutdown((void *) 0);
@@ -5727,12 +5696,12 @@ diff -Nura php-5.3.9/sapi/cli/php_cli.c suhosin-patch-5.3.9-0.9.10/sapi/cli/php_
                                }
  
                                request_started = 1;
--                              php_printf("PHP %s (%s) (built: %s %s) %s\nCopyright (c) 1997-2012 The PHP Group\n%s",
+-                              php_printf("PHP %s (%s) (built: %s %s) %s\nCopyright (c) 1997-2014 The PHP Group\n%s",
 +                              php_printf("PHP %s "
 +#if SUHOSIN_PATCH
 +                                      "with Suhosin-Patch "
 +#endif
-+                                      "(%s) (built: %s %s) %s\nCopyright (c) 1997-2012 The PHP Group\n%s",
++                                      "(%s) (built: %s %s) %s\nCopyright (c) 1997-2014 The PHP Group\n%s",
                                        PHP_VERSION, sapi_module.name, __DATE__, __TIME__,
  #if ZEND_DEBUG && defined(HAVE_GCOV)
                                        "(DEBUG GCOV)",
@@ -5745,15 +5714,15 @@ diff -Nura php-5.3.9/sapi/litespeed/lsapi_main.c suhosin-patch-5.3.9-0.9.10/sapi
                  if (php_request_startup(TSRMLS_C) != FAILURE) {
 +#if SUHOSIN_PATCH
 +  #if ZEND_DEBUG
-+                                      php_printf("PHP %s with Suhosin-Patch (%s) (built: %s %s) (DEBUG)\nCopyright (c) 1997-2011 The PHP Group\n%s", PHP_VERSION, sapi_module.name, __DATE__, __TIME__, get_zend_version());
++                                      php_printf("PHP %s with Suhosin-Patch (%s) (built: %s %s) (DEBUG)\nCopyright (c) 1997-2014 The PHP Group\n%s", PHP_VERSION, sapi_module.name, __DATE__, __TIME__, get_zend_version());
 +  #else
-+                                      php_printf("PHP %s with Suhosin-Patch (%s) (built: %s %s)\nCopyright (c) 1997-2011 The PHP Group\n%s", PHP_VERSION, sapi_module.name, __DATE__, __TIME__, get_zend_version());
++                                      php_printf("PHP %s with Suhosin-Patch (%s) (built: %s %s)\nCopyright (c) 1997-2014 The PHP Group\n%s", PHP_VERSION, sapi_module.name, __DATE__, __TIME__, get_zend_version());
 +  #endif
 +#else                                 
  #if ZEND_DEBUG
-                     php_printf("PHP %s (%s) (built: %s %s) (DEBUG)\nCopyright (c) 1997-2004 The PHP Group\n%s", PHP_VERSION, sapi_module.name, __DATE__, __TIME__, get_zend_version());
+                     php_printf("PHP %s (%s) (built: %s %s) (DEBUG)\nCopyright (c) 1997-2014 The PHP Group\n%s", PHP_VERSION, sapi_module.name, __DATE__, __TIME__, get_zend_version());
  #else
-                     php_printf("PHP %s (%s) (built: %s %s)\nCopyright (c) 1997-2004 The PHP Group\n%s", PHP_VERSION, sapi_module.name, __DATE__, __TIME__, get_zend_version());
+                     php_printf("PHP %s (%s) (built: %s %s)\nCopyright (c) 1997-2014 The PHP Group\n%s", PHP_VERSION, sapi_module.name, __DATE__, __TIME__, get_zend_version());
  #endif
 +#endif
  #ifdef PHP_OUTPUT_NEWAPI
@@ -5767,9 +5736,9 @@ diff -Nura php-5.3.9/sapi/milter/php_milter.c suhosin-patch-5.3.9-0.9.10/sapi/mi
                                SG(headers_sent) = 1;
                                SG(request_info).no_headers = 1;
 +#if SUHOSIN_PATCH
-+                              php_printf("PHP %s with Suhosin-Patch (%s) (built: %s %s)\nCopyright (c) 1997-2012 The PHP Group\n%s", PHP_VERSION, sapi_module.name, __DATE__, __TIME__, get_zend_version());
++                              php_printf("PHP %s with Suhosin-Patch (%s) (built: %s %s)\nCopyright (c) 1997-2014 The PHP Group\n%s", PHP_VERSION, sapi_module.name, __DATE__, __TIME__, get_zend_version());
 +#else
-                               php_printf("PHP %s (%s) (built: %s %s)\nCopyright (c) 1997-2012 The PHP Group\n%s", PHP_VERSION, sapi_module.name, __DATE__, __TIME__, get_zend_version());
+                               php_printf("PHP %s (%s) (built: %s %s)\nCopyright (c) 1997-2014 The PHP Group\n%s", PHP_VERSION, sapi_module.name, __DATE__, __TIME__, get_zend_version());
 +#endif
                                php_end_ob_buffers(1 TSRMLS_CC);
                                exit(1);
This page took 0.039719 seconds and 4 git commands to generate.