]> git.pld-linux.org Git - packages/php.git/blobdiff - php.spec
Merge 4:5.3.28-7, 4:5.6.4-2 triggers for rpm 4.16
[packages/php.git] / php.spec
index 46d81934ed0749de62c68053f089107efa5a76e7..ecf40b37363e3c55d62324741a9a2a4f6247816c 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -1,5 +1,7 @@
 # NOTES
 # - mysqlnd driver doesn't support reconnect: https://bugs.php.net/bug.php?id=52561
+# TODO 8.0:
+# - removed packages: xmlrpc
 # TODO 5.6:
 # - enable --with-fpm-systemd, but ensure it checks for sd_booted()
 # TODO:
@@ -14,7 +16,7 @@
 %bcond_without alternatives    # use alternatives system to select default phar and php-fpm
 %bcond_with    default_php     # build this PHP as default PHP in system (disables alternatives)
 # - General options:
-%bcond_without embed           # disable building Embedded API
+%bcond_with    embed           # disable building Embedded API
 %bcond_with    gcov            # Enable Code coverage reporting
 %bcond_without kerberos5       # without Kerberos5 support
 %bcond_with    systemtap       # systemtap/DTrace support
 %bcond_without cgi             # disable CGI/FCGI SAPI
 %bcond_without fpm             # disable FPM SAPI
 %bcond_without litespeed       # build litespeed SAPI
-%bcond_with    milter          # disable Milter SAPI
 %bcond_without phpdbg          # disable phpdbg SAPI
 # - Extensions
 %bcond_without bcmath          # without bcmath extension module
-%bcond_without bz2             # without bz2 extension module
+%bcond_without bzip2           # without bz2 extension module
 %bcond_without calendar        # without calendar extension module
 %bcond_without ctype           # without ctype extension module
 %bcond_without curl            # without CURL extension module
@@ -48,7 +49,6 @@
 %bcond_without iconv           # without iconv extension module
 %bcond_without imap            # without IMAP extension module
 %bcond_without intl            # without Intl extension module
-%bcond_without json            # without json extension module
 %bcond_without ldap            # without LDAP extension module
 %bcond_without mbstring        # without mbstring extension module
 %bcond_without mhash           # without mhash extension (supported by hash extension)
@@ -79,7 +79,6 @@
 %bcond_without sqlite2         # without SQLite extension module
 %bcond_without sqlite3         # without SQLite3 extension module
 %bcond_without tidy            # without Tidy extension module
-%bcond_without xmlrpc          # without XML-RPC extension module
 %bcond_without xsl                     # without xsl extension module
 %bcond_without zip                     # without zip extension module
 # extensions options
@@ -90,7 +89,6 @@
 %bcond_without system_gd       # system gd
 %bcond_without webp            # Without WebP support in GD extension (imagecreatefromwebp)
 
-%define apxs1          /usr/sbin/apxs1
 %define        apxs2           /usr/sbin/apxs
 
 # segfaults on x32
 %undefine      with_mm
 %endif
 
-# milter requires ZTS
-%if %{with milter} && %{without zts}
-%undefine      with_milter
-%endif
-
 %if %{without odbc}
 %undefine      with_pdo_odbc
 %endif
 %undefine      with_pdo_sqlite
 %endif
 
-%define                subver beta2
-%define                rel     1
 %define                orgname php
-%define                ver_suffix 74
+%define                ver_suffix 80
 %define                php_suffix %{!?with_default_php:%{ver_suffix}}
 Summary:       PHP: Hypertext Preprocessor
 Summary(fr.UTF-8):     Le langage de script embarque-HTML PHP
 Summary(pl.UTF-8):     Język skryptowy PHP
 Summary(pt_BR.UTF-8):  A linguagem de script PHP
-Summary(ru.UTF-8):     PHP Версии 7 - язык препроцессирования HTML-файлов, выполняемый на сервере
-Summary(uk.UTF-8):     PHP Версії 7 - мова препроцесування HTML-файлів, виконувана на сервері
+Summary(ru.UTF-8):     PHP - язык препроцессирования HTML-файлов, выполняемый на сервере
+Summary(uk.UTF-8):     PHP - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          %{orgname}%{php_suffix}
-Version:       7.4.0
-Release:       1.%{subver}.%{rel}
+Version:       8.0.0
+Release:       2
 Epoch:         4
 # All files licensed under PHP version 3.01, except
 # Zend is licensed under Zend
 # TSRM is licensed under BSD
 License:       PHP 3.01 and Zend and BSD
 Group:         Libraries
-#Source0:      https://php.net/distributions/%{orgname}-%{version}.tar.xz
-Source0:       https://downloads.php.net/~derick/php-%{version}%{subver}.tar.xz
-# Source0-md5: 51a42ffa81be306d7a1b2f073e4fba05
+Source0:       https://php.net/distributions/%{orgname}-%{version}.tar.xz
+# Source0-md5: 52ad70ea64968d6095c6e38139533d57
 Source1:       opcache.ini
 Source2:       %{orgname}-mod_php.conf
 Source3:       %{orgname}-cgi-fcgi.ini
@@ -186,12 +176,10 @@ Patch2:           %{orgname}-mail.patch
 Patch3:                %{orgname}-link-libs.patch
 Patch4:                intl-stdc++.patch
 Patch7:                %{orgname}-sapi-ini-file.patch
-Patch8:                milter.patch
 Patch9:                libtool-tag.patch
 Patch10:       %{orgname}-ini.patch
 Patch11:       embed.patch
 Patch14:       %{orgname}-no_pear_install.patch
-Patch17:       %{orgname}-readline.patch
 Patch18:       %{orgname}-nohttpd.patch
 Patch21:       %{orgname}-dba-link.patch
 Patch22:       %{orgname}-both-apxs.patch
@@ -203,12 +191,10 @@ Patch29:  %{orgname}-fcgi-graceful.patch
 Patch31:       %{orgname}-fcgi-error_log-no-newlines.patch
 Patch39:       %{orgname}-use-prog_sendmail.patch
 Patch41:       %{orgname}-fpm-config.patch
-Patch42:       %{orgname}-fpm-shared.patch
 Patch43:       %{orgname}-silent-session-cleanup.patch
 Patch44:       %{orgname}-include_path.patch
 Patch50:       extension-shared-optional-dep.patch
 Patch53:       fix-test-run.patch
-Patch55:       bug-52078-fileinode.patch
 Patch59:       %{orgname}-systzdata.patch
 Patch60:       %{orgname}-oracle-instantclient.patch
 Patch66:       php-db.patch
@@ -228,10 +214,6 @@ BuildRequires:     cyrus-sasl-devel >= 2
 BuildRequires: db-devel >= 4.0
 BuildRequires: elfutils-devel
 %{?with_enchant:BuildRequires: enchant-devel >= 1.1.3}
-%{?with_kerberos5:BuildRequires:       heimdal-devel}
-%{?with_argon2:BuildRequires:  libargon2-devel >= 20161029}
-%{?with_ffi:BuildRequires:     libffi-devel}
-%{?with_sodium:BuildRequires:  libsodium-devel >= 1.0.8}
 %if %{with pdo_dblib}
 BuildRequires: freetds-devel >= 0.82
 %endif
@@ -241,13 +223,17 @@ BuildRequires:    gd-devel >= 2.1
 %endif
 BuildRequires: gdbm-devel
 BuildRequires: gmp-devel >= 4.2
+%{?with_kerberos5:BuildRequires:       heimdal-devel}
 %{?with_imap:BuildRequires:    imap-devel >= 1:2007e-2}
 %{?with_gcov:BuildRequires:    lcov}
 %{?with_fpm:BuildRequires:     libapparmor-devel}
+%{?with_argon2:BuildRequires:  libargon2-devel >= 20161029}
+%{?with_ffi:BuildRequires:     libffi-devel}
 %{?with_intl:BuildRequires:    libicu-devel >= 50.1}
 BuildRequires: libjpeg-devel
 BuildRequires: libltdl-devel >= 1.4
 BuildRequires: libpng-devel >= 1.0.8
+%{?with_sodium:BuildRequires:  libsodium-devel >= 1.0.8}
 %{?with_intl:BuildRequires:    libstdc++-devel}
 BuildRequires: libtool >= 2:2.4.6
 %{?with_webp:BuildRequires:    libwebp-devel}
@@ -282,7 +268,6 @@ BuildRequires:      tar >= 1:1.22
 %{?with_tidy:BuildRequires:    tidy-devel}
 BuildRequires: tokyocabinet-devel
 %{?with_odbc:BuildRequires:    unixODBC-devel}
-%{?with_xmlrpc:BuildRequires:  xmlrpc-epi-devel >= 0.54.1}
 BuildRequires: xz
 BuildRequires: zlib-devel >= 1.2.0.4
 %if %{with apache2}
@@ -297,9 +282,9 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                _sysconfdir                     %{php_sysconfdir}
 
 # must be in sync with source. extra check ensuring that it is so is done in %%build
-%define                php_api_version         20190529
+%define                php_api_version         20200930
 %define                zend_module_api         %{php_api_version}
-%define                zend_extension_api      3%{zend_module_api}
+%define                zend_extension_api      4%{zend_module_api}
 %define                php_pdo_api_version     20170320
 
 # Extension versions
@@ -311,7 +296,7 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                jsonver         %{version}
 %define                pharver         %{version}
 %define                sqlite3ver      %{version}
-%define                zipver          1.15.4
+%define                zipver          1.19.1
 %define                phpdbgver       %{version}
 %define                sodiumver       %{version}
 
@@ -842,7 +827,8 @@ support in image files.
 Moduł PHP dodający obsługę znaczników EXIF w plikach obrazków.
 
 %package ffi
-Summary:       %{modname} - Foreign Function Interface
+Summary:       Foreign Function Interface module for PHP
+Summary(pl.UTF-8):     Moduł Foreign Function Interface (interfejsu do obcych języków) dla PHP
 Group:         Libraries
 URL:           https://www.php.net/manual/en/book.ffi.php
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
@@ -852,6 +838,10 @@ Provides:  php(ffi) = %{version}
 FFI is a multi-platform extension for PHP that allows you to bind to
 functions from arbitrary shared libraries and call them.
 
+%description ffi -l pl.UTF-8
+FFI to wieloplatformowe rozszerzenie dla PHP pozwalające dowiązywać
+funkcje z dowolnych bibliotek współdzielonych i wywoływać je.
+
 %package fileinfo
 Summary:       libmagic bindings
 Summary(pl.UTF-8):     Wiązania do libmagic
@@ -1604,6 +1594,7 @@ Moduł PHP dodający obsługę gniazdek.
 
 %package sodium
 Summary:       Wrapper for the Sodium cryptographic library
+Summary(pl.UTF-8):     Interfejs do biblioteki kryptograficznej Sodium
 Group:         Libraries
 URL:           https://paragonie.com/book/pecl-libsodium
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
@@ -1612,6 +1603,9 @@ Provides: php(sodium) = %{sodiumver}
 %description sodium
 A simple, low-level PHP extension for libsodium.
 
+%description sodium -l pl.UTF-8
+Proste, niskopoziomowe rozszerzenie PHP wykorzystując libsodium.
+
 %package sqlite3
 Summary:       SQLite3 extension module for PHP
 Summary(pl.UTF-8):     Moduł SQLite3 dla PHP
@@ -1778,23 +1772,6 @@ Moduł PHP umożliwiający analizę plików XML w trybie Pull. Czytnik
 działa jako kursor przechodzący przez strumień dokumentu i
 zatrzymujący się na każdym węźle po drodze.
 
-%package xmlrpc
-Summary:       xmlrpc extension module for PHP
-Summary(pl.UTF-8):     Moduł xmlrpc dla PHP
-Group:         Libraries
-URL:           http://php.net/manual/en/book.xmlrpc.php
-Requires:      %{name}-common = %{epoch}:%{version}-%{release}
-Requires:      %{name}-xml = %{epoch}:%{version}-%{release}
-Provides:      php(xmlrpc)
-Obsoletes:     php-xmlrpc < 4:5.3.28-7
-
-%description xmlrpc
-This is a dynamic shared object (DSO) for PHP that will add XMLRPC
-support.
-
-%description xmlrpc -l pl.UTF-8
-Moduł PHP dodający obsługę XMLRPC.
-
 %package xmlwriter
 Summary:       Fast, non-cached, forward-only means to write XML data
 Summary(pl.UTF-8):     Szybka, nie cachowana metoda zapisu danych w formacie XML
@@ -1871,48 +1848,45 @@ Moduł PHP umożliwiający używanie kompresji zlib.
 
 %prep
 %setup -q -n %{orgname}-%{version}%{?subver}
+
 cp -p php.ini-production php.ini
 %patch0 -p1
 %patch1 -p1
-%patch2 -p1
+#%patch2 -p1 -b .mail
 %patch3 -p1
 %patch4 -p1
 
-%patch7 -p1
-%{?with_milter:%patch8 -p1}
+%patch7 -p1 -b .sapi-ini-file
 %patch9 -p1
-%patch10 -p1
+%patch10 -p1 -b .ini
 %patch14 -p1
-%patch17 -p1
 %patch18 -p1
 %patch21 -p1
 %patch22 -p1
 %patch23 -p1
-%patch24 -p1
+%patch24 -p1 -b .zlib-for-getimagesize
 %patch25 -p1
 %patch27 -p1
 %patch29 -p1
 %patch31 -p1
-%patch39 -p1
+%patch39 -p1 -b .use-prog_sendmail
 %patch41 -p1
-%patch42 -p1
 %patch43 -p1
 %patch44 -p1
 %patch50 -p1
-
 %patch53 -p1
-%undos ext/spl/tests/SplFileInfo_getInode_basic.phpt
-%patch55 -p1
 %patch59 -p1 -b .systzdata
 %if %{with instantclient}
 %patch60 -p1 -b .instantclient
 %endif
 %patch66 -p1
-%patch67 -p1
+%patch67 -p1 -b .mysql-lib-ver-mismatch
 #%patch68 -p1 DROP or update to 7.0 APIs
-%patch71 -p1
+%patch71 -p1 -b .libdb-info
 
-%{__sed} -i -e '/PHP_ADD_LIBRARY_WITH_PATH/s#xmlrpc,#xmlrpc-epi,#' ext/xmlrpc/config.m4
+sed -E -i -e '1s,#!\s*/usr/bin/env\s+(.*),#!%{__bindir}\1,' \
+      ext/ext_skel.php \
+      run-tests.php
 
 # cleanup backups after patching
 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
@@ -1931,7 +1905,6 @@ find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
 #%{__rm} -r ext/mbstring/libmbfl
 #%{__rm} -r ext/pcre/pcre2lib
 #%{__rm} -r ext/soap/interop
-%{__rm} -r ext/xmlrpc/libxmlrpc
 #%{__rm} -r ext/zip/lib
 %{__rm} ext/date/lib/timezonedb.h
 
@@ -2111,7 +2084,7 @@ export PEAR_INSTALLDIR=%{php_pear_dir}
 # configure once (for faster debugging purposes)
 if [ ! -f _built-conf ]; then
        # now remove Makefile copies
-       rm -f Makefile.{cgi-fcgi,fpm,cli,apxs1,apxs2,litespeed,phpdbg,milter}
+       rm -f Makefile.{cgi-fcgi,fpm,cli,apxs2,litespeed,phpdbg}
 
        # Force use of system libtool:
        mv build/libtool.m4 build/libtool.m4.saved
@@ -2124,8 +2097,7 @@ if [ ! -f _built-conf ]; then
        touch _built-conf
 fi
 export PROG_SENDMAIL="/usr/lib/sendmail"
-export CPPFLAGS="-DDEBUG_FASTCGI -DHAVE_STRNDUP %{rpmcppflags} \
-       -I%{_includedir}/xmlrpc-epi"
+export CPPFLAGS="-DDEBUG_FASTCGI -DHAVE_STRNDUP %{rpmcppflags}"
 
 # This should be detected by configure and set there,
 # but looks like the build system is hosed on 7.3
@@ -2157,9 +2129,6 @@ apxs2
 %if %{with phpdbg}
 phpdbg
 %endif
-%if %{with milter}
-milter
-%endif
 "
 for sapi in $sapis; do
        : SAPI $sapi
@@ -2190,9 +2159,6 @@ for sapi in $sapis; do
        phpdbg)
                sapi_args='--enable-phpdbg %{?debug:--enable-phpdbg-debug}'
        ;;
-       milter)
-               sapi_args='--with-milter'
-       ;;
        esac
 
        %configure \
@@ -2211,7 +2177,7 @@ for sapi in $sapis; do
        %{?with_argon2:--with-password-argon2} \
        --%{!?with_debug:dis}%{?with_debug:en}able-debug \
        %{?with_zts:--enable-maintainer-zts} \
-       --enable-inline-optimization \
+       --enable-option-checking=fatal \
        %{__enable_disable bcmath bcmath shared} \
        %{__enable_disable calendar calendar shared} \
        %{__enable_disable ctype ctype shared} \
@@ -2227,7 +2193,6 @@ for sapi in $sapis; do
        --enable-mbregex \
        %{__enable_disable pcntl pcntl shared} \
        %{__enable_disable pdo pdo shared} \
-       %{__enable_disable json json shared} \
        --enable-xmlwriter=shared \
 %if %{with fpm}
        --with-fpm-user=http \
@@ -2261,7 +2226,7 @@ for sapi in $sapis; do
        --enable-tokenizer=shared \
        --enable-xml=shared \
        --enable-xmlreader=shared \
-       %{__with_without bz2 bz2 shared} \
+       %{__with_without bzip2 bz2 shared} \
        %{__with_without curl curl shared} \
        --with-db4 \
        %{__with_without iconv iconv shared} \
@@ -2296,7 +2261,6 @@ for sapi in $sapis; do
        %{__with_without sqlite3 sqlite3 shared} \
        %{?with_tidy:--with-tidy=shared} \
        %{?with_odbc:--with-unixODBC=shared} \
-       %{__with_without xmlrpc xmlrpc shared,/usr} \
        %{?with_xsl:--with-xsl=shared} \
        --with-zlib=shared \
        %{?with_zip:--with-zip=shared} \
@@ -2337,10 +2301,6 @@ cp -af Makefile.cli Makefile
        PHPDBG_EXTRA_LIBS=-lreadline
 %endif
 
-%if %{with milter}
-%{__make} -f Makefile.milter milter
-%endif
-
 # CGI/FCGI
 %if %{with cgi}
 cp -pf php_config.h.cgi-fcgi main/php_config.h
@@ -2417,7 +2377,8 @@ exit $rc
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_libdir}/{php,apache},%{_sysconfdir}/cgi} \
+install -d \
+       $RPM_BUILD_ROOT%{_libdir}/{php,apache} \
        $RPM_BUILD_ROOT%{_sysconfdir}/{conf,cgi-fcgi,cli,apache2handler}.d \
        $RPM_BUILD_ROOT{%{_sbindir},%{_bindir}} \
        $RPM_BUILD_ROOT/etc/httpd/conf.d \
@@ -2468,11 +2429,6 @@ libtool --mode=install install -p sapi/litespeed/php $RPM_BUILD_ROOT%{_sbindir}/
 %endif
 %endif
 
-%if %{with milter}
-%{__make} -f Makefile.milter install-milter \
-       INSTALL_ROOT=$RPM_BUILD_ROOT
-%endif
-
 libtool --mode=install install -p libphp_common.la $RPM_BUILD_ROOT%{_libdir}
 
 # install CGI/FCGI
@@ -2480,7 +2436,7 @@ libtool --mode=install install -p libphp_common.la $RPM_BUILD_ROOT%{_libdir}
 # install-cgi
 libtool --mode=install install -p sapi/cgi/php-cgi $RPM_BUILD_ROOT%{_bindir}/%{name}.cgi
 ln -sf %{name}.cgi $RPM_BUILD_ROOT%{_bindir}/%{name}.fcgi
-cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/php-cgi-fcgi.ini
+cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/cgi-fcgi.d/php.ini
 %endif
 
 # install FCGI PM
@@ -2528,11 +2484,11 @@ ln -sf php%{ver_suffix} $RPM_BUILD_ROOT%{_bindir}/php
 
 cp -p php.ini $RPM_BUILD_ROOT%{_sysconfdir}/php.ini
 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/timezone.ini
-cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/php-cli.ini
+cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/cli.d/php.ini
 
 %if %{with apache2}
 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/httpd/conf.d/70_mod_php.conf
-cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/php-apache2handler.ini
+cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/apache2handler.d/php.ini
 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/apache/libphp7.la
 %endif
 
@@ -2628,7 +2584,14 @@ fi
 # restart webserver at the end of transaction
 [ ! -f /etc/httpd/conf.d/??_mod_php.conf ] || %service -q httpd restart
 
-%triggerpostun common -- php-common < 4:5.3.28-7
+%triggerpostun common -- %{name}-common < 4:5.6.4-2, php-common < 4:5.6.4-2
+# switch to browscap package if the ini file has original value
+%{__sed} -i -e 's#%{_sysconfdir}/browscap.ini#/usr/share/browscap/php_browscap.ini#' %{_sysconfdir}/php.ini
+# disable browscap, if optional package not present
+if [ ! -e /usr/share/browscap/php_browscap.ini ]; then
+       %{__sed} -i -e 's#^browscap = /usr/share/browscap/php_browscap.ini#;&#' %{_sysconfdir}/php.ini
+fi
+
 # migrate configs /etc/php/conf.d -> /etc/phpXY/conf.d/
 # do config migration in php-common trigger, as the trigger is ran after all packages are upgraded
 # this way we can stick to one trigger, instead of attaching one for each (sub)package!
@@ -2649,14 +2612,6 @@ for f in /etc/php/*.ini.rpmsave /etc/php/*.d/*.ini.rpmsave; do
        ' $nf
 done
 
-%triggerpostun common -- %{name}-common < 4:5.6.4-2, php-common < 4:5.6.4-2
-# switch to browscap package if the ini file has original value
-%{__sed} -i -e 's#%{_sysconfdir}/browscap.ini#/usr/share/browscap/php_browscap.ini#' %{_sysconfdir}/php.ini
-# disable browscap, if optional package not present
-if [ ! -e /usr/share/browscap/php_browscap.ini ]; then
-       %{__sed} -i -e 's#^browscap = /usr/share/browscap/php_browscap.ini#;&#' %{_sysconfdir}/php.ini
-fi
-
 %triggerpostun -n apache-mod_%{name} -- apache-mod_%{name} < 4:7.0.0-2.RC4
 sed -i -e 's#modules/libphp[57].so#modules/mod_php.so#g' /etc/httpd/conf.d/*_mod_php.conf
 
@@ -2737,7 +2692,6 @@ fi \
 %extension_scripts tokenizer
 %extension_scripts xml
 %extension_scripts xmlreader
-%extension_scripts xmlrpc
 %extension_scripts xmlwriter
 %extension_scripts xsl
 %extension_scripts zip
@@ -2768,7 +2722,7 @@ fi
 %files -n apache-mod_%{name}-core
 %defattr(644,root,root,755)
 %dir %{_sysconfdir}/apache2handler.d
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/php-apache2handler.ini
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache2handler.d/php.ini
 %attr(755,root,root) %{_libdir}/apache/libphp7-*.*.so
 %endif
 
@@ -2782,7 +2736,7 @@ fi
 %files cgi
 %defattr(644,root,root,755)
 %dir %{_sysconfdir}/cgi-fcgi.d
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/php-cgi-fcgi.ini
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cgi-fcgi.d/php.ini
 %attr(755,root,root) %{_bindir}/%{name}.cgi
 %attr(755,root,root) %{_bindir}/%{name}.fcgi
 %endif
@@ -2796,7 +2750,7 @@ fi
 %files cli
 %defattr(644,root,root,755)
 %dir %{_sysconfdir}/cli.d
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/php-cli.ini
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cli.d/php.ini
 %attr(755,root,root) %{_bindir}/php%{ver_suffix}
 %{_mandir}/man1/php%{ver_suffix}.1*
 
@@ -2828,12 +2782,6 @@ fi
 %{_mandir}/man1/phpdbg%{php_suffix}.1*
 %endif
 
-%if %{with milter}
-%files milter
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/php-milter
-%endif
-
 %files common
 %defattr(644,root,root,755)
 %doc EXTENSIONS LICENSE NEWS UPGRADING* Zend/{LICENSE.Zend,README*} php.ini-* .gdbinit
@@ -2866,7 +2814,7 @@ fi
 %attr(755,root,root) %{php_extensiondir}/bcmath.so
 %endif
 
-%if %{with bz2}
+%if %{with bzip2}
 %files bz2
 %defattr(644,root,root,755)
 %doc ext/bz2/CREDITS
@@ -3010,13 +2958,9 @@ fi
 %attr(755,root,root) %{php_extensiondir}/intl.so
 %endif
 
-%if %{with json}
 %files json
 %defattr(644,root,root,755)
 %doc ext/json/CREDITS
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/??_json.ini
-%attr(755,root,root) %{php_extensiondir}/json.so
-%endif
 
 %if %{with ldap}
 %files ldap
@@ -3318,14 +3262,6 @@ fi
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/??_xmlreader.ini
 %attr(755,root,root) %{php_extensiondir}/xmlreader.so
 
-%if %{with xmlrpc}
-%files xmlrpc
-%defattr(644,root,root,755)
-%doc ext/xmlrpc/CREDITS
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/??_xmlrpc.ini
-%attr(755,root,root) %{php_extensiondir}/xmlrpc.so
-%endif
-
 %files xmlwriter
 %defattr(644,root,root,755)
 %doc ext/xmlwriter/CREDITS
This page took 0.082875 seconds and 4 git commands to generate.