]> git.pld-linux.org Git - packages/php.git/blobdiff - php.spec
Rename --enable-libxml to --with-libxml to meet naming guidelines
[packages/php.git] / php.spec
index f8c899af465ab9df23bdb7c9434d743c7f95c5dc..cc74c0ab07377dbb3f2821f40cbf30c161229743 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -2,7 +2,6 @@
 # - mysqlnd driver doesn't support reconnect: https://bugs.php.net/bug.php?id=52561
 # TODO 7.4:
 # - follow upstream: drop spl, pcre, hash subpackages (tired of maintaining them)
-# - handle acinclude.m4 -> build/php.m4 rename
 # TODO 7.3:
 # - branch php-7.2 and merge dev-7.3 into head once official announcement ready
 # TODO 7.2:
@@ -18,7 +17,6 @@
 #   - 2.3M fileinfo.so php-fileinfo-5.3.16-1.x86_64
 #   -  13K fileinfo.so php-pecl-fileinfo-1.0.4-8.amd64
 # - ttyname_r() misdetected http://bugs.php.net/bug.php?id=48820
-# - wddx: restore session support (not compiled in due DL extension check)
 # - modularize standard (output from pure php -m)?
 # - some mods should be shared:
 #$ php -m
@@ -97,7 +95,6 @@
 %bcond_without sqlite2         # without SQLite extension module
 %bcond_without sqlite3         # without SQLite3 extension module
 %bcond_without tidy            # without Tidy extension module
-%bcond_without wddx            # without WDDX extension module
 %bcond_without xmlrpc          # without XML-RPC extension module
 %bcond_without xsl                     # without xsl extension module
 %bcond_without zip                     # without zip extension module
 %undefine      with_filter
 %endif
 
-%define                subver %{nil}
+%define                subver alpha1
 %define                orgname php
 %define                ver_suffix 74
 %define                php_suffix %{!?with_default_php:%{ver_suffix}}
@@ -167,10 +164,9 @@ Epoch:             4
 # TSRM is licensed under BSD
 License:       PHP 3.01 and Zend and BSD
 Group:         Libraries
-#Source0:      https://downloads.php.net/~cmb/php-%{version}%{subver}.tar.xz
 #Source0:      https://php.net/distributions/%{orgname}-%{version}.tar.xz
-Source0:       https://github.com/php/php-src/archive/PHP-7.4/%{orgname}-%{version}.tar.gz
-# Source0-md5: e54970ae767eae731995f5bb2b4e0f43
+Source0:       https://downloads.php.net/~derick/php-%{version}%{subver}.tar.xz
+# Source0-md5: 29592e9a73c0ae615c4b7e2b4761184f
 Source1:       opcache.ini
 Source2:       %{orgname}-mod_php.conf
 Source3:       %{orgname}-cgi-fcgi.ini
@@ -186,7 +182,6 @@ Patch1:             %{orgname}-pldlogo.patch
 Patch2:                %{orgname}-mail.patch
 Patch3:                %{orgname}-link-libs.patch
 Patch4:                intl-stdc++.patch
-Patch5:                %{orgname}-filter-shared.patch
 
 Patch7:                %{orgname}-sapi-ini-file.patch
 Patch8:                milter.patch
@@ -232,7 +227,7 @@ URL:                http://php.net/
 %{?with_pspell:BuildRequires:  aspell-devel >= 2:0.50.0}
 BuildRequires: autoconf >= 2.59
 BuildRequires: automake >= 1.4d
-BuildRequires: bison
+BuildRequires: bison >= 3.0.0
 BuildRequires: bzip2-devel >= 1.0.0
 %{?with_curl:BuildRequires:    curl-devel >= 7.15.5}
 BuildRequires: cyrus-sasl-devel >= 2
@@ -312,9 +307,9 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                _sysconfdir                     %{php_sysconfdir}
 
 # must be in sync with source. extra check ensuring that it is so is done in %%build
-%define                php_api_version         20180731
-%define                zend_module_api         20180731
-%define                zend_extension_api      320180731
+%define                php_api_version         20190529
+%define                zend_module_api         %{php_api_version}
+%define                zend_extension_api      3%{zend_module_api}
 %define                php_pdo_api_version     20170320
 
 # Extension versions
@@ -1827,27 +1822,6 @@ support.
 %description tokenizer -l pl.UTF-8
 Moduł PHP dodający obsługę tokenizera do PHP.
 
-%package wddx
-Summary:       wddx extension module for PHP
-Summary(pl.UTF-8):     Moduł wddx dla PHP
-Group:         Libraries
-URL:           http://php.net/manual/en/book.wddx.php
-Requires:      %{name}-common = %{epoch}:%{version}-%{release}
-# - wddx doesn't require session as it's disabled at compile time:
-#   if HAVE_PHP_SESSION && !defined(COMPILE_DL_SESSION)
-#   see also php.spec#rev1.120.2.22
-#Requires:     %{name}-session = %{epoch}:%{version}-%{release}
-Requires:      %{name}-xml = %{epoch}:%{version}-%{release}
-Provides:      php(wddx)
-Obsoletes:     php-wddx < 4:5.3.28-7
-
-%description wddx
-This is a dynamic shared object (DSO) for PHP that will add wddx
-support.
-
-%description wddx -l pl.UTF-8
-Moduł PHP umożliwiający korzystanie z wddx.
-
 %package xml
 Summary:       XML extension module for PHP
 Summary(pl.UTF-8):     Moduł XML dla PHP
@@ -1980,18 +1954,13 @@ compression support to PHP.
 Moduł PHP umożliwiający używanie kompresji zlib.
 
 %prep
-%if 0
 %setup -q -n %{orgname}-%{version}%{?subver}
-%else
-%setup -q -n php-src-PHP-7.4
-%endif
 cp -p php.ini-production php.ini
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
-%patch5 -p1
 
 %patch7 -p1
 %{?with_milter:%patch8 -p1}
@@ -2048,7 +2017,6 @@ find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
 %{__rm} ext/recode/config9.m4
 
 # remove all bundled libraries not to link with them accidentally
-%{__rm} -r ext/sqlite3/libsqlite
 #%{__rm} -r ext/bcmath/libbcmath
 #%{__rm} -r ext/date/lib
 #%{__rm} -r ext/fileinfo/libmagic
@@ -2057,7 +2025,6 @@ find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
 #%{__rm} -r ext/dba/libinifile
 #%{__rm} -r ext/gd/libgd
 #%{__rm} -r ext/mbstring/libmbfl
-%{__rm} -r ext/mbstring/oniguruma
 %{__rm} -r ext/pcre/pcre2lib
 #%{__rm} -r ext/soap/interop
 %{__rm} -r ext/xmlrpc/libxmlrpc
@@ -2236,8 +2203,13 @@ export EXTENSION_DIR="%{php_extensiondir}"
 if [ ! -f _built-conf ]; then
        # now remove Makefile copies
        rm -f Makefile.{cgi-fcgi,fpm,cli,apxs1,apxs2,litespeed,phpdbg,milter}
+
+       # Force use of system libtool:
+       mv build/libtool.m4 build/libtool.m4.saved
+       cat %{_aclocaldir}/{libtool,ltoptions,ltsugar,ltversion,lt~obsolete}.m4 > build/libtool.m4
        %{__libtoolize}
        %{__aclocal}
+
        cp -f /usr/share/automake/config.* .
        ./buildconf --force
        touch _built-conf
@@ -2341,7 +2313,7 @@ for sapi in $sapis; do
        %{__enable_disable fileinfo fileinfo shared} \
        %{__enable_disable ftp ftp shared} \
        %{?with_intl:--enable-intl=shared} \
-       --enable-libxml \
+       --with-libxml \
        %{__enable_disable mbstring mbstring shared,all} \
        --with-onig=/usr \
        --enable-mbregex \
@@ -2381,7 +2353,6 @@ for sapi in $sapis; do
        --enable-sockets=shared \
        %{__with_without sodium sodium shared} \
        --enable-tokenizer=shared \
-       %{?with_wddx:--enable-wddx=shared} \
        --enable-xml=shared \
        --enable-xmlreader=shared \
        %{__with_without bz2 bz2 shared} \
@@ -2498,8 +2469,6 @@ generate_inifiles() {
                # opcache.so is zend extension
                nm $so | grep -q zend_extension_entry && ext=zend_extension
                conf="$mod.ini"
-               # xml needs to be loaded before wddx
-               [ "$mod" = "wddx" ] && conf="xml_$mod.ini"
                # pre needs to be loaded before SPL
                [ "$mod" = "pcre" ] && conf="PCRE.ini"
                # spl needs to be loaded before mysqli
@@ -2910,7 +2879,6 @@ fi \
 %extension_scripts sysvshm
 %extension_scripts tidy
 %extension_scripts tokenizer
-%extension_scripts wddx
 %extension_scripts xml
 %extension_scripts xmlreader
 %extension_scripts xmlrpc
@@ -3513,14 +3481,6 @@ fi
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/tokenizer.ini
 %attr(755,root,root) %{php_extensiondir}/tokenizer.so
 
-%if %{with wddx}
-%files wddx
-%defattr(644,root,root,755)
-%doc ext/wddx/CREDITS
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*wddx.ini
-%attr(755,root,root) %{php_extensiondir}/wddx.so
-%endif
-
 %files xml
 %defattr(644,root,root,755)
 %doc ext/xml/CREDITS
This page took 0.179298 seconds and 4 git commands to generate.