]> git.pld-linux.org Git - packages/php.git/blobdiff - php.spec
up to 5.5.4
[packages/php.git] / php.spec
index dadec0ae5cd29046fb7635524b83a3946297480d..bae73a1045e892e79fc00e88c9cd4879c7c21407 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -1,5 +1,6 @@
 # TODO 5.5:
 # - enable --with-fpm-systemd, but ensure it checks for sd_booted()
+# - build with system libgd 2.1, see 73c5128
 # TODO 5.4:
 # - do not remove PatchX: definitions until merged to HEAD, needed for tracking their state
 # - check php-sapi-ini-file.patch for safe mode removal
@@ -46,6 +47,7 @@
 %bcond_with    instantclient   # build Oracle oci8 extension module against oracle-instantclient package
 %bcond_with    system_gd       # with system gd (we prefer internal since it enables few more features)
 %bcond_with    system_libzip   # with system libzip (reported broken currently)
+%bcond_with    default_php     # use this PHP as default PHP in distro
 %bcond_without curl            # without CURL extension module
 %bcond_without enchant         # without Enchant extension module
 %bcond_without filter          # without filter extension module
@@ -126,11 +128,10 @@ ERROR: You need to select at least one Apache SAPI to build shared modules.
 %undefine      with_filter
 %endif
 
+%define                rel     1
 %define                orgname php
-%define                php_suffix 55
-
-%define                rel     0.3
-%define                subver  RC3
+%define                ver_suffix 55
+%define                php_suffix %{!?with_default_php:%{ver_suffix}}
 Summary:       PHP: Hypertext Preprocessor
 Summary(fr.UTF-8):     Le langage de script embarque-HTML PHP
 Summary(pl.UTF-8):     Język skryptowy PHP
@@ -138,13 +139,13 @@ Summary(pt_BR.UTF-8):     A linguagem de script PHP
 Summary(ru.UTF-8):     PHP Версии 5 - язык препроцессирования HTML-файлов, выполняемый на сервере
 Summary(uk.UTF-8):     PHP Версії 5 - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          %{orgname}%{php_suffix}
-Version:       5.5.0
-Release:       %{rel}%{?subver:.%{subver}}%{?with_type_hints:.th}%{?with_oci8:.oci}
+Version:       5.5.4
+Release:       %{rel}%{?with_type_hints:.th}%{?with_oci8:.oci}
 Epoch:         4
 License:       PHP
 Group:         Libraries
-Source0:       http://downloads.php.net/dsp/%{orgname}-%{version}%{subver}.tar.xz
-# Source0-md5: 1221aff0c050611d5ec04d73349f9db6
+Source0:       http://www.php.net/distributions/%{orgname}-%{version}.tar.xz
+# Source0-md5: 32c1dc56701d21def91a39a312392b54
 Source2:       %{orgname}-mod_%{orgname}.conf
 Source3:       %{orgname}-cgi-fcgi.ini
 Source4:       %{orgname}-apache.ini
@@ -165,7 +166,7 @@ Patch5:             %{orgname}-filter-shared.patch
 Patch6:                %{orgname}-build_modules.patch
 Patch7:                %{orgname}-sapi-ini-file.patch
 Patch8:                %{orgname}-config-file-scan-dir.patch
-Patch9:                %{orgname}-sh.patch
+
 Patch10:       %{orgname}-ini.patch
 Patch11:       embed.patch
 %if %{with type_hints}
@@ -318,7 +319,7 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                hashver         1.0
 %define                intlver         1.1.0
 %define                jsonver         1.2.1
-%define                opcachever      7.0.2-dev
+%define                opcachever      7.0.3-dev
 %define                pharver         2.0.1
 %define                sqlite3ver      0.7-dev
 %define                zipver          1.11.0
@@ -1886,7 +1887,7 @@ compression support to PHP.
 Moduł PHP umożliwiający używanie kompresji zlib.
 
 %prep
-%setup -q -n %{orgname}-%{version}%{?subver}
+%setup -q -n %{orgname}-%{version}
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
@@ -1896,7 +1897,7 @@ Moduł PHP umożliwiający używanie kompresji zlib.
 %patch6 -p1
 %patch8 -p1
 %patch7 -p1
-%patch9 -p1
+
 cp -p php.ini-production php.ini
 %patch10 -p1
 %if %{with type_hints}
@@ -2488,10 +2489,11 @@ cp -p sapi/embed/php_embed.h $RPM_BUILD_ROOT%{_includedir}/php/sapi/embed
 %endif
 
 # install CLI
-libtool --mode=install install -p sapi/cli/php $RPM_BUILD_ROOT%{_bindir}/%{name}
-cp -p sapi/cli/php.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
-echo ".so %{name}.1" >$RPM_BUILD_ROOT%{_mandir}/man1/php.1
-ln -sf %{name} $RPM_BUILD_ROOT%{_bindir}/php
+# versioned suffix is always installed
+libtool --mode=install install -p sapi/cli/php $RPM_BUILD_ROOT%{_bindir}/php%{ver_suffix}
+cp -p sapi/cli/php.1 $RPM_BUILD_ROOT%{_mandir}/man1/php%{ver_suffix}.1
+echo ".so php%{ver_suffix}.1" >$RPM_BUILD_ROOT%{_mandir}/man1/php.1
+ln -sf php%{ver_suffix} $RPM_BUILD_ROOT%{_bindir}/php
 
 cp -p php.ini $RPM_BUILD_ROOT%{_sysconfdir}/php.ini
 
@@ -2754,8 +2756,8 @@ fi
 %defattr(644,root,root,755)
 %dir %{_sysconfdir}/cli.d
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/php-cli.ini
-%attr(755,root,root) %{_bindir}/%{name}
-%{_mandir}/man1/%{name}.1*
+%attr(755,root,root) %{_bindir}/php%{ver_suffix}
+%{_mandir}/man1/php%{ver_suffix}.1*
 
 %files program
 %defattr(644,root,root,755)
@@ -2993,7 +2995,7 @@ fi
 %if %{with oci8}
 %files oci8
 %defattr(644,root,root,755)
-%doc ext/ico8/{CREDITS,README}
+%doc ext/oci8/{CREDITS,README}
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/oci8.ini
 %attr(755,root,root) %{php_extensiondir}/oci8.so
 %endif
This page took 0.100295 seconds and 4 git commands to generate.