]> git.pld-linux.org Git - packages/php.git/blobdiff - php.spec
up to 7.4.0RC5
[packages/php.git] / php.spec
index 1b870a60e0394c96b0fc22b0e89d4c996c757f82..a3a0ca0a8d5e0e7744ecc99e8d970edd3cc8ba67 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -26,7 +26,6 @@
 %bcond_without cgi             # disable CGI/FCGI SAPI
 %bcond_without fpm             # disable FPM SAPI
 %bcond_without litespeed       # build litespeed SAPI
-%bcond_with    milter          # disable Milter SAPI
 %bcond_without phpdbg          # disable phpdbg SAPI
 # - Extensions
 %bcond_without bcmath          # without bcmath extension module
 %undefine      with_mm
 %endif
 
-# milter requires ZTS
-%if %{with milter} && %{without zts}
-%undefine      with_milter
-%endif
-
 %if %{without odbc}
 %undefine      with_pdo_odbc
 %endif
 %undefine      with_pdo_sqlite
 %endif
 
-%define                subver beta2
+%define                subver RC5
 %define                rel     1
 %define                orgname php
 %define                ver_suffix 74
@@ -158,7 +152,7 @@ Summary(ru.UTF-8):  PHP Версии 7 - язык препроцессирова
 Summary(uk.UTF-8):     PHP Версії 7 - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          %{orgname}%{php_suffix}
 Version:       7.4.0
-Release:       1.%{subver}.%{rel}
+Release:       2.%{subver}.%{rel}
 Epoch:         4
 # All files licensed under PHP version 3.01, except
 # Zend is licensed under Zend
@@ -167,7 +161,7 @@ License:    PHP 3.01 and Zend and BSD
 Group:         Libraries
 #Source0:      https://php.net/distributions/%{orgname}-%{version}.tar.xz
 Source0:       https://downloads.php.net/~derick/php-%{version}%{subver}.tar.xz
-# Source0-md5: 51a42ffa81be306d7a1b2f073e4fba05
+# Source0-md5: f26a23a42fd663400219b7145fcf4d0f
 Source1:       opcache.ini
 Source2:       %{orgname}-mod_php.conf
 Source3:       %{orgname}-cgi-fcgi.ini
@@ -185,7 +179,6 @@ Patch2:             %{orgname}-mail.patch
 Patch3:                %{orgname}-link-libs.patch
 Patch4:                intl-stdc++.patch
 Patch7:                %{orgname}-sapi-ini-file.patch
-Patch8:                milter.patch
 Patch9:                libtool-tag.patch
 Patch10:       %{orgname}-ini.patch
 Patch11:       embed.patch
@@ -202,7 +195,6 @@ Patch29:    %{orgname}-fcgi-graceful.patch
 Patch31:       %{orgname}-fcgi-error_log-no-newlines.patch
 Patch39:       %{orgname}-use-prog_sendmail.patch
 Patch41:       %{orgname}-fpm-config.patch
-Patch42:       %{orgname}-fpm-shared.patch
 Patch43:       %{orgname}-silent-session-cleanup.patch
 Patch44:       %{orgname}-include_path.patch
 Patch50:       extension-shared-optional-dep.patch
@@ -296,7 +288,7 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                _sysconfdir                     %{php_sysconfdir}
 
 # must be in sync with source. extra check ensuring that it is so is done in %%build
-%define                php_api_version         20190529
+%define                php_api_version         20190902
 %define                zend_module_api         %{php_api_version}
 %define                zend_extension_api      3%{zend_module_api}
 %define                php_pdo_api_version     20170320
@@ -310,7 +302,7 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                jsonver         %{version}
 %define                pharver         %{version}
 %define                sqlite3ver      %{version}
-%define                zipver          1.15.4
+%define                zipver          1.15.5
 %define                phpdbgver       %{version}
 %define                sodiumver       %{version}
 
@@ -1878,7 +1870,6 @@ cp -p php.ini-production php.ini
 %patch4 -p1
 
 %patch7 -p1
-%{?with_milter:%patch8 -p1}
 %patch9 -p1
 %patch10 -p1
 %patch14 -p1
@@ -1894,7 +1885,6 @@ cp -p php.ini-production php.ini
 %patch31 -p1
 %patch39 -p1
 %patch41 -p1
-%patch42 -p1
 %patch43 -p1
 %patch44 -p1
 %patch50 -p1
@@ -2110,7 +2100,7 @@ export PEAR_INSTALLDIR=%{php_pear_dir}
 # configure once (for faster debugging purposes)
 if [ ! -f _built-conf ]; then
        # now remove Makefile copies
-       rm -f Makefile.{cgi-fcgi,fpm,cli,apxs2,litespeed,phpdbg,milter}
+       rm -f Makefile.{cgi-fcgi,fpm,cli,apxs2,litespeed,phpdbg}
 
        # Force use of system libtool:
        mv build/libtool.m4 build/libtool.m4.saved
@@ -2156,9 +2146,6 @@ apxs2
 %if %{with phpdbg}
 phpdbg
 %endif
-%if %{with milter}
-milter
-%endif
 "
 for sapi in $sapis; do
        : SAPI $sapi
@@ -2189,9 +2176,6 @@ for sapi in $sapis; do
        phpdbg)
                sapi_args='--enable-phpdbg %{?debug:--enable-phpdbg-debug}'
        ;;
-       milter)
-               sapi_args='--with-milter'
-       ;;
        esac
 
        %configure \
@@ -2336,10 +2320,6 @@ cp -af Makefile.cli Makefile
        PHPDBG_EXTRA_LIBS=-lreadline
 %endif
 
-%if %{with milter}
-%{__make} -f Makefile.milter milter
-%endif
-
 # CGI/FCGI
 %if %{with cgi}
 cp -pf php_config.h.cgi-fcgi main/php_config.h
@@ -2468,11 +2448,6 @@ libtool --mode=install install -p sapi/litespeed/php $RPM_BUILD_ROOT%{_sbindir}/
 %endif
 %endif
 
-%if %{with milter}
-%{__make} -f Makefile.milter install-milter \
-       INSTALL_ROOT=$RPM_BUILD_ROOT
-%endif
-
 libtool --mode=install install -p libphp_common.la $RPM_BUILD_ROOT%{_libdir}
 
 # install CGI/FCGI
@@ -2480,7 +2455,7 @@ libtool --mode=install install -p libphp_common.la $RPM_BUILD_ROOT%{_libdir}
 # install-cgi
 libtool --mode=install install -p sapi/cgi/php-cgi $RPM_BUILD_ROOT%{_bindir}/%{name}.cgi
 ln -sf %{name}.cgi $RPM_BUILD_ROOT%{_bindir}/%{name}.fcgi
-cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/php-cgi-fcgi.ini
+cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/cgi-fcgi.d/php.ini
 %endif
 
 # install FCGI PM
@@ -2528,11 +2503,11 @@ ln -sf php%{ver_suffix} $RPM_BUILD_ROOT%{_bindir}/php
 
 cp -p php.ini $RPM_BUILD_ROOT%{_sysconfdir}/php.ini
 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/timezone.ini
-cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/php-cli.ini
+cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/cli.d/php.ini
 
 %if %{with apache2}
 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/httpd/conf.d/70_mod_php.conf
-cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/php-apache2handler.ini
+cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/apache2handler.d/php.ini
 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/apache/libphp7.la
 %endif
 
@@ -2768,7 +2743,7 @@ fi
 %files -n apache-mod_%{name}-core
 %defattr(644,root,root,755)
 %dir %{_sysconfdir}/apache2handler.d
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/php-apache2handler.ini
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache2handler.d/php.ini
 %attr(755,root,root) %{_libdir}/apache/libphp7-*.*.so
 %endif
 
@@ -2782,7 +2757,7 @@ fi
 %files cgi
 %defattr(644,root,root,755)
 %dir %{_sysconfdir}/cgi-fcgi.d
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/php-cgi-fcgi.ini
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cgi-fcgi.d/php.ini
 %attr(755,root,root) %{_bindir}/%{name}.cgi
 %attr(755,root,root) %{_bindir}/%{name}.fcgi
 %endif
@@ -2796,7 +2771,7 @@ fi
 %files cli
 %defattr(644,root,root,755)
 %dir %{_sysconfdir}/cli.d
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/php-cli.ini
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cli.d/php.ini
 %attr(755,root,root) %{_bindir}/php%{ver_suffix}
 %{_mandir}/man1/php%{ver_suffix}.1*
 
@@ -2828,12 +2803,6 @@ fi
 %{_mandir}/man1/phpdbg%{php_suffix}.1*
 %endif
 
-%if %{with milter}
-%files milter
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/php-milter
-%endif
-
 %files common
 %defattr(644,root,root,755)
 %doc EXTENSIONS LICENSE NEWS UPGRADING* Zend/{LICENSE.Zend,README*} php.ini-* .gdbinit
This page took 0.064275 seconds and 4 git commands to generate.